Jump to content

Recommended Posts

2 hours ago, killzone_kid said:

Try doing the same with different profile

 

That seems to solve the issue. Thanks.

Share this post


Link to post
Share on other sites

Not sure if it's the right thread, but does anyone know if the "always onscreen" compass from Contact can be hidden? 

Share this post


Link to post
Share on other sites
8 minutes ago, haleks said:

Not sure if it's the right thread, but does anyone know if the "always onscreen" compass from Contact can be hidden? 

Either from difficulty options or execute this command:

showHUD false

 

Share this post


Link to post
Share on other sites
21 hours ago, haleks said:

Not sure if it's the right thread, but does anyone know if the "always onscreen" compass from Contact can be hidden? 

Debug Console:

false call BIN_fnc_showHorizontalCompass

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, R3vo said:

Debug Console:


false call BIN_fnc_showHorizontalCompass

 

Is there a way to show this compass outside of the Contact campaign? Sending true to that function doesn't do anything for me. I quite like the look of the new map too.

Share this post


Link to post
Share on other sites
3 minutes ago, Tankbuster said:

Is there a way to show this compass outside of the Contact campaign? Sending true to that function doesn't do anything for me. I quite like the look of the new map too.

The function is only for Contact file aka PLAY CONTACT so you can't use outside... yet. I hope they make some of functions into platform.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Nice compass, I didn't even notice. What is this for?

Share this post


Link to post
Share on other sites

@DnA, Could you confirm if any changes have been made recently to the Skate Helmet, I've looked back over all the recent changelogs and can't see any documented changes. The Skate Helmet now has a very peculiar looking flat matt finish where before it was shiny. 

Share this post


Link to post
Share on other sites
55 minutes ago, EO said:

@DnA, Could you confirm if any changes have been made recently to the Skate Helmet

No targeted changes, but there was a full data pipeline cache clearing some weeks ago. It could be either a RVMAT is missing or it needs proper repacking. I'll ask an Artist to check.

  • Thanks 1

Share this post


Link to post
Share on other sites
Quote

Added: Missing private keywords to BIS_fnc_3DENInterface (General Discussion - Dev-Branch

Thanks for that quick fix.

Share this post


Link to post
Share on other sites
On 8/6/2019 at 5:52 PM, reyhard said:

Thanks for spotting it, it will be fixed in next stable patch. There was engine fix to "interpolate" command which broke expression which was previously working by miracle.


Thanks a lot for the fast fix the the newest dev build. I still have issues with missing trails and body vapor on a lot of community addons (for instance most of Firewills planes or Tetete3's F/A-18 Super Hornet). Those were definitely working before Contact was released. I compared their configs to those of the Jets DLC and cannot spot what causes them to not work anymore.

 

Strangely in the Jets DLC there's also config entries for body vapor FX besides the discussed wing trails - I haven't seen those FX working in the current build on the Jets DLC planes. (?)

Share this post


Link to post
Share on other sites
On 8/18/2019 at 5:51 PM, uzabit said:


Thanks a lot for the fast fix the the newest dev build. I still have issues with missing trails and body vapor on a lot of community addons (for instance most of Firewills planes or Tetete3's F/A-18 Super Hornet). Those were definitely working before Contact was released. I compared their configs to those of the Jets DLC and cannot spot what causes them to not work anymore.

 

Strangely in the Jets DLC there's also config entries for body vapor FX besides the discussed wing trails - I haven't seen those FX working in the current build on the Jets DLC planes. (?)

Jets DLC was created by B01 which also happen to be part of community members who created F/A-18 Super Hornet mod. I can imagine that  all of those community addons are copy pasting same mistake which was done in vanilla data since F18 mod was used as a template for many plane creators at some point. Namely, following function seems to be copy pasted

        enabled="accelY interpolate [39.9999999,40,-1,1]";

Engine default number precision is 6 digits after comma and anything with higher number of decimals will be rounded. In this particularly case, 39.999999 was rounded to 40 so following expression was evaluated after rounding

        enabled="accelY interpolate [40,40,-1,1]";

And now, I have to make a little digression about how interpolate used to work before Contact release (kudos to @killzone_kid for pointing out that error)
 

rain interpolate [0, 1, 0, 100]
rain 0; result 0 (as expected)
rain 1; result 100 (as expected)

rain interpolate [1, 0, 100, 0]
rain 0; result 1 (expected 0)
rain 1; result -99 (expected 100)

rain interpolate [0, 1, 100, 0]
rain 0; result 100 (as expected)
rain 1; result 0 (as expected)

rain interpolate [1, 0, 0, 100]
rain 0; result -99 (expected 100)
rain 1; result 1 (expected 0)

Because of that bug, inverted syntax was used (regular evaluation was when a>b, since a==b, else was used) and code in "enabled" expression was always returning 2 (inverted using 1 - result of regular interpolation, so in this case it was 1-(-1) ). Therefor, whole intent to optimize those particularly particle effects was flawed from begging and instead was adding few more lines of code to evaluated.

 

In short, community addons which copy pasted those particle effects should adjust their configs by i.e. changing all expressions with .999999 to i.e. .99 or fall back to using ones from Jet DLC in case they are copy pasting those effects from F18 mod. While indeed it's sort of inconvenience I hope that this fix will help for greater good of sandbox.

  • Like 12

Share this post


Link to post
Share on other sites
On 8/14/2019 at 5:21 PM, EO said:

@DnA, Could you confirm if any changes have been made recently to the Skate Helmet, I've looked back over all the recent changelogs and can't see any documented changes. The Skate Helmet now has a very peculiar looking flat matt finish where before it was shiny. 

 

Thanks for spotting  and reporting this. Due to some spooky issue, material and linked textures were not working anymore without any errors, but after refreshing the data it seems to be solved. 

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

The looter t-shirts have a problem with a scarf in 1st person.

3A28A48BF9A821091FD8E52C4A76AF4D53596234

Share this post


Link to post
Share on other sites

Looks like a recent patch may have caused the Carrier Special Rigs and the Carrier GL rigs to loose their .nohq maps again.

Vanilla, all expansions, no mods and not on Dev branch.

  • Like 1

Share this post


Link to post
Share on other sites

https://feedback.bistudio.com/T143979 MIM-145 Defender, AN/MPQ-105 Radar, S-750 Rhea and R-750 Cronus Radar continue to emit sound after being destroyed (like T-100 Varsuk did before)

 

https://feedback.bistudio.com/T127814 List of vehicles with dashboards lighten up only when headlights are switched on (despite engine on)

 

https://feedback.bistudio.com/T137525 AAF and CSAT full ghillie have their injury RVMATs swapped

G7HMVv0.jpg

 

https://feedback.bistudio.com/T137524 Qilin LSV's RVMATs make it darker than other vehicles

P53c2QH.jpg

 

https://feedback.bistudio.com/T137522 "clothing1_injury.rvmat" is lighter than "clothing1.rvmat"

1ItHR6k.jpg

  • Like 5
  • Thanks 2

Share this post


Link to post
Share on other sites

found a problem on the USS librety, one of the sections has a wrong texture as well as a lighting bug.

 

The texture is misplaced and is from the flight deck.

the lighting bug just makes it really really dark at night inside.

 

A9BKvRm.jpgxds7IxK.jpg5NNZWn2.jpgkV6oO6P.jpg

Share this post


Link to post
Share on other sites

ScriptCommands.jpg

@killzone_kid Awesome utility. This will be very handy in the future.

One suggestion though: would it be possible to add a button which links to the corresponding biki page of the selected command?

Share this post


Link to post
Share on other sites

I am not sure if this is a weapons model bug and if it was already reported.

If you put a weapon on the ground in the Eden Editor, they don't have (show) a magazine.
If you check the equipment storage (right click -> Attributes) there should be a magazine.
If you walk to the (visually) empty weapon and go to the inventory (do not grab the weapon), you can also see, that there is a magazine (but not shown in the weapon).

There are only two weapon models, which have their magazin loaded: MAR-10 .338 & Rahim 7.62 mm

Share this post


Link to post
Share on other sites
11 hours ago, KoalaDSK said:

MAR-10 .338 & Rahim 7.62 mm

 

I agree. We need proxy magazines even for weapons that apparently make no sense since there is only one type of magazine. For better mod compatibility 😀

  • Like 2

Share this post


Link to post
Share on other sites

Anything new about "Old man" scenario that was mentioned at the end of last year? 

Share this post


Link to post
Share on other sites
13 minutes ago, Bobrus said:

Anything new about "Old man" scenario that was mentioned at the end of last year? 

yes... he has grown a long white beard by now!

 

  • Like 2
  • Haha 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×