Jump to content

Recommended Posts

1 minute ago, Grumpy Old Man said:

Debug console is fixed,

now I'm unable to select the secondary weapon as of todays update.

 

Cheers

 

I can

Share this post


Link to post
Share on other sites
26 minutes ago, killzone_kid said:

 

I can

Actually I can't switch to any weapon.

Mousewheel up/down doesn't do anything, controls are set.

Launcher, pistol and rifle equipped.

Action menu just won't show up unless I use

player addAction ["Test", {}];

which shows up fine.

Weapon selection doesn't.

ViyyKH7.jpg

 

No mods, empty mission.

 

Cheers

Share this post


Link to post
Share on other sites
1 minute ago, Grumpy Old Man said:

Actually I can't switch to any weapon.

Mousewheel up/down doesn't do anything, controls are set.

Launcher, pistol and rifle equipped.

Action menu just won't show up unless I use


player addAction ["Test", {}];

which shows up fine.

Weapon selection doesn't.

 

Cheers


You are using Apex preset then. Weapon switching are number keys
1 - primary
2 - handgun
3 - secondary

; and right ctrl ; also work for me

But yeah it has been ages since weapon switching was removed from scroll down menu

 

Share this post


Link to post
Share on other sites
3 minutes ago, Grumpy Old Man said:

 

Mousewheel up/down doesn't do anything, controls are set.

 

You can't have both of those at the same time.

Share this post


Link to post
Share on other sites
6 minutes ago, Greenfist said:

You can't have both of those at the same time.

Why not? Mousewheel up or down opened the action menu just fine.

 

 

7 minutes ago, killzone_kid said:


You are using Apex preset then. Weapon switching are number keys
1 - primary
2 - handgun
3 - secondary

; and right ctrl ; also work for me

But yeah it has been ages since weapon switching was removed from scroll down menu

 

Oh well that explains it.

I was also using shift+mouse button 5/6 for selecting next/previous weapon, also ceased to work with the apex preset. Only seems to change firemode of the current weapon. Odd.

Changing from Apex preset back to Arma 3 did the trick.

Devbranch automatically changing the keybind presets can be confusing as heck.

 

Back to rebinding all of my keys now...

 

Cheers

 

Share this post


Link to post
Share on other sites

oh yeah, thanks BIS : 

Quote

Added: A new setAirplaneThrottle script command

Share this post


Link to post
Share on other sites

Sonic boom has been added to DEV Build today, no Prandtl–Glauert singularity though.

 

  • Like 7

Share this post


Link to post
Share on other sites

Shock collars don't always appear when going through the sound barrier. The air has to be particularly humid. It would probably be, on an island in the middle of Mediterranean (or in the south Pacific), but either way, the effect is not so important. Sonic boom is great, though.

  • Like 1

Share this post


Link to post
Share on other sites

Aye, I noticed that was added when flying around earlier. Took me by surprise the first time the boom echoed through the cockpit as I hit ~1250kph.

 

Also if you pan the camera around to the front of the aircraft when flying at Mach, engine sound from the rear of the aircraft cannot be heard because of speed of sound simulation. I thought that was pretty neat

 

I'm not certain, but it also felt like altitude was a factor in the speed at which the planes would break the sound barrier? Also pretty cool if that is indeed factored in

  • Like 2

Share this post


Link to post
Share on other sites

It seems that Buzzard's flight model got some improvements. It still needs work (for example, turning when banked is too slow and there isn't any "overrudder bounce"), but it's better than it used to be.

 

BTW, I noticed a problem that was either missed or ignored for a long time. Would that be possible to make clouds appear at a realistic altitude? IRL, clouds like the ones in ArmA are generally found around 2km of altitude. In ArmA, it's double that. I'm not saying that they can't appear from 4 to 6km, but the clouds should start much lower, especially when the weather is bad. They can appear as low as 500m above the surface.

  • Like 4

Share this post


Link to post
Share on other sites
On 4/26/2017 at 7:06 PM, R3vo said:

The new 3den Attribute "DLC" and "Required DLC" is splendid, almost.

 

What if a scenario requires multiple DLCs?

 

This is Content Licensing (CL) of the scenario itself (i.e. of the SQM file). Currently the engine only supports one (primary) DLC to be applied to a scenario. In this case it's rather used to allow for premium playable content, rather than to mark what content might be used in a scenario (individual asset CL takes care of this + Steam Workshop dependencies if you publish there). It's more something for us to use, but if you wish, you can apply it to make it very clear a scenario requires ownership of a DLC before you can even start it. They are not new properties, but they weren't exposed in Eden Editor so far. Having said that, we would ourselves prefer to have multi-DLC CL on scenarios. So far however, we haven't had the need for it and its addition is unplanned at the moment.

  • Like 4

Share this post


Link to post
Share on other sites

K so since the release of 1.68 ive been getting the same dxig error. Ive tried absolutely everything to fix it on my end. Only thing that work was downloading the dev version which at the time was 1.69 . something. I was at least able to play the game a little. Now version 1.71.something and im getting the same error as 1.68. Im part of   the group with amd gear being effect by this bug. Can any devs try to help me?

Edited by wolfpak420
K my bad i forgot to delete my 1.68 version profile

Share this post


Link to post
Share on other sites
On 4/28/2017 at 10:07 AM, DnA said:

...

Having said that, we would ourselves prefer to have multi-DLC CL on scenarios. So far however, we haven't had the need for it and its addition is unplanned at the moment.

 

Would be VERY useful for people, like myself, who are making missions/campaigns that incorporate all official DLCs besides some mods.

Share this post


Link to post
Share on other sites
On 4/28/2017 at 9:07 AM, DnA said:

 

This is Content Licensing (CL) of the scenario itself (i.e. of the SQM file). Currently the engine only supports one (primary) DLC to be applied to a scenario. In this case it's rather used to allow for premium playable content, rather than to mark what content might be used in a scenario (individual asset CL takes care of this + Steam Workshop dependencies if you publish there). It's more something for us to use, but if you wish, you can apply it to make it very clear a scenario requires ownership of a DLC before you can even start it. They are not new properties, but they weren't exposed in Eden Editor so far. Having said that, we would ourselves prefer to have multi-DLC CL on scenarios. So far however, we haven't had the need for it and its addition is unplanned at the moment.

 

So all in all, not very useful.

Share this post


Link to post
Share on other sites
47 minutes ago, R3vo said:

 

So all in all, not very useful.

 

What would be the use for us anyway? What we need we already have with dependencies in the mission.sqm that existed since OFP. And then there is Steam/Launcher stuff that warns and downloads for you. It's not like any one of us will publish a new paid DLC tied to Arma 3 on Steam.

 

And it's not like it makes sense to include a scenario in paid content that requires purchase of yet another paid content. "Oh, we've set Showcase Jets on Tanoa, so you just bought Jets DLC to get it, but you can't play it, even though you bought it, because you also need to buy APEX. Lolololololol!".

  • Like 1

Share this post


Link to post
Share on other sites

I found that the sonic boom doesn't work all that great from the ground. When overflown by a supersonic Shikra with a minimum distance of about 700m, the boom was very quiet, quieter, in fact, than the following sound of its engines. At that distance, it should be quite ear-shattering.

 

Also, the sonic boom isn't heard inside the aircraft. It's a shockwave emitted from the nose, so unless the aircraft goes way too fast and its own wings end up in the shock (which is bad for efficiency and the reason swept wings are better in supersonic flight), it's not going to experience it in any way. On the ground, it can be very loud, but from the inside of the aircraft the aural cues that you broke the sound barrier are rather subtle and generally do not originate from the "primary" shock.

Share this post


Link to post
Share on other sites

Hello dev branch,

 

EDIT :

I've just realized that setUnitPos "UP" does work but it seems it does not work on AI units that have previously been ordered by a player to crouch or go prone.

 

Can anyone tell me if there is another way to get AI units previously ordered by a player to crouch or go prone, to stand up after the player has either left the squad or been killed ?

 

Thanks.

Share this post


Link to post
Share on other sites
On 2/2/2017 at 7:58 PM, Sniperwolf572 said:

On a slightly different note. Tanoa seems to have that horrible bug with the "Fixed length loading time".

 

I'm not sure how to describe it. The loading time always seems to last ~15 seconds, and finishes in 15 fixed chunks, no matter if it's the first time loading, or millionth.

This used to happen with specific rifles, and the devs have fixed it for those weapons. 

I'm assuming it has something to do with one or more of the common models on the island, although I have no clue which one as it's not as simple as removing a rifle from a soldier in the previous case.

I'm sure it's something on the island, and not any kit on the rifleman as this does not happen on Stratis/Altis, and the distance from the shore plays a role.

 

The only place I've found on Tanoa so far where the loading time will not be problematic, is if I place myself in the top right corner of the map.

I've even narrowed it down to the two locations right next to each other that exhibit and don't exhibit this problem, only a few meters of separation.

 

Anyway, repro:


1) Download the repro mission from here.

2) Set view distance and object view distance to 3000 (Other video settings might play a role I guess, I'm not sure)

3) Just in case, load the mission in editor, and preview it once.

4) Switch the player to be the unit closer to shore (marked with "Slow loading" marker) and preview, observe that the loading time goes in 15 increments of ~1 second

5) Return back to the editor and switch the player to be the unit further away from the shore (marked with "Quick loading" marker)

6) Preview and observe that the loading time is almost instant (might vary depending on your machine I guess)

7) Repeat steps 4 to 6 any number of times and you should experience the same results

 

As this is affected by view distances, it's very important to set the view/object distance to 3000 for the repro to work, otherwise the "problem radius" moves.

Hopefully, this should be easy to find, as the object should lie somewhere in the band where the 3000m circles around two units do not overlap.

 

Fixed length loading, described in the above post, is back. The repro mission above no longer repros it, but can be reproed anywhere on main Tanoa airport.

 

Since this magically goes away in builds every time after I report it without any return info from whoever fixes it, does anyone know what causes this in the models in the first place? I've always suspected it's something to do with textures/materials/material maps. Can we make some kind of a test/linter into BI tooling so this does not happen in the future? :tounge_o:

  • Like 1

Share this post


Link to post
Share on other sites

 

Nice OPREP today on the intricacies of the new Jet sensor combat/targeting system - it pretty much sealed the deal of me buying the DLC. Honestly those 10 threads about all the technical aspects of sensor combat make my IQ literally manifest as a cartoon cat who turns and points at me and laughs. Bluntly Im too dumb for dem maths, but sho am glad there there (english is my forte).

  • Like 6

Share this post


Link to post
Share on other sites

Can we get a little tweak on smoke abruptly disappearing when you turn to face it?  I know it is to do with scene complexity but IF they smoke is already there please let it be !

  • Like 3

Share this post


Link to post
Share on other sites

Seems like aircraft respawned (by the Vehicle Respawn module) on the USS Freedom, spawn flying at full throttle with gear up, usually resulting in catastrophic results.

Related to this issue: https://feedback.bistudio.com/T79620

 

For now, does anyone know of a script that forces the vehicle to spawn with engine off, no throttle and gear down?

Share this post


Link to post
Share on other sites
27 minutes ago, nmdanny said:

Seems like aircraft respawned (by the Vehicle Respawn module) on the USS Freedom, spawn flying at full throttle with gear up, usually resulting in catastrophic results.

Related to this issue: https://feedback.bistudio.com/T79620

 

For now, does anyone know of a script that forces the vehicle to spawn with engine off, no throttle and gear down?

Spawn it on solid land and then teleport it aboard ship.

Share this post


Link to post
Share on other sites

Are there any plans to add the various munitions that are available for helicopters and planes to the in game field manual with some basic information (guidance type, min/max range, etc.)?

  • Like 7

Share this post


Link to post
Share on other sites
2 hours ago, rebel12340 said:

Are there any plans to add the various munitions that are available for helicopters and planes to the in game field manual with some basic information (guidance type, min/max range, etc.)?

 

This is actually a very good idea!!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×