Jump to content

Recommended Posts

In the past, it did not work when setting this command on the fly (Atleast i have only ever made it work from the editor.). Does that work now?

Quote

(group this) setVariable ["Vcm_Disable",true]; //This command will disable Vcom AI on a group entirely.

 

Share this post


Link to post
Share on other sites

Awesome stuff dude, really happy to see 3.0
ARMA just isn't right without VCOM.

Thank you for all the work you've put into this, I even enjoy watching all the YouTube coding videos :hammer:
 

  • Like 1

Share this post


Link to post
Share on other sites
14 minutes ago, pandex said:

In the past, it did not work when setting this command on the fly (Atleast i have only ever made it work from the editor.). Does that work now?

 

I sure hope so, don't see any reason for it not too

 

3 minutes ago, JD Wang said:

Awesome stuff dude, really happy to see 3.0
ARMA just isn't right without VCOM.

Thank you for all the work you've put into this, I even enjoy watching all the YouTube coding videos :hammer:
 

Thank you :)  It's always fun to work on ArmA...I am always learning.

 

I just snuck in a mini-fix for CBA & Vcom just now....

  • Like 1

Share this post


Link to post
Share on other sites

I'm testing the new mod version in Dissension (after disabling the script version in the init) and a group is stuck in a loop of embark disembark with their APC. They have received a call for reinforcement and known the enemy position but are to far away (500m).

 

Maybe it's better to disable the embark order if they are in combat mode or test the distance with enemy before disembarking.

 

 

Share this post


Link to post
Share on other sites

I have also tested the AI with Hetman war stories and it's troublesome that vcom call for backup artillery units or empty unarmed transports.

 

Also got those errors :

 

13:57:35 Error in expression < %1, expected %2, on index %3, in %4", [_par] call _fnc_getTypeName, [_x] call _>

13:57:35 Error position: <_par] call _fnc_getTypeName, [_x] call _>

13:57:35 Error Undefined variable in expression: _par

13:57:35 File A3\functions_f\Debug\fn_errorParamsType.sqf [BIS_fnc_errorParamsType], line 84

13:57:35 Error in expression <EqualTypeArray [objNull,0]) exitWith {[[_building,_max], "isEqualTypeArray", [ob>

13:57:35 Error position: <_building,_max], "isEqualTypeArray", [ob>

13:57:35 Error Undefined variable in expression: _building

13:57:35 File A3\functions_f_EPA\Misc\fn_buildingPositions.sqf [BIS_fnc_buildingPositions], line 23

13:57:35 Error in expression <["_building", ["_max", -1]];

if !([_building,_max] isEqualTypeArray [objNul>

13:57:35 Error position: <_building,_max] isEqualTypeArray [objNul>

13:57:35 Error Undefined variable in expression: _building

13:57:35 File A3\functions_f_EPA\Misc\fn_buildingPositions.sqf [BIS_fnc_buildingPositions], line 23

13:57:35 Error in expression <te _GroupUnits = units _this;

if (count _TempA > 0) then

{

{

private _Foot = isN>

13:57:35 Error position: <_TempA > 0) then

{

{

private _Foot = isN>

13:57:35 Error Undefined variable in expression: _tempa

13:57:35 File \Vcom\Vcom\Functions\fn_GarrisonLight.sqf [VCM_fnc_GarrisonLight], line 15

Share this post


Link to post
Share on other sites

CBA settings is not showing up in the addon version.

EDIT: it does show up but only inside the mission, not 3DEN editor. It would be nice if you could edit the parameters before the mission launch via CBA settings.

Thanks for the update by the way!

Share this post


Link to post
Share on other sites
58 minutes ago, Andres97 said:

CBA settings is not showing up in the addon version.

EDIT: it does show up but only inside the mission, not 3DEN editor. It would be nice if you could edit the parameters before the mission launch via CBA settings.

Thanks for the update by the way!

 

I have the same issue. Would be nice to change CBA settings in 3DEN editor.

Share this post


Link to post
Share on other sites

So, if I'm updating to 3.0  I should just wipe my old 2.x folder on server, and install full 3.0 @VCOM folder to server. 
We use CBA, so do I need to include any of the USERCONFIG folders like normal?

Share this post


Link to post
Share on other sites

Thanks for the update.

 

I loved using this AI behaviour mod but I stopped using it in the past because my AI team members wouldn't follow orders and eventually would stop moving all together.

I understood that was a know issue at the time, has that problem been resolved? Does using the command [(group this) setVariable ["Vcm_Disable",true]; //This command will disable Vcom AI on a group entirely] in the init field work to resolve this problem?

 

thanks

Share this post


Link to post
Share on other sites

BIG THX for the update!!! :thumbs-up:    :icon_dj:

 

 

And +1 to playing tonite! 

Share this post


Link to post
Share on other sites

Shit I'm on holidays and can't play Arma for a few days. Thanks genesis for putting some needed I into the AI

Share this post


Link to post
Share on other sites

@genesis92x If I'm hosting a mission on my pc for some friends and I and we're running CBA, should I make the AI changes I want via the userconfig, VcomAI_DefaultSettings.sqf, or using the CBA settings?

Share this post


Link to post
Share on other sites

Amazing work, and it seems to have sorted a issue I had where I wanted to run both Vcom AI and VCOM AI Driving together. Before it seemed to cancel out the great benefits from VCOM AI Driving, but now I can run both  woohoo.

 

Tested several times and clever driving around large obstacles like crashed helicopters etc is persisting. and I can now get the extra benefits of your latest Vcom AI to boot.

 

Can you please confirm if you have completely removed driving elements from the v3.0 Vcom AI?

 

only error I'm seeing so far is this:

https://imgur.com/a/y1Gjtsx

happens when I place a load of soldiers in the way of vehicles route.

 

Thank you for your hard work on this one.

Share this post


Link to post
Share on other sites

I cant get the AI to see ir lasers.

 

using ACE3 here

Share this post


Link to post
Share on other sites

Same here, happens when there are no enemies around and a unit in a squad dies.

X1TJrbS.png

 

Happens in SQUADBEH.fsm in class Arty_Check

Share this post


Link to post
Share on other sites

Posted this in the old thread just before it was closed, hoping for a clarification on some of the "fluff" that got removed. 

 

It was mentioned that the driving is now "default behavior", does that mean VCOM driving has been taken out and is handed back to vanilla? If so will VCOM driving still be supported as a separate mod/script? Personally i find the driving improvements to be one of the most important things, my community has become so heavily reliant on VCOM driving just for enemy AI to get from A to B let alone actually do any kind of convoy stuff remotely well.

 

 

 

Share this post


Link to post
Share on other sites

Hi, Despite the optimization, I still have some delay issue for ordering high command in Liberation with C2/AIC link to vcom. Does somebody see the same things?

Share this post


Link to post
Share on other sites

The grabbing of empty cars seems a bit arbitrary at times -especially when enemy squads are hanging out all about town in old sedans :P It actually makes for some fun surprising gameplay when you have actually civilians in cars mixed in with Takistani militia but not sure why they seem to just jump in cars with no waypoint. Also, is this mod adding something like speed or explosiveness to the getting shot animation? -It seems like guys are getting slammed to the ground (add the cool headwear blowup mod) and its glorious. Overall this AI mod adds so much -love it

Share this post


Link to post
Share on other sites
8 hours ago, -ben- said:

Posted this in the old thread just before it was closed, hoping for a clarification on some of the "fluff" that got removed. 

 

It was mentioned that the driving is now "default behavior", does that mean VCOM driving has been taken out and is handed back to vanilla? If so will VCOM driving still be supported as a separate mod/script? Personally i find the driving improvements to be one of the most important things, my community has become so heavily reliant on VCOM driving just for enemy AI to get from A to B let alone actually do any kind of convoy stuff remotely well.

 

 

 

Ben - I noted above that seperate Driving mod seems to work well with new update.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×