Jump to content

Recommended Posts

1 hour ago, froggyluv said:

The grabbing of empty cars seems a bit arbitrary at times -especially when enemy squads are hanging out all about town in old sedans :P It actually makes for some fun surprising gameplay when you have actually civilians in cars mixed in with Takistani militia but not sure why they seem to just jump in cars with no waypoint. Also, is this mod adding something like speed or explosiveness to the getting shot animation? -It seems like guys are getting slammed to the ground (add the cool headwear blowup mod) and its glorious. Overall this AI mod adds so much -love it

You can turn off the settings you don't want to use, such as the AI taking empty vehicles. The AI has a chance of ragdolling when getting shot. This too can be customized. This is all explained in the original post.

Share this post


Link to post
Share on other sites

Has anyone had issues with ai being pretty invulnerable ? I think something else is going on with our server tbh and doubt its vcom, but just wanted to rule vcom out. 

 

Be grateful if someone could let me know me know, if all is normal regarding invulnerability, or noticed any significant changes regarding invulnerability .

Thanks

 

Share this post


Link to post
Share on other sites

 

 I had some enemy AI in civilian cars that wouldnt die but they weren't returning fire either -its was like I had killed them but the animation didnt kick in until I either got real close or kicked them out of the car (entering vehicle)

 

@Montgomery - im not really criticizing Im just mentioning they could be tweaked a bit of deciding when to jump into a vehicle. Meaning jumping into a sedan without a waypoint is kinda silly but again, did lead to some surprise encounters when they jumped out on me rifles blazing

Share this post


Link to post
Share on other sites
On 9/5/2018 at 12:14 PM, genesis92x said:

I sure hope so, don't see any reason for it not too

 

 

 

 

Just tested it intensively in yesterdays mission and it works like a charm. Instant effect. Great work !!! Nice to have vcom back. Arma is just not the same.

 

 

12 hours ago, Duke101 said:

Has anyone had issues with ai being pretty invulnerable ? I think something else is going on with our server tbh and doubt its vcom, but just wanted to rule vcom out. 

 

Be grateful if someone could let me know me know, if all is normal regarding invulnerability, or noticed any significant changes regarding invulnerability .

Thanks

 

We had an op last night, experienced nothing like you decribe.

Share this post


Link to post
Share on other sites

Hi all,

 

I am trying to use Vcom with Alive but I have an issue that my air support and arty support get taken over by Vcom. 

 

If I understand correctly the command

On 9-5-2018 at 7:39 PM, dr@gon said:

 [(group this) setVariable ["Vcm_Disable",true]; //This command will disable Vcom AI on a group entirely]

 

disables Vcom for a group but would this also work for a single vehicle, aircraft or helicopter?

 

thanks

RedeyeX

Share this post


Link to post
Share on other sites
Hi, Despite the optimization, I still have some delay issue for ordering high command in Liberation with C2/AIC link to vcom. Does somebody see the same things?

My mistake, finally it’s not vcom ai 3.0 but vcom driver which delay the gameplay. Sorry


Envoyé de mon iPhone en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Great stuff Dom,

 

FYI, I'm seeing a lot of these in my RPTs

 

  Error position: <objectParent _Unit;
if (_Foot) then
{
if>
  Error objectparent: Type Array, expected Object
File Vcom\Functions\fn_ArmStatics.sqf [VCM_fnc_ArmStatics], line 10
Error in expression <VCM_fnc_ClstObj;
private _Foot = isNull objectParent _Unit;
if (_Foot) then
{
if>
 

Share this post


Link to post
Share on other sites
On 5/11/2018 at 11:05 AM, pandex said:

 

 

Just tested it intensively in yesterdays mission and it works like a charm. Instant effect. Great work !!! Nice to have vcom back. Arma is just not the same.

 

 

We had an op last night, experienced nothing like you decribe.

Yeah thanks, appreciated. Found the problem and as expected nothing to do with vcom. 

Loving the new version of vcom. Thanks again Genesis.  

Share this post


Link to post
Share on other sites

I keep getting the following error message spam all through the logs.

21:11:18   Error Undefined variable in expression: vcm_fnc_squadexc
21:11:18 File C:\Users\KrisRoB\Documents\Arma 3 - Other Profiles\JD%20Wang\mpmissions\ALiVE_Missions\Operation_Grindstone.Napf\Vcom\VcomInit.sqf, line 75
21:11:18 Error in expression <alive _x}) isEqualTo -1) then
{
_x call VCM_fnc_SquadExc;
};
};
};
true;
} count>
21:11:18   Error position: <VCM_fnc_SquadExc;
};
};
};
true;
} count>

Share this post


Link to post
Share on other sites

Having the ai steal vehicles was amusing but ultimately was unpopular with players. If disabling this ability is new, I'll be trying it again.

Also, does this include vcom driving?

Share this post


Link to post
Share on other sites

is the behaviour of AI Pilots in planes been altered?
like, priority targeting, using dumb bombs and so on.

also, does ground units call for CAS if there are friendly air assets available, similar to artillery?
 

i really like this mod.. but AI is still behaving rather irradic at times..
but, i guess nothing is perfect. its a lot better then stock AI atleast :D

 

Share this post


Link to post
Share on other sites

I'm going through the settings for my server and I have a few questions, are the difficulty variables fixed values now instead of a value with a random swing variable, and is the suppression mechanic gone for ai as well as players?

Share this post


Link to post
Share on other sites

i have to AI issues

1- Genesis AI not replaying our quistions

2- Ai in vehicles got some issues and specially in mission MORAL FIBER they dont move

 

this mod is Epic..much better then other ai mods

but it fuked up some Campaign mission..anyway to fix this?

Share this post


Link to post
Share on other sites

Can anyone please confirm that even with ai skills changed to false the ai still has their skill altered by Vcom? Spawned some units in the editor and via Zeus and their skill levels were immediately changed by Vcom - only possible way to change their skills was to manually alter it in Zeus. Tried it with and without user config, filepatching turned on, "vcom affecting skill settings" changed to false. In 2.94 it worked flawlessly.
Another issue I encountered so far was that several AI like to bunch at one spot they consider to be cover.
Thanks for your work Genesis.
 

Share this post


Link to post
Share on other sites
4 hours ago, Lothear said:

several AI like to bunch at one spot they consider to be cover.


Sounds like accurate human like behaviour if my units anything to go by :rofl:

  • Haha 2

Share this post


Link to post
Share on other sites
4 hours ago, JD Wang said:


Sounds like accurate human like behaviour if my units anything to go by :rofl:

Yeah, they are so affraid of war that they try to hide inside each other in the middle of the road :icon_biggrin::icon_biggrin:

Share this post


Link to post
Share on other sites

I'm trying to set the following:

   VCM_StealVeh = false; //Will the AI steal vehicles.

 

from within the hpp files:

   \@Vcom AI V3.0\addons\userconfig\VCOM_AI\AISettingsV3.hpp

   \@Vcom AI V3.0\userconfig\VCOM_AI\AISettingsV3.hpp

 

I can of course do it via CBA in game, but just wondered why it's not possible via settings files?

Share this post


Link to post
Share on other sites

Well, this file ("\VCOM_AI\AISettingsV3.hpp") needs to be in the Userconfigs folder in your Arma 3 installation folder (if I'm not completely wrong)

 

Share this post


Link to post
Share on other sites

GLove this mod !

You made what BIS should have done !

Thanks man !

Share this post


Link to post
Share on other sites
10 hours ago, rossoe said:

I'm trying to set the following:

   VCM_StealVeh = false; //Will the AI steal vehicles.

 

from within the hpp files:

   \@Vcom AI V3.0\addons\userconfig\VCOM_AI\AISettingsV3.hpp

   \@Vcom AI V3.0\userconfig\VCOM_AI\AISettingsV3.hpp

 

I can of course do it via CBA in game, but just wondered why it's not possible via settings files?

@rossoe you need to drag the userconfig folder out into the main Arma3 directory..  Edit it then with how you want it.

You will then need to add @VCOM_AI onto your command line.

 

EDIT:  @Moon_chilD beat me to it.

  • Haha 1

Share this post


Link to post
Share on other sites
16 hours ago, rossoe said:

I'm trying to set the following:

   VCM_StealVeh = false; //Will the AI steal vehicles.

 

from within the hpp files:

   \@Vcom AI V3.0\addons\userconfig\VCOM_AI\AISettingsV3.hpp

   \@Vcom AI V3.0\userconfig\VCOM_AI\AISettingsV3.hpp

 

I can of course do it via CBA in game, but just wondered why it's not possible via settings files?

 

 Same here. Just double checked that it was set to false in Userconfig, added enemy squad + empty pickup truck and as soon as they detected me (combat mode) they loaded into the truck

Share this post


Link to post
Share on other sites
1 hour ago, froggyluv said:

 

 Same here. Just double checked that it was set to false in Userconfig, added enemy squad + empty pickup truck and as soon as they detected me (combat mode) they loaded into the truck

 

You have seen kremator and my answer?

Share this post


Link to post
Share on other sites
1 hour ago, Moon_chilD said:

 

You have seen kremator and my answer?

It won't help. There is something wrong with the user config. I have similar issues  -  formation set to false in user config and they still changed their formation. The same goes for AI skills. And yes, file patching enabled and userconfig placed in the right folder. 2.94 worked fine though, dunno know what could be causing it.

  • Confused 1

Share this post


Link to post
Share on other sites

@froggyluv @Lothear

There are settings for vcom in 3 different locations. There are the CBA settings that you can only change in game from the addon options menu, there is the .hpp file in the userconfig, and there is the VcomAI_DefaultSettings.sqf file located inside the functions folder I believe. I'm still not sure which one takes precedence, but if you make the settings the same in all of them, you should get the desired result.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×