Jump to content

Recommended Posts

10 hours ago, Montgomery said:

@froggyluv @Lothear

There are settings for vcom in 3 different locations. There are the CBA settings that you can only change in game from the addon options menu, there is the .hpp file in the userconfig, and there is the VcomAI_DefaultSettings.sqf file located inside the functions folder I believe. I'm still not sure which one takes precedence, but if you make the settings the same in all of them, you should get the desired result.

I am using the mod version, so no "DefaultSettings.sqf" for me ;) I tried changing the settings both in CBA AND user config, as far as I know, changing it in one of them affects the other.
But thanks for the tip. :smile_o:

Share this post


Link to post
Share on other sites

@genesis92x
i've a little question...i wish that some AI with no waypoints (so menaged by VCOM i suppose), at a certain point that a trigger fires,  start to move to a certain specific point (lets call it point "P"). i usually use "move" command in the script to make this happen.
will this work, or will VCOM take AI control before the AI unit reach its P point ?
thanks!

Share this post


Link to post
Share on other sites

Hey all, thanks for the assistance and thanks. I just wanted to request if you have a feature request or bug report that I can track it much easier, and will see it, if you post it on the GitHub

 

https://github.com/genesis92x/VcomAI-3.0

 

I believe anyone should be able to post issues or requests there with a free GitHub account. This helps me out greatly as I am busy and...well...lazy to go through every post during my work weeks.

 

On 5/17/2018 at 6:10 AM, Lothear said:

I am using the mod version, so no "DefaultSettings.sqf" for me ;) I tried changing the settings both in CBA AND user config, as far as I know, changing it in one of them affects the other.
But thanks for the tip. :smile_o:

@Lothear , forgive me if I missed you already trying this. If you are changing setting in the userconfig file location, you will need to enable -filepatching to your launch line or enable it in the A3 launcher.

 

Another thing to try is to simply add VCM_SKILLCHANGE = false at the end of the init.sqf and see if that forces it to halt.

 

Here is the direct code for the skill change


{
	if (!(isPlayer _x) && {VCM_SKILLCHANGE} && {!(_Group getVariable ["VCM_Skilldisable",false])}) then
	{
		_x disableAI "SUPPRESSION";
		_x addEventHandler ["Killed",{_this spawn VCM_fnc_ClstWarn;}];
		_x addEventHandler ["Fired",{_this call VCM_fnc_HearingAids;}];
		_x addEventHandler ["Hit",{_this call VCM_fnc_AIHIT;}];
	};
} foreach (units _Group);

 

20 hours ago, dlegion said:

@genesis92x
i've a little question...i wish that some AI with no waypoints (so menaged by VCOM i suppose), at a certain point that a trigger fires,  start to move to a certain specific point (lets call it point "P"). i usually use "move" command in the script to make this happen.
will this work, or will VCOM take AI control before the AI unit reach its P point ?
thanks!

Hey dlegion, there are a few conditions that Vcom will ignore generating new waypoints. If you use anything else but a move, Vcom should not generate new waypoints. If you are using a move waypoint, simply give them 2 move waypoints on the same location. Vcom will not generate new waypoints if there is more than 1 waypoint.

  • Like 1

Share this post


Link to post
Share on other sites

perfect, thanks for the info, and again thanks for this great script man !!

Share this post


Link to post
Share on other sites

Thanks for suggestions Genesis :smile_o:
I do have file-patching enabled :smile_o: Call me stupid, but I can't seem to find init.sqf in the mod version of VCOM :grinning:

Edit

After checking that file patching is enabled, trying changing both the option in config and in-game, and trying the init, still no change whatsoever. Only option I have is to manually adjust their skills after they have been spawned.

 

 

Edited by Lothear
Testing

Share this post


Link to post
Share on other sites
1 minute ago, Lothear said:

Thanks for suggestions Genesis :smile_o:
I do have file-patching enabled :smile_o: Call me stupid, but I can't seem to find init.sqf in the mod version of VCOM :grinning:

 

 

 

You should create one in your mission folder. You do not have to modify the mod, simply by adding code to your mission init.sqf you can change the parameters.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, Andres97 said:

 

You should create one in your mission folder. You do not have to modify the mod, simply by adding code to your mission init.sqf you can change the parameters.

I see, thanks!

Share this post


Link to post
Share on other sites

@genesis92x i noticed AI steal empty land vehicles, but not air vehicles (helo / airplanes) , is that normal ?
thanks man !

Share this post


Link to post
Share on other sites

Well I managed to fix my rpt spam 5 mins before my units new campaign (Protip if you use the script version it always helps to add the code in the description.ext :faceplam: ) 

@genesis92x after a couple of nights running this in our new ALiVE mission I've got to say you knocked out of of the park with this rewrite.
The AI are smart, challenging and deadly without being aimbot super soldiers. We're now cautious about heading blindly into towns because of how well the AI maneuver.
We also have to keep reminding ourselves not to stay in one spot and fortify for too long because the combination of ALiVE and VCOM will lead to us being surrounded and our position being over run.  

Thanks again for all the work you put into this, we all appreciate it.

Share this post


Link to post
Share on other sites

I'm getting the same errors as JD Wang:

 

Spoiler

19:34:39 Error in expression <alive _x}) isEqualTo -1) then
{
_x call VCM_fnc_SquadExc;
};
};
};
true;
} count>
19:34:39   Error position: <VCM_fnc_SquadExc;
};
};
};
true;
} count>
19:34:39   Error Undefined variable in expression: vcm_fnc_squadexc
19:34:39 File mpmissions\__cur_mp.ChernarusRedux\Vcom\VcomInit.sqf, line 75

 

edit:  D'oh!  Just read JD Wang's post above..... I forgot that, too!

Share this post


Link to post
Share on other sites

@bob_the_k check my post above yours. I bet you forgot to add the code into the description.ext 
That was my issue 


class CfgFunctions

{

#include "vcom\cfgFunctions.hpp"

};

class Extended_PreInit_EventHandlers {

VCM_CBASettings = call compile preprocessFileLineNumbers "Vcom\Functions\VCM_CBASettings.sqf";

};

Share this post


Link to post
Share on other sites

One quick question: I have not understood how I can configure Vcom per mission (ie not using the same parameters everytime) while using the script version for a server that doesn't allow file patching. I just have to set the variable directly in the mission (so most likely in the initserver.sqf) ?

 

Thx !

Share this post


Link to post
Share on other sites

I was using the previous version of VCOM, and when I upgraded I cleared everything out.

 

I see this many times when I try to launch my server:

 

I've looked at the rpt files but I don't really see any red flags...

 

[EDIT]: Code wasn't in the correct part of class CfgFunctions, nevermind :)

Edited by techladdie

Share this post


Link to post
Share on other sites
7 hours ago, Jack Ost said:

Hi @genesis92x

 

For a better use of your mod and your commands, I made a pbo to defines the attributes in eden. You can check it here and integrate it, if you want : https://drive.google.com/open?id=1kj-06aId_RMpFrYn6xZ8MylY8-ACab5G

What it looks like : https://imgur.com/a/NFJjchZ

You are free to change and adapt it.

 

Great! Thanks.

Share this post


Link to post
Share on other sites
19 hours ago, Jack Ost said:

Hi @genesis92x

 

For a better use of your mod and your commands, I made a pbo to defines the attributes in eden. You can check it here and integrate it, if you want : https://drive.google.com/open?id=1kj-06aId_RMpFrYn6xZ8MylY8-ACab5G

What it looks like : https://imgur.com/a/NFJjchZ

You are free to change and adapt it.

This ie real cool

 

Share this post


Link to post
Share on other sites

So now that I'm playing longer, I'm seeing other errors crop up repeatedly in the logs:

Spoiler

20:42:22 Error in expression <VCM_ARTYDELAY) < time && {count (units (group _NearestEnemy)) > 2}>
20:42:22   Error position: <group _NearestEnemy)) > 2}>
20:42:22   Error group: Type Array, expected Object

 

and 

 

private _Foot = isNull objectParent _Unit;
if (_Foot) then
{
if>
20:34:41   Error position: <objectParent _Unit;
if (_Foot) then
{
if>
20:34:41   Error objectparent: Type Array, expected Object
20:34:41 File Vcom\Functions\fn_ArmStatics.sqf [VCM_fnc_ArmStatics], line 10
20:34:44 Error in expression <VCM_fnc_ClstObj;

 

But it seems to be working.  No more battleeye restrictions.

 

 

 

Share this post


Link to post
Share on other sites

im enjoying this Vcom more than others ai mods..really like it alot

but one thing really makes me disable it and use other ai mods to beat mission witch i dont lik

 

is there any fix to make it works with vanilla and Dlc's Campagin? cus sometimes charachters/Viechels  dont move to the point they should to beat the mission

any fix?

 

im using mod version..Vcom is beast but hope a fix for this 

Share this post


Link to post
Share on other sites
Quote

12:01:18 Error in expression <VCM_fnc_ClstObj;
private _Foot = isNull objectParent _Unit;
if (_Foot) then
{
if>
12:01:18   Error position: <objectParent _Unit;
if (_Foot) then
{
if>
12:01:18   Error objectparent: Type Array, expected Object
12:01:18 File Vcom\Functions\fn_ArmStatics.sqf [VCM_fnc_ArmStatics], line 10

 

Share this post


Link to post
Share on other sites

Jus61, I'm getting that error and one other - see two posts above.   Are you getting that one, too?  I've not found a fix yet.

 

 

 

Share this post


Link to post
Share on other sites
On 5/21/2018 at 9:42 PM, kaicooper87 said:

im enjoying this Vcom more than others ai mods..really like it alot

but one thing really makes me disable it and use other ai mods to beat mission witch i dont lik

 

is there any fix to make it works with vanilla and Dlc's Campagin? cus sometimes charachters/Viechels  dont move to the point they should to beat the mission

any fix?

 

im using mod version..Vcom is beast but hope a fix for this 

guys any tip?

Share this post


Link to post
Share on other sites

I posted this as an issue on GitHub but I am not sure if its really an issue or just something that will not work.

 

I am trying to use VCOM on an existing BECTI mission which I believe uses the ARMA High Command module. After completing the first objective I lose control of the ai units and they will not respond to any new commands. Does VCOM work with HC? 

Share this post


Link to post
Share on other sites
On 5/24/2018 at 7:08 AM, kaicooper87 said:

guys any tip?

 

Having the same issues. But very thankful for the mod regaurdless!

Share this post


Link to post
Share on other sites

Hello, I've been using the VCOMAI Script for quite some time and haven't really had any issues with it until now.

I'm getting the following error in my mission:

Ez7VOJ3.png

Link to Picture!

 

I have everything I am suppose to have in the description.ext and in the init.sqf.

Sorry if this has already been mentioned but I have a hard time reading large quantaties of text.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×