Jump to content
Sign in to follow this  
snkman

Group Link 4 Special FX Edition

Do you use the "Script/Mission Based" initialize?  

67 members have voted

  1. 1. Do you use the "Script/Mission Based" initialize?

    • Yes
      24
    • No
      32
    • Sometimes
      12


Recommended Posts

SNKMAN ... wonder if you can shed light on this.

I cannot seem to remove makers from missions in GL4 since patches. I have ACE and GL4 and setting not changed with makers off in all but disabling Gl4 is ok, re enambling shows markers ... heres all the values I have in configs:

GL4_Debug.sqf:

// GL4 Enemy A.I. Map Marker Debug:

// ==============================================================

// Choose if the "Map Marker" debug should be used.

// Note: This debug creates a map marker for each enemy A.I. group which was initialized by Group Link 4.

// Info: This debug is available in multiplayer.

// True / False, default is True

GL4_Debug set [3, False];

// Enemy A.I. Map Marker Debug Type:

// Choose which "Map Marker Type" should be used.

// Note: Choose True to enable millitary markers.

// "Dot", "Arrow", "Select", "Destroy" / True, default is True

// GL4_Debug set [4, "Dot"];

GL4_Local:
// ==============================================================

// GL4 Player Map Marker:

// ==============================================================

// Choose if a player should use/get a map marker.

// True / False, default is True

(GL4_Local select 0) set [0, False];

// GL4 Player Map Marker Type:

// ==============================================================

// Choose which "Map Marker Type" should be used.

// Note: Choose True to enable millitary marker types.

// "Dot", "Arrow", "Select", "Destroy" / True, default is True

// (GL4_Local select 0) set [1, "Dot"];

in GL4_Global there is a text entry:

2.) Enemy A.I. Debug:

* Array

* Marker

I search for "Marker" and looked but that entry isnt in there for anything to switch off (I assume its moved to the debug script?)

ANy tes with this setting (that were ok) I can still see enemy markers, the clue for me is some markers will add "Garrison" to the tag so guess thats GL4. If I simply take Gl4 out of modline and run all markers are off via ACE ... they just come back with GL4 running.

Any pointers? Anyone else not able to turn them off no matter what?

EDIT ... ok I think I had my GL4 mod folder mixed up .. I seem to be using official, and then realised the config is the beta you sent, and I wasn't running the beta mod folder, please forget.

Edited by mrcash2009

Share this post


Link to post
Share on other sites

Hi guys. I have a problem with Group Link 4 : airplanes seem loose they fuel and crush them to the ground but not the player's one; how could this possible ? could you help me ? I say I've downloaded it firstly from Six Updater, then from Armaholic

Share this post


Link to post
Share on other sites

Hi,

I just want to say thank you for your hard work on this mod. As an Arma newb, I in particular like the auto-initialize option, I am sure it saves me from myself!

I am still learning the basics by creating little fire-fight scenarios in the editor, and using this in conjunction with Zeus has given me many great moments.

Thank you again for all of the effort you have obviously put into this mod :)

Share this post


Link to post
Share on other sites

@SNKMAN

Are you still working on GL4? Yes I know you are still working on it, I just wanted to hear anything of you and about how GL4 is progressing.

Any chance you will release a new public version soon? Yes I know BIS is releasing patches like in a factory, but I think it would be a good moment to release GL4 Triforce based on 1.56 patch. Although maybe 1.57 is bringing soon more changes.

I am still amazed how good your old GL4 works, after all these patches. But still there are some features missing (because of incompatibility with OA) like radio chatter.

So please release us from waiting and share the version you cooked up please!

Share this post


Link to post
Share on other sites

I have a basic question: I want all of the AI enhancements, Artillery FX, Backblast FX, Blood FX, Burning FX, Crew Burning, Explosion FX, Impact FX, and Rocket FX.

What Pbos would I use or not use. I don't want any new sounds other than the incoming arty sound.

Share this post


Link to post
Share on other sites

Does anyone else have a problem with the OA campaign with GL4 turned on? Mine keeps freezing if it loads something in the middle of a mission (for example, using the UAV backpack in the 4th mission, or the spot where the friendlies come in to setup FOB Planck in the Pathfinder mission)?

Share this post


Link to post
Share on other sites

Hi SNKMAN,

I disabled a lot of the FX features in the GL4_Local.sqf. At the moment Blastcore WARFX is my favorite FX-mod ;) .I enhanced it with some of your features, i missed in WARFX. I only activated some features under GL4 Explosion FX like: fuel smoke dust wave and also the wrack fx.

I would like to reactivate the fire at the debris laying around. What GL4 local set number is it and what other numbers have to be activated (True or for example 100%). Thx.

Tino

Share this post


Link to post
Share on other sites

A bit of historical trivia. I just found out (through research) that the files inside the GL4_Air_Land_Chatter folder in the GL4_Radio_Chatter pbo are radio transmissions recorded on June 22nd, 1967. The unit is 2nd Battalion, 503rd Infantry, 173rd Airborne Brigade which was based from Dak To. "Alpha 6" is Captain David A. Milton, and the 2 elements he says he believes he has "lost completely" were his 2nd and 3rd platoons. Alpha company had ran into an entire NVA battalion on the slopes near Dak To.

The daylong firefight ended with 76 KIA and 24 WIA Americans, and an estimated 400-500 dead NVA.

Share this post


Link to post
Share on other sites

I love the mod and my favorite part is being able to recruit AI, but sadly I cannot get this feature to work in MP. I can recruit AI of the friendly side no problem in single player, but when it comes to MP no luck, please help

Share this post


Link to post
Share on other sites

does gl4 work well with the changes made to take cover and dofire commands?

will the next version?

Share this post


Link to post
Share on other sites

I hope that everything is OK with SNKman as it has been over a month since he last posted here. Before he was regular, even a pillar of the community...

So does anyone have any news from him?

Share this post


Link to post
Share on other sites

Isn't he with Project Reality now? If so, then I'm sure that is keeping more than plenty busy and why he hasn't been heard from in awhile. :)

Share this post


Link to post
Share on other sites
Isn't he with Project Reality now? If so, then I'm sure that is keeping more than plenty busy and why he hasn't been heard from in awhile. :)

looking forward to PR, going to be epic, but would hate to have to use that mod all the time in order to enjoy GL's new goodness.

Share this post


Link to post
Share on other sites

Is this compatible with sound mods and Blastcore? Thanks.

EDIT: Ah I just realized this is all done via modules. This means I can't play an existing mission with this right?

Edited by JuggernautOfWar

Share this post


Link to post
Share on other sites

EDIT: Ah I just realized this is all done via modules. This means I can't play an existing mission with this right?

I was asking myself that question and I found this post in this very thread. I'm not sure if this answers our Q:

Description:

------------

This release allows you to initialize all Enemy/Player/Friendly and Special FX features of Group Link 4 by default at mission start.

How To:

--------

Group Link 4 System Initialize ( Default ):

The Enemy A.I. Enhancement Player and Friendly A.I. Enhancement and Special FX will be initialized by default if you do not create the “Group Link 4: System†module.

This means all features of Group Link 4 will be initialized directly after the mission was started.

Note:

------

The default initialize of Group Link 4 may need up to 3 – 5 seconds ( depending on the group count ) of a mission becouse Group Link 4 need to wait/check if a “Group Link 4: System†module was created in the mission and set which groups/units are Enemy/Friendly to the player.

If no “Group Link 4: System†module was detected and the Enemy/Friendly sides was assigned then Group Link 4 will start to initialize all Enemy/Player/Friendly and Special FX features.

Info: The “Group Link 4: Custom†and “Group Link 4: Static†modules are still supported by the default initialize of Group Link 4.

Share this post


Link to post
Share on other sites
Is this compatible with sound mods and Blastcore? Thanks.

EDIT: Ah I just realized this is all done via modules. This means I can't play an existing mission with this right?

in my experience it works fine with most existing missions and makes em quite a bit better. there might be a problem for dynamically added AI (that is AI added in during the mission and after GL4 has initialised) but i am not sure.

also, if there's loads of groups/AI then i find quite a bit of slowdown but most missions do not use loads of AI as arma2 engines slows down a lot with them anyway (GL4 makes it more pronounced to me though.)

Share this post


Link to post
Share on other sites

Sorry, I have to jump in here and ask... as it seems you are talking about what I myself am wondering, but I'm still a bit confused.

I generally play dynamic missions, like Cipher or Flashpoint: Takistan... and among a few mods, I have GL4 installed.

At the start of the missions, I see the initialization messages, so I know something is happening there... but, I'm still a bit confused whether I need to set anything up or do anything in order for GL4 to be functioning during such random/dynamic missions... as I can't tell if they are present in the missions themselves... (I haven't noticed special explosions or fire... although I'm not entirely sure what I'm looking for, nor what the previous ones looked like, so it's hard to tell if it's 'working'...).

So, (again, forgive me if this has been answered already) after installing GL4 the usual way (resulting in the initialization messages appearing at the start of a random mission such as Cipher), is everything 'set and operational'... or is there some other setup I need to do?

Share this post


Link to post
Share on other sites

I have the UAV module placed in my mission with the following init

this setVariable ["name","Predator"]; this synchronizeObjectsAdd [(unitBackpack player)]
and this on my player unit init
removeBackpack this; this addBackpack "US_UAV_Pack_EP1";
This works fine and I get an action to go to UAV cam. However the second after I use the GL4 recruiting action on another unit and he is added to my group, I see the UAV action is gone and never reaapears untill I restart. Can anyone see if they can reproduce this or know of a reason/workaround? Thank you

Share this post


Link to post
Share on other sites

Hi. I'm getting the " 'sound/' is not a class " error message when starting a mission, and it seems to be from GL4.

Is it? And, if so, how would I fix it?

I'm running JSRS as well.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×