Jump to content

Recommended Posts

Hello Gemini.

We have played the mission today several ahours and we had a great time. Thanks a lot.

I have one question. Is it normal that when launching the mission first time and with the Virtual Arsenal activated, once the mision is saved "Save mision and player" when you launch the mision again the virtual arsenal is no longer available. Is this a feature or a glitch?

I have tested it in Tanoa and Stratis and happens the same

Share this post


Link to post
Share on other sites
Posted (edited)

Gemini,

 

I've been having fun playing the latest version (PR FATA).  An odd thing I noticed:  The past four tasks have been (destroy/recover armor, capture a bomb maker, deliver humanitarian supplies and find mortar).  What I've noticed is that the operation area on the map (for example, the mortar mission shows a region where the mortar might be found with a "?" in it" is always showing the previous goal.  This current mortar map is displaying as Deliver Supplies.  Deliver supplies was indicated on the map as (i forget exactly) capture the suspect.  The capture suspect task was indicated on the map as destroy/recover armor.  

 

Otherwise things have been going fairly well and the group is enjoying themselves.

 

Edit:  None of the PR FATA repair/rearm/refuel areas worked automatically (which the FAQ mentions should happen).  We were able to use a refuel truck and rearm truck but the repair trucks we spawned weren't able to repair.  We tried with engineer specialists and without.  Is there something special?

Also, enemies seem to have stopped spawning for missions.  The mortar position was abandoned, though empty vehicles were in the vicinity.  The drone recovery likewise had no enemy spawns.  Previous recoveries were crawling with enemies, but not this time.  I don't remember if zero spawns is possible or if something has gone on here.  I'm going to try to get a bug report from the game.

This server has been running constantly for 24 hours, no shut downs, only periodic saves at the TOC settings laptop.

Edited by Dynablue
Additional:

Share this post


Link to post
Share on other sites

@vitali66

Try to manually reset the mission.

Start a local MP game, then open the debug console (Esc), write execVM "reset.sqf" then press Exec.

 

@Say_Hey

I don't understand what is the issue ? The enemy amount and position is random and may also depend on the selected task.

 

@furia

Already reported, I'm working on it.

 

@Dynablue

This could be caused by server overload. When something strange happens, the best thing to do first is to restart the mission. If you used the persistent save after succeeding a task, this shouldn't be a problem as your progression has been saved.

Anyway, repairing/rearming/refueling areas are working properly on my side, even it's not automatic anymore - but you just need to select the proper wheel action (you are right, I need to update the FAQ).

 

  • Like 1

Share this post


Link to post
Share on other sites

OPEX has been updated to version 2.05.

 

Changelog :

  • Added: compatibility with the French faction from OFrP (Operation Frenchpoint) mod
  • Added: compatibility with the French faction from the combination of OFrP + R3F + AMF mods
  • Fixed: access to the virtual arsenal no longer disappears after loading a game
  • Fixed: task 12 "Repatriate dead bodies" should now be succeeded as intended after unloading the bodies near the medical center
  • Fixed: actions attached to portable tents and sleeping bags should now work properly
  • Fixed: actions to join/leave a player's group is now properly shown
  • Fixed: some HQ markers were sometimes disappearing after loading a game
  • Updated: enemy AI skills has been decreased (please don't hesitate to share your feedback about it)
  • Updated: usage of NVGs with any optic is now authorized again (as it seems it's now possible in real life)
  • Updated: added an entry in the FAQ to help users with the basic things to do before reporting a bug or an issue
  • Updated: contributor's panel and list (thanks to Rhinoferox)
  • Updated: a few other minor things

 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Gemini,

 

Did support/transport change during the update?  We summon transport, wait for map to open, click LZ, see the blue transport marker appear, wait for helo, helo lands and the transport marker immediately changes to green and we cannot command the helo to a destination (it used to just require waiting for the map to open again and selecting the destination, correct?).  It simply sits there on the ground, the map never opens and if we all disembark the helo never leaves.  We left one for three hours and it was still just waiting around on the green transport marker at the spot we designated as the pickup LZ.  

Share this post


Link to post
Share on other sites

No, nothing changed about that. Simply keep in mind that this is ArmA: some unexpected things may sometimes happen. Also, maybe the one who called for the transport did a missclick.

Share this post


Link to post
Share on other sites

Tested 2.05 today. Virtual Arsenal works great after a save. Camp Tents work great however the new  action to join a players group is not working or does nothing that we can appreciate. Is it intended to operate as a normal ARMA 3 group where the leader sees all soldier icons below?

 

I have experience what I think it is a bug now. Whe you try to spawn an infantry units no matter the size of the selected unit, you only get 1 single soldier that is the team leader. Rest of soldiers do not show up.

Another thing I have seen in OPEX Livonia version 2.04 is that when using the Spanish FFAA mod the spawned soldiers use desert cammo clothing that maybe its not the best option on the green forest of Poland. Base personel dresses in Woodland but spawned units in desert.

 

Thanks for all corrections and keeping OPEX as magnificent as it is. Me and my friends are playing daily and enjoying it a lot

Share this post


Link to post
Share on other sites
On 3/31/2020 at 10:02 PM, furia said:

I have experience what I think it is a bug now. Whe you try to spawn an infantry units no matter the size of the selected unit, you only get 1 single soldier that is the team leader. Rest of soldiers do not show up.

Well we probably have to disregard this above since yesterday everything was working good on this area in Livonia when I started a new game. I had this issue on a saved game in Tanoa so I will explore it today again to see if it reproduces.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the feedback.

  • It seems that most of the times, possible issues encountered with OPEX are because the server is overloaded by remote scripts execution. So restarting it may help a lot.
  • In addition, even if the persistent save should avoid losing progression, resetting all can help too, as it assures you to play with 100% fresh data.

There is probably many ways to improve all scripts included in OPEX, especially because I'm developping it since 2012 (so some scripts and way to think are totally outdated) but as I said previously I have unfortunatly almost no more time to work on it agin.

 

There will probably be a last update in a few days to fix last things I've noticed but after that do not excpect much more and frequent updates. In case of troubles, just apply the two tips above.

  • Like 1

Share this post


Link to post
Share on other sites

Nice work on these newest versions of OPEX. I've especially been enjoying playing on Livonia with the British Armed Forces from the 3CB mods. With v2.04 everything seemed to work fine except for a few crashes but I believe I fixed those problem by trimming my mod set a bit. However, with v2.05 I'm experiencing troops dressed for desert combat on the Livonia terrain. Furia mentioned the same error above but with the FFAA mod (though he said he encountered the bug with v2.04). I don't know if he experienced it with v2.04 (I didn't) or if that was a typo but the bug definitely exists in v2.05 of the Livonia port. I also tried it with the RHS Russian faction and they were dressed for desert warfare as well. I suspect it's just a typo in a config file and hopefully an easy fix. Thanks again for such an awesome mission experience.

  • Thanks 1

Share this post


Link to post
Share on other sites

Yep, there's an issue with the camo selection. I'm working on it.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

 Hello, everyone, hello Gemini.

 

First of all, a big bravo for all the work done on this mod, I'm blown away!

Me and a few simulation freaks are just discovering this universe and we are still far from having discovered everything. By the way, the OPEX in game FAQ is very useful, thanks for that too!

Well, you can imagine that if I'm writing it's because I have some questions, otherwise it's not funny ! 😉

 

Having some computer knowledge, I started the project to create a dedicated server which is for the moment only for my friends. I would like to dedicate it only to play the OPEX mod and nothing else for the moment.

To do this, I created a virtual machine under debian 10, I then followed the installation on linuxgsm.com. So far no problem. I also inserted the following mods:

"@armamodfrance v_0.0.5.1", @cba_a3, "@cup terrains - core", "@cup terrains - maps", "@cup units", "@cup vehicles", "@cup weapons", "@gemini - items for opex", "@mod jackfrench arma 3", "@r3f armes 3.6.2", "@r3f units 3.8", "@r3f vehicules 1.0".

According to the logs, they are well recognized and not to worry. (log available if needed).

 

I launched the server, and connected to it, and ran an OPEX scenario! And now I have some questions.

For starters I have vehicles overturned or completely bugged in the ground, how to fix this problem?

Then when I do a mod check using the "laptop" in the tactical center here's what is displayed: thumb.php?api=SYNO.PhotoStation.Thumb&me

Did I miss something in my setup?

I apologize in advance if this kind of question has been addressed before, but despite my research, I have not found an answer anywhere.

Anyway, congrats again on the monster job!

 

Yours sincerely.

Stan

 

Spoiler

 

Bonjour à tous, bonjour Gemini.

 

Tout d'abord, un grand bravo pour tous le travail effectué sur ce mod, je suis époustouflé ! 

Moi et quelques mordu des simulations, découvrons à peine cette univers et nous sommes encore loin d'avoir tout découvert. D'ailleurs au passage le FAQ OPEX in game nous est très utile, merci pour ça aussi !

Bon on se doute bien que si j'écris c'est que j'ai quelques questions, sinon c'est pas drôle ! 😉

 

Ayant quelques notions informatique, je me suis lancé dans le projet de créer un serveur dédiée qui est pour l'instant uniquement pour ma bande d'amis. Je voudrai le dédier uniquement pour jouuer au mod OPEX et rien d'autre pour l'instant.

Pour ce faire, j'ai créé une machine virtuelle sous debian 10, j'ai ensuite suivi l'installation sur linuxgsm.com. Jusqu'à là pas de souci. j'ai également inséré les mods suivant :

"@armamodfrance v_0.0.5.1", @cba_a3, "@cup terrains - core", "@cup terrains - maps", "@cup units", "@cup vehicles", "@cup weapons", "@gemini - items for opex", "@mod jackfrench  arma 3", "@r3f armes 3.6.2", "@r3f unites 3.8", "@r3f vehicules 1.0".

Selon les logs, ils sont bien reconnu et pas de souci. (log dispo si nécessaire).

 

J'ai lancé le serveur, et me suis connecté dessus, et j'ai lancé un scénario OPEX ! Et là j'ai quelques questions.

Pour commencé j'ai des véhicules retournés ou complètement bugé dans le sol, comment régler ce souci ?

Ensuite quand j'effectue une vérification de mods à l'aide de l'"ordi portable" dans le centre tactique voilà ce qui s'affiche : thumb.php?api=SYNO.PhotoStation.Thumb&me

Ai-je loupé quelque chose dans ma configuration ?

Je m'excuse d'avance si ce style de questions a déjà été traitée, mais malgré mes recherches, je n'ai trouvé de réponse nul part.

Quoi qu'il en soit, encore bravo pour le boulot monstre !

 

Cordialement.

Stan

 

 

 

Edited by Dedmen
Translated to english. Keep in mind this forum is english only.
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Stan, thanks for this message.

I can't visit the picture URL, can you please provide a functional one ?

Share this post


Link to post
Share on other sites

This check is case sensitive so if mod folders are not exactly the same, this happens. But if mods are properly installed I suppose that should work.

Anyway, did you try to reset the mission, or try the other versions, to check if your issues happen every time ? If yes, can you please use the "Report bug" action from the same laptop in the game, and send me your RPT file ? So I could have more details about what's going on.

 

Anyway, OPEX has just been updated to version 2.06.

 

Changelog :

  • Added: phronk's Addon-Free Arma Radio script (AFAR) - for people playing in MP without TFAR or ACRE
  • Added: compatibility with the French faction from the combination of OFrP + FAF + AMF mods (thanks to Mikelima)
  • Fixed: camo selection based on played map
  • Fixed: wheel action to join/leave a player's group should now work as intended
  • Fixed: the AI guy who was moving through the TOC shouldn't do it anymore (Kunduz)
  • Updated: increase IED probability
  • Updated: Tanoa has been virtually relocalized in French Guiana

 

 

Edit : OPEX has been updated to version 2.061.

 

Changelog :

  • Fixed: no more error message when using AFAR radio
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Does this mission track which area you have cleared and enemy camp destroyed while going out for a patrol? i.e., once i secure a town it stay secured until AI come to take it again? i guess what i am after is similar to alive. Or is the open world patrol just a way to farm intel and but no real impact on the mission progression?

 

Also is there any way to save AI teammate? does it help if i move them to High command? and would high command team be saved?

is it possible to do persistent save outside TOC?

 

Thanks for the great mission, just wish to have more video in english on youtube to get a better sense from it.

 

edit: test and seems no AI, HC or teammate can be saved sadly.

  • Thanks 1

Share this post


Link to post
Share on other sites

Salut Gemini,

I've a question regarding loadout,

Why when we select a loadout in the rolling menu in armory, no one have a silencer in the vest or backpack?

But when you recruit a unit, they have it when you go to steath.

Is it possible to add directly in unit backpack to avoid forgetting our own?

Or don't have it if you switch a unit and want to add silencer?

Anyway, again all my congratulations for this great job

Thanks,

  • Thanks 1

Share this post


Link to post
Share on other sites

how to use it on dedicated server ?  need author recomendation about mod list and mission settings

Share this post


Link to post
Share on other sites

@shi4stone

Everything outside the HQ is dynamic and regenerated each time a player leaves the area so there is not sector to control. Getting intel allows to recruit extra supplies, supports etc...

At this time the persistent save doesn't allow to save AI teammates because it requires to much work and I have no time left to work on it. Maybe someday Bohemia will add a save system compatible in MP, so we won't have to try to do it by ourselves.

 

@Guillaume Massé

Sorry I don't have time left to update it.

 

@otarius-big

What recommendation about mod list and mission settings do you need ? To install OPEX on a dedicated server, just do it as any other MP mission.

Share this post


Link to post
Share on other sites
1 hour ago, Gemini said:

@shi4stone

Everything outside the HQ is dynamic and regenerated each time a player leaves the area so there is not sector to control. Getting intel allows to recruit extra supplies, supports etc...

At this time the persistent save doesn't allow to save AI teammates because it requires to much work and I have no time left to work on it. Maybe someday Bohemia will add a save system compatible in MP, so we won't have to try to do it by ourselves.

 

Would it be possible to add refund function so that i get the intel bacak if i bring the AI back to HQ and demobilize them?

A bit of pity that the world itself is not persistent. I can only dream one day Alive and this can be combined:)

Share this post


Link to post
Share on other sites

Hi, 

 

When I sent up a tent as a respawn, when I die and press respawn,  button does not work, cones up with you died, restart or end ? mission restarts from computer, what am I doing wrong here ? 

I was having better luck with the old save system, so annoying when you get so far then some bad guy takes you out, then having to restart from scratch   help !

Share this post


Link to post
Share on other sites

@shi4stone

This is already the case, demobilizing AI units in the delivery area funds back the intel.

 

@terrydraper

I don't understand, can you say it again with an understandable syntax ?

Share this post


Link to post
Share on other sites

Hi!
Great mission, we've had a lot of fun playing it with friends!

  • Like 1

Share this post


Link to post
Share on other sites
55 minutes ago, Gemini said:

@shi4stone

This is already the case, demobilizing AI units in the delivery area funds back the intel.

 

@terrydraper

I don't understand, can you say it again with an understandable syntax ?

I pick up the tent and deploy, it tells me it's a respawn point, but when I die there's no option to respawn,  end up having to start again from toc, I play sp 

Share this post


Link to post
Share on other sites

Respawn is a feature for MP.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×