Jump to content

Recommended Posts

Why is it, that when others do things however they want I always (yes, always) get blamed for causing confusion while I am not the one causing the confusion in the first place. I guess my name just writes easier....... ?

It seems that if I adapt to mess I am the one causing it, and if I ignore mess I get told I am not messy enough.

How can I cause confusion when I write, and I quote:

There is nothing to update as nothing was updated by the author himself.

Versionning is a pain; we should use release dates as version numbers! ^^

Nice idea, but all you do is change the way how people will get confused....believe me .... :D

  • Like 6

Share this post


Link to post
Share on other sites
LJ, There is a small problem with the sound of movement. Or is it a problem with vanilla animations? I'm not sure

If the player character uses the pistol and is in a crouch, then while sprinting (W+shift) the rhythm of the sound of players steps is not correct.

This sound runs like a horse, but not like man. 

 

For comparison, you can take up your primary weapon and do sprint. You will hear the normal rhythm of the steps. 

LJ please fix this, in next update if possible.

  • Like 1

Share this post


Link to post
Share on other sites

 

LJ, There is a small problem with the sound of movement. Or is it a problem with vanilla animations? I'm not sure
If the player character uses the pistol and is in a crouch, then while sprinting (W+shift) the rhythm of the sound of players steps is not correct.
This sound runs like a horse, but not like man. 
 
For comparison, you can take up your primary weapon and do sprint. You will hear the normal rhythm of the steps. 
LJ please fix this, in next update if possible.

 

I can confirm that! I noticed when I played as civilian.. 

Share this post


Link to post
Share on other sites

Versionning is a pain; we should use release dates as version numbers! ^^

 

For mods that are updated regularly this is a great idea....TPW MOD has been doing it this way from it's original release, works a treat and causes no confusion....apologies for veering of topic slightly.  :)

Share this post


Link to post
Share on other sites

For mods that are updated regularly this is a great idea....TPW MOD has been doing it this way from it's original release, works a treat and causes no confusion....apologies for veering of topic slightly.  :)

Well then lets get back on topic then please ;)

  • Like 1

Share this post


Link to post
Share on other sites

Just for one last time: What the first page on this topic says, matters! Not someone telling you a version, not pws, not anything else... Just what I tell you! Because I must know, right?

Good.

LJ

  • Like 2

Share this post


Link to post
Share on other sites

This is what I get when searching for JSRS on PWS:

geP3qsp.jpg

:yay:

JSRS3: DragonFyre (latest v2.0.1), JSRS 2 (latest v2.2), JSRS 2 LITE (latest v1.0), JSRS3: DragonFyre 2.5 (latest v1.1), JSRS3: DragonFyre LITE (latest v1.0.0.2), JSRS3: DragonFyre EDEN (latest v1.4.0.1)

:yay:

 

This is confusing as heck for someone who didn't follow the mods development over time.

I only install it from the links on the first page for this very reason.

I'd kindly suggest for the PWS people to remove all but the latest version of JSRS, that would clear up most confusions for beginners/newbies.

 

Curious about the Apex release, it's always a pleasure to go through various weapons/vehicles and see what has changed.

 

Cheers

  • Like 4

Share this post


Link to post
Share on other sites

And that's exactly the problem. All of them need to be deleted to stop this confusion...

LJ

Share this post


Link to post
Share on other sites

So finally...

 

The JSRS4 APEX 1.0 release is here!

 

https://forums.bistudio.com/topic/187343-jsrs4-apex/?p=2966265

 

So, now again to the confusing topic: This is the 4th mod, JSRS4! The name of this mod is APEX as it covers the new content, and the version of this 4th mod is 1.0!

 

So, please, delete all old files you have, even the 1.4RC version of the third JSRS (JSRS3 DragonFyre EDEN 1.4). Everything gotta go! This is a stand alone mod. Also this goes to PWS and ArmAholic, please delete the old mods as those tend to cause malfunctions as ArmA got updated and many changes coming our way.

 

The full release of APEX with probably change a few things again, so basically you can use the stable and the apex preview, but as soon as APEX gets released (somewhere around July I think) you can switch back to stable and it should work fine.

 

Due to the fact that most vehicles are not final ingame yet, I decided to add the missing vehicle contents of APEX later, probably when APEX hits the stable branch.

 

LJ

  • Like 7

Share this post


Link to post
Share on other sites

Congratulations on the release LJ ! And perfect timing as I am about to start a full day of playing Arma ;)

Share this post


Link to post
Share on other sites

Congrats LJ.

 

Aural Pleasure Emitting X-factor. 

  • Like 1

Share this post


Link to post
Share on other sites

So with the stuff in the EXTRAS folder.If I have all the DLC and only play SP, I should add all of that into Addons?

 

Seems to be an issue with the SPAR-17. you only hear the echo and sonic crack when firing it suppressed. Everything else sounds amazing though-i love the sounds for the SPAR-16

Share this post


Link to post
Share on other sites

Awesome, thanks a lot !!

 

Question:

I still have "JSRS DragonFyre 2.5 - RHS" running ... isn´t it working anymore or does it cause malfunctions now?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Thanks very much for release LJ, much appreciated as usual.

 

Still getting this popup running dev:

popup2.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Thanks very much for release LJ, much appreciated as usual.

 

Still getting this popup running dev:

popup2.jpg

That doesn't have anything to do with JSRS though does it?

Share this post


Link to post
Share on other sites

That doesn't have anything to do with JSRS though does it?

 

It could; it's usually related to config inheritance problems.

 

Haven't downloaded JSRS4 yet though, so I can't confirm.

Share this post


Link to post
Share on other sites

So with the stuff in the EXTRAS folder.If I have all the DLC and only play SP, I should add all of that into Addons?

 

Seems to be an issue with the SPAR-17. you only hear the echo and sonic crack when firing it suppressed. Everything else sounds amazing though-i love the sounds for the SPAR-16

 

The content under extras is for the APEX weapons and the movement sounds on Tanoa island. The "jsrsapex_reloadingsounds..." are for normal and apex weapons, either separated. Those are the sounds that cause the server rpt problems and you can decide to use them or not. The reloading sounds can be allowed on the server via the jsrs_apex_handling.bikey! The reloading sounds have a different signature as well.

 

Awesome, thanks a lot !!

 

Question:

I still have "JSRS DragonFyre 2.5 - RHS" running ... isn´t it working anymore or does it cause malfunctions now?

 

Thanks in advance!

 

I think that wont work properly anymore and can be deleted. The sound engine has been changed since the release of this RHS pack I made! And if you have trouble with it or anything, I dont support it anymore.

 

Thanks very much for release LJ, much appreciated as usual.

 

Still getting this popup running dev:

popup2.jpg

 

I only support Stable or Apex preview build ;)

 

LJ

Share this post


Link to post
Share on other sites

Testing it right now and like it so far. 

However, the LIM-85 (The M249 Para alike) does have two fire modes. Both sound different with JSRS. (I think only the first mode, the slow one is changed by JSRS)

Share this post


Link to post
Share on other sites

Testing it right now and like it so far. 

However, the LIM-85 (The M249 Para alike) does have two fire modes. Both sound different with JSRS. (I think only the first mode, the slow one is changed by JSRS)

 

Yeah thats one of the things I have no clue how to fix it. The fast firemode is based on the slow one, if I type that into the config however, the fast mode is as slow as the slow one... weird!

 

LJ

Share this post


Link to post
Share on other sites

Anyone else having the SPAR-17 issue? only can hear the echo and sonic crack when suppressed-no sound of the actual shot.

Share this post


Link to post
Share on other sites

Thanks very much for release LJ, much appreciated as usual.

 

Still getting this popup running dev:

popup2.jpg

 

I'm getting the same issue on Apex Sneak Peek branch too,

I also experience the silenced SPAR-17 issue, can't hear the firing itself.

  • Like 1

Share this post


Link to post
Share on other sites

JSRS4 creates a reloading and reloadingAPEX-something dependency in an editor mission files. Gotta fix that?

 

In fact today I've learned the hard way not to binarize editor mission files because JSRS3 was creating a Dragonfyre_P07 dependency which made mission unopenable and all JSRS3 download links are dead so only a fake dummy config creating that class helped to load my mission.

Share this post


Link to post
Share on other sites

JSRS4 creates a reloading and reloadingAPEX-something dependency in an editor mission files. Gotta fix that?

 

In fact today I've learned the hard way not to binarize editor mission files because JSRS3 was creating a Dragonfyre_P07 dependency which made mission unopenable and all JSRS3 download links are dead so only a fake dummy config creating that class helped to load my mission.

 

Pro tip: Always ever launch those mods that are needed for the mission. Otherwise stuff like this happens.

(Maybe besides mods like 3denhance)

Share this post


Link to post
Share on other sites

Yes I've noticed the same exact thing. Something changed recently and strictly clientside only mods are creating dependencies when they never ever did in the past.

I almost fluffed a mission of mine because I had LSD's Full Screen Night Vision in the launcher when I saved my mission file. It had never ever happened to me before.

This is definitely a good word or warning for JSRS mission makers.

  • Like 1

Share this post


Link to post
Share on other sites

I'm getting the same issue on Apex Sneak Peek branch too,

I also experience the silenced SPAR-17 issue, can't hear the firing itself.

I have that error without any JSRS - I think its a Dev Branch issue....I think?

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×