Jump to content

Recommended Posts

Love the mod, big fan, just wanted to ask about a problem I noticed, with JSRS creating a dependency for the mission when (if you create it while jsrs is installed). 

Got a bad surprise when some of my players who didn't have it tried to join and were unable to.

 

Never had that happen with previous versions, but enough has changed with the base game of arma that maybe something else is the problem here. Has anyone else seen this? 

Share this post


Link to post
Share on other sites

Love the mod, big fan, just wanted to ask about a problem I noticed, with JSRS creating a dependency for the mission when (if you create it while jsrs is installed).

Got a bad surprise when some of my players who didn't have it tried to join and were unable to.

Never had that happen with previous versions, but enough has changed with the base game of arma that maybe something else is the problem here. Has anyone else seen this?

That's most likely an updating base class error. They appear when something within the classes had changed, for example in weapon or vehicle or what ever. Like if I had a burst firemode for the sting9 in my config but BIS upgraded their game and now it has only semi and full auto firemode, my mod becomes an 'updating base class' mod, because I do not only change something, I also ADD something. That's why the 'update' base class.

I will have to look into the rpt and pin point the updated class and then I'll fix it. Its a common problem during the development as many classes get updates or changes I don't know about until someone posts a problem like this.

Thanks for the info ;)

LJ

  • Like 1

Share this post


Link to post
Share on other sites

No problem, thanks for the clarification. And thanks for the awesome mod!

Share this post


Link to post
Share on other sites

Yeah they are RHS.

 

The thing is, if i disable your mod, those weapon sounds work fine. But when I enable it, they get messed up.

 

 

 

 

 

Is it known to cause issues if you use this mod with RHS? 

 

I think he's talking about the old JSRS RHS 2.5 mod. It no longer works since it depends on configs of old JSRS EDEN 1.3, and many file name changes (mainly "+.ogg") have taken placed during the 1.3 => 1.4 update. You'd better disable it until LJ releases new RHS support.

 

Other than that, JSRS & RHS should be ok to use together ( just don't expect RHS weapons to use JSRS sounds, they still use default RHS sounds), unless there is really an "updatng base class" issue, mentioned by LJ. I don't think it's the case because since I fixed JSRS RHS 2.5 mod manually for 1.4, my group have played with them with no issue for many hours.

 

About the SMAW spotting round, you still need the patch in my old post to get rid of the explosion sound. JSRS 1.4 update didn't magically fix RHS's round, I'm afraid.  :)  

 

Edit:

After some digging, Here:

 

RHS SMAW Spotting Rounds Explosion Sound Fix
  • Like 1

Share this post


Link to post
Share on other sites

Updated mod v1.4.0.1 available at withSIX. Download now by clicking:

banner-420x120.png

 

 

This addresses the problem with the ServerSide mod folder problem on the PwS network and is just the 1.4 RC release.

Share this post


Link to post
Share on other sites

This addresses the problem with the ServerSide mod folder problem on the PwS network and is just the 1.4 RC release.

Thanks. The server side files will be separated in future and only be published in our ftp ;)

I edited most when not all of the reloading sounds. The new ones for apex where so great that I had to adjust the vanilla ones :) also made some progress further to the release and will update you with changes tomorrow.

LJ

  • Like 4

Share this post


Link to post
Share on other sites
Hi LJ! 

In the Previous versions of your mod (I don't remember exactly in which version) You have added the sounds of the destruction of the building, durring building collapse.

Unfortunatelly In Arma, the visual destruction is not good, but at least, by means your mod it sounded fine!

 

I recently discovered, that this sounds of a building destruction has disappeared! 

I even tried to run version 1.0 of Eden-version, but I never heard the sound of destruction.

What happened? Why the player will no longer hear these sounds?

Please try return this sounds in the next version DragonFyre  ;), these sounds were beautiful

Share this post


Link to post
Share on other sites

 

Hi LJ! 
In the Previous versions of your mod (I don't remember exactly in which version) You have added the sounds of the destruction of the building, durring building collapse.
Unfortunatelly In Arma, the visual destruction is not good, but at least, by means your mod it sounded fine!
 
I recently discovered, that this sounds of a building destruction has disappeared! 
I even tried to run version 1.0 of Eden-version, but I never heard the sound of destruction.
What happened? Why the player will no longer hear these sounds?
Please try return this sounds in the next version DragonFyre  ;), these sounds were beautiful

 

 

There had been a Change with the entries during the development of the APEX Version. I think I'll rebuild the environment config anyways, as I have to make the Altis and Stratis sounds fit the Tanoa sound level.

 

The building effects are based on a environmental effect, dont ask me why tho...

 

LJ

  • Like 3

Share this post


Link to post
Share on other sites

LJ please update downloadable version 1.4.0.1 on the Armaholic

That's for Armaholic to do, not LJ. Perhaps notify them.

  • Like 1

Share this post


Link to post
Share on other sites

That's for Armaholic to do, not LJ. Perhaps notify them.

I not know about, thanks

  • Like 1

Share this post


Link to post
Share on other sites

There is nothing to update as nothing was updated by the author himself.

However, since others cause confusion to others making those others believe others (and that would be Armaholic) are not properly up to date I have simply updated our page, using the authors own original file (to make 200% sure we host the most up to date) and adapted to the same, unofficial version number to take away the confusion.

Armaholic mirror updated adapted:

news_download_a3_3.png

JSRS3: DragonFyre EDEN v1.4.0.1RC

  • Like 2

Share this post


Link to post
Share on other sites

There is nothing to update as nothing was updated by the author himself.

However, since others cause confusion to others making those others believe others (and that would be Armaholic) are not properly up to date I have simply updated our page, using the authors own original file (to make 200% sure we host the most up to date) and adapted to the same, unofficial version number to take away the confusion.

Armaholic mirror updated adapted:

news_download_a3_3.png

JSRS3: DragonFyre EDEN v1.4.0.1RC

 

Now I'm confused :X There was no 1.4.1 or 1.4.0.1 or what so ever... Its just 1.4 and its a standalone mod, all elder files should've been deleted... Any how I'll uploading JSRS APEX today and this will be the new and up to date standard...  it'll be available later the weekend.

 

LJ

  • Like 3

Share this post


Link to post
Share on other sites

Your uploading JSRS APEX today? Thats good news :D

 

Yeah but most likely wont release until sunday. There are some minor things I just spotted and the APEX vehicles are not fully finished by BIS, so I either wait for their full APEX release or have to reupate the mod, again :/

 

Beside that, I think JSRS4 APEX is going to be my best version so far! I'm really really pleased with my results so far and for the first time ever, there is nothing really bothering me! Before there were always some sounds I couldn't stand but was too lazy to fix them^^ Not this time, this time everything seems to legit and fits well... Really happy with it!

 

LJ

  • Like 8

Share this post


Link to post
Share on other sites

Lord, links in the first post are broken

 

Edit: Friend of mine setup a ded. server. Is there still the file, i guess in A2 it was called modparams.par or so, where u can enter all the addons the server should launch. I always found it easier to turn that file on and off in Arma2, for switching between vanilla and addons.

Share this post


Link to post
Share on other sites

Someone needs to merge this with SoS,as they both have their pros and cons  :P

Share this post


Link to post
Share on other sites

On the Armaholic version of DragonFyre was updated from 1.4 RC to 1.4.0.1 RC(in the discription section), but in the upload section I don't see any patch. 

Still only one link with the same size : 599 MB.

 

When I downloaded version 1.4 RC was a same size.  :(

Share this post


Link to post
Share on other sites

I loveit how foxhound wanted to clear things up to have the same versioning that is going around the internet (I think mainly PwS, where they had to use a different version because of a internal mistake), but with that he created an even bigger confusion.

However, when I understand that right (the above could be wrong aswell) there is no new version, the new versioning was an unofficial versioning in order to prevent confusion (fail).

Sorry if thats wrong! :3
 

Share this post


Link to post
Share on other sites

 

On the Armaholic version of DragonFyre was updated from 1.4 RC to 1.4.0.1 RC(in the discription section), but in the upload section I don't see any patch. 
Still only one link with the same size : 599 MB.
 
When I downloaded version 1.4 RC was a same size.  :(

 

 

 

I loveit how foxhound wanted to clear things up to have the same versioning that is going around the internet (I think mainly PwS, where they had to use a different version because of a internal mistake), but with that he created an even bigger confusion.

However, when I understand that right (the above could be wrong aswell) there is no new version, the new versioning was an unofficial versioning in order to prevent confusion (fail).

Sorry if thats wrong! :3

 

There is no new version, 1.4 RC is the current release. As LJ has said the next release would be the Apex release as per post #869.

  • Like 1

Share this post


Link to post
Share on other sites

Jesus :/

Its always the same will all the site trying to update it their way ... That's why I always recommend to use the links I give in the front page.

For usually Foxhound always updates correctly as I sometimes have a good chat with him...

And before there is any update somewhere on pws or armaholic, wouldn't it be mentioned here on the front page first? Yes! So it's still 1.4 until the next release today or tomorrow ;)

LJ

  • Like 3

Share this post


Link to post
Share on other sites

Versionning is a pain; we should use release dates as version numbers! ^^

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×