Jump to content

Recommended Posts

19 hours ago, Snipertac said:

Is there any setup procedures to getting GM to work on a dedicated Server?

I've loaded all of the files over to the server, but the server fails to load the addons for GM.  I'm able to run in on my machine as a Internet game via Arma - but not on dedicated.

 

Did you try to use the ARMA 3 LAUNCHER, click on PARAMETERS, ALL PARAMETERS and select HOST, SERVER? 

 

It would launch ARMA 3 into DEDICATED SERVER MODE with all the mods from a PRESET. 

 

You can do this to TEST it on your PC or remote machine if you cannot launch it properly with the command line.

Share this post


Link to post
Share on other sites
On 4/9/2021 at 11:04 PM, HeadshotFee said:

Thanks mate! 😄

 

 I think what you are actually looking for is the parameter menu in the multiplayer lobby. You can access it in the top right of the lobby screen when you are a logged in admin or selfhosting the mission.

Share this post


Link to post
Share on other sites

This mission seems to be limiting view distance to ~3k overriding game and server settings for view distance but I cant find the setting in any of the files.

If you could point me in the right direction would be great.

 

Thanks.

Share this post


Link to post
Share on other sites

@dasa I just use the debug console at the start of the mission and do a global execute for view distance commands.

Share this post


Link to post
Share on other sites

I've have been trying to edit the basic vanilla escape on stratis mission to create a custom unitclasses.sqf.

 

I changed the AI units and it works.

 

But when I add another mod's vehicles, and start up the game, it says something like "cannot find search heli. unit must have defined name."

 

This happens if the default heli is used, but if I added a tank or another vehicle to the O or I lists for example.

 

Do I have to actually REPLACE the existing units instead of adding to it? Or are there other related script files I need to update as well?

 

I do not want to change the map spawn locations or compositions. Just mainly the vehicles and AI units and some of the weapons available from the crates. Appreciate any advice.

Share this post


Link to post
Share on other sites
3 hours ago, Valken said:

 

But when I add another mod's vehicles, and start up the game, it says something like "cannot find search heli. unit must have defined name."

 

This happens if the default heli is used, but if I added a tank or another vehicle to the O or I lists for example.

 

Do I have to actually REPLACE the existing units instead of adding to it? Or are there other related script files I need to update as well?

 

 

No, you don't need to exactly replace the classes if it is an array. The error arises from a failed spawn: Unknown classname -> no vehicle spawned, script can't find the heli and throws the error.

The reason could be either you made a typo in the unitclasses.sqf so it is not read correctly by the mission or you made an array out of a single string. Could also be that the mod you are trying to add is not loaded on the server properly.

 

Share this post


Link to post
Share on other sites
8 hours ago, NeoArmageddon said:

 

No, you don't need to exactly replace the classes if it is an array. The error arises from a failed spawn: Unknown classname -> no vehicle spawned, script can't find the heli and throws the error.

The reason could be either you made a typo in the unitclasses.sqf so it is not read correctly by the mission or you made an array out of a single string. Could also be that the mod you are trying to add is not loaded on the server properly.

 

 

I think there is something off about the mod or the config.cpp files are not listing the vehicles names correctly.

 

I tested it by loading ARMA into VR map with the mod, dropped each vehicle with crew onto the map then highlighted the names, and copy and pasted it into the unitclasses.sqf in the missions SUB FOLDED de-pbo'ed.

 

Then loaded the mission in SP or MP mode. SP would throw up the error, MP would just hang.

 

I will check it one vehicle at time to see which ones vehicles work or not.

 

Thank you for the help!

Share this post


Link to post
Share on other sites

A dev release containing the new SOGPF CDLC release is out on Github: https://github.com/NeoArmageddon/co10_Escape/releases/tag/e5f1a95

 

The port to the awesome Cam Lao Nam terrain is probably one of our biggests ports yet, with 414 patrol spawn zones and 81 handselected comcenter positions.

Have fun and make sure to report all bugs like missing classnames etc here or on the escape Github.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×