Jump to content

Recommended Posts

There are already servers running custom versions of Escape for Western Sahara. Do a search for Sahara in the ARMA 3 Launcher to find it.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Valken said:

There are already servers running custom versions of Escape for Western Sahara. Do a search for Sahara in the ARMA 3 Launcher to find it.

I found the server you mentioned is SaltyDog. The problem is that they created \ edited and binarized it (Fair enough, as it certainly took work to edit, it's not fair for people to log into the server just download the mission and edit it without crediting), not being possible extract the PBO and edit the mission my way. The good thing about NeoArmageddon missions is that it is possible to add scripts and modify it freely.

Share this post


Link to post
Share on other sites
7 hours ago, Valken said:

There are already servers running custom versions of Escape for Western Sahara. Do a search for Sahara in the ARMA 3 Launcher to find it.

 

DLC port is already in the dev build since DLC was released.

To get the newest dev build, you can use the devpacker:

http://escape.anzp.de/EscapeDevPacker1.7z

  • Thanks 1

Share this post


Link to post
Share on other sites

@P4nz3rW4r Glad you found it. They put a lot of work into scripting their missions as well so that is probably why they binarized it.  Server is opened to anyone to play tho and they are a good group of players to game with.

 

@NeoArmageddonThank you! 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Valken said:

@P4nz3rW4r Glad you found it. They put a lot of work into scripting their missions as well so that is probably why they binarized it.  Server is opened to anyone to play tho and they are a good group of players to game with.

 

co10 Escape is released under APL-SA. As far as I understand, that means they must disclose the changes they made to the mission.

  • Like 1

Share this post


Link to post
Share on other sites

If you check their mission file, it has other scripts inside which are QoL type changes such as speeding up the player movements. I am unsure what actual mission code if any they changed.

Share this post


Link to post
Share on other sites
On 10/20/2021 at 12:00 PM, determity@googlemail.com said:

@aussie battler , ya know i completely forgot that Scuffy posted detailed instructions on how to correctly port to other maps , well ive now taken this all on board and made great progress ( it was easier than i thought , but very time consuming ! )

 

 I have now created a correctly ported mission on the UMB Colombia terrain and edited the unit configs to use South American factions from the selected mods. 

 

Here is the published steam workshop version , the dropbox link to the mission PBO can be found there too. 

 

 https://steamcommunity.com/sharedfiles/filedetails/?id=2631992796

 

Me and a friend have done many hours of testing , and with debug on at times , i have yet to find anything that is broken , evac is working fine , all military traffic and patrols seem to be spawning correctly , all village and boat markers populate as they should , altho im not sure how to get boat evac working, but apart from that everything plays solid from start to finish 

 

 

Hey determity, good job. Can you also send me the marker missions, then I'll put it into the next versions. I had also already looked at UMB Colombia and thought that might be a nice terrain for an Escape.

Small thing: If you do any other terrains in the future, best do a "clean" version first without other addons, it's easier to add when no additional mods are needed. No big deal here, I'll just ctrl+f the braf_ boatsin mission.sqm.

 

Also thank you to aussie battler for helping 👍

  • Like 2

Share this post


Link to post
Share on other sites

I'm having difficulties in creating a dedicated server with DLC Western Sahara, I can create a host through the game menu normally with the mission co10_Escape_WS_NATO_Desert_vs_SFIA_and_Tura.SefrouRamal, but when I try to up a dedicated server, the server process is terminated without reporting an error or sometimes the following error appears:

 

19:48:46 Game Port: 2302, Steam Query Port: 2303
19:48:47 Mission Escape Sefrou-Ramal Western Sahara NATO Desert vs SFIA 1.10 dev 4c7d6ac read from bank.
19:48:47 Host identity created.
19:48:47 Roles assigned.
19:48:47 Reading mission ...
19:48:47 mpmissions\__cur_mp.SefrouExtension\mission.sqm/Mission/Entities/Item21/Entities/Item0.type: Vehicle class B_D_Soldier_TL_lxWS no longer exists

 

Stay in this infinite loop trying to read the mission. I think I don't know how to get the server up by forcing it to load the DLC Western Sahara...

 

A friend created the following .bat and it always worked very well to create a server with any other mission or mod (just edit which mods will be used.)

title LEAL SERVER
@echo off
C:\Windows\System32\mode con cols=50 lines=7 >nul
set /a var=0
color f
 
:start
cls
 
title LEAL SERVER ( %var% CRASHES )
echo -------------------------------------------------
echo           SERVIDOU CRASHOU %var% VEZ(ES)
echo -------- Esta Sessao comecou as: %time% ---------
echo ---------------- Rodando Servidor ---------------
echo ---------------- ARMA DEDICADO ------------------
echo -------------------------------------------------

 
start "" /wait /high "D:\Arma 3\Master\arma3server_x64.exe" -maxMem=8196 -cpuCount=4 -exThreads=8 -hugepages -malloc=tbbmalloc_x64 -pid=pid -server -port=2302 "-config=D:\Arma 3\Master\serverconfig.cfg" "-profiles=D:\Arma 3\Master" -name=cceezz "-mod=@AdvancedRappelling;@AdvancedUrbanRappelling;@EnhancedMovement;@CBAA3" -filePatching "-servermod=;" -autoInit -bepath=D:\a3s\BattlEye
set /a var+=1
cls
title LEAL SERVER ( %var% CRASHES )

quit

The error is not in the mission, I'm pretty sure that this error mentioned above is being caused by the absence of the DLC when the server is started, the problem is that I don't know which command line to make a DLC be loaded with the server.

 

Edit: Guys, I solved the problem. There were actually 2 problems. First I should have signed up at Steam's Workshop to download the content (Western Sahara - Creator DLC Compatibility Data for Non-Owners) and the second problem was a ( , ) in the wrong place where there should be a ( ; ) there on the line server startup command.

Edited by P4nz3rW4r
Problem Solved!

Share this post


Link to post
Share on other sites

@NeoArmageddon

I noticed that extraction via armored vehicles or trucks is having some problem, the NPC's that drive the vehicles don't move the vehicles after all the players board, the mission is successfully completed but the vehicles don't move.

Has anyone reported this problem to you?

Share this post


Link to post
Share on other sites

After some time with the server active the FPS starts to drop and the server almost stops. I need to restart the mission to normalize. Does anyone have the same problem?

Share this post


Link to post
Share on other sites

Question on customizing missions.

 

The MSKE missions have numerous boats placed around the islands.  I wanted to find out how to place more and have them remain after INIT.  I suspected the "cleanupTerrain" function was deleting them, but that does not seem to be the case.  Could you please describe how to disable any "cleanup" that happens at init so my extra boat placements will remain?

Share this post


Link to post
Share on other sites
On 12/1/2021 at 9:39 PM, hcpookie said:

Question on customizing missions.

 

The MSKE missions have numerous boats placed around the islands.  I wanted to find out how to place more and have them remain after INIT.  I suspected the "cleanupTerrain" function was deleting them, but that does not seem to be the case.  Could you please describe how to disable any "cleanup" that happens at init so my extra boat placements will remain?

 

There is no cleanup (the function cleans comcenters and sourroundings).

If you add boats to the mission.sqm they should be ingame. I suspect the packing of the mission.sqm into the final PBO is where you have a problem.

Share this post


Link to post
Share on other sites

We did some more testing, and turns out the civ boats ARE appearing in-game as we expected.  So that suggests that my boat problem has to do with faction-sided boats... I'm going to convert them all to CIV boats and see what happens.

Share this post


Link to post
Share on other sites
On 11/21/2021 at 9:50 PM, scruffy said:

Hey determity, good job. Can you also send me the marker missions, then I'll put it into the next versions. I had also already looked at UMB Colombia and thought that might be a nice terrain for an Escape.

Small thing: If you do any other terrains in the future, best do a "clean" version first without other addons, it's easier to add when no additional mods are needed. No big deal here, I'll just ctrl+f the braf_ boatsin mission.sqm.

 

Also thank you to aussie battler for helping 👍

 

 

Yes sir absolutely!

 

https://www.dropbox.com/sh/p7hvmeai5taplpr/AADsHJtNTIG17MMVq-BZCqKaa?dl=0

 

https://www.dropbox.com/sh/zzdin1bmdyj3zyb/AABcKWErHVmUNGcTT902dcPSa?dl=0

 

https://www.dropbox.com/sh/r9v06dfa9m7drhp/AAAteP76HK56z2FXsoYjC4rna?dl=0

  • Like 1

Share this post


Link to post
Share on other sites

Hey, this might be an easy answer, but my friends and I cannot seem to ever either kill, escape from, or simply not have spawn the enemy AI search helicopter. On some maps that is fine. It does a search pattern a few times while we hide, then goes away. But we recently updated to the latest co10 Escape map lists and no matter what we do they just hover a few hundred meters above our positions. They never leave. My question is, can we turn them off some how? Because its getting old hearing NOTHING but the helicopter all the time.

 

 

EDIT: First post but I have been playing Arma 3 since release.

Share this post


Link to post
Share on other sites
On 11/21/2021 at 10:15 PM, NeoArmageddon said:

 

DLC port is already in the dev build since DLC was released.

To get the newest dev build, you can use the devpacker:

http://escape.anzp.de/EscapeDevPacker1.7z

 

FYI, for those with Windows 11 (sometimes Windows 10), the link won't open, mainly because Windows see the file as a Trogen or Spam - or not digitally signed etc..  The trick is to open the link in Ingenito mode, the extract the file to a place on your PC and run the program.

 

Share this post


Link to post
Share on other sites

Hey guys, great mod, been playing since Arma 2. Been wanting to do my own dedicated server, just having issues finding a good guide on what I need to do. Can someone point me in the right direction? Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, Drej_X_Army said:

Hey guys, great mod, been playing since Arma 2. Been wanting to do my own dedicated server, just having issues finding a good guide on what I need to do. Can someone point me in the right direction? Thanks.

Ok, I figured out where to get the PBO needed and where to place it, but now, I am unable to change the parameters of the mission.

I log into the server, login as admin, click parameters, and unable to edit ......

Search of the webs says that I should edit the PBO file, which I don't want to do, since I want to be able to change the parameters on the fly.

Share this post


Link to post
Share on other sites
16 hours ago, Drej_X_Army said:

Ok, I figured out where to get the PBO needed and where to place it, but now, I am unable to change the parameters of the mission.

I log into the server, login as admin, click parameters, and unable to edit ......

Search of the webs says that I should edit the PBO file, which I don't want to do, since I want to be able to change the parameters on the fly.

Ok, now I figured out that if you changed the difficulty and then connect/login as admin, I can change parameters (mostly). 

 

Trying to do the new Dev Test of SOG, but getting errors when trying to connect with DLC off and with the DLC on.

 

Has anyone gotten the SOG maps to work? If so, what did you have to do? Thanks.

 

PS - If I dont ask, I will never find the answer, but if I do ask, then Karma rewards me...

Share this post


Link to post
Share on other sites
On 1/23/2022 at 8:56 PM, Drej_X_Army said:

Trying to do the new Dev Test of SOG, but getting errors when trying to connect with DLC off and with the DLC on.

 

Sorry, my crystal ball is in repair so you have post these errors.

Share this post


Link to post
Share on other sites
4 hours ago, NeoArmageddon said:

 

Sorry, my crystal ball is in repair so you have post these errors.

Hey Neo, thanks for responding.

I will get you screenshots of the errors, but currently we lost all parameters control. We can no longer select parameters and get them to stick.

Besides placing the PBO file into mpmissions, is there anything else we should be doing to the config or in the PBO to get parameters to stick to what we like?

 

Thanks.

Share this post


Link to post
Share on other sites

@NeoArmageddon

 

The error I get with and without the DLC on is - 

 

No Entry 'bin\config.bin/CfgWorlds.prei_khmaoch_luong'.

 

I verified I got the PBO in the MPMissions and have the config showing - template = co10_Escape_SOGPF_PAVN_vs_MACV_and_ARVN.prei_khmaoch_luong;

 

Share this post


Link to post
Share on other sites

prei_khmaoch_luong is a custom terrain. You need it (obviously):

 

The map from VN is Cam Nao Lam.

 

Quote

 - template = co10_Escape_SOGPF_PAVN_vs_MACV_and_ARVN.prei_khmaoch_luong;

 

You don't need this. Remove it.

The params stick if you are logged in as admin and change the first parameter to "Use below and save".

  • Thanks 1

Share this post


Link to post
Share on other sites

For Cam Lao Nam, does anyone know where in the configs (or PBO) I can force it to always show where you are on the map and to allow pings?

I still play with people that want the simple stuff...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×