Jump to content

Recommended Posts

6 hours ago, Rapaxlegio said:

 Thank you Leopard, essential mod for me,  although  the readme keeps says 1.2.5 version.

Sorry! Forgot to change that!

  • Thanks 1
  • Haha 1

Share this post


Link to post
Share on other sites

Hello! 

Probably a stupid question but still...

I'm trying to load this mod (open arma launcher -- mods -- local mod -- loading the mods (both of them..) )and trying to launch the game but i'm getting an error...

How can i install it and try it? what am i doing wrong?

Share this post


Link to post
Share on other sites
18 hours ago, omri2050 said:

Hello! 

Probably a stupid question but still...

I'm trying to load this mod (open arma launcher -- mods -- local mod -- loading the mods (both of them..) )and trying to launch the game but i'm getting an error...

How can i install it and try it? what am i doing wrong?

Hi. What error are you getting? 

The only thing you need to run the mod is CBA. Make sure it's loaded in the launcher (preferably put it at the top of the list)

Share this post


Link to post
Share on other sites
45 minutes ago, Leopard20 said:

Hi. What error are you getting? 

The only thing you need to run the mod is CBA. Make sure it's loaded in the launcher (preferably put it at the top of the list)

This is what i get

 https://ibb.co/nRzMue

 

Tried also to move the up but same thing..

I've pasted the mods to this folder 

https://ibb.co/eSg1ue

 

Any idea ? 

Thanks in advance

Share this post


Link to post
Share on other sites
1 hour ago, WAR326 said:

On first page pointed that it mod requirement WW AI Menu by Windwalking:
http://www.armaholic.com/page.php?id=22380

Actually, since version 1.0.0 this requirement was removed due to some difficulties in setting up WW AI Menu (file patching, etc.). I removed it for the sake of users' convenience.

Share this post


Link to post
Share on other sites
4 hours ago, omri2050 said:

This is what i get

 https://ibb.co/nRzMue

 

Tried also to move the up but same thing..

I've pasted the mods to this folder 

https://ibb.co/eSg1ue

 

Any idea ? 

Thanks in advance

Please unload WW AI Menu. It's not required anymore (see the above post for reason). I'll correct the first page and contact foxhound to correct the Armaholic post as well.

 

Sorry for the inconvenience.

Share this post


Link to post
Share on other sites
1 hour ago, Leopard20 said:

Please unload WW AI Menu. It's not required anymore (see the above post for reason). I'll correct the first page and contact foxhound to correct the Armaholic post as well.

 

Sorry for the inconvenience.

Works! 

Thanks for the help and the hard work your are investing

upgrades arma in every aspect

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, gaverio said:

Hey @Leopard20

Is there a chance to have the "fire on my lead" command on a keyboard key/combination?

Hi.

Sure. I'll add it in the next version!

Share this post


Link to post
Share on other sites

@Leopard20

 

 I thought I would try this out but so far I am having no luck getting it to work. I  have the same issue @Dallas Medina posted about a couple of months ago. I can get AIO to load. I even the the pop-up error you mentioned

15:06:32 Error in expression <};
_leader = _possibleLeaders select 0;
_leader setvariable ["BIS_HC_scope",_log>
15:06:32   Error position: <_leader setvariable ["BIS_HC_scope",_log>
15:06:32   Error Undefined variable in expression: _leader
15:06:32 File A3\modules_f\HC\data\scripts\hc.sqf, line 71

I get absolutely no other error messages in .rpt. On screen I wait until i see "AIO initialized" in side chat. I press "Y" and get the menu but AI does nothing no matter what I choose, defense, weapon management etc. The AI does not respond in any way. I dropped all mods except CBA and AIO. I even tried it in single player and multiplayer just to see if somehow that was the problem. Other than @Dallas Medina i found no other posts detailing my problem. I wish I had at least an error to send you but .RPT is clean(other than already mentioned hc.sqf error). CBA and AIO are both latest versions.

 

Nomad

 

edit: When I issue any command I get the message in side chat, but AI does nothing. Will continue to test it.

Share this post


Link to post
Share on other sites
17 hours ago, nomadd said:

@Leopard20

 

 I thought I would try this out but so far I am having no luck getting it to work. I  have the same issue @Dallas Medina posted about a couple of months ago. I can get AIO to load. I even the the pop-up error you mentioned


15:06:32 Error in expression <};
_leader = _possibleLeaders select 0;
_leader setvariable ["BIS_HC_scope",_log>
15:06:32   Error position: <_leader setvariable ["BIS_HC_scope",_log>
15:06:32   Error Undefined variable in expression: _leader
15:06:32 File A3\modules_f\HC\data\scripts\hc.sqf, line 71

I get absolutely no other error messages in .rpt. On screen I wait until i see "AIO initialized" in side chat. I press "Y" and get the menu but AI does nothing no matter what I choose, defense, weapon management etc. The AI does not respond in any way. I dropped all mods except CBA and AIO. I even tried it in single player and multiplayer just to see if somehow that was the problem. Other than @Dallas Medina i found no other posts detailing my problem. I wish I had at least an error to send you but .RPT is clean(other than already mentioned hc.sqf error). CBA and AIO are both latest versions.

 

Nomad

 

edit: When I issue any command I get the message in side chat, but AI does nothing. Will continue to test it.

That's really strange.

The error shouldn't cause any problem that I know of. I get it too. I still haven't been able to fix it. But you can uncheck "Create High Command Module" from CBA Settings to avoid it (some HC functions might not work without it though).

 

Can you test something for me please? Go to Editor (preferably not in VR), place a few units, run the mission and then paste this code in Debug Console:

[(units group player), 30, 0] execVM "AIO_AIMENU\moveToCover.sqf"

If it works, it means that the command "groupSelectedUnits" doesn't work, which is weird. Speaking of which, how do you select your units exactly? Note that you should select your units first, then open the menu.

Share this post


Link to post
Share on other sites

Leopard20

 

 Well the good news is I dont think my problem with AIO had anything to do with your mod. I started to notice some other glitches, then arma began crashing for no apparent reason. I went into Steam and did a verify local game files. It didn't go well, so ended up removing Arma3 and letting Steam reinstall it. Problems have gone away. 

Last test I just did with AIO, AI is responding to all commands. No idea what happened to my Arma3 files. Sorry to have bothered you, problem appears to have been on my end the whole time.

 

Nomad

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, nomadd said:

Leopard20

 

 Well the good news is I dont think my problem with AIO had anything to do with your mod. I started to notice some other glitches, then arma began crashing for no apparent reason. I went into Steam and did a verify local game files. It didn't go well, so ended up removing Arma3 and letting Steam reinstall it. Problems have gone away. 

Last test I just did with AIO, AI is responding to all commands. No idea what happened to my Arma3 files. Sorry to have bothered you, problem appears to have been on my end the whole time.

 

Nomad

Thanks for the feedback. Glad it worked!

Share this post


Link to post
Share on other sites

Hey Leopard!

 

Very awesome mod you have here it works like a charm (most of the time). Uh I do experience something akin to a glitch where If I select some or all my units and I tell them to 'Combat heal' they actually all leave my group and someone else becomes the commander. I am not sure why that is. I am trying to run this mod with another mod called "KP liberation - Atlas". But this isnt my actually concern. I usually have quite a lot of AI following me (~50+) cause I like commanding an army haha. My question is can I tweak the 'Garrison building' button in the command menu to allow my guys to garrison the surrounding buildings as well (like in an area) so I do not have to take the time to individually tell my guys to go into specific buildings.

 

Again thanks for your hard work!

  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, Bomber147 said:

Hey Leopard!

 

Very awesome mod you have here it works like a charm (most of the time). Uh I do experience something akin to a glitch where If I select some or all my units and I tell them to 'Combat heal' they actually all leave my group and someone else becomes the commander. I am not sure why that is. I am trying to run this mod with another mod called "KP liberation - Atlas". But this isnt my actually concern. I usually have quite a lot of AI following me (~50+) cause I like commanding an army haha. My question is can I tweak the 'Garrison building' button in the command menu to allow my guys to garrison the surrounding buildings as well (like in an area) so I do not have to take the time to individually tell my guys to go into specific buildings.

 

Again thanks for your hard work!

Hi!

 

Thanks for the bug report. I'll look into it.

 

If you use the "Fortify Position" infantry command under "Defense" sub-menu, you can get them to spread around in a circular fashion and take cover within a set radius. They will also use nearby buildings. I haven't checked this function in a while so it might not work perfectly but give it a go!

Share this post


Link to post
Share on other sites

How do I get to the Create Convoy -option?  Question: Can we get a option to decide spacing and speed option for aircraft? I`m thinking of helicopters to make them orbit by making them do that by setting it in advance at WP and maybe get Ai to board any helicopter within 100m.

 

Formations flight like this would be great,like Go Ladder High.  https://www.facebook.com/UH1HUEY.U.S/photos/a.108979816453106/114662129218208/?type=3&theater

 

If we could change the spacing between the helos up and to the side,this would be so much better than any other mods,if we can get ViV and to place 3 helicopters in a line and make them turn on a line onto a certain direction and then climb out to set altitude ,would be great.  A "Saturate Area" option ,gunrun it repeats until depleted would be a new option .

Can we also get a "ultra slow" -speed -3km/h to be able to fly below treetop height,would be useful sometimes.

 

Could we make our vehicle become `semi-bullet proof` by ,making the planes take say 50 % damage and then take 150% damage before it gets destroyed to mimic armor ,like "delayed damage"-system from meny option.

 

 

Can we get a way to choose load out by using a Spawn Vehicle- mod of choice (Dcon) ,can we also get the possibility to turn on light bars from the Menu ,it would be fantastic.

 

If we can use insert by Fast Rope ,it would be a nice addition.   Thanks for a great mod.

 

Share this post


Link to post
Share on other sites
6 hours ago, john1 said:

1-Can we get a option...? 

2-this would be great,like Go Ladder High....

3-If we could change...

4-this would be so much better....

5-if we can get....

6-would be a new option... .

7-Can we also get....

8-Could we make our vehicle....

9-making the planes take say 50 % damage...

10-Can we get a way to choose....

11-can we also get...

12-If we can use insert by Fast Rope ,it would be a nice addition....

 

Beside the fact that requests are against forum rules..and ground for disciplinary actions...ANYTHING ELSE YOU DESIRE?

What about a car wash by 5 bikini girls ?, or maeby you like him to iron your shirts or paint your house? 

 

GEEZ bro.. chill out with those "Can we get" questions.

 

Beside, if it was so easy to do those things you could probably do it yourselves. So "WE COULD"all enjoy whatever you come up with!

 

  • Like 2

Share this post


Link to post
Share on other sites

@john1

For creating convoys, fast roping and heli pickups you might wanna check C2 by mad_cheese. He's doing a great job at them.

He also has a vehicle spawner mod you might wanna check out. They're all at his Discord channel.

You can also spawn vehicles via Zeus if you enable it in my mod's settings.

 

Changing spacing and formation for vehicles (especially air vehicles) is not possible in ARMA 3 (at least not without complicated coding). Even getting a convoy to successfully move from one point to another is a hit-or-miss.

 

As for the half-damage-feature request, lucky for you I've been developing something similar (although more complex) for my upcoming mission. I'll post it for you when I get a chance. But I won't incorporate it into the mod, because it's nothing but a cheat. You can, however, add it to the vehicle's init field or create a mod for it yourself. You can dismantle a mod that does something similar (Liability Insurance is a great example), namely adding an EH, replace the code and recompile it for your personal use.

  • Like 1

Share this post


Link to post
Share on other sites

Here's the code:
Init box:

this setVariable ["VehDamage", (getDammage this)];
this addEventHandler ["HandleDamage", {
	params ["_obj", "_selection", "_damage", "_source", "_projectile", "_hitIndex", "_instigator", "_hitPoint"];
    _damage = ((_obj getVariable ["VehDamage", 0]) + _damage)/2 min 1; //****
    _obj setDamage _damage;
	_obj setVariable ["VehDamage", _damage];
	_damage
}];

If you want to reduce the damage even further, like 1/3, change the asterisked line as follows:

 _damage = ((_obj getVariable ["VehDamage", 0])*2 + _damage)/3 min 1; //****

Note that it won't necessarily reduce the damage by half; it will simply keep it "close" to the previous damage to prevent "excessive" damage (sometimes damages over 1 can be dealt to objects!)

 

For the mod version, you can add a loop like this:
 

waitUntil {
	sleep 10;
	{
		if (vehicle _x != _x) then {
			_veh = vehicle _x;
			if (_veh getVariable ["damageEH", -1] == -1) then {
				_veh setVariable ["VehDamage", (getDammage _veh)];
				_EH = _veh addEventHandler ["HandleDamage", {
						params ["_obj", "_selection", "_damage", "_source", "_projectile", "_hitIndex", "_instigator", "_hitPoint"];
						_damage = ((_obj getVariable ["VehDamage", 0]) + _damage)/2 min 1; //****
						_obj setDamage _damage;
						_obj setVariable ["VehDamage", _damage];
						_damage
					}];
				_veh setVariable ["damageEH", _EH];
			}
		}
	} forEach allUnits;
	false
}

This will add the EH to all manned vehicles.

Of course you can still make this more elaborate but I'm not in the mood to explain!

  • Like 1

Share this post


Link to post
Share on other sites
On 9/18/2017 at 9:38 PM, Leopard20 said:

Hey old friend!

To be honest I'm not entirely sure if the mod obeys the forum rules, so I'm waiting for more feedback before uploading it on Armaholic and Steam Workshop (although I asked a couple of moderators about it and they weren't sure either!)

As soon as the final and signed version is released I'll upload it to both sites. Hopefully it won't be long.

Steam?

  • Like 2

Share this post


Link to post
Share on other sites

very nice mod outstanding ! however im getting config error "no entry config cfgPatches" 

Share this post


Link to post
Share on other sites

@AirShark Thanks!

 

Please wait a few days. I'm gonna release a new update by the end of this week. Hopefully that will fix your issue.

 

By the way, have you loaded CBA? I'm not sure why it's giving you a cfgPatches error. That's weird...

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×