Jump to content
ACRE_Team

Advanced Combat Radio Environment 2 (ACRE2)

Recommended Posts

On ‎7‎/‎7‎/‎2018 at 1:04 PM, magnetar said:

Appreicated!


Another test session done. This time at the start of the game only a few players couldn't hear each other (myself included) but about 2 hours into the session the radios stopped working completely.
I've uploaded the client and server RPT here:
https://1drv.ms/f/s!AqUMiHfLAgXYpohNOR44t2k6N080Mw

Share this post


Link to post
Share on other sites

What worries me is that you have a lot of these messages that are the Arma3 "spiral of death" although the server recovered

 

Quote

Server: Network message aa52d0 is pending


with a lot of desync:

Quote

[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_3' from player 'XXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27
[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_8' from player 'XXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27


and then 4 in a row from the same player with different IDs!
 

Quote

[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_19' from player 'XXXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27
[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_10' from player 'XXXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27
[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_2' from player 'XXXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27
[ACRE] (sys_server) WARNING: Desync - Garbage collection prevented for radio 'acre_prc343_id_5' from player 'XXXXX' as it still exists for them locally! idi\acre\addons\sys_server\fnc_stopRadioGarbageCollect.sqf:27

 

with the worst in here
 

Quote

[ACRE] (sys_server) WARNING: Duplicate radio ID found! Attempting replace of (izweracre_prc117f_id_1) idi\acre\addons\sys_server\fnc_masterIdTracker.sqf:192
[ACRE] (sys_server) WARNING: Id object relation created independently of unique ID creation process (acre_prc117f_id_10)! idi\acre\addons\sys_server\fnc_masterIdTracker.sqf:246

 

I do not know what izweracre_prc117f_id_i is and never seen it. Actually this points to a custom acre classnames unless you have modified the RPT. Is this the case?

 

How do you assign radios? With a custom loadout script? Do you change uniforms or use in your custom modpack something like backpack on chest?

Share this post


Link to post
Share on other sites

For this particular test (it was a WW2 tank assault mission with infantry support, IFA mod) only the vehicles have radios (VRC103 rack), the infantry have one RTO with the PRC-117F (assigned via ACE Loadout in the editor).

The server itself is still new and we're still in the process of tweaking the settings. 

On the other hand, we had another test last night (mechanized infantry with 5 vehicles with 1 helo, CUP mod) with no radio issues.  We're gonna run more tests to narrow it down.

Share this post


Link to post
Share on other sites

Hi is there any fix/solution to ACRE2 un-muting my mic when I mute it in teamspeak 3 while in an arma 3 server?

Share this post


Link to post
Share on other sites
2 hours ago, The_Elkin said:

Hi is there any fix/solution to ACRE2 un-muting my mic when I mute it in teamspeak 3 while in an arma 3 server?

 

If you think that this is an issue, please post it in github https://github.com/IDI-Systems/acre2/

Share this post


Link to post
Share on other sites
16 hours ago, R. Razor [WP] said:

Has anyone checked this works with the new TS 3.2.0 client and 3.3.0 server? 

We have had gamecrashes and massive problems with TS and ACRE. I suggest not to update to TS 3.2.0 until ACRE is ready with a patch.

Share this post


Link to post
Share on other sites

Having Arma and TS freezes with TS 3.2.1 here.

Share this post


Link to post
Share on other sites

Can confirm, ACRE devs know about the issue aswell.

 

Only thing I can recommend now is to rollback the client to 3.1.10.

Share this post


Link to post
Share on other sites
6 hours ago, -ben- said:

Having Arma and TS freezes with TS 3.2.1 here.

 

Ok cool, I was super worried it was unique to my PC. Good to hear the Devs are onto it.

I simply can't play ArmA right now, my game and TS crashed 3 times tonight before I gave up.

Share this post


Link to post
Share on other sites
2 hours ago, rekkless said:

 

Ok cool, I was super worried it was unique to my PC. Good to hear the Devs are onto it.

I simply can't play ArmA right now, my game and TS crashed 3 times tonight before I gave up.

Just revert Teamspeak back to 3.1.9 if it's that bad.

Share this post


Link to post
Share on other sites

If possible, stay on 3.1.10, there is an issue with TeamSpeak that we cannot do much about at this time.

 

You may downgrade TeamSpeak using the link @Dedmen provided:

7 hours ago, Dedmen said:

TFAR has the same. It's Teamspeaks fault.
You can get Teamspeak 3.1.10 here: http://dl.4players.de/ts/releases/3.1.10/

 

Thank you for your understanding.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Can anyone help me out with setting up the BABEL module? I'm trying to have different langauges for different sides and also with translators possible.

 

Here's my init.sqf:

 


acre_sys_core_postmixGlobalVolume = 1;
acre_sys_core_premixGlobalVolume = 1;
acre_sys_core_spectatorVolume = 1;
acre_sys_core_unmuteClients = true;
acre_sys_core_ts3ChannelSwitch = false;
acre_sys_core_ts3ChannelName = "";
acre_sys_core_interference = false;
acre_sys_core_fullDuplex = false;
acre_sys_core_ignoreAntennaDirection = true;
acre_sys_core_terrainLoss = 0;
acre_sys_core_revealToAI = true;

f_available_languages = [
["pl", "Polski"],
["pt", "Paszto"]
];
{
    _x call acre_api_fnc_babelAddLanguageType;
} forEach f_available_languages;

[] spawn {
    if (!hasInterface) exitWith {};
    if (player != player) then {waitUntil {player == player};};
    if (!alive player) then {waitUntil {alive player};};
 
    _languagesPlayerSpeaks = player getVariable ["f_languages", []];
    
    diag_log format ["The Variable f_languages is set to: %1", _languagesPlayerSpeaks];    

    switch (playerside) do {
    case west: {
            if (_languagesPlayerSpeaks isEqualTo []) then {_languagesPlayerSpeaks = ["pl"];};
        };
    case east: {
            if (_languagesPlayerSpeaks isEqualTo []) then {_languagesPlayerSpeaks = ["pt"];};
        };
    case independent: {
            if (_languagesPlayerSpeaks isEqualTo []) then {_languagesPlayerSpeaks = ["pt"];};
        };
    case civilian: {
            if (_languagesPlayerSpeaks isEqualTo []) then {_languagesPlayerSpeaks = ["pt"];};
        };
    };
    _languagesPlayerSpeaks call acre_api_fnc_babelSetSpokenLanguages;
};

Only PL language is added, doesn't matter if I spawn as a civ or blufor or indfor, it's not possible to cycle langauges for the translator too. His init field is like this:

this setVariable ["f_languages", ["pt", "pl"]];

And he speaks only PL with no option to cyclelanguages. Is there any tutorial or a sample mission? Also I want it to be JIP compatible, hence scripting used (borrowed from some cool dude on reddit). I've read ACRE documentation and following steps didn't help me.

Share this post


Link to post
Share on other sites

Why does the AcreIntercoms code in my vehicle config.cpp cause acre script errors on mission load please?

 

class AcreRacks {
    class AcreIntercoms {
        class Intercom_1 {
            displayName = "Crew intercom";
            shortName = "Crew";
            allowedPositions[] = {"crew", {"cargo", "all"}};
            disabledPositions[] = {};
            masterPositions[] = {"driver"};
            limitedPositions[] = {};
            numLimitedPositions = 0;
            connectedByDefault = 1;
        };
    };
    class Rack_1 {
        displayName = "Rack 1";
        shortName = "Rack1";
        componentName = "ACRE_VRC110";
        allowedPositions[] = {"inside"};
        disabledPositions[] = {};
        defaultComponents[] = {};
        mountedRadio = "";
        isRadioRemovable = 1;
        intercom[] = {};
    };
    class Rack_2 {
        displayName = "Rack 2";
        shortName = "Rack2";
        componentName = "ACRE_VRC103";
        allowedPositions[] = {"inside"};
        disabledPositions[] = {};
        defaultComponents[] = {};
        mountedRadio = "ACRE_PRC117F";
        isRadioRemovable = 0;
        intercom[] = {};
    };
    class Rack_3 {
        displayName = "Rack 3";
        shortName = "Rack3";
        componentName = "ACRE_VRC103";
        allowedPositions[] = {"inside"};
        disabledPositions[] = {};
        defaultComponents[] = {};
        mountedRadio = "ACRE_PRC117F";
        isRadioRemovable = 0;
        intercom[] = {};
    };			
};

 

Error in expression < };
(acre_sys_radio_radioBaseClassCache setVariable [_radio, _baseClassRadio]);
>
Error position: <setVariable [_radio, _baseClassRadio]);
>
Error Reserved variable in expression
File idi\acre\addons\sys_radio\fnc_getRadioBaseClassname.sqf, line 13
Cannot create non-ai vehicle _id_1,


 

The vehicle rack radios work as expected.

If I comment out the AcreIntercoms section the script error does not occur.

Share this post


Link to post
Share on other sites
10 hours ago, UK_Apollo said:

Error Reserved variable in expression

Empty variable name. _radio is for some reason a empty string. First thing that meets my eye is

10 hours ago, UK_Apollo said:

mountedRadio = "";

Empty radio name.

Share this post


Link to post
Share on other sites
6 hours ago, UK_Apollo said:

Two reasons why that should be unlikely Dedmen,

1) it follows their documentation example: http://acre2.idi-systems.com/wiki/frameworks/vehicle-racks

2) it's the AcreIntercoms {} class that is causing the script error, not the Racks

 

Hopefully one of the Acre devs will have seen this before and know the solution.

 

I will have a look at it at the weekend.

 

  • Like 1

Share this post


Link to post
Share on other sites

I think I've just realised what the problem is:

class AcreIntercoms{} should not be inside class AcreRacks{}.  Looks like a copy error my side.

Share this post


Link to post
Share on other sites

To the ACRE devs

 

Has anyone considered making or porting ACRE to DayZ Standalone.

 

Earlier this week the server files for DayZSA were released and there was a mention that shortly modding tools will be available to creators to make mods for DayZ.

 

Considering DayZ has an existing Radio and Megaphone system it seems like a no brainer to get ACREs awesome 3d audio and teamspeak support in DayZSA.

 

Not only would it be awesome to see ACRE in DayZ but it would also give the ACRE developers a head start on the Infusion engine which we know will be the underlying engine in ArmA 4.

 

By getting a head start in DayZ it would give ACRE the advantage upon ArmA 4s release to release ACRE 3 to the public before Task Force Radio and help cement itself as the go to radio mod for not only ArmA 3, DayZ but for ArmA 4.

 

I'm sure we all know the main reason TFAR is so popular with ArmA 3 is not because it is actually the better mod, but simply because it was the first reliable mod. ACRE took too long to come to ArmA 3 in any kind of reliable way and that is why TFAR is used by most communities at least 9 times out of 10.

 

Anyway as I stated, ACRE in DayZ would be awesome and it would give you guys the much need insight into the infusion engine for when ArmA 4 releases.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, rekkless said:

it seems like a no brainer to get ACREs awesome 3d audio and teamspeak support in DayZSA

We haven't seen any trace of Extension support yet. Which will probably be needed to interface with Teamspeak.

 

8 hours ago, rekkless said:

on the Infusion engine

Enfusion*

 

8 hours ago, rekkless said:

to the public before Task Force Radio

Hah. We'll see how that'll go. TFAR is much simpler/easier/smaller code wise. Thus faster to rewrite for A4.

 

Nothing is set for Arma 4 yet. Maybe we'll see just a single Radio mod as a ACRE/TFAR collab? There are still years between now and A4.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×