Jump to content
ALiVEmod

ALiVE - Advanced Light Infantry Virtual Environment 1.0 (GA)

Recommended Posts

0:41:53 Error in expression <_fnc_profileEntity;_markers = _markers + _marker;_profiles pushback _profile;>
0:41:53   Error position: <+ _marker;_profiles pushback _profile;>
0:41:53   Error +: Type Bool, expected Number,Array,String,Not a Number
0:41:53 File \x\alive\addons\fnc_analysis\fnc_liveAnalysis.sqf [ALiVE_fnc_liveAnalysis], line 3001

23:44:09 Error in expression <e = ([ALiVE_ProfileHandler,"getProfile",_profileID] call ALiVE_fnc_profileHandle>
23:44:09   Error position: <_profileID] call ALiVE_fnc_profileHandle>
23:44:09   Error Undefined variable in expression: _profileid
23:44:09 File \x\alive\addons\mil_opcom\fnc_OPCOM.sqf [ALiVE_fnc_OPCOM], line 2550

I've been getting these kinds of errors with the current update, completely fresh mission, no database used. The OPCOM acts very passive, not attacking the enemy. Watching debug, units mostly get destination waypoints on their own side of the map, even if I set 500+ priority custom objectives to use as targets.

Share this post


Link to post
Share on other sites
On 13/07/2018 at 4:02 PM, drdetroit said:

 

I believe one of the Alive devs said to replace some/all moduels in the editor if mission doesn't start or locks up during the loading.

 

Had the same issue. I just renamed the mission name in the descrption file and the mission file name as well. Loaded and played fine after that.

 

 

Tried this, made no difference, still locked on loading.

 

Through trial and error I found the issue though.  It's the Player Logistics (Disable) module.  If I place it (settings Debug NO, all other settings YES), then it stops the mission loading, if I remove it, mission runs fine as usual.

 

This happens in SP, MP (hosted and dedicated), and trawling through my logs I can see no obvious messages about why this is happening, or even connected to it.

Share this post


Link to post
Share on other sites
1 hour ago, Capt Childs said:

 

Tried this, made no difference, still locked on loading.

 

Through trial and error I found the issue though.  It's the Player Logistics (Disable) module.  If I place it (settings Debug NO, all other settings YES), then it stops the mission loading, if I remove it, mission runs fine as usual.

 

This happens in SP, MP (hosted and dedicated), and trawling through my logs I can see no obvious messages about why this is happening, or even connected to it.

Can you post a vanilla mission and/or a rpt file from a vanilla mission that won’t load? Some errors have been reported and seen internally with Logistics, but no reports of an error preventing a mission from loading completely have been shared directly with the devs yet.

 

This would be useful if you could.

Share this post


Link to post
Share on other sites

I get this error with a freshly created mission.

10:16:32 Error in expression <e = ([ALiVE_ProfileHandler,"getProfile",_profileID] call ALiVE_fnc_profileHandle>
10:16:32   Error position: <_profileID] call ALiVE_fnc_profileHandle>
10:16:32   Error Undefined variable in expression: _profileid
10:16:32 File \x\alive\addons\mil_opcom\fnc_OPCOM.sqf [ALiVE_fnc_OPCOM], line 2550

Share this post


Link to post
Share on other sites

RFX0nkZ.jpg

 

ALiVEmod.com

The next generation dynamic persistent mission addon for ArmA3
 

Hotfix
Due to accidental redundancies in our QA department following explosive decompression of the charity coffee machine, management has concluded that QA should henceforth be outsourced, off shored, crowd funded and delegated to public committee.  There is nothing to see here, please move along. :sulkoff:

 

There were a number couple regression bugs in the 1.7 release that for some unfathomable reason didn't manifest in testing.  The performance improvements on Virtual profiles somehow impacted logistics requests for groups of AI.  There was also a bug with static data (such as map indexes) not loading properly and causing the infamous infinite loading screen, which has apparently been there for more than 3 years but only just decided to become a problem now.  #justArmAthings

 

Release Highlights

Download

Grab the latest version from ALiVEmod.com
Also available from PlayWithSix, ArmAholic and Steam (Usually within 24 hours of this post)

 

 

Please note that as with all updates, if you have an issue loading a mission made with a previous version of ALiVE, delete and replace the modules in that mission.

 

Known Issues & Support
Existing bugs are listed on Github here. Feel free to submit bugs (with vanilla repros please) or discuss any issues or ideas on our forum at http://alivemod.com/forum/.

 

Manual
Please refer to the ALiVE Wiki. All the info you need is there. If anything is missing or unclear, please let us know.

 

Are you using Linux?
ALiVE is fully supported on a Linux Dedicated Server (as well as Windows). In fact the ALiVE Official Server for testing is running Ubuntu. Here are some tips on getting ALiVE running smoothly on Linux and integrated with War Room - http://www.alivemod.com/forum/1916-setting-up-linux- dedi-server

 

Acknowledgements and Thanks
Particular thanks to all those on our support forum who have worked closely with us to identify bugs, provide logs and generally help us improve ALiVE. Your assistance is valuable and your dedication to ALiVE makes it all worth the effort!

 

Have fun!

 

ALiVE War Room is Hosted By

logo.png

  • Like 8
  • Thanks 3

Share this post


Link to post
Share on other sites

Hi Folks,

 

If someone has a few minutes - I could use a little helping hand with ORBAT with some of the undocumented features... Starting to dive in pretty deep with this fantastic tool...

 

ORBAT ALiVE: If I automatically close the ORBAT interface during an editing session (staying within the launched mission) - is there a way to open it again without losing my work .

 

As per the ALiVE Wiki: [if you close the tool by pressing the escape key, you can reopen the interface via the ALiVE interaction menu by selecting “ORBAT Creator”].

 

I can’t seem to get that to work..

 

ORBAT ALiVE: How do I use the “Create File” and “Create Image” features that have been added to the tool since the tutorial were made ? Does the ORBAT tool write files somewhere directly negating the need for the GitHhub Template ? If so - where ?

 

ORBAT ALiVE: When creating motorized or mechanized infantry - do I include the vehicle, crew, and mounted squad in the same group ? The mounted squad will mount and up mount automatically when needed ?

 

ORBAT ALiVE: When creating a new unit [unit Editor] - the first dialog - last field is something like unit type - this allows you to select an existing unit type like “Rifleman” or “Medic” but doesn’t allow you to type in the box - what if I delete all the original types and want to create a new one - is there a way to do it ?

 

ORBAT ALiVE: Is there a way to control which face is assigned to infantry - one group may need a certain skin color - and my special forces groups should have painted faces - can I achieve that with this tool ?

 

Generic ALiVE - the logistics module under the OPCOM still seems to have resupply helicopters hover indefinitely over the resupply point...

 

Generic ALiVE - the players logistics module seems broken - while I can make the request selecting the desired items - nothing is ever delivered and when I check status there is no delivery scheduled - the same happens with either of the the three delivery types...

 

Thanks for your patience and any help appreciated...

 

Also - thanks for this great mod !!!

 

Regards,

Scott

 

 

Sent from my iPad using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites

FYI we’ve updated on Steam Workshop and probably our website. Not sure when or if we’ll have an official release post; just wanted to give everyone a heads up ALiVE has updated.

  • Like 1

Share this post


Link to post
Share on other sites

Does the updated ALiVE change the ORBAT faction-maker to make it easier than before?

Share this post


Link to post
Share on other sites

Is it possible to let players use Combat Support from opposing sides?

In my scenario the US Army of WW2 is attacking and as there are no 155 mm Gun M1s,  I'd like to use M4 Scorchers instead. Problem is the US Army is Independent, so Artillery support is not available for players of this side (as the Artillery is BLUFOR).

Share this post


Link to post
Share on other sites

Hey all,

I made the same post on the Alive Forums, but I thought I would post here as well.
 

I am having an issue with connecting to the war room with one of my dedicated servers. It comes up with the cutlGet issue when trying to connect to the DB as seen below:
 

[2018-10-01 20:02:53] [info] Checking WarRoom access...
[2018-10-01 20:02:53] [info] URL: http://alivemod.com/api/authorise?group=SORD&localDB=false
[2018-10-01 20:02:53] [info] WarRoom access granted.
[2018-10-01 20:02:53] [info] Checking DB access...
[2018-10-01 20:03:15] [error] ###### curlGet ######
[2018-10-01 20:03:15] [error] Error: curl_easy_perform() failed
[2018-10-01 20:03:15] [error] RAW: Couldn't connect to server
 

I firstly built an Arma 3 server on my home PC and then connected to the war room following the instructions in the add a server section under group profile on the alive website. I created a simple mission and everything worked. The info appears in the war room and my stats updated.

I then repeated the process on a dedicated server running Windows Server 2016 Standard. I used the same build process, creating a new server in the war room and used the same mission which I tested on my PC server earlier. No joy.

I tried to connect to the database (http://db.alivemod.com:5984/) using firefox from my PC and everything looks normal. Comes up with the below:
 

couchdb: "Welcome"
version: "2.1.1"
features:
0: "scheduler"
vendor:
name: "The Apache Software Foundation"
 

However, when I try the same process using both IE and Chrome on my dedicated server, it says "This site can't be reached.....".

The dedicated servers firewall is turned off for testing, I have also added exceptions to Windows Defender for both the Arma server folder and the ALiVE folder in my appdata/local..... folder location.
 

Does anyone have any ideas what is stopping the connection?
 

aliveplugin text file >>> https://pastebin.com/dUzZT1E3
Server RPT File >>> https://pastebin.com/TwuPQr1U
 

Peace,

TPM

Share this post


Link to post
Share on other sites

Would really want to see a couple of fixed functionalities become available for the Workshop version of ALiVE so here I am, apologizing for having to ask for a release date of the next stable build of ALiVE. Any indicators of when such thing is going to happen?

Share this post


Link to post
Share on other sites

Hello guys, just wanted to say that Alive is awesome and next to Ravage is the single most impressive piece of work (more like piece of art) that I've ever seen in Arma. (I am pretty sure you already know that by know).

 

I would like to do 2 suggestions before I go.

 

1) Please make the support modules a stand alone release. You know that part that is basically a remake of http://www.armaholic.com/page.php?id=15906 but on Arma 3. Perhaps adding a cool interface like that. =)

2) Please make a lite version of Alive that can be run on Hosted Servers rather than "Dedicated server only". We have huge issues with players not authenticating correctly on the latest Arma 3 but all works fine on Hosted servers. (I am sure you get this request far too often).

 

Anyways, thanks!

Share this post


Link to post
Share on other sites

It's a shame that civilian vehicles seem to spawn in the middle of the road, as if someone ran out of gas and left them there. Is there any way to make them spawn with an offset depending on the direction they're facing and if it's on a road? You know, so they're more to the side like they're parked cars and not post-apocalyptic remnants.

 

Also a shame you still can't set what weapons angered civilians will spawn with. Is it possible to add this?

 

Thanks.

Share this post


Link to post
Share on other sites

You have always been able to set insurgent weapons using static data.

 

Follow the static data example from here: http://alivemod.com/wiki/index.php/Custom_Blacklists

 

But use this text for your static data  file instead:


 

if (!isServer) exitWith {};



waitUntil {!isNil "ALiVE_STATIC_DATA_LOADED"};



ALIVE_civilianWeapons = [] call ALIVE_fnc_hashCreate;
[ALIVE_civilianWeapons, "CIV", [["hgun_Pistol_heavy_01_F","11Rnd_45ACP_Mag"],["hgun_PDW2000_F","30Rnd_9x21_Mag"],["SMG_02_ARCO_pointg_F","30Rnd_9x21_Mag"],["arifle_TRG21_F","30Rnd_556x45_Stanag"]]] call ALIVE_fnc_hashSet;

 

Change the faction and weapons list as needed

  • Thanks 2

Share this post


Link to post
Share on other sites

Quoting myself, is such a thing even possible!
 

On 07/10/2018 at 12:43 PM, Asmodeuz said:

Would really want to see a couple of fixed functionalities become available for the Workshop version of ALiVE so here I am, apologizing for having to ask for a release date of the next stable build of ALiVE. Any indicators of when such thing is going to happen?

Aand lo and behold there was Pre-Release Build 1.8.1 and those couple of functionalities indeed were good to go with their committed fixes!
Apologizing again for asking but eager me can't wait: what and when might be the chances to see the Steam Workshop version be updated to the latest version?

Share this post


Link to post
Share on other sites
On 10/28/2018 at 3:59 AM, Asmodeuz said:

Quoting myself, is such a thing even possible!
 

Aand lo and behold there was Pre-Release Build 1.8.1 and those couple of functionalities indeed were good to go with their committed fixes!
Apologizing again for asking but eager me can't wait: what and when might be the chances to see the Steam Workshop version be updated to the latest version?

 

Stand by for a fashionably late answer.

  • Haha 1

Share this post


Link to post
Share on other sites
On 10/28/2018 at 3:59 AM, Asmodeuz said:

Quoting myself, is such a thing even possible!
 

Aand lo and behold there was Pre-Release Build 1.8.1 and those couple of functionalities indeed were good to go with their committed fixes!
Apologizing again for asking but eager me can't wait: what and when might be the chances to see the Steam Workshop version be updated to the latest version?

 

Waiting on one more fix, and possibly two more indexes before a release is posted.

  • Like 3

Share this post


Link to post
Share on other sites

RFX0nkZ.jpg


ALiVEmod.com


The next generation dynamic persistent mission addon for ArmA3


Spyder's ego is writing checks that his body can't cash.  It's not his coding, it's his attitude. Code is dangerous, but right now he's worse. Dangerous and foolish. He may not like who's coding with him, but whose side is he on?  That is right, but I held something back. I see some real genius in his coding, but I can't say that in here. I'm afraid that everyone in the tax trailer would see right through me, and I just don't want anyone to know that I've fallen for him.

 

Release Highlights

Combat Support - bunch of fixes and enhancements and you can now talk to a pilot from outside the chopper for quick RTB commands when dropping off in a hot LZ / HLS

MACC - Planes should avoid immediate terminal lithobraking after spawning in flight (I've been playing too much KSP)

C2ISTAR - Added a setting to exclude custom objectives from player tasking

Map Index - I44 Merderet v3; Alaska 2035; Ruha (thanks to all those who contributed)

    
See full commit history on Github
    

Download
Grab the latest version from ALiVEmod.com
Also available on Steam

Please note that as with all updates, if you have an issue loading a mission made with a previous version of ALiVE, delete and replace the modules in that mission.

 

Known Issues & Support
Existing bugs are listed on Github here. Feel free to submit bugs (with vanilla repros please) or discuss any issues or ideas on our forum at http://alivemod.com/forum/.

Manual


Please refer to the ALiVE Wiki. All the info you need is there. If anything is missing or unclear, please let us know.

Are you using Linux?


Acknowledgements and Thanks
Particular thanks to all those on our support forum who have worked closely with us to identify bugs, provide logs and generally help us improve ALiVE. Your assistance is valuable and your dedication to ALiVE makes it all worth the effort!

 

Have fun!

  • Like 5
  • Thanks 4

Share this post


Link to post
Share on other sites
On 12/7/2018 at 6:32 PM, icebreakr said:

What is needed for your team to re-index the latest Lingor 3.9.5?

Hi @icebreakr If you newest update added any buildings or altered the order or amount of building ID’s then yes it will need a new indexing to be ALiVE compatible.

 

Assuming you haven’t obfuscated your PBO files, which in the past was never an issue (I’ve indexed quite a few of your maps) an indexing can be completed with public tools we make available which are included in the ALiVE mod (it has a pretty UI and everything!).

 

http://alivemod.com/wiki/index.php/Map_Indexing

 

I tend to be one of our most prolific indexers, but haven’t Arma’d in a couple months now (RDR 2 owns me). I’m certainly not opposed to doing it when I have some time, however if anyone needs it lickity-split for an OP or whatever I encourage that person to give the indexer a whirl.

 

Otherwise I’ll do it when I’m able (your maps take a couple uninterrupted hours generally due to the copious amount of objects) and link it in your thread until we can include it in a future release.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×