Jump to content

Recommended Posts

Good question HerestotheGears.

It seems like the spawned AI vehicles are getting around and finding me just fine but my AI sqd dudes have still done some silly shit while driving.

No big deal honestly after all these years, I'm used to it hah.

 

Anyone run into the "Insufficient Resources" issue while using Zeus and trying to move spawned Ravage AI?  I have never been able to tackle what it is.  Im down to loading CBA, TPW and Ravage only  ( ok I lied, Eden Enhanced, Achilles, Sullen Skies and Aegis but I just piled those back on after testing with out them )  and can't move any foot soldiers.  I can move Zeds and AI if they are in their vehicles but not AI on foot.

 

Ok back to this new map, BI did a wicked job on it, really fun place to play with the height changes and all the cover.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, EO said:

Accept my apologies, I thought your issue was related to the Dead Rising feature, gotta little mixed up with another poster, sorry man...ignore my suggestion

:hammer:

Share this post


Link to post
Share on other sites
5 hours ago, alekzenit said:

Yes, I think it too. I guess it began to cause a conflict after ravage update with 1775. But with tpw_furniture more loot.. Thanks for help anyway :rthumb:

Disable tpw_furniture actually did not solve my problem. It causes something else.. I don’t even know. Need to turn off one by one consistently, maybe it help to find a solution of my issue.

Share this post


Link to post
Share on other sites
Posted (edited)

@alekzenit I'm not sure if this is helpful but I had a framerate as well as a (similar to you) slowdown issue using TPW and Ravage. I noticed an odd error with the line "crows" in it, so on a whim I disabled the ambient animals part of it. It seems to have solved my framerate and slowdown issue altogether.

Edited by ContheJon

Share this post


Link to post
Share on other sites
6 hours ago, HerestotheGears said:

Haleks, amazing update with the driving AI. One question though...does it affect all AI or only randomly generated AI from the Ravage mod? 

 

Every AI is affected : the system constantly checks for "car" entities that are driven by an AI, no matter how it was spawned.

  • Like 4
  • Thanks 2

Share this post


Link to post
Share on other sites

I am also getting the light bug. None of the lights on Gila work with ravage enabled.

Share this post


Link to post
Share on other sites
2 hours ago, ContheJon said:

@alekzenit I'm not sure if this is helpful but I had a framerate as well as a (similar to you) slowdown issue using TPW and Ravage. I noticed an odd error with the line "crows" in it, so on a whim I disabled the ambient animals part of it. It seems to have solved my framerate and slowdown issue altogether. 

Glad to hear it 👍 thanks

  • Like 1

Share this post


Link to post
Share on other sites

Is there a function to get the zombies in blacklisted buildings to work? 

 

Im also using EBM, would this work as one of the buildings "Flag_CSAT_F_Kit" or does it have to be a house/building?

Share this post


Link to post
Share on other sites

@Vald77r, The most recent update added support for a decent chunk of Contact assets, ranging from music, gear and weapons. It would take a lot of time to fully support all that Contact has to offer....even then the assets have to fit in with the Ravage "theme". 

Share this post


Link to post
Share on other sites

I have no idea why this will not work. Is the blacklisted buildings working for everyone else? 😖

Share this post


Link to post
Share on other sites
1 hour ago, sniperb said:

I have no idea why this will not work. Is the blacklisted buildings working for everyone else? 😖

 

Just ran a few tests on a few A3 buildings, the blacklisted structures array works just fine. 

Are you using the array as the tool tip suggests?

Share this post


Link to post
Share on other sites
58 minutes ago, EO said:

 

Just ran a few tests on a few A3 buildings, the blacklisted structures array works just fine. 

Are you using the array as the tool tip suggests?

 I have this ["Land_Sign_WarningMilAreaSmall_F_Kit"]

 

Does it only work on A3 Buildings ? 

 

This object is from this mod:

https://steamcommunity.com/sharedfiles/filedetails/?id=647753401

 

Spoiler

                class Attribute19
                {
                    property="Ravage_zombies_z_blacklist_m";
                    expression="_this setVariable ['z_blacklist_m',_value,true];";
                    class Value
                    {
                        class data
                        {
                            class type
                            {
                                type[]=
                                {
                                    "STRING"
                                };
                            };
                            value="[""Land_ds_HouseV_1L2"",""Land_A_Castle_Bergfrit"",""Land_ds_HouseV_3I3""]";
                        };
                    };
                };
                class Attribute20
                {
                    property="Ravage_zombies_sunF_m";
                    expression="_this setVariable ['sunF_m',_value,true];";
                    class Value
                    {
                        class data
                        {
                            class type
                            {
                                type[]=
                                {
                                    "BOOL"
                                };
                            };
                            value=1;
                        };
                    };
                };

 

Share this post


Link to post
Share on other sites

@sniperb, I'd imagine it works for all buildings supported by the zombie spawner script.  Beyond that it would be for @haleks to comment further as I don't recognize any of the classnames you've posted above, especially the ones in your spoiler. 

Share this post


Link to post
Share on other sites
1 minute ago, EO said:

@sniperb, I'd imagine it works for all buildings supported by the zombie spawner script.  Beyond that it would be for @haleks to comment further as I don't recognize any of the classnames you've posted above, especially the ones in your spoiler. 

They are from the ChernarusRedux map, 

 

Also I think this mod:

https://steamcommunity.com/workshop/filedetails/?id=1113351114

Share this post


Link to post
Share on other sites

@haleks I'm finding I cannot gut the Boars....would the omission of Wildboar_F from the rvg_animals list stop me from doing so? They are present in the rvg_animalsArray, just not rvg_animals.

  • Thanks 1

Share this post


Link to post
Share on other sites

Woops, thanks for the heads up mate!

  • Like 2

Share this post


Link to post
Share on other sites
22 hours ago, acoustic said:

I am also getting the light bug. None of the lights on Gila work with ravage enabled.

Just to add to this: They fully work in ED3N, but not when actually playing.

 

It's as if the module is turning them off no matter what.

Share this post


Link to post
Share on other sites
4 hours ago, acoustic said:

Just to add to this: They fully work in ED3N, but not when actually playing. It's as if the module is turning them off no matter what.


I thought the issue was just related to New Haven. I guess I'm not alone. On New Haven, a very small percentage of lights are working. Maybe 1 out of 10. I made several tweaks but it didn't change.

Share this post


Link to post
Share on other sites

 

 

On 8/2/2019 at 1:19 PM, haleks said:

 

Saw it this morning, but I was working at the same time and totally forgot... ^^'

 

To answer your questions, yep, the gear pool module affects everything : AI, loot & traders.

Controlling what traders do trade is possible, but not via module at the moment. I can share some code later if you want.

 

I'll see what I can do about the 10 kilometers long lists. 😉 

 

Back to this from a couple of days ago, do you think if I pass for example:

_rvg_supplies_custom = ["Supplies",
    [["rvg_beans", 30,"CfgMagazines", 2],
        ["rvg_bacon", 30,"CfgMagazines", 2] ]
];

this setVariable ["isTrader", "_rvg_supplies_custom", true];

 

in the init for the supplies trader it would do what I am looking for.

Share this post


Link to post
Share on other sites

the  "android" character would be a good idea for Contact sequel.

The aliens infected Rudwell with biologic neural antenna, to decrypt  their language...... or something like that

Share this post


Link to post
Share on other sites
On 8/3/2019 at 9:24 PM, Zakuaz said:

 

Anyone run into the "Insufficient Resources" issue while using Zeus and trying to move spawned Ravage AI?  I have never been able to tackle what it is.  Im down to loading CBA, TPW and Ravage only  ( ok I lied, Eden Enhanced, Achilles, Sullen Skies and Aegis but I just piled those back on after testing with out them )  and can't move any foot soldiers.  I can move Zeds and AI if they are in their vehicles but not AI on foot.


Yes, I can't move the AI squads either, I get the same report. I can order them to move here and there but cannot move them myself. Vehicles and zeds yes, but not squads. Had this thing since I started playing Ravage.

Share this post


Link to post
Share on other sites

@Zakuaz, @RZNUNKWN

The "Insufficient Resources" is not related to Ravage, it's been a Zeus "thing" since before Ravage was even released.....have you guys looked into using the Zeus Manage Resources/Set Costs modules, you can add resources available to Zeus using those modules, that may help your issue with Ravage AI.

  • Like 4

Share this post


Link to post
Share on other sites
4 hours ago, EO said:

The "Insufficient Resources" is not related to Ravage, it's been a Zeus "thing" since before Ravage was even released.....have you guys looked into using the Zeus Manage Resources/Set Costs modules, you can add resources available to Zeus using those modules, that may help your issue with Ravage AI.

This is not true if you have on a Zeus "Game Master module and no other Zeus resource related modules.

 

"If you just place a player unit and a Zeus Game Master module down in the editor and sync them together, you won't have any restrictions whatsoever."  If you only have the Zeus Game Master module and you are still getting the error then it is most likly a config issue with the mod.  I have used many mods that have this issue with one or two items.

 

An example of the config needed to allow the item to be used in Zeus.

scopeCurator = 2; // 2 = class is available in Zeus; 0 = class is unavailable in Zeus.

 

If the item that has the value set to zero is placed in the editor or via script and you try to move it in Zeus you will get the mentioned error.

  • Like 1

Share this post


Link to post
Share on other sites
 
 
 
 
15 hours ago, acebelew said:

 

 

 

Back to this from a couple of days ago, do you think if I pass for example:

_rvg_supplies_custom = ["Supplies",
    [["rvg_beans", 30,"CfgMagazines", 2],
        ["rvg_bacon", 30,"CfgMagazines", 2] ]
];

this setVariable ["isTrader", "_rvg_supplies_custom", true];

 

in the init for the supplies trader it would do what I am looking for.

 

edit:

FYI this did work when I make the variable global as below

rvg_supplies_custom = ["Supplies",
    [["rvg_beans", 30,"CfgMagazines", 2],
        ["rvg_bacon", 30,"CfgMagazines", 2] ]
];

this setVariable ["isTrader", "rvg_supplies_custom", true];

 

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×