Jump to content

Recommended Posts

@tyl3r99 here's a more detailed explanation of the available options.

 

https://3cbmod.wordpress.com/released-mods/3cb-baf-units/usage-units/

 

Provided you have the top 4 options "enabled" (which is the default) you should respawn with your initial loadout.

 

The process is:

1. place the loadout module on the mission.

2. place the units

 

By default you should respawn with your initial loadout, you do not need to change any of the options.

 

Looking at your video, I suspect the issue is that you're trying to combine Zeus loadout controls with 3CB unit controls.  The unit mod was just designed to ensure all units have a role defined loadout, without having to rely on any other functionality.

 

The video is useful, and I'll see if I recreate your issues.  Thanks

 

 

 

 

 

Share this post


Link to post
Share on other sites

ohh okay so theoretically speaking the mod isnt usable with zeus respawn loadout functionality? hope that makes sense. 

Share this post


Link to post
Share on other sites

The video was extremely helpful in seeing what you were doing.

 

Our unit load out is in two parts, the gun, vest and selected items (gps, watch, etc) are defined in the config.  All the rest of the equipment, inducing the backpack is added via a script.  This runs on the server before the unit is passed to your PC.

 

The vanilla respawn load out just uses the load out info from the config.  It knows nothing about our scripts, and hence the majority of the equipment is lost.

 

To avoid this, just switch off the vanilla respawn in the multiplayer menu.  Our respawn will then ensure you respawn with the correct kit.  You can still place zeus respawn markers (as per your video) they work fine with our code.

 

Hope that helps

Share this post


Link to post
Share on other sites

Hello

 

First of all thank you for provinding such a great mod.

 

I have a bit of an odd problem. Once I enable the BAF mods on my server and throw the keys in the folder I get a signature missmatch on all my mods. I have checked all your keyfiles with DSUtilities in Arma Tools and they seem to be fine. I am a bit lost currently and was wondering if you have any idea what else could be wrong on my end.

 

Anyway stay awsome

 

--

 

seems to be some issue with compatability between mods. Pain in the a** but harly your fault.

Edited by Sternkraft

Share this post


Link to post
Share on other sites

We've never experienced any key mismatch across our mods.  

 

If you're downloading from Steam its worth checking you have only one copy of each mod installed.

 

I'd suggest adding just a few mods to your server and checking it works, then add more in small batches.

Share this post


Link to post
Share on other sites

That is what I am currently doing. Started with ACRE,ACE, CBA and BAF and am slowly adding the other mods. I'll let you know should I find anything that I can reproduce

 

Update: Seems to have to do with either the ammount of mods or the lenght of the -mod= setting. Either way has nothing to do with this particular mod. Sorry for bothering you with it. Looking forward to playing with all your cool toys either way

Edited by Sternkraft
  • Like 1

Share this post


Link to post
Share on other sites

As they say, long time listener, first time caller.

 

Or in this case, long time lurker, first time poster.

 

Support Question: We (my small group) seem to have an incompatibility between your (quite fantastic if I do say so myself) mod and RHS. They for the most part work perfectly fine, but a minor issue is present in that the players' voiceovers will be reverted back to American English when taking control of any RHS faction (AI are not affected by this). This doesn't happen with any other faction in game. The issue is consistently replicable and happens when 3CB is installed onto the client, and persists even after complete reinstallation of both 3CB and the RHS mods and can only be fixed by complete reinstallation. We can say with certainty that this issue is related to RHS and 3CB. I have also filed a support ticket with the RHS Mod team about the issue.

 

Thank you in advance, and have a pleasant day!

Share this post


Link to post
Share on other sites

I have an issue to report when using 3CB addons with CUP addons all CUP units use the US voices am i the only one geting this issue?

  • Like 1

Share this post


Link to post
Share on other sites

Hi! Could you possibly upload a version of the mod without all the duplicate factions (AKA, rather than having army, navy, RAF etc versions of every camo, just have the army versions)? We'd like to use the mod, but there are so many units that it clogs up the zeus interface and has an impact on loading times.

 

It would be greatly appreciated.

  • Like 1

Share this post


Link to post
Share on other sites

It is unlikely that will ever happen, sorry. As for increased loading times, I am not sure what you mean. You can minimize the factions in Zeus and Eden so that each of them are reduced to single lines for each in the menu. We use the mod as it is in all of our in-house Ops and have had no issues with it. Given that mods such as CUP, RHS and Project Opfor have considerably more entries for multiple factions, I am not sure ours should be much of an issue.

 

Edit: Actually, thinking about this, you may be able to remove the other factions from the folder. I think the units are modular .pbos. It might be worth experimenting with it.

Share this post


Link to post
Share on other sites
12 hours ago, lifetap said:

@BlueNexus  You can remove the other faction pbos to get your desired behaviour.

Noted. Would we have permission to reupload our version on the workshop, (with it very explicitly stated that it's not ours), so that our players can download it easily without having to manually remove pbos? Again, this is solely to make it practical for us to use.

Share this post


Link to post
Share on other sites

I'm not sure this will work:

Removing a pbo, such as "uk3cb_baf_units_desert.pbo", will remove the desert camo scheme entirely, whereas, you have asked if it's possible to remove the "Airforce" / "Navy" components, leaving just "Army".

 

There may also be an issue with the Steam Workshop EULA which states that to upload a mod you must own the Intellectual Property contained within? Not sure.

EDIT: probably we'd need to assign IP to allow it, but it's a moot point as what you want can't be done just by removing pbo's. 

  • Like 1

Share this post


Link to post
Share on other sites

I'm very pleased to announce the next release of our  3CB_BAF_Units, along with updates to 3CB_BAF_Weapons, 3CB_BAF_Vehicles and 3CB_BAF_Equipment.

 

This release includes many small tweaks and bug fixes.

 

A download link and change log is available on the front page 

  • Like 6

Share this post


Link to post
Share on other sites

Hey fellas,

 

I've noticed in some ALiVE missions that the AI 3cb Units are not using their Night Vision goggles when patroling at night, even though they have them in their inventory.

 

Is this known? 

Share this post


Link to post
Share on other sites

I guess it's because we Brits eat our carrots and don't need no silly NVG's.

Also because the AI isn't smart enough to realise they could take the NVG'S from their backpacks and put them on their heads. From a human player perspective we prefer not to spawn with them in place.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, UK_Apollo said:

I guess it's because we Brits eat our carrots and don't need no silly NVG's.

Also because the AI isn't smart enough to realise they could take the NVG'S from their backpacks and put them on their heads. From a human player perspective we prefer not to spawn with them in place.

Gotcha,

 

Well our group is small so we typically have friendly AI units on the battlefield.  Is there a way to force them to use NVGs when at night?  perhaps someone has a script out there to do this?

Share this post


Link to post
Share on other sites
On 7/28/2017 at 12:35 AM, Phantom Hawk said:

I have an issue to report when using 3CB addons with CUP addons all CUP units use the US voices am i the only one geting this issue?

 

Same here: CBA_A3 + all 3CB loaded -> got English voices for the player.

Unload just 3CB Units -> got the rights player voices.

 

It may miss requiredAddons[]={"A3_Dubbing_Radio_F","A3_Dubbing_Radio_F_EXP"}; when you state your English voices in your mod.

 

 

Anyway, your mod is great, have been a pleasure using it :)

Share this post


Link to post
Share on other sites

Thanks for the feedback and possible solution to the issue. We'll investigate.

Share this post


Link to post
Share on other sites

BUG REPORT - error message when starting game (all 3cb mods active including ACE and ACEX)

Addon "UK3CB_BAF_Units_Common" requires addon "UK3CB_BAF_Equipment"

 

BUG REPORT 2 - error message on main menu after starting the game up (all mods active including ACE, ACEX)
 

no entry 'bin\config.bin/cfgvehicles/uk3cb_baf_solder_DDPM_longsleeve_RM_base.scope.'

 

MAJOR BUG 3 - no units found in editor

all mods active including ace, ACEX

 

edit - re loaded mods again without ACE 

still broken this is a massive game breaking bug??? 

 

mods downloaded from WORKSHOP

  • Confused 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×