Jump to content
Sign in to follow this  
Dwarden

ARMA 2: OA beta build 112555 (1.63 build release, not backward compatible)

Recommended Posts

http://www.arma2.com/beta-patch.php

WARNING: this build is major build 1.63.x thus not compatible backward with 1.62 clients !

both client and server must have this beta build

+ new linux dedicated server http://forums.bistudio.com/showthread.php?168768-ARMA-2-Operation-Arrowhead-Linux-Server-beta-1-63-112555

+ several more engine fixes (performance/stability)

[112156] Update: squad.xml stuff limited to 250 kBytes

[111952] New: squad.xml stuff limited to 50 kBytes

[111941] New: Commandline swich -nologs

[111759] Fixed: Reduced bandwidth usage in MP.

[108074] Fixed: Patch installation problems on Windows XP

+ all previous fixes http://forums.bistudio.com/showthread.php?159418-ARMA-2-OA-beta-build-108074-MP-compatible-build-post-1-62-release)

the build contain quite some of crash fixes

suggested to be used for server hosting as it shall be noticeably stabler

(if you still get any crashes, it's very important for us to get server's mdmp,bidmp,rpt files

(compressed e.g. to my email (which is my BIForum nickname @ bistudio.com)with subject CRASH)

BattlEye compatibility: ... SUPPORTED, enjoy ! ...

note: also not yet deployed on STEAM! (inside "test" branch, default beta is 103419)

+++

Data fixes and improvements by the Community Config Project (CCP)

Changelog: https://dev-heaven.net/versions/1391

More info: http://forums.bistudio.com/showthread.php?141732-ARMA-2-Community-Configuration-Project-(A2CCP)

Edited by Dwarden

Share this post


Link to post
Share on other sites

Good to see that we're getting closer to 1.63 !

One question though : who will take care of CCP fixes ?

Share this post


Link to post
Share on other sites
Good to see that we're getting closer to 1.63 !

One question though : who will take care of CCP fixes ?

CCP is community project so either the community does there are no CCP fixes. I do not recall the exact process but I believe kju was so kind he volunteered to review and submit ccp addons to us for release in the past.

Share this post


Link to post
Share on other sites

Yes, the best approach seems to be to simply to delete the folder ..\Expansion\beta

Then install the beta automatically (double-click ARMA2_OA_Build_112555.exe)

Share this post


Link to post
Share on other sites
Still get wrong cd key error.
I always had the wrong cd key error (this beta and the last one) and didn't had any problem to play (server & client side) despite this error during the installation.

Share this post


Link to post
Share on other sites

May I ask if there is still a chance to see more changes in A2CCP being accepted to appear in the game when 1.63 will hit stable release? Just to know if its worth trying.

Share this post


Link to post
Share on other sites

Thanks! One step closer to 1.63 final...

/KC

Share this post


Link to post
Share on other sites

There are simply no 1.63 servers out there. O.K. one server but that one is runnign ACE.

Share this post


Link to post
Share on other sites

this is up to community, this release has several important security/stability fixes and the wanted -nologs solving performance issues from RPT spam

Share this post


Link to post
Share on other sites

Have you update with new battleye v1.178?

Some logs:

BattlEye Server: Failed to receive from BE Master (6)

BattlEye Server: Update attempt failed

Edited by devd

Share this post


Link to post
Share on other sites

Thank you BIS. I´m sure that -nologs will prove to be very usefull :)

Share this post


Link to post
Share on other sites
Thank you BIS. I´m sure that -nologs will prove to be very usefull :)

i still wonder where are all these posts about great FPS gains on client/server from it? :confused::D

Share this post


Link to post
Share on other sites

Well with v-sync on I'm still at 60fps so :p

But thanks a lot for that -nologs, no more huge rpt file on my server after each game.

And overall thanks, it run smoother

Share this post


Link to post
Share on other sites

when I enter multiplayer a message appears "Patch 1.62 available at arma2.com", i click ok and i join my dedicated server with 1.63 with no problem, but that message shows everytime i launch arma.

Share this post


Link to post
Share on other sites

It seems that server Admins don't give much attention to 1.63 beta. I found two servers so far (angry Insects) but all are empty.

Share this post


Link to post
Share on other sites
May I ask if there is still a chance to see more changes in A2CCP being accepted to appear in the game when 1.63 will hit stable release? Just to know if its worth trying.

http://forums.bistudio.com/showthread.php?141732-ARMA-2-Community-Configuration-Project-%28A2CCP%29

Maybe post there, but I seem to remember a few posters got into a tizzy about "tab" key reveal nonsense and Kju said fuckit. Tho there are a few more contributors.

Share this post


Link to post
Share on other sites

Situation unchanged, the 1.63 beta is not well accepted because of the community split it inttroduces...it's really time to make it official patch. The days when hundreds of player here actually tested the A2 betas is obvioulsy over...most of them seem to have already completely migrated to ArmA III.

Share this post


Link to post
Share on other sites

What keeps me from using the recent beta patches is the .rpt spam caused by BIS scripts (undefined variables).

I can't simply turn the logs off when I am creating content.

As a result of this I can not test stuff with the newest patches.

And I can not use untested content.

That's why I advise our community NOT to use the latest patches, so we can play in a tested environment.

Which results in our server not running the latest patches.

-> Our players or course don't use those patches either.

Share this post


Link to post
Share on other sites
What keeps me from using the recent beta patches is the .rpt spam caused by BIS scripts (undefined variables).

I can't simply turn the logs off when I am creating content.

As a result of this I can not test stuff with the newest patches.

And I can not use untested content.

That's why I advise our community NOT to use the latest patches, so we can play in a tested environment.

Which results in our server not running the latest patches.

-> Our players or course don't use those patches either.

use "-nologs" commandline parameter, it was introduced EXACTLY for that reason

(and it improve performance of BOTH client and server (must be used onboth ofcourse))

also there were and are OTHER spams in RPT (like network and object related)

which were even before the introduction of warning about "undeclared variable after 'spawn'"

so unless You debugging You not need RPT file

note: also if you run older builds than 1.63 then you sort of fool

due to security fixes, stability fixes and mp and memory optimizing and several other low level fixes

the -nologs solves the issue with RPT spam

there is no error in GUI that was removed long time ago

in short if you run -nologs, the declaring variable warning RPT spam is no bother to you

it's not breaking anything it's just warning

---------- Post added at 13:57 ---------- Previous post was at 13:56 ----------

Situation unchanged, the 1.63 beta is not well accepted because of the community split it inttroduces...it's really time to make it official patch. The days when hundreds of player here actually tested the A2 betas is obvioulsy over...most of them seem to have already completely migrated to ArmA III.

can't be final yet, because for that we need ACR 1.01 patch and OA data fixes ;)

so first step would be 1.63 RC1 then final

Edited by Dwarden

Share this post


Link to post
Share on other sites
Situation unchanged, the 1.63 beta is not well accepted because of the community split it inttroduces...it's really time to make it official patch. The days when hundreds of player here actually tested the A2 betas is obvioulsy over...most of them seem to have already completely migrated to ArmA III.

Keep calm, it will take some time; also becase there were no betas lately... Personally, I have recognized the new beta today.

Share this post


Link to post
Share on other sites

@Dwarden: You didn't read carefully: I can not use -nologs, because then I can not debug.

I can not debug with the logs either after the latest patches because they are full of undefined variables spam from BI scripts.

Also I am well aware that this does not break anything.

It just makes it harder to find real bugs in the rpt.

Edited by Dimitri_Harkov

Share this post


Link to post
Share on other sites
can't be final yet, because for that we need ACR 1.01 patch and OA data fixes ;)

It's great to hear official mention of an ACR patch!! :) Big thumbs-up!

Share this post


Link to post
Share on other sites
they are full of undefined variables spam from BI scripts.
yes,i confirm this....and i bet some missions and addons needs hotfixes

Share this post


Link to post
Share on other sites

can't be final yet, because for that we need ACR 1.01 patch and OA data fixes ;)

:) thumbs up...

Share this post


Link to post
Share on other sites
@Dwarden: You didn't read carefully: I can not use -nologs, because then I can not debug.

I can not debug with the logs either after the latest patches because they are full of undefined variables spam from BI scripts.

Also I am well aware that this does not break anything.

It just makes it harder to find real bugs in the rpt.

+1

@Dwarden: Oh came on! Please don't tell me there are no plans on fixing those warnings coming from BIS scripts. We can't develop no more with all those warnings, every time you hit the G key you get one, and many modules produce them too. Besides, in my experience, almost every time I got a warning of an undefined variable, there was a real problem with the code, so thank you BIS, but please debug your own code now.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×