Jump to content
tophe

Tophe's Arma Dedicated Server Tool (TADST)

Recommended Posts

Ah yes, you're right. Windows had removed the 'run as administrator' from the desktop shortcut to taste, so it couldn't write a new file.

Thanks for the advice

Share this post


Link to post
Share on other sites

Hi

Is there a way of forcing the server using forceRotorLibSimulation in TADST ?

Edit: I found that currently it can be done only mission side...

Edited by Sjaba

Share this post


Link to post
Share on other sites

Feature request... A filter on the mods page to click and have it show only the selected mods... or make the red x work as I would interpret it that selected mods (those that have been checked) are hidden from the list. As it is now, the HIGHLIGHTED mod is hidden when clicked, not checked mods.

Share this post


Link to post
Share on other sites

Hey all long time now see :)

Ive just getting back into arma 2.

I have all retail copys of arma 2,arrow head,baf etc etc but I have just registered them on steam whice I think is where the problem stareted :(

I have got it to show all the icons in the bottom left corner on game start so I know its running in combined ops though there is no icon for it whice sucks.

I want to use this great toll to create a dedicated server like I all ways do but I cant see a combined ops server EXE am i stupid? please help.

I chose arrow head server exe and it moaned it could not find some files map_EU or some thing?

Thanks :)

STEAM has totaly fucked arma 2 :(

I use the dedicated server exe using this tool start arma via steam and it says program is all ready running I mean WTF please help :(

Edited by stk2008

Share this post


Link to post
Share on other sites

OK I have finally got it to load the server with mods and as combined ops I think with out it kicking up errors using the arma2_OA server exe buuutttt :(

When i load arma 2 oa using steam it says its all ready running I mean please help me here :(

---------- Post added 11-24-2014 at 12:01 AM ---------- Previous post was 11-23-2014 at 11:34 PM ----------

OK I have finally got it to load the server with mods and as combined ops I think with out it kicking up errors using the arma2_OA server exe buuutttt :(

When i load arma 2 oa using steam it says its all ready running I mean please help me here :(

Ok more info

I installed the arma 2 server exe using steam tools it just places a binery in arma 2 oa

If I DONT use this tool and start the server and then use steam to start arma 2 oa its fine.

Its only when I use this tool and point it to the oa server exe and then start arma 2 oa via steam it says the programme is all ready running that sucks.

I used to use this tool all the time now its STEAM has messed every thing up ~:(

Share this post


Link to post
Share on other sites

Everytime I update my mission, I need to download it on the game. Isn't possible to transfer the mission instantly to the client?

Thanks.

Share this post


Link to post
Share on other sites

would it be possible to add the command equalModRequired = 1; in the server rules?

Share this post


Link to post
Share on other sites

Using this server tool, after the last arma 3 update today im getting an "C:\Windows\SysWOW64\ntdll.dll" error in my rpt and crash on my server. Tried on two different computers with same result.

Anyone help please?

Edited by Sixt

Share this post


Link to post
Share on other sites

As its now is possible to use this forceRotorLibSimulation: 1 on server side, how can i run that using TADST ?

Share this post


Link to post
Share on other sites
Using this server tool, after the last arma 3 update today im getting an "C:\Windows\SysWOW64\ntdll.dll" error in my rpt and crash on my server. Tried on two different computers with same result.

Anyone help please?

Run sfc /scannow in cmd and restarting the machine afterwards should fix it

Share this post


Link to post
Share on other sites
As its now is possible to use this forceRotorLibSimulation: 1 on server side, how can i run that using TADST ?

Not exactly a solution, but I think it works for now: set up TADST the way you want, save the profile, then find your "TADST_config.cfg" file (in your TADST folder) and add the line:

forceRotorLibSimulation = 1;

Now in TADST, make sure to tick "Launch as is" to prevent it overwriting the cfg when it launches and removing your amendment.

For Headless Clients you also need to do something similar, but in the cfg where it says "localClient[];{xxx.xxx.xxx.xxx};" change it to "headlessClients[]={xxx.xxx.xxx.xxx};"

Share this post


Link to post
Share on other sites

Tophe, I believe the latest update to the headless client made the LocalClient[] array useless. I believe it's been changed to HeadlessClient[].

Share this post


Link to post
Share on other sites

edit: never mind, I seem to have fixed it the issue.

Edited by GDent

Share this post


Link to post
Share on other sites

Dear JohnnyBravo: Have you solved this problem now?? I have the same problem that it can only showed in LAN but not Internet.:butbut:

Thank you

Hi guys, I hope this is the appropriate thread for this question.

No matter what I seem to do, my server only shows up in the LAN listing. (In the game browser. In the steam server browser it doesn't even show up anywhere at all.)

I have port forwarded the necessary ports, and even some extra ports just to be sure- as i have read extensively on the matter but can't seem to find a solution. (Yes, both through firewall and router)

The server seems to boot up fine, and creates a host etc. But no one can join, and it is also impossible to join via the steam friend function. I have tried different ports, but all to no avail.

I am currently using an ethernet cable in stead of wifi- but I have been able to host very succesfully with this setup before, so it must be something to do with the 1.22 patch/gamespy server shutdown!

Please help me and those who are experiencing the same trouble, as it is very frustrating and confusing- it would be much appreciated!

Extra details: Using TADST 2.6

Have tested with and without mods/addons

Using GamePort 2302

Using Steamport 2304 (sometimes 8766 but still ends up in LAN)

Share this post


Link to post
Share on other sites
I have a similar problem have you guys solved it?

FYI : I have solved the problem! simply go to your router and foward the steam port together with arma port. In my case port 2302,2303,2304,2304 and 8766. Hope that helps!

Share this post


Link to post
Share on other sites

I have recently resurrected a Windows 7 computer with the intent of hosting an ArmA III server on it from home (using TADST). What I have discovered with my Billion router is, when you set up port forwarding for ArmA III and Steam; ensure the desktop computer hosting the ArmA III server has a static IP address configured under the DHCP Server settings of your router.

My issue was the IP address for my desktop computer hosting the ArmA III server was leased in DHCP and thus when it expired (every 24hrs) the IP address changed. This caused the IP address of the desktop computer hosting the ArmA III server to be different to the router port forwarding rules I previously created (thus why I could not see the server session being hosted on the Internet from my gaming PC).

Once I assigned the desktop computer hosting the server an internal static IP address (via DHCP Server options) and setup the port forwarding rules to mirror this IP on the router, it was consistently displaying the hosted server on my gaming PC Internet browsing function.

Router Port Settings

TCP/UDP: 2302-2305

*Note* I use TCP also, as its seems to affect the ArmA III Squad XML tags if its UDP only (ie./ they didn't appear for me when joining the server mission)

TADST Port Settings

Port: 2302

Steam: 2303

Procedure I use for best results:

-Start up ArmA III hosted server using TADST

-Start up Game and select PLAY > MP > Internet and refresh server listing straight away (once I have done this it can take between 10-30 seconds for the server to appear in the listing (server name filtered).

-If it it does not show, restart game on your gaming PC and try again.

-If its still not there, restart router and try process again

The only issue I have now is getting subscribed Steam workshop missions on the PC which hosts the ArmA III server, to show in the MP Missions listing when I connect to it via my gaming PC (on a normal PC they will be in orange font, however don't see them when I connect to the server box). BIS Feedback Tracker ticket has been lodged :)

cheers and beers (thanks Tophe for a great utility)

Edited by Sledge

Share this post


Link to post
Share on other sites
how are your mods placed in parameter? @mod;@mod;...? etc? are they turned on? are they in the Arma 3 folder? Does the mod mission play in editor? if so, check your mod set on server and in TADST.

I have a similar problem. I get hung on the intro load screen before the Player select screen and the parameter doesnt show all the mods if i scroll along. Is there a limit to the amount of mods that'll work. I've got 70 and they are turned on in game. I use Arma3Sync plus enable them in the expansions page from initial install. Mods work fine in LAN only multiplayer/single player. I also get a random map picture in the loading page rather than the relevant one for the map in use. It works fine in LAN and SP too.

Vanilla set up works fine.

Help :/

EDIT: Its keeps saying the mission file 'read from bank'. Over and over in the box that tells you its connected.

Edited by markh7991

Share this post


Link to post
Share on other sites

Hi.

Maybe my searchskills are poor since I did not find an answer, but is it possible to use BEC with TADST?

Secondly, in the MOTD filed in TADST, when using empty lines, TADST ignores it, how can you override this?

Do I simply need to "Launch as is" and edit the config manually, or is there another way?

*EDIT* Looks like I sorted the TADST part, my searchskills was just a bit rusty.

Edited by sendjes

Share this post


Link to post
Share on other sites

I can't get TADST to launch my server with the difficulty settings I have selected. The only way I can change the difficulty is to jump into the game, join the server, and then sign in as admin and change mission.

Share this post


Link to post
Share on other sites

Hey this is great. been using for some time on my personal DS. I have a question. apparently other players cannot see what mods are on my server in the expansion box when they use the server filter. Is there a way to do this so it shows that I have CBA_A3 to allow clients side mods for audio and visual effects.

Share this post


Link to post
Share on other sites

Does TADST recognize Steam Workshop downloaded missions? Doesn't look like it or at least they don't show up in my list of missions in TADST.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×