Jump to content
Sign in to follow this  
warlock2511

Arma2 dedicated server howto

Recommended Posts

when i add this to my config

{

class crcti_WARFARE_09 // name for the mission, can be anything

{

template = crcti_WARFARE_09.Chernarus // omit the .pbo suffix

difficulty = "Regular"; // difficulty: Recruit,Regular,Veteran,Expert as specified in *.Arma2profile

};

};

I get the next message :

File server cfg,line 49:Missions, member already defined

Share this post


Link to post
Share on other sites

You are missing a semicolon after mission name.

template = crcti_WARFARE_09.Chernarus;

Share this post


Link to post
Share on other sites

aah , i see it

Tnks!

Edit:

I still get an error message

Edited by Sneaker-78-

Share this post


Link to post
Share on other sites
File server cfg,line 49:Missions, member already defined

Are you sure you have only one class Missions section in server.cfg?

Maybe post the whole server.cfg here or just double check everything in your file against wiki example.

Share this post


Link to post
Share on other sites

difficulty = "Regular";

Must that not be difficulty = "Regular"

I am not sure because i dont use that part of the server.cfg ;)

Share this post


Link to post
Share on other sites

here is my config :

// password = ""; // password to protect server access

passwordAdmin = "***"; // password to protect admin access

hostname="Joint operations A2"; // This is the server name that will appear in gamespy

motd[]=

{

"Welcome to ARMA 2",

"Enjoy and play fair!",

"This server will be monitored",

"So don`t get bannend",

}; // Welcome message

motdInterval=50; // period between motd rotation

voteThreshold=1.5;

maxPlayers=20;

reportingIP="arma2.master.gamespy.com";

voteMissionPlayers=0; // start voting when 1 players connect

logfile = "MyServer.log";

kickduplicate=1; // do not allow duplicate id

equalModRequired=0; // require equal mod

disableVoN=1;

vonCodecQuality=7;

VonID=1;

timeStampFormat=full;

NetStats=1;

DeathMessages=1;

persistent=1;

regularcheck="{}";

verifySignatures=1;

class crcti_WARFARE_09 // name for the mission, can be anything

{

template = crcti_WARFARE_09.Chernarus; // omit the .pbo suffix

difficulty = "Regular"; // difficulty: Recruit,Regular,Veteran,Expert as specified in *.Arma2profile

};

};

Share this post


Link to post
Share on other sites

You have:

class crcti_WARFARE_09 // name for the mission, can be anything
{
template = crcti_WARFARE_09.Chernarus; // omit the .pbo suffix
difficulty = "Regular"; // difficulty: Recruit,Regular,Veteran,Expert as specified in *.Arma2profile

Try this:

class Missions
{
class Mission_01 // name for the mission, can be anything
{
template = crcti_WARFARE_09.Chernarus; // omit the .pbo suffix
difficulty = "regular"; // difficulty: recruit, regular, veteran & expert as specified in *.Arma2profile

Share this post


Link to post
Share on other sites
here is my config :

I seems to me that you have a "};" too much at the end...but I have been wrong before.

Share this post


Link to post
Share on other sites

I have a dedicated server running on the same machine I play on after a LOT of help from Mr Khan (thank you) it runs well and there is no lag from the server.

I copied the Bohemia folder to a partition and run the dedi server just fine.

I have just installed 1.03 patch and it wotn run the server now !!! I installed the 1.03 patch to my main hddd then copied it all over again put in the default folders etc but it wont run a 1.03 server is there something else I need to change?.

---------- Post added at 06:50 AM ---------- Previous post was at 06:34 AM ----------

I have a dedicated server running on the same machine I play on after a LOT of help from Mr Khan (thank you) it runs well and there is no lag from the server.

I copied the Bohemia folder to a partition and run the dedi server just fine.

I have just installed 1.03 patch and it wotn run the server now !!! I installed the 1.03 patch to my main hddd then copied it all over again put in the default folders etc but it wont run a 1.03 server is there something else I need to change?.

OK OK it hasnt been released yet DOH!.

Share this post


Link to post
Share on other sites

Do the ArmA2 Dedicated server files use more than 1 core? it only seems to use 25% of my quad core server.

is it safe to run 4 servers locking them to 1 core each?

Share this post


Link to post
Share on other sites

Steam Version Can I Run A Server?

I purchased the steam version, can I still run a server?

I noticed in order to use mods I could not use the -mod=mod1;@mod2

scenario just did not work, I had to just place all PBO and files into the addons dir and they work.

so seems like the files structure is different obviously.

Any ideas...

Also I am a noob with hosting a game server can someone tell me if im correct.

1. Install game

2. add server exe and other server files to main game install dir

(assuming i had the actual game not steam version?

3. would having a server allow me to unlock vehicles in maps like evolution by editing the server config file?

Thanks

Share this post


Link to post
Share on other sites

3. would having a server allow me to unlock vehicles in maps like evolution by editing the server config file?

Thanks

Sorry can only answer this one, go online and join a server where you see the mission as "evo unlocked"

you can then get a copy by going for example c drive/document and settings/name/aplication data/local settings/ arma2

In that folder you will see mpmissioncache folder inside you will see the evo unlocked map.

just copy that and paste it in the mpmission folder inside arma2 durectory and it should appear when you create a server.

Southy

Share this post


Link to post
Share on other sites

ok I think Ive figured out why some people do not see the passwords etc working on their servers. You need to make sure that when you save the file (ie server.cfg) after editing that you do not save it as a Text file. Save it in notepad as a unicode text file. Otherwise the system will not see it with an extension of cfg it sees it with an extension of txt.

Share this post


Link to post
Share on other sites

I have just installed 1.03 patch and it wotn run the server now !!! I installed the 1.03 patch to my main hddd then copied it all over again put in the default folders etc but it wont run a 1.03 server is there something else I need to change?.

You can run the latest beta as a dedicated server but you have to start the arma2.exe from the beta folder with the parameter -server.

Looks like this:

start /HIGH /wait /AFFINITY 0x14 x:\ArmA2Server\beta\arma2.exe -server -cpuCount=2 -profiles=x:\ArmA2Server\profilespublic -config=Server.cfg  -port=2302 -mod=beta

This line is part of a batch file in the normal A2 folder on the server.

Do the ArmA2 Dedicated server files use more than 1 core? it only seems to use 25% of my quad core server.

is it safe to run 4 servers locking them to 1 core each?

I wouldn't run it on one core, the A2 server utilizes max two cores, one core and you will definately get performance problems if you have higher player numbers.

Xeno

Share this post


Link to post
Share on other sites
58815 Fixed: Enemy kills made by player using stolen enemy vehicle are no longer considered as friendly kills.

Only works if hosting. Tried on my dedicated server and you still get minus for enemy kills if using stolen enemy vehicle.

I should add that I used the beta as a mod folder in the shortcut for the 1.03 dedi server.

You can run the latest beta as a dedicated server but you have to start the arma2.exe from the beta folder with the parameter -server.

Looks like this:

start /HIGH /wait /AFFINITY 0x14 x:\ArmA2Server\beta\arma2.exe -server -cpuCount=2 -profiles=x:\ArmA2Server\profilespublic -config=Server.cfg  -port=2302 -mod=beta

This line is part of a batch file in the normal A2 folder on the server.

Tried it on my private dedi server and even replaced the files with the beta ones and still no go. I guess this is dependent on the Actual server.exe or did you get it to work Xeno and how? Thanks and congratulations on your award for domination, you deserved it for your wonderful mission.

Share this post


Link to post
Share on other sites

I just hnoticed that ANYONE can log in as admin on my server even thoguh I have a password on it.

Also my MOITD doesnt work anyone know why?.

password = "";

passwordAdmin = "xxxxxx";

hostname="XXXXXXX server";

motd[]={

"Welcome to XXXXXXX Squad server",

"Teamplay only please",}; // Welcome message

My server name is still the name of my pc and not the one I l;ist in the default/arma.cfg folder.

motdInterval=10; // period between motd rotation

Something not right?.

Edited by jammymutt
Missed something

Share this post


Link to post
Share on other sites

Hi there !

I got a simple question i think. Im trying to write my server.cfg and get parameters correct so the mission will last for 120 minutes. This is config.hpp from the berezino mission and i'm guessing this is where i have to look for those parameters.

onLoadMission="Berzerk v2.0 beta66 - Berezino";onLoadIntroTime=true;disabledAI=1;debriefing=1;showWatch=1;showNotepad=1;showCompass=1;showGPS=1;showMap=1;respawn=3;respawnDelay=10;estimatedTimeLeft=3600;titleParam1="Respawn/View/Time";valuesParam1[]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30};defValueParam1=13;textsParam1[]={"Standard/1200m/30min","Standard/1200m/45min","Standard/1200m/60min","Standard/1200m/120min","Standard/1200m/unlimited","Standard/2400m/30min","Standard/2400m/45min","Standard/2400m/60min","Standard/2400m/120min","Standard/2400m/unlimited","Standard/4000m/30min","Standard/4000m/45min","Standard/4000m/60min","Standard/4000m/120min","Standard/4000m/unlimited","No Task/1200m/30min","No Task/1200m/45min","No Task/1200m/60min","No Task/1200m/120min","No Task/1200m/unlimited","No Task/2400m/30min","No Task/2400m/45min","No Task/2400m/60min","No Task/2400m/120min","No Task/2400m/unlimited","No Task/4000m/30min","No Task/4000m/45min","No Task/4000m/60min","No Task/4000m/120min","No Task/4000m/unlimited",};titleParam2="Weather/Vehicles/Time";valuesParam2[]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16};defValueParam2=5;textsParam2[]={"Clear/All/Day","Clear/All/Night","Clear/All/Morning","Clear/All/Evening","Clear/Side/Day","Clear/Side/Night","Clear/Side/Morning","Clear/Side/Evening","Changes/All/Day","Changes/All/Night","Changes/All/Morning","Changes/All/Evening","Changes/Side/Day","Changes/Side/Night","Changes/Side/Morning","Changes/Side/Evening"};class Header{gameType=Hold;minPlayers=1;maxPlayers=128;};

Now.. what to i set my parameter to in my server.cfg to make this work?

Do i use this value

  ;valuesParam1[]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30}

for standard/4000m/120min i would choose =9

And my server.cfg would look like this ?

class Mission04
  {
  template = ch128_berzerk_v2_beta65_berezino.chernarus;
  cadetmode = 1;
  param1 = 9;
  };//end of this mission

Hmm.. nobody knows how to set parameters in the server.cfg? please help

Edited by cri74

Share this post


Link to post
Share on other sites

Server seems to crash loading some missions, but not other missions. That is, the mission will not even start and everyone would get stuck at "waiting for host" or "receiving mission files". Server will never send those missions to clients. The missions that do work seem to take a bit of a long time to start up.

Any ideas what can be causing this? I couldn't find any trend in which missions work and which don't. From missions I made 2 worked and 2 didn't. Berzerk works. Domination (latest version) doesn't work.

Nothing on the wiki or on kellys-heroes was of any help :(

Share this post


Link to post
Share on other sites

Hi, I have a question, we have recently set up a server, but need to figure out how to autokick players with too high ping.

How is this done?

Share this post


Link to post
Share on other sites

How do I change the default grass and view distance settings for the server? I know how to make them for a specific mission via the class missions, but I want something that will be global to all missions.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×