Jump to content
Sign in to follow this  
warlock2511

Arma2 dedicated server howto

Recommended Posts

We had the same issue, i put a ticket in about it and it was the drivers on the box needed updating, which ones they where i canot tell you, sry.

I suggest you do the same m8

Share this post


Link to post
Share on other sites

I'm going to write a full tutorial on how to setup the ArmA2 dedicated server. I'll post something up shortly.

Share this post


Link to post
Share on other sites
Jman;1334262']I'm going to write a full tutorial on how to setup the ArmA2 dedicated server. I'll post something up shortly.

Sweet Mate.. I'm still struggling with mine.

Share this post


Link to post
Share on other sites

I have followed this and got my server up and running. But I am unsure how to give a map/mission list.

Can someone help me?

Share this post


Link to post
Share on other sites

Thanks JMAN!

I'm close and the server is up but don't have the server, user or profile cfgs set up quite right. Part of my problem is the parameter line in Firedaemon, I'm trying to avoid using the ARMA2.exe shortcut on the desktop. It didn't launch correctly from the desktop icon but did with the way I set it up following the instructions in this thread. But I could get it to launch via Firedaeomon when the ARMA2.exe is located in C:\Program Files\Bohemia Interactive\ARMA2\My Server

Biggest request I have is to see which .cfgs and .log files are required and in which folders and what the paths are to those folders.

Here's what my friend said is going on with my server;

There are no maps selectable but you can join the lobby.

A raw ArmA-II server gives the first person the opportunity to choose the mission. There is a vote is there are more than one player in the lobby at the time. After the time limit everyone gets to chose their roll, load the map and play. After the last player leaves the server defaults to the "Creating" state that your server is in now. It's not like server for other games, if no one is in the server then it just sits there not dong anything.

So with out the configs your server is there but not taking part. You need some configs m8...

@Jammy, my friend looked for our server by going to the Multiplayer section and clicking on "Remote" from there you can enter the IP of your server to search for it.

Side note, we also had to update our server to the latest directx version.

Share this post


Link to post
Share on other sites
class Missions

{

class MPCTF_01 // name for the mission, can be anything

{

template = M02CaptureTheFlag.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

class MPCOOP_01 // name for the mission, can be anything

{

template = M01Cooperative.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

class MPCTI_01 // name for the mission, can be anything

{

template = M03ConquerTheIsland.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

};

Guys can you please provide some extra explanations. So say I want to make a coop mode map, how is it done? Or if say I used the editor in the game, how do I parse that map into here? How this works?

Share this post


Link to post
Share on other sites
Guys can you please provide some extra explanations. So say I want to make a coop mode map, how is it done? Or if say I used the editor in the game, how do I parse that map into here? How this works?

You have to save your mission in the editor as multiplayer. This will create a .pbo file in your MPMissions folder.

then move this to your ded server mp missions folder and place the name in the line without the .pbo postfix.

{

template = MY_MP_MISSION_NAME.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

Share this post


Link to post
Share on other sites
You have to save your mission in the editor as multiplayer. This will create a .pbo file in your MPMissions folder.

then move this to your ded server mp missions folder and place the name in the line without the .pbo postfix.

{

template = MY_MP_MISSION_NAME.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

Thanks for fast replay m8, also another question. When the map classes are completely left out of the server.cfg, the server starts loading a mission when people are on and just gets stuck at loading with this message "No entry

'bin\config.bin/CfgWorlds.GenericNames'." Any idea what that might be?

*SOLVED*

Some of the files were not patched up to 1.02 somehow, repatched and server started working properly.

Edited by leeroyka

Share this post


Link to post
Share on other sites
{

template = MY_MP_MISSION_NAME.Chernarus;

cadetMode = 1; // difficulty 0=veteran 1=cadet (not only AI, but radar, map etc)

};

Yet some more questions. :P When you have made some custom missions, and added to your server.cfg, the server automatically starts the first map on the list once a player joins, is it possible to add more cvars like "timelimit"? Or is that done in the actual map file?

Edited by leeroyka

Share this post


Link to post
Share on other sites

It's actually:

class Missions
{
   class Mission_01   // name for the mission, can be anything
   {
       template = mymission.Chernarus; // omit the .pbo suffix
       difficulty = "Regular";   // difficulty: Recruit,Regular,Veteran,Expert as specified in *.Arma2profile
   };
   class Mission_02
   {
       template = anothermission.Chernarus; 
       difficulty = "Veteran";
   };
};

Refer to my guide.

Share this post


Link to post
Share on other sites

@[KH]Jman

Why do you use "voteThreshold=25;" in the server.cfg. I don't think BIS uses much more than 0-1 and I think it should be "voteThreshold=0.25;"

Why are you using these lines in the server.cfg

// Enables ingame scoreboard.
NetStats=1;

// Enables death messages ingame
DeathMessages=1;

When they are represented in the Server.ArmA2Profile

Are there any spesific reason for this??

In the ArmA2.cfg, you have just used the performance tips from ArmA1. But you have left out those things that has to do with the maskin. Like

language="English";
adapter=-1;
3D_Performance=93750;
Resolution_Bpp=32;
Resolution_W=800;
Resolution_H=600;

Are there any spesific reason for this??

In the firewall setting, you have:

port          2302        UDP         ArmA2 game network communication.
port+1      2303        UDP         Gamespy public server reporting.
port+3      2305        UDP         Voice Over Net transmission.

Don't you need TCP also??

I'm just asking. Thanks for making a tutorial.

Share this post


Link to post
Share on other sites

1. Sorry typo. I've corrected it.

2. They can be defined globally in the server.cfg

3. As I explain in the guide, I have omitted these from ArmA2.cfg since they are generated automatically and are not related to multiplayer.

4. No you only need UDP

Share this post


Link to post
Share on other sites

Thanks for writting this guide [KH]Jman :)

I have added a sticky on our forums to linking to your page as we have had many questions about setting up a dedi as well.

I hope with your guide more people will have better luck setting up things :)

Share this post


Link to post
Share on other sites

Thanks and please do PM me if there is any new information or corrections that need to be made I've tried to make it as concise as possible but since there is no official ArmA2 documentation at present it seems like a practical thing to do.

Edited by [KH]Jman

Share this post


Link to post
Share on other sites

Do you have to add the -cpucount=4 to use all cores of a quad core. I was running a dedicated server last night and noticed that it never used more than 1 core. 'Whats going on' as Marvin once said.

Cheers

GC

Share this post


Link to post
Share on other sites

You can set affinity if you like but I find that windows distributes the cpu load across all cores by default.

Share this post


Link to post
Share on other sites
Do you have to add the -cpucount=4 to use all cores of a quad core. I was running a dedicated server last night and noticed that it never used more than 1 core. 'Whats going on' as Marvin once said.

Cheers

GC

-cpucount= defines how many cores arma client or server uses. By default it uses all cores.

This parameter helps to limit the number of cores arma uses. It exists because arma executable allocates working threads to cpus at the start. Therefore, you need to allocate CPUs before you run the executable.

So if you are going to limit arma to say 2-cores out of 4-cores, do it by using this command or by setting affinity in the start-up.

Try to avoid changing affinity thru task manager after firing up the exe.

By default you do not need to change affinity or use this command. No extra benefits.

Share this post


Link to post
Share on other sites
looool leeroy arma2 server noooob :yay::bounce3:

I think we are all noobs or we would all have sevrers running wouldnt we?.

Share this post


Link to post
Share on other sites

I am working on getting test demo dedicated server running. I am having issues getting the server running. I think I have two issues remaining.

1. pointing to a mission template. Are there any sample templates to use.

2. Keep getting an error in server report.

Mods: CA

Distribution: 0

Preloaded texture Chernarus not found in bin\config.bin/CfgWorlds/

Preloaded texture utes not found in bin\config.bin/CfgWorlds/

Any Ideas. I want to try the dedicated server.

Share this post


Link to post
Share on other sites

This is what I havew in my server .cfg file which is inside a folder called default.

password = "X";

passwordAdmin = "X";

hostname="My Squad";

motd[]=

{

"Welcome to Wasp Squad server",

"Teamplay only please",

}; // Welcome message

motdInterval=50; // period between motd rotation

voteThreshold=1.5;

maxPlayers=80;

reportingIP="arma2.master.gamespy.com";

voteMissionPlayers=1; // start voting when 1 players connect

logfile = "MyServer.log";

class Missions

{

};

kickduplicate=1; // do not allow duplicate id

equalModRequired=0; // require equal mod

disableVoN=1;

vonCodecQuality=7;

VonID=1;

timeStampFormat=full;

NetStats=1;

DeathMessages=1;

persistent=0;

BattlEye=0;

regularcheck="{}";

verifySignatures=1;

The serve rstarts fine and runs but when I start Arma2 it does not find the server on the mp server list HOWEVER when I click on LAN theres a server which has the name of my computer.

Any Ideas?.

Thanks Jammy

Share this post


Link to post
Share on other sites

@MookieBlack

1. Just join a multiplayer server, join the mission and let it download to your client. Quit out of ArmA2 and copy it out of your client's multiplayer mission cache. Copy it to the server's ArmA2\MPMissions folder and add a reference to it in your server.cfg (see my online guide for more info).

2. If your getting data written to the .rpt file but the mission is still functioning as intended ignore it, alot are just warnings and do not effect gameplay.

@jammymutt

Can you post your startup line please?

Edited by [KH]Jman

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×