Jump to content

Recommended Posts

4 hours ago, GEORGE FLOROS GR said:

 

I just noticed the same ! did you came up with a solution ?



You can delete the bugged new lines 29-31from fnc_getArea.sqf located in Arma 3/Addons/functions_f/Misc and get rid of the error without any adverse consequences, as far as I've seen.
It's an interim solution, but until the new format gets fixed it's better than nothing.

  • Like 1

Share this post


Link to post
Share on other sites

I checked on how to yesterday and i found a way actually , so i approach this with a different method , but i don't know yet with what more codes it might interfere with.

Share this post


Link to post
Share on other sites

for usage in my script, just do not add any marker names to the arrays (vd_settings) that are not actually representing a placed area marker on the map.

before, non existenr markers that whrre mentioned in a script, where just ignired it seems. but this is just in bis fnc find savepos

Share this post


Link to post
Share on other sites

The poblem comes up with the following :

Spoiler
1 hour ago, Dedmen said:

Had 3 occurences of this "bug" in Arma Discord. All of them were caused by people using BIS_fnc_randomPos with invalid parameters that they all copied from somewhere else, weirdly enough they all had the same wrong parameters.

 

Same thing in invade and annex https://github.com/iamlegend23/invade-annex/search?q=bis_fnc_randomPos&unscoped_q=bis_fnc_randomPos

The "out" parameter is invalid.

 

It has been invalid for 2 years, all that changed was that BI is now properly checking for errors.

 

Share this post


Link to post
Share on other sites
On 12/10/2018 at 11:56 PM, Vandeanson said:

@lv1234

oh, have you placed the blacklistvarea markers?

Did we have to do that in the previous version, since I didn't do that in the previous version and the scripts still worked fine

On 12/11/2018 at 8:51 AM, jandrews said:

 

In all honesty if you have server issues with scripts, first and foremost you have to test in vanilla arma.  Mods do strange things to vanilla code. Especially if you have mods that may change ai behaviors.

 

Secondly I would just delete all old code and download most recent version.

 

If you have done both ( no mods and updated code ) and still have issues then it's probably appropriate to post here.  It's really hard to replicate your issues when you have some mods and possible server configs different then default.

 

Just consider.

So these are the mods that I have used for my test

-CBA3

-Ravage 

-Dbo horses

-Cup terrains core 

As you see it is all minimal and of course required for the scripts and ravage to work 

 

Old code has already been deleted and up to date with the latest ones. Same thing still happens when nothing happens (no horses spawn inc. bandit camps, crashsite and hideouts) 

Share this post


Link to post
Share on other sites
29 minutes ago, lv1234 said:

Did we have to do that in the previous version, since I didn't do that in the previous version and the scripts still worked fine

So these are the mods that I have used for my test

-CBA3

-Ravage 

-Dbo horses

-Cup terrains core 

As you see it is all minimal and of course required for the scripts and ravage to work 

 

Old code has already been deleted and up to date with the latest ones. Same thing still happens when nothing happens (no horses spawn inc. bandit camps, crashsite and hideouts) 

 

Ok.  Next thing is look at your server rpt file and -showscripterrors on the server parameters to see if its loading and if there are any script errors.  I wonder is the server hanging on a mod or is it loading your mission at start?

Share this post


Link to post
Share on other sites
33 minutes ago, jandrews said:

 

Ok.  Next thing is look at your server rpt file and -showscripterrors on the server parameters to see if its loading and if there are any script errors.  I wonder is the server hanging on a mod or is it loading your mission at start?

Where is this located? 

 

Does this apply to SP too? Since going in both mp and sp shows the same thing. 

Share this post


Link to post
Share on other sites
10 hours ago, lv1234 said:

Where is this located? 

 

Does this apply to SP too? Since going in both mp and sp shows the same thing. 

 

Ok.  Before we go on a rpt goose chase.  Could you be specific when you say nothing happens.  Does that mean the server loads the mission and nothing spawns.  Does it mean some things load but not others.  Have you edited anything or added extra code before this script in your initserver.sqf file? If so it could be as easy as missing a ( ; ) after a line of code and it is just not loading after that.

 

You can post your initserver.sqf here under <> option and place in spoiler so not to take up a pg.

Share this post


Link to post
Share on other sites
5 hours ago, jandrews said:

 

Ok.  Before we go on a rpt goose chase.  Could you be specific when you say nothing happens.  Does that mean the server loads the mission and nothing spawns.  Does it mean some things load but not others.  Have you edited anything or added extra code before this script in your initserver.sqf file? If so it could be as easy as missing a ( ; ) after a line of code and it is just not loading after that.

 

You can post your initserver.sqf here under <> option and place in spoiler so not to take up a pg.

I don't think my scenario folder doesn't have an initserver.sqf only init.sqf and VDinit.sqf. 

 

When i play the game nothing spawns at all, inc the horses and such. 

Share this post


Link to post
Share on other sites
2 hours ago, Vandeanson said:

@lv1234

 

have you placed the area markers for shipwrecks and land sites?

 

I do not, but I'm positive that I'm using the non-marker version for both of those ( at least i think i am)

Share this post


Link to post
Share on other sites

you need to place those markers to avoid that land site spawns spawn outside the map or that shipwrecks spawn in small lakes inside the map. if you do not want that, then you need to delete the area markernames in the two arrays in vd_settings. i dont recall the exact name right now but the vd_settings has comments for all setting so it should make sense if you check the various options. 

 

unfortunately, since the latest patch, it is causing an issue if you do not place the markers, but have area markers in the map defined as blacklist areas in a bisfncsafepos function.

 

cheets vd

Share this post


Link to post
Share on other sites
On 12/14/2018 at 5:46 PM, Vandeanson said:

you need to place those markers to avoid that land site spawns spawn outside the map or that shipwrecks spawn in small lakes inside the map. if you do not want that, then you need to delete the area markernames in the two arrays in vd_settings. i dont recall the exact name right now but the vd_settings has comments for all setting so it should make sense if you check the various options. 

 

unfortunately, since the latest patch, it is causing an issue if you do not place the markers, but have area markers in the map defined as blacklist areas in a bisfncsafepos function.

 

cheets vd

So those markers are for what scripts? Just to double check again (IK campsites are one of them, even though THEY should be automatic like before)

 

And did we have to do this for the previous script before the arma 3 update? Because, I didn't do the land marker stuff and it worked flawlessly since I was using the "marker-less" scripts including the shipwreck spawn. 

Share this post


Link to post
Share on other sites
On 5.3.2018 at 12:46 PM, Vandeanson said:

3. Minimum setup in eden editor:

- read the comments under VD_Settings.sqf

- place the blacklist areas for the sites that spawn at land this is done to avoid that sites spawn outside maps such as chernarus:

6FE5BFD8BFA68AD8AD3209A2035EEC4D68872F28

 

 

- place the blacklist area markers for the shipwreck spawner

- place markers on airfields for the plane spawner

 

hi @lv1234

 

i am talking about these blacklist markers, second and third point above.

these avoid that banditcamps anf other sites spawn outside the map or that shipwrecks spawn inside the land in small lakes.

i should have some time today and test and maybe Update the script to a default setting without the need to place blacklist markers.

 

note that this is different from placement markers, the sites are still spawned automatically. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
13 hours ago, Vandeanson said:

hi @lv1234

 

i am talking about these blacklist markers, second and third point above.

these avoid that banditcamps anf other sites spawn outside the map or that shipwrecks spawn inside the land in small lakes.

i should have some time today and test and maybe Update the script to a default setting without the need to place blacklist markers.

 

note that this is different from placement markers, the sites are still spawned automatically. 

Yeah I think I will wait until the script is updated again without blacklists. Also I think even without the blacklists, the script should still spawn stuff inside the land right? 

Share this post


Link to post
Share on other sites
On 11/28/2018 at 6:26 AM, CHICKENLICKEN said:

any idea how to remove the whimpering noise the dogs make? The bark is fine but the whimper hardly makes them intimidating .

@Vandeanson and @CHICKENLICKEN I have released a new version of JBOY Dog that no longer has constant yelping for AI controlled dogs or dog pack dogs.   I also reduced amount of shots it takes to kill AI controlled dogs and dog pack dogs.  So you might want to pick up the latest version of JBOY Dog here.

 

Merry Xmas guys!

  • Like 3

Share this post


Link to post
Share on other sites

@Vandeanson sir, i have to commend you on some amazing work you (and jboy) have done with these scripts. you are a scholar and a gentleman. :) this really makes it super easy to bring coolness go a survival mission.

 

i have one q&a tho: i have set all 3 factions (blufor, opfor and ind) as hostile to each other. in my mission the players are IND. what i want to know is this: is there a way to customize the loottables/arrays to give each faction their own gear sets? i see in the BC scripts when a new group is created its always "east". 

 

this applies to the standard ravage spawns as well. 

 

any ideas where i can go rummage to alter to my requirements? 

 

digging through your scripts is a fun exercise on its own. 

 

enjoy your holidays.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

guys, I wasn't playing arma/ravage for an year or smth and I would never imagine that such a great stuff like Vandeansons scripts appears since then. I am excited about those mechanics and rly want to try to play classic SP endless ravage with  those scripts. Could u pls advice ravage user missions with dynamic spawn scripts that are ready to go? thank you in advance!

  • Like 1

Share this post


Link to post
Share on other sites

Good morning everyone and happy new year!

 

I have spent some off time in Azeroth lately and since keeping up with one game at a time is hard enough for me, my arma time suffered terribly;)

 

However, due to the ongoing murder of blizzard by activision, im confident that i ll be back to being fully dedicated to arma scripting at some point:)

 

in the meantime i am happy to gather feedback on the current state of the script for later improvement.

 

i will likely change the direction of future features a bit, moving away from things like basebuilding, mission generator and such, partially because there are such scripts out there already or because i lack the knowledge to properly (incl. persistence and MP compability) implement a solution. this might change again but its something that i thought about recently.

no worries thought, there are alot of other things that can be done;)

 

@johnnyboy

thanks! will be included once I start working on the script again. including some of your other scripts as discussed last year.

 

@BlackFerret

thank you, I appreciate the feedback and kind words in general;)

For my scripts, yes it is possible and i give you a general direction on what to do below:

1: you need a faction specific loadout script.

you can use my code within VD_functions.sqf.

its called "VD_equipper = {... Code...}" .

this function puts together random gear for AI based on my equipment arrays.

copy paste that code to the end of vd_functions, rename it and amend the code to your liking.

You can either assign a specific item/gear/weapon to the respective equipment slot or put together arrays per equipment slot for each faction. E.G. OPFORuniform = ["uniformclassname1","uniformclassname2,...];

then you replace the existing arrays with your new ones in the equipper code.

e.g. 

x forceadduniform selectrandom OPFORuniform;

do that for all equipment slots.

this also works if you only enter one classname into the uniform array of your faction.

 

2: you either need a site spawner per faction or you externalize the AI spawner from the site spawners, create a AI spawner per faction and let the site spawner randomly select one of em.

lets assume that you create one spawner per side/faction.

copy paste the BC spawner.sqf and rename it.

in the AI spawner code part change the group to west or indep (check if this is the right independend side name, i am not sure).

and take the "survivor" classname of the respective faction.

here you then change the equipper script that is called to your site faction specific version created above.

 

the references

 

east

VD_equipper

B_G_Survivor_F

 

need to be changed in the lines below:

 

_bandits1 = createGroup east;
_bandits2 = createGroup east;
_bandits3 = createGroup east;
_bandits4 = createGroup east;


{if (3 >= (random 10)) then {"B_G_Survivor_F" createUnit [([getPosATL _VD_BC_Fireplace, 5, 15, 0, 0, 100, 0] call BIS_fnc_findSafePos), _x, "", 1, "private"];};"B_G_Survivor_F" createUnit [([getPosATL _VD_BC_Fireplace, 2, 15, 0, 0, 100, 0] call BIS_fnc_findSafePos), _x, "", 1, "private"];} foreach [_bandits1, _bandits2,_bandits3,_bandits4];

{[_x] call VD_equipper;}forEach units _bandits1;
{[_x] call VD_equipper;}forEach units _bandits2;
{[_x] call VD_equipper;}forEach units _bandits3;
{[_x] call VD_equipper;}forEach units _bandits4;

 

the dog spawner s and IED spawner needs some faction specific tweaking same as above too.

 

in VD_init.sqf, add lines to call your new faction specific bc spawners. just copy the regular bc spawner line and amned it where needed.

 

so in general this should give you some guidance on what to change. depending on your experience with scripting this might be helpful or utter confusing nonsense.

if the latter is the case, let me know. i am happy to help but can not promise an ETA for providing you with code;)

 

@damsous

yessir,

 

all AI kills have a chance to reward you with anti infection pills. they are not "phisically" in your inventory but just a variable.

if you are infected and carry such pills, u ll get an addaction to use pills.

at some point i want to add some sort of a hud showing how many pills you have.

 

please let me know if you experience issues with that.

 

@CHICKENLICKEN

thanks!

 

@Caites

thank you and welcome back to arma/ravage;)

@MuRaZorWitchKING has a mission for you i believe. also there is a ravage steam group where missions are listed if i remember correctly.

 

@all please post any mission you know about or have created here;)

 

i general i would however encourage you to create a basic mission template with ravage and my scripts by yourself. ravage has very easy to use eden editor modules and my scripts can just be pasted into the mission folder.

this way you can customize the mission to your liking. there are a lot of good videos on youtube on how to create arma and even ravage mission. and if u struggle, everyone on the ravage bi forum thread will be happy to help you, including myself;)

 

no promises, but i ll try to provide such basic ravage mission including my scripts on next update.

 

cheers

VD

 

  • Like 4

Share this post


Link to post
Share on other sites

Van Deanson, any idea how to add gib effects to zombies? like in warfare thai. he added them to Ryans Z so wondering id possible to Rvaage zombies.

Share this post


Link to post
Share on other sites
4 hours ago, Vandeanson said:

 

@Caites

thank you and welcome back to arma/ravage;)

@MuRaZorWitchKING has a mission for you i believe. also there is a ravage steam group where missions are listed if i remember correctly.

 

@all please post any mission you know about or have created here;)

 

i general i would however encourage you to create a basic mission template with ravage and my scripts by yourself. ravage has very easy to use eden editor modules and my scripts can just be pasted into the mission folder.

this way you can customize the mission to your liking. there are a lot of good videos on youtube on how to create arma and even ravage mission. and if u struggle, everyone on the ravage bi forum thread will be happy to help you, including myself;)

 

ty for an answer, I will check out this murazor's mission. one more question tho - I used to play ravage with third-party AI mods (like bCombat and VCOM) cos vanilla hostiles are a bit straightforward to my taste. do those mods compatible with your scripts? also my main balance issue year ago was inability of AI hostiles to enter building. I wonder if smth have changed since then, for both your spawn sites and vanilla buildings.

Share this post


Link to post
Share on other sites

@Caites

 

there should be no issue with AI improvement mods. and i tested the most common ones:)

 

i have worked on a script that makes AI search buildings and sometimes they did indeed get suck at the entrance. im afraid thats just a arma thing:( these mods might improve pathfinding tho (not an expert).

 

cheers

vd

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×