Jump to content
tpw

TPW MODS: enhanced realism and immersion for Arma 3 SP.

Recommended Posts

thats more mission specific... if i may oppose this.... I certainly dont want random IED's in cars.. unless i specify that in my mission....

yea sure ! i mean to add this in an extra script or u can turn it on in ur tpw userconfig or the script init .. whatever

its only a suggestion for myself and my realism unit .. i dont want to destroy the ambient of the parked cars :)

Share this post


Link to post
Share on other sites
No offense but still many many red dots every where :(

No offense, but that's not a bug report unless you can tell me what TPW MODS version, what A3 version, SP/MP/Dedi.

;2539152']thx for ur mod and ur fast fixes ! we love it !

but i have one suggestion .. can u add ied´s to the parked cars ? maybe with an small percentage

this would be really awsome for our insurgency where we have to patrol through streets

what do u think about it ?

It's not really within the scope of the mod at present. If/when I get round to ambient combat stuff then I will probably add something like this.

Silly question' date=' but do you have plans to add birds to your animal script. While not add barmy as dogs they could be interesting.... Aka by diing things like flying up when startled.[/quote']

SLX_Birds from COSLX did the startled birds thing. It's a nice effect, but it requires bird sprites/models, which is way outside my expertise.

Share this post


Link to post
Share on other sites

TPW,

your mods have been brilliant immersing the group I play into the game,from checking their targets, to obeying loose road rules. even so far as to politely asking civies to leave their cars before commandeering them. THANKYOU!!!!

been wondering though, is there anyway of fixing a spawn point for the cars script to another car. (basically I have a mission with the target driving along a road, but I dont want a plane to be able to get a lock from ages away and kill him, the most realistic way of doing this that i can think of is have the Target set to spawn cars around him, as if he was a player) hope this makes sense.

cheers for any help you can give.

Share this post


Link to post
Share on other sites
No offense, but that's not a bug report unless you can tell me what TPW MODS version, what A3 version, SP/MP/Dedi.

I got them today while playing SP and client run server any time I proned. Also running WW_AICover. Not sure which one is at fault yet.

Share this post


Link to post
Share on other sites

Hi TPW,

I hope I get a "leave it with me" on this one. Is it possible to have separate userconfig option to enable/disable Radio in vehicles vs. radio in buildings?

Share this post


Link to post
Share on other sites

TPW MODS v20131022: https://dl.dropboxusercontent.com/u/481663/TPW_MODS_20131022.zip

Changes:

[ANIMALS 1.25] Fixed goat calling non existent sound

[CARS 1.25] Fewer cars at night

[RADIO 1.06] Radio selectable: houses, vehicles or both.

Please update your TPW_MODS.hpp file to accommodate the new configuration for TPW_RADIO.

tpw_radio_house = 1; // Radio in houses. 0 = no radio in houses

tpw_radio_car = 1; // Radio in vehicles. 0 = no radio in houses

At this point in time I am more or less happy with the mods as far as SP performance and features. There are 2 niggling bugs:

1 - red balls not being hidden when scripts called by a server. #$%^ed if I know how to deal with that one.

2 - units being stuck crouched as a result of TPW_EBS. I unfortunately simply cannot replicate it though. If people are regularly observing this behaviour can you please try running with debugging on and tell me what colour the stuck crouched units are. That will give me some ideas.

I am doing some preliminary coding around the idea of ambient furniture. The basic idea is to only have the furniture spawn when the player is within a few metres of the house, and despawn when the player moves away. There will be no furniture spawned in houses that only have AI. This should keep the performance up and minimise the chances of AI getting stuck.

I'm thinking of a per house type template for each of the habitable houses:

"Land_i_House_Small_01_V1_F",

"Land_i_House_Small_01_V2_F",

"Land_i_House_Small_01_V3_F",

"Land_i_House_Small_02_V1_F",

"Land_i_House_Small_02_V2_F",

"Land_i_House_Small_02_V3_F",

"Land_i_House_Small_03_V1_F",

"Land_i_House_Big_01_V1_F",

"Land_i_House_Big_01_V2_F",

"Land_i_House_Big_01_V3_F",

"Land_i_House_Big_02_V1_F",

"Land_i_House_Big_02_V2_F",

"Land_i_House_Big_02_V3_F"

Each house will have positions/directions defined for eg 1 table, 2 chairs, 1 bed (roll), 1 shelf, and some random small object clutter. In lieu of BIS providing some additional furniture down the line this will have to do. It might not look great, but it'll look better than current.

Any ideas are welcome at this stage. There's been a lot of overheated discussion about furniture, don't bother bringing any of that shit here thanks!

---------- Post added at 18:53 ---------- Previous post was at 18:35 ----------

TPW,

your mods have been brilliant immersing the group I play into the game,from checking their targets, to obeying loose road rules. even so far as to politely asking civies to leave their cars before commandeering them. THANKYOU!!!!

been wondering though, is there anyway of fixing a spawn point for the cars script to another car. (basically I have a mission with the target driving along a road, but I dont want a plane to be able to get a lock from ages away and kill him, the most realistic way of doing this that i can think of is have the Target set to spawn cars around him, as if he was a player) hope this makes sense.

cheers for any help you can give.

This is a pretty specialised case so I'm not about to rewrite my mods to accommodate it sorry to say. My suggestion is to try editing TPW_CARS.sqf to replace all instances of player with a name that you have assigned your car. It might or might not work...

I got them today while playing SP and client run server any time I proned. Also running WW_AICover. Not sure which one is at fault yet.

What's at fault is setobjecttexture when called by a dedicated server. When you go prone TPW_FOG is attaching heat haze to the balls around you. These should be set invisible, and it works for SP and MP client, but not for server for some reaosn.

Hi TPW,

I hope I get a "leave it with me" on this one. Is it possible to have separate userconfig option to enable/disable Radio in vehicles vs. radio in buildings?

Well you left it with me and here 'tis!

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

=================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Hi tpw,

I found that I was killed by a hand grenade I threw which is fairly near the container where I was hinding behind. How could this happend? Is it a addtional effect of your mods?

Thx.

regards,

Hsiulung

Share this post


Link to post
Share on other sites

You're a coding machine! Was going to mention the Greek Music in houses thing, but by the

time I get a chance you're 2 or 3 updates ahead of me. Was just going to mention in MP

the Greek Music is not localized to the building. It just plays forever in your ear like an iPod.

Also others were reporting the tracks were stacking up and not turning off. As-is (ok, was)

you could NOT play near any towns. Fingers crossed this works now in MP. I'm sure by the

time I can test this weekend you'll be another 4 updates down the road. ;)

And as far as ambient furniture spawning in, wow! You should be on the BIS payroll. This

is the kind of "atmosphere" that really makes the game into a masterpiece. Thank You!!!!!

Share this post


Link to post
Share on other sites

Tpw, you've done an outstanding job on this mod, really enjoying it SP. The parked cars you added a while back are nice. Looking forward to what you can come up with with ambient furniture. One thing I also think would be cool to have, is more sound effects, like sounds of seagulls at the coast for example.

Share this post


Link to post
Share on other sites

Maybe spawn and despawn some civillians together with the furniture inside the buildings to make them real inhabited....maybe also spawn some plastic chairs and tables at these tavern gardens and of course some desks and computers inside the office buildings...adding random market places would also be cool as well as placing a few of the fish trawlers at the piers ..last but not least spawning some civs inside or around the churches at specific times would also be cool...

just some random thoughts :)

Share this post


Link to post
Share on other sites

Thanks TPW for the radio user config!

On furniture...spawning near real-time...keep in mind how to you'll handle when players switch characters. E.g. switching between two players placed indoors in different buildings.

Share this post


Link to post
Share on other sites

TPW,

I have been using your mods in script form, and they have worked soundly in the editor and in MP. However, the scripts seemed to have stopped working.

I am running Arma 3 at current non-dev version, my TPW Mods pack is on version 20131016, and I am trying to witness your scripts while in the editor (which I assume works like SP).

I have the following scripts in my mission directory folder: tpw_animals, tpw_bleedout, tpw_cars, tpw_civs, tpw_park, tpw_radio. I am using these other scripts: BTC Revive, TPWCAS, and AI Spawn Script. I have used these scripts with your scripts before without issue, except TPWCAS (but I assume you made your own scripts play nice together). I have never noticed Bleedout working, but that's probably because I use it in MP and it may not work in MP, however I have see animals, cars, civs, and radio working in the past.

Here is my init.sqf:

call compile preprocessFile "=BTC=_revive\=BTC=_revive_init.sqf";

null = [3] execvm "tpwcas\tpwcas_script_init.sqf"

0 = [10,15,200,75,60] execvm "tpw_animals.sqf";

0 = [5,0.6,0.75,0.9] execvm "tpw_bleedout.sqf";

0 = [5,1000,15,2,0] execvm "tpw_cars.sqf";

0 = [5,150,15,5,4,50,0,10,15,0] execvm "tpw_civs.sqf";

0 = [25,300,150,20,10] execvm "tpw_park.sqf";

0 = [60] execvm "tpw_radio.sqf";

Keep in mind that none of my tpw scripts are in a folder called "scripts" so I removed that part of the script call.

I play with a bounty of mods, and I recently (around or post the scripts ceasing to work) added the latest versions of MRB Voice Stop, Mag Repack, and SUPER Flashbang. I have tried removing each one, and removing all three, to see if the scripts work again - to no benefit. Any other mods I use have previously worked with TPW scripts,a nd did not hinder the scripts. I also tried removing tpw_park (as it is the most recent), to no benefit.

Upon testing today, none of the scripts are working. Any ideas?

Share this post


Link to post
Share on other sites

tpw,

Just a reminder, when using tpw_civ_casdisplay at 1 or 2, I'm still not seeing either a popup warning hint, or an ending of mission.

today's dev build

yesterday's tpw build

sp editor/preview

all tpw mods turned off except CIVS

also running;

CBA

norrins 10/23/2013 revive (just to be thorough in my bug report - but had same results a week or so ago w/o revive)

Don't mean to pester (I had reported this previously), I even waited some time before reposting because I know you're busy. Just a friendly reminder.

As always, thanks for all you do.

Edited by R.Flagg

Share this post


Link to post
Share on other sites
TPW,

I have been using your mods in script form, and they have worked soundly in the editor and in MP. However, the scripts seemed to have stopped working.

I am running Arma 3 at current non-dev version, my TPW Mods pack is on version 20131016, and I am trying to witness your scripts while in the editor (which I assume works like SP).

I have the following scripts in my mission directory folder: tpw_animals, tpw_bleedout, tpw_cars, tpw_civs, tpw_park, tpw_radio. I am using these other scripts: BTC Revive, TPWCAS, and AI Spawn Script. I have used these scripts with your scripts before without issue, except TPWCAS (but I assume you made your own scripts play nice together). I have never noticed Bleedout working, but that's probably because I use it in MP and it may not work in MP, however I have see animals, cars, civs, and radio working in the past.

Here is my init.sqf:

call compile preprocessFile "=BTC=_revive\=BTC=_revive_init.sqf";

null = [3] execvm "tpwcas\tpwcas_script_init.sqf"

0 = [10,15,200,75,60] execvm "tpw_animals.sqf";

0 = [5,0.6,0.75,0.9] execvm "tpw_bleedout.sqf";

0 = [5,1000,15,2,0] execvm "tpw_cars.sqf";

0 = [5,150,15,5,4,50,0,10,15,0] execvm "tpw_civs.sqf";

0 = [25,300,150,20,10] execvm "tpw_park.sqf";

0 = [60] execvm "tpw_radio.sqf";

Keep in mind that none of my tpw scripts are in a folder called "scripts" so I removed that part of the script call.

I play with a bounty of mods, and I recently (around or post the scripts ceasing to work) added the latest versions of MRB Voice Stop, Mag Repack, and SUPER Flashbang. I have tried removing each one, and removing all three, to see if the scripts work again - to no benefit. Any other mods I use have previously worked with TPW scripts,a nd did not hinder the scripts. I also tried removing tpw_park (as it is the most recent), to no benefit.

Upon testing today, none of the scripts are working. Any ideas?

Hmm, very strange. There's no reason why the scripts shouldn't run when called that way. What happens if you comment out the BTC_revive and TPWCAS lines?

tpw,

Just a reminder, when using tpw_civ_casdisplay at 1 or 2, I'm still not seeing either a popup warning hint, or an ending of mission.

today's dev build

yesterday's tpw build

sp editor/preview

all tpw mods turned off except CIVS

also running;

CBA

norrins 10/23/2013 revive (just to be thorough in my bug report - but had same results a week or so ago w/o revive)

Don't mean to pester (I had reported this previously), I even waited some time before reposting because I know you're busy. Just a friendly reminder.

As always, thanks for all you do.

Sorry about that R. It turns out to be a stupid stupid error in the init of the addon. I have fixed it and it works fine now. I will release the update shortly.

---------- Post added at 20:24 ---------- Previous post was at 20:14 ----------

TPW MODS v20131024: https://dl.dropboxusercontent.com/u/481663/TPW_MODS_20131024.zip

Changes:

[CIVS 1.24] Mission failure due to civilian casualties now working properly (fixed addon init error).

Share this post


Link to post
Share on other sites

No single mod has enhanced the game more than this one. Just the logical things you add make the immersion so perfect!

One thing that would be needo would be you and the "Max_Cops and Robbers MOD" blending in a few coppers. I guess cops could be civis and their cars too.

Thanks for making Arma3 a new experience in the Arma series with this unique MOD!

Share this post


Link to post
Share on other sites

I could be wrong here, but based on how its done in tpwcas, im almost positive it can be done, its up to "Tha Man" if he is going to add it :)

1) you need an !(isNil "class name of the cop mod main sqf file") and then a list of class names are added to the vehicle and civ agent pool

2 the next thing to check would be if the cop cars spawned to make sure they have a cop driver.. which i can surmise would be a classname check for the police car/truck and then a subsequent createvehiclecrew... which "should" create the right vehicle crew by default...??

Share this post


Link to post
Share on other sites

tpw,

are you still working on improvements to tpw_fall?

With tpw_ebs its my personal favourite of your mods. It adds very much to A3 gameplay, but their are still some visual glitches which can break immersion and might need a little bit polishing. I think it is mostly the transition between ragdolls and dead bodies. (I am well aware this issue may be easier to report than to fix, but then your update frequency is so impressive you might just squeeze this in ;) )

Thanks a lot!

A.

P.S.: It is not easy to reproduce. Played quite a while today, and sometimes the dead body of an enemy seemed to bop a bit off the ground. I am not sure, but it might happen when a unit gets killed while still being in the ragdoll animation of a previous non-lethal hit.

Edited by oldy41
Additional testing

Share this post


Link to post
Share on other sites

Has anyone else run into a bug using Fall and EBS (not Bleedout) where you get shot but can't heal yourself even though you have a medkit in your inventory? Twice now, I've been shot and the damage makes it so that I can no longer run or jog, just walk, and even though I'm playing a medic with a full supply of medkits, I can't heal myself.

I don't know if this is a bug related to the mods; I'm just trying to narrow down possible causes and to see if anyone else who uses these mods has experienced this behaviour. It's hard to replicate without getting killed first. :)

Share this post


Link to post
Share on other sites

Hi, recently I've noticed that with this mod, my m320 grenades bounces from the ground to far off distance. Simply doesnt explode on first impact. Anybody else is having this?

Share this post


Link to post
Share on other sites

Probably you are using Dev.version of ArmA 3?..

@TPW

The excellent LoS calculations have really changed our lives.

Please check this thread http://forums.bistudio.com/showthread.php?167439-AI-Behavior%28Combat-Mode%29-quot-Aware-quot-the-mission-maker-s-beloved-one&p=2542539#post2542539

Besides the problem i m describing with the "Default Behavior" most mission makers are (wrongly imo) are using..we must find a way that separates the effectiveness of LoS checks-depending on the unit's "Combat Behavior".

In example:

A unit who is not in "Aware" mode (aka "Safe","Careless") means he isn't totally concentrated to hear the "leaf" falling from the tree-neither to recognize as threat "a shadow crossing from a window 4 buildings away" :)

That way we can create infiltration/recon scenarios on a non-fully-coffee-filled enemy without messing with general skills. :)

It will open another dimension for scenarios!

Edited by GiorgyGR

Share this post


Link to post
Share on other sites

Hey , I just wanted to ask about the TPW LOS function. Why is it disabled by default? Is it because its buggy/redundant or perhaps just not advisable? :) I recently played a mission where AI's were supposed to defend their perimeter and they pretty much failed miserably and got nearly wiped. On another try I've enabled tpw los and they held they own a LOT better :). One last question, there s a feature in userconfig, saying that all units in 25 meters distance are immeadiately visible. I wonder why is that? is it necesseary? I don't want AI's to know im about to turn corner and ambush them from behind .

Share this post


Link to post
Share on other sites

I believe that you give a man a fish you feed him for a day, you teach him to fish, and he can feed his family and others for a lifetime... in this thread tpw answered your questions about LOS almost Directly."it is disabled because recent changes to AI by BIS possibly render it obsolete"... the userconfig setting.. well its arma... do we really have to explain this one... Ill just say i set mine to 2 meters... and leave it at that....

Edited by Lordprimate

Share this post


Link to post
Share on other sites

**content deleted**

*EDITED AFTER READING BELOW POST

Moderator please remove this post.

Edited by GiorgyGR

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×