Jump to content
noubernou

A.C.R.E - Advanced Combat Radio Environment for Arma 3

Recommended Posts

Thank's but dont work.

119 Radio doesn't appear in the back ... :(

Try using:

(unitBackpack this) addItemCargo ["ACRE_PRC119",1];

Tryed and tested, it works fine.

Share this post


Link to post
Share on other sites

Hello everyone. I have been digging through the code for Acre and doing some bug testing today to see if i can get it functioning.

Based off the latest CBA build, and latest public build, i have only one error. Everything else functions properly.

F207C372138ABF4D53331B557550EBD9F97C88C7

This error is caused by hitting a button. By button, i mean only buttons. Knobs on the 343/119 dont cause this error message to show up. Traced the file location and it specify's a folder and file that does not exist. Then looked in the code for the 148 buttons and it does not branch into this file also.

I am by no means a code junkie. But i was wondering if anyone has found a fix for this and/or has the problem also. A friend of my also reported this issue, but to no avail of fixing it.

Share this post


Link to post
Share on other sites

Hi - I haven't trawled through the entire thread - but can someone tell me if ACRE is official yet? Will there be an ACRE2, updated for ARMA 3?

Share this post


Link to post
Share on other sites

you could also go to the first post and read most of it:

IDI Systems and the ACRE team would like to proudly announce that ACRE for Arma 3 is now currently being tested by our test groups and is in mostly stable condition! It is an almost direct port of ACRE 1.4 for Arma 2 and should be available soon for public release!

More news to follow! Thank you to the community for your support and for BIS for their hard work and amazing products!

Share this post


Link to post
Share on other sites

Ah okay, yes. Saw that. Just wondered if perhaps anything had changed since the beginning of this thread.

Share this post


Link to post
Share on other sites

The XEH_preinit.sqf, line 24 error is almost constantly on screen.

Any easy way around this?

Share this post


Link to post
Share on other sites

I've notice that wheeled vehicule didn't get radio in the rack.

Is there a way to add some to the AMV-7 for example ?

Share this post


Link to post
Share on other sites

Is this ACRE A3 Beta version legit?

http://www.armaholic.com/page.php?id=19324

I tried to use it, but i got a lot of A2 errors and it looks very similar to the default A2 ACRE version.

On the other side, is there any way to get his hands on those UOACREs serverkeys? The version i downloaded from UO only contains the default A2 ACRE serverkeys..

Share this post


Link to post
Share on other sites

Regarding the Armaholic link.

It is the exact same version as the Arma 2 release.

I did my best to find which version it actually is but it seems so many clans/units have their own files it is impossible to know which file is the correct/latest one.

About the UO links.......is that the version which should be used for Arma 3? Is it the actual Arma 3 release or is it the Arma 2 release?

Sorry, I have no idea about this and after looking at all links for some time I gave up. The only reason I added that page to Armaholic is cause so many people release A3 missions which require ACRE so we need something to link to......people can than try to fix the issues themselves as it is not officially released :)

Share this post


Link to post
Share on other sites

Hi Guys!

Is there no one who can help getting this "XEH_preinit.sqf, line 24 error" error fixed?

ACRE works fine in the actual ARMA 3 Beta, aside from this error, only the low voice soundlevel is a bit annoying. But this constant Error Message Window makes it sort of unuseable.

Share this post


Link to post
Share on other sites
For anyone that has been having issues on the dedicated servers with errors regarding undefined variables please check out this patch: http://raceriv.com/arma2/acre/acre_A3_Beta_Patch_addons.rar

It only needs to be placed on the server.

Thanks to ViperMaul and ShackTac for the help in fixing it.

Does this work for 0.72?

Share this post


Link to post
Share on other sites

Thanks, Nou and others who helped. I just threw it on the server and I'm not getting script errors with the 148 anymore.

I haven't mentioned this yet just because you haven't officially released ACRE, but in conjunction with All in Arma there is a small box that appears toward the left middle of the screen on Chernarus and some other maps like in this screenshot.

http://i.imgur.com/Kl0QbKZ.jpg

It was fixed with the latest version of CBA_A3, however, ACRE still causes the box to show up (Tried with just CBA_A3 and then with ACRE enabled). Kju said you could contact him or CBA people to fix it. Not sure if it's an easy fix or would break anything else just letting you know.

Share this post


Link to post
Share on other sites
For anyone that has been having issues on the dedicated servers with errors regarding undefined variables please check out this patch: http://raceriv.com/arma2/acre/acre_A3_Beta_Patch_addons.rar

It only needs to be placed on the server.

Thanks to ViperMaul and ShackTac for the help in fixing it.

I suppose you need the unofficial UO ACRE Release and overwrite the files with this patch addon?

Does anyone have server keys for the "unofficial" release?

Share this post


Link to post
Share on other sites

I have a problem(don't know if it has been mentioned, if so please enlighten me.)

I normally carries 2 radios, a 343 and a 148(or 119).

343:

class PTTRadioAlternate_1 // Talk over radio 2nd radio

{

key = 58;

shift = 0;

ctrl = 0;

alt = 0;

148/119:

class PTTRadioAlternate_2 // Talk over radio 3nd radio

{

key = 46;

shift = 0;

ctrl = 0;

alt = 0;

Whenever I am missing a secondary radio and pushes the button for talk on second radio which is "C", my TS crash and I have to restart TS.

"class PTTRadio // Talk over radio" is placed on another button than "Caps lock".

Share this post


Link to post
Share on other sites

I down loaded the patched files, and I notice that it did not come with any Jayarma3lib files. As the old one are throwing up undifined variables errors every 5 seconds.. So ACRE is still unusable ?!?! (by unusable i mean the error messages on the screen RUIN the game)

Anyone have the fix??

Share this post


Link to post
Share on other sites
I down loaded the patched files, and I notice that it did not come with any Jayarma3lib files. As the old one are throwing up undifined variables errors every 5 seconds.. So ACRE is still unusable ?!?! (by unusable i mean the error messages on the screen RUIN the game)

Anyone have the fix??

Thats UOs fault. They distributed the A2 version of JayArma2Lib with ACRE for A3. It worked fine till recently when BIS added undefined variable error throwing.

Share this post


Link to post
Share on other sites

@NouberNou:

I have already sent you a pm about this issue. Could you please provide us with the proper server keys? You only added the default A2 server keys for the UO ACRE Release

and running a server without sig checks, is definitely a hackers pain in the ass..

Share this post


Link to post
Share on other sites

Thanks for the awesome mod! It's like JSRS: once you try it, it feels that something important is missing if you have to play without it after that... :p

I'd have one suggestion. Could you please decrease the volume of the squawk sound? It's really loud when compared to regular volume level of speech. With regular TS settings (speech volume level at +0.0 - +6.0 dB) the squawk sound is so loud that it hurts my ears. I believe it could be changed in seconds with eg. Audacity. But like said, it's otherwise great mod in my opinion, it's just this detail that bothers me when I'm playing with ACRE.

Share this post


Link to post
Share on other sites
Thanks for the awesome mod! It's like JSRS: once you try it, it feels that something important is missing if you have to play without it after that... :p

I'd have one suggestion. Could you please decrease the volume of the squawk sound? It's really loud when compared to regular volume level of speech. With regular TS settings (speech volume level at +0.0 - +6.0 dB) the squawk sound is so loud that it hurts my ears. I believe it could be changed in seconds with eg. Audacity. But like said, it's otherwise great mod in my opinion, it's just this detail that bothers me when I'm playing with ACRE.

I second that .. Its to loud

Share this post


Link to post
Share on other sites

Todays 0.74 stabile update is throwing up JayArmaLib errors:

Error in expression <
};
_args = _args + _str;

};
_return = _JERR_ERR_U;
_call = _functionName + ",">
 Error position: <_JERR_ERR_U;
_call = _functionName + ",">
 Error Undefined variable in expression: _jerr_err_u
File x\jayarma2lib\addons\common\XEH_preinit.sqf, line 24
[1865,66.168,0,"XEH: PostInit Started"]
[1865,66.217,0,"CBA_VERSIONING: cba=1.0.4.198, "]
[1865,66.494,0,"XEH: PostInit Finished. State: _isClient=true, _isJip=false, _isDedClient=false, _isServer=true, _isDedServer=false, _playerCheckDone=true, _sp=true, _startInitDone=true, _postInitDone=true, _mpRespawn=false, _machineType=1, _sessionId=1, _level=0, _timeOut=false, _game=3, BIS_functions=L Alpha 1-1:1, group=L Alpha 1-1, player=<NULL-object>, _playerType="", _playerGroup=<NULL-group>"]
"JayArmA2Lib: ACTIVE"
Error in expression <= getPos player;

Anyone else got this? Is there a known fix for it?

Share this post


Link to post
Share on other sites
Anyone else got this? Is there a known fix for it?

Yes, wait until JayArmaLib is updated :rolleyes:

Share this post


Link to post
Share on other sites

I figured out tonight why I never used ACRE. No matter what I read or how many youtube videos I watch, I cannot install ACRE correctly to work.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×