Jump to content
R3fl3x

ArmA2 / OA (low) performance issues

Recommended Posts

It seems that I get lower FPS in ARMA2 since I installed the game first time. I have downloaded many addons and mods.

Should I make a fresh install because I hade 10-20 more FPS when the game didnt have a lot of addons.

Share this post


Link to post
Share on other sites

Travelling in vehicles (as in travelling fast) overloads my system. If I walk it does not (more time to load/render i guess).

When I travel in vehicles over distance I navigate by map and let a teamate do the driving (mapview = no rendering).

Funny on a rare occasion in the manhatten level I crawled through bush close enough to see a chedaki about 10m away. When I looked through the weapon scope and zoomed the chedaki disappeared - put down the scope and he appears again!

Share this post


Link to post
Share on other sites

Hello All,

I just spent the last 2 hours reading this entire thread for ideas on how to improve my performance.

Rig

i7860

asus p7p55d evo

4 gigs ddr3@1600

XFX 5850 XXX edition

Win 7 Pro 64bit

I have been playing around with the ingame settings as well as the configuration for a while with mixed results. What I am looking for is the optimal settings for my setup. I know it is vague but any help would be appreciated.

As for the commandline I would rather avoid disabling ht as it is very helpful with my work -video decoding, and the like - does the cpucount=2 serve the same function as disabling ht?

Thanks for the help.

Dirtyallen

Share this post


Link to post
Share on other sites
I have a doubt to change my 4890 vapor-X for one of these cards:

-gtx 295

-HD 5870 vapor-x

wich one do you recommend for this game?? ´cause with my 4890 i can run all in mid-high with 30-40 fps

rig:

i7 920 @4ghz

4gb ram ddr3

win7 x64

hdd caviar black 750gb

Regards

The GTX295 is a faster card, but I've heard several people on here having issues with getting the dual-GPU setup of that card working right. Probably would go for the 5870 if I were you.

Share this post


Link to post
Share on other sites

Definitely 5870. After all it is more modern card.

edit: and by that I mean it runs cooler and eats less power. And single-GPU solution is always better than Crossfire/SLI.

Share this post


Link to post
Share on other sites
Hello All,

I just spent the last 2 hours reading this entire thread for ideas on how to improve my performance.

Rig

i7860

asus p7p55d evo

4 gigs ddr3@1600

XFX 5850 XXX edition

Win 7 Pro 64bit

I have been playing around with the ingame settings as well as the configuration for a while with mixed results. What I am looking for is the optimal settings for my setup. I know it is vague but any help would be appreciated.

As for the commandline I would rather avoid disabling ht as it is very helpful with my work -video decoding, and the like - does the cpucount=2 serve the same function as disabling ht?

Thanks for the help.

Dirtyallen

You have a quadcore, so use -cpucount=4 in commandline (yes, serves the same function as disabling HT);

in your ArmA2 config (see under Documents) set:

3D_ Performance=180000

GPU_MaxFramesAhead=0

GPU_DetectedFramesAhead=0

HDRPrecision=32

Videomemory=default

Viewdistance=3600

all other settings maxed out;) should be running really smooth between 30 - 40 fps.

Share this post


Link to post
Share on other sites

except for all the micro stuttering. 59 fps here. microstutters like crazy. like permenant rubber band lag

Share this post


Link to post
Share on other sites

hi guys, can you suggest me video settings and / or nhancer settings for optimum performance. i am not happy aa performance.

my pc specs are:

amd x4 630 2.8 @ 3.3 ghz

leadtek gtx260 extreme +

4 gig ram

what are advises from smilar pc owners;

view distance, texture detail, terrain detail, post process, shadow etc i think i need a ss from whole settings.

especially i wonder what aa and af settings in game, and is there anyone uses nhancer for aa. if yes , what is your nhancer preferences?

Share this post


Link to post
Share on other sites
You have a quadcore, so use -cpucount=4 in commandline (yes, serves the same function as disabling HT);

in your ArmA2 config (see under Documents) set:

3D_ Performance=180000

GPU_MaxFramesAhead=0

GPU_DetectedFramesAhead=0

HDRPrecision=32

Videomemory=default

Viewdistance=3600

all other settings maxed out;) should be running really smooth between 30 - 40 fps.

Thank you Sir.

My ArmaII was a little suboptimal in regards of FPS. Especially in bigger Cities (20-25 FPS). But with your settings it is so much more enjoyable now (35-50 FPS) :bounce3: . Thank you so much.

My System:

Phenom II X4 955

HD 4870

4 GB DDR3 1333

Share this post


Link to post
Share on other sites
Thank you Sir.

My ArmaII was a little suboptimal in regards of FPS. Especially in bigger Cities (20-25 FPS). But with your settings it is so much more enjoyable now (35-50 FPS) :bounce3: . Thank you so much.

My System:

Phenom II X4 955

HD 4870

4 GB DDR3 1333

Hey, np, you are welcome, have a nice time with ArmA 2:)

Share this post


Link to post
Share on other sites

CENKCNK: take a leaf out of dirtyallen's book, i.e. search this thread.

If you had bothered, you would have found a lot of good info, such as this post.

Share this post


Link to post
Share on other sites
You have a quadcore, so use -cpucount=4 in commandline (yes, serves the same function as disabling HT);

in your ArmA2 config (see under Documents) set:

3D_ Performance=180000

I have yet to figure out what changing this value actually does. Anyone have any insight into this? Mine is set at negative 400000 something or some such. :p

Share this post


Link to post
Share on other sites

My rig is kinda low end but if I could squeeze 5-10 fps more from my Arma I would be more than satisfied. Please help

amd athon x2 5000+

ati radeon 4870

2gt ddr2 ram

windows vista

without touching the cfg or anything I got 26fps from in-game benchmark. In towns fps gets significantly lower.

Share this post


Link to post
Share on other sites
My rig is kinda low end but if I could squeeze 5-10 fps more from my Arma I would be more than satisfied. Please help

amd athon x2 5000+

ati radeon 4870

2gt ddr2 ram

windows vista

without touching the cfg or anything I got 26fps from in-game benchmark. In towns fps gets significantly lower.

Overclock your Cpu, wish I wasnt so paranoid otherwise I would do it to mine, I have a amd phenom 9750 @ 2.4ghhz it would be WAY better off at 3.6 or 4.0ghz

Mind you if your overclocking your CPU you better be damn careful or else you could cause serious stability problems or Massive damage to your motherboard and Cpu.

Other tricks, use C Proper mods by Kju primarily Tree Proper this will give you a few extra frames.

and adding this command line

-maxmem=2047 I found helps with the stutter alot.

Keep Terrain detail on Normal This has to be the single biggest FPS killer along with the resolution of course.

20 FPS differance with VERY HIGH and Very Low Terrain Detail.

Very HIGH and High are OVERKILL.

Hope this helps you.

Share this post


Link to post
Share on other sites

i have the same problem with my pc i run windows 7 and arma 2 just seems to lagg hat ever setting i have it on i have emailed the tech support but i was woundering if u guys had any sugestions

Share this post


Link to post
Share on other sites

not really. win7 and i7 930 here. getting performance like i was playing it on a pentium 4

Share this post


Link to post
Share on other sites

I have pretty good FPS and my settings are as follows:

-Resolution 1280x1024, 3Dresolution:100%, View Distance:2500m.

-All settings in game on HIGH except PPE:LOW and Terrain Detail:NORMAL.

-Nvidia CPL set to Performance.

-ARMA2.CFG both Detected and Max Frames both set to either "2" or "1". Test this to find best feeling.

-A good addon to make Chernarus flow better regarding the grass is SAP Clutter wich only lowers it and make it more scarce. The grass is what steals most FPS from me when vanilla so this is a good one.

Keep your system tidy when playing the ARMA series wich means to defrag your HDD properly with a good defragger and make sure you got no websites or other services running in the background that shouldnt be there. I noticed some websites make the game lag badly when they are updating themselves so turn it all off while playing. I understand my resolution is a bit low but you have to do something to get the game to play good as im after the experience of a good game with friends rather than trying to go as high as possible just because. The game looks great when i play and flows really good so im happy. I want the grass and the heaviest trees optimized however as that would probably give me more room for upping the settings.

So the above is working for me personally so test it if you havent. And remember that all BIS titles gets better over time like a good wine or a cheese going green... :D Dont know why but all BIS titles were the same on my systems. They start out rather cranky but get better after tweaking and time. Both because of patches and maybe perhaps magic. Not sure.

System:

i7 quad 930

GTX 275

P6X58D Premium

OCZ 1600mhz 6GB Tri Channel

WD Black 500GB 7200RPM 32MB Cache

Share this post


Link to post
Share on other sites

hi, reccomend overclocking your CPU to atleast 3GHz, that would improve performance. also turn off hyperthreading in the BIOS this will dramatically improve performance :)

Share this post


Link to post
Share on other sites

I have an a decent rig - but for some reason my FPS is 27 fps at very low at 640 x 480 and around 19 on very high at 1680 x 1050 (Duala).

AMD Phenom II X4 955 @ 3.2 Ghz

4 gigs of 667 Mhz DDR2 RAM

500 GB of disk space

Windows Vista Ultimate 32-bit

ATI 4870 512 MB

I've tried tweaking it so much, nothing seems to be helping. Also, all of this is multiplayer. Single player runs 50+ fps on very high in the same map. It's not internet lag either.

Share this post


Link to post
Share on other sites

Hello BIF users!

My rig:

Phenom II 940 BE 3.00 Ghz

Radeon 4890 OC 1GB

4GB DDR 2

I have under 20 FPS on default settings. I mean WTF! Are you BIS f***g kidding me!?! :mad:

The best part is that you can not see the difference between very low setting and very high settings. LOL. My FPS is all the time horrible low.

Edited by kristofer

Share this post


Link to post
Share on other sites

Kristof: try these tweaks and, if you're confident, try overclocking your CPU: start gently, i.e. no more than +2% (+5 FSB) each time.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×