Jump to content

Recommended Posts

1 minute ago, cosmic10r said:

 

I hear you.

Plus all the unexpected workarounds that become needed.

 

I'm no expert but what I learned is that for MP you have to be really cognizant of where stuff is executing in terms of locality and once you wrap your brain around what/where the engine wants it becomes much easier... 

 

So I'm told lol

I haven't added much stuff to ADDON #2 yet, so perhaps I could include some of the locality stuff and such as I'm adding more code. I'll test them later! 😉

  • Like 1

Share this post


Link to post
Share on other sites

congratulations for the new release, very impressive and powerful expansion to the arma interaction menu indeed !

however i faced some issues with it

 

i got error no entry "bin\config.bin/cfgPatches.Warfxpe" each time i load up a mission.
activating super pilot mode from Vehicle commands/Vehicle controls will pop up infinite errors but when using create driver and select the option from pilot settings it will work just fine.
sometimes when activating super pilot mode and add loiter waypoint, the pilot wont fly 

when commanding unit to place explosives from a distance, sometimes it wont work thankful that option is included in the waypoint options
maybe expanding waypoint settings with loiter/cycle/garrison buildings will help when commanding large group of units otherwise its well done and outstanding 

 

im really looking forward on this mod it contains unique additions and very needed options to go full tactical especially for loner wolves that are still playing SP = ) 

Share this post


Link to post
Share on other sites
1 hour ago, AirShark said:

i got error no entry "bin\config.bin/cfgPatches.Warfxpe" each time i load up a mission.

Thanks for the report. This should've been fixed though. For now, uncheck "Enable Zeus" from settings. I'll fix this later.

You have loaded Blastcore right? I think that's the mod that's throwing this error.

 

 

1 hour ago, AirShark said:

activating super pilot mode from Vehicle commands/Vehicle controls will pop up infinite errors but when using create driver and select the option from pilot settings it will work just fine.

Strange. I can't reproduce the issue. How did it happen?

 

1 hour ago, AirShark said:

sometimes when activating super pilot mode and add loiter waypoint, the pilot wont fly 

Had you landed the helicopter (using 'non-super-pilot' landing mode)? If so, I noticed this issue too and will fix it in the next release.

 

Also, are you sure the flight height wasn't zero or negative (In 'Pilot Settings')? I use these values to make Super Pilots land. Anyway, I'll make sure the flight height is reset (if less than 10m) when using Loiter and Cruise modes to avoid this issue.

Share this post


Link to post
Share on other sites
1 hour ago, Leopard20 said:

Strange. I can't reproduce the issue. How did it happen?

_veh setVariable >
16:49:27   Error Type Number,Not a Number, expected Number
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 103
16:49:27 Error in expression <orDiff [0,0,0.25];
_hasContact = count (lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error position: <lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error 0 elements provided, 3 expected
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 114
16:49:27 Error in expression <orDiff [0,0,0.25];
_hasContact = count (lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error position: <lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error 0 elements provided, 3 expected
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 114
16:49:27 Error in expression < {_skids pushBack _SkidR1};
if (_SkidR1 distance2D _SkidR2 > 1) then {_skids pus>
16:49:27   Error position: <distance2D _SkidR2 > 1) then {_skids pus>
16:49:27   Error Type Number,Not a Number, expected Number
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 87
16:49:34 Unknown attribute itemsCmd
16:49:34 Unknown attribute itemsCmd
16:49:52 Error in expression <le _tempVeh;

_skids = _skids apply {_x vectorAdd [0,0,0.1]};

_veh setVariable >
16:49:52   Error position: <vectorAdd [0,0,0.1]};
Quote

Had you landed the helicopter (using 'non-super-pilot' landing mode)? If so, I noticed this issue too and will fix it in the next release.

that must be it,  glad you found the issue too 

Quote

when commanding unit to place explosives from a distance, sometimes it wont work thankful that option is included in the waypoint options

i was mistaken on this one it happens when there is objects nearby the area that should be detonate, when the explosives specialist reaches the location he couldnt plant the charges..

Share this post


Link to post
Share on other sites
15 minutes ago, AirShark said:

_veh setVariable >
16:49:27   Error Type Number,Not a Number, expected Number
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 103
16:49:27 Error in expression <orDiff [0,0,0.25];
_hasContact = count (lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error position: <lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error 0 elements provided, 3 expected
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 114
16:49:27 Error in expression <orDiff [0,0,0.25];
_hasContact = count (lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error position: <lineIntersectsSurfaces [_skid, _skidbott>
16:49:27   Error 0 elements provided, 3 expected
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 114
16:49:27 Error in expression < {_skids pushBack _SkidR1};
if (_SkidR1 distance2D _SkidR2 > 1) then {_skids pus>
16:49:27   Error position: <distance2D _SkidR2 > 1) then {_skids pus>
16:49:27   Error Type Number,Not a Number, expected Number
16:49:27 File AIO_AIMENU\functions\driver\fn_analyzeHeli.sqf [AIO_fnc_analyzeH..., line 87
16:49:34 Unknown attribute itemsCmd
16:49:34 Unknown attribute itemsCmd
16:49:52 Error in expression <le _tempVeh;

_skids = _skids apply {_x vectorAdd [0,0,0.1]};

_veh setVariable >
16:49:52   Error position: <vectorAdd [0,0,0.1]};

that must be it,  glad you found the issue too 

i was mistaken on this one it happens when there is objects nearby the area that should be detonate, when the explosives specialist reaches the location he couldnt plant the charges..

For the first issue, seems like you had selected an invalid unit (probably not a helicopter). Because my script couldn't detect the skid!

 

I'll look into the issue with explosives.

Share this post


Link to post
Share on other sites
Quote

For the first issue, seems like you had selected an invalid unit (probably not a helicopter). Because my script couldn't detect the skid!

thanks for clearing this out, it happens when you select more than 1 unit and activate super pilot mode from the commands/Vehicle controls 

in my case i mistakenly selected all my units and activate the super pilot mode i didnt know that i should select the pilot only : p

 

Share this post


Link to post
Share on other sites
23 minutes ago, AirShark said:

thanks for clearing this out, it happens when you select more than 1 unit and activate super pilot mode from the commands/Vehicle controls 

in my case i mistakenly selected all my units and activate the super pilot mode i didnt know that i should select the pilot only : p

 

It's okay. I fixed it. Now it doesn't matter whether you select all units or not.

  • Thanks 1

Share this post


Link to post
Share on other sites

After some more testing with the new update, I see that It doesn't let me create HC groups anymore.
I dunno if it is a problem only on my side.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, MrStregatto said:

After some more testing with the new update, I see that It doesn't let me create HC groups anymore.
I dunno if it is a problem only on my side.

Hmm. Will take it look. Thanks for reporting the issue.

Share this post


Link to post
Share on other sites

All-in-one Command Menu (Deluxe) - v1.0.2-Beta

 

Fixed

- Super Pilot: Make sure flight height is not zero when switching to cruise/loiter mode + fixed vanilla AI preventing the super pilots from taking off (they forced off the engine!) + misc bug fixes

- High Command: Fixed Create HC Group not working after the last change to the Create Support Groups option

- Mod icon: Fixed transparent background made texts illegible (replaced with white)

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the Update!

Now I've still sone suggestion for the mod, but I prefer to save it for later and let you finish the other two addons!
😁

  • Like 1

Share this post


Link to post
Share on other sites

Two more things I forgot to mention (derp!):

 

1. The Trigger Mode and Undo functions in the Waypoint UI don't work right now. I'll add them later.

 

2. If you use the Custom Menus, in the formation menu you see two extra formations: W and M. Those two will be added along with addon 2. I had added them at first but there were some issues with the vanilla AI.

  • Like 1

Share this post


Link to post
Share on other sites
On 8/14/2019 at 12:49 PM, Leopard20 said:

Basically I'm creating a new AI. I don't mean like the current AI mods such as VCOM, TCL and ASR AI. I actually mean a NEW AI.

Please if it possible add optional futures to turn on AI long distance skirmish like in real life wars ( not aimed fire but semi blind suppression ). Vanilla arma 3 AI can only prone when distance is more than 400-500m 😥 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, sammael said:

Please if it possible add optional futures to turn on AI long distance skirmish like in real life wars ( not aimed fire but semi blind suppression ). Vanilla arma 3 AI can only prone when distance is more than 400-500m 😥 

Will do my best, my friend! 😉

  • Like 3

Share this post


Link to post
Share on other sites
31 minutes ago, Dallas Medina said:

Will the command menu thing be compatible with ACE3? Like, the healing aspect of it?

ACE Medical is fully supported and the AI can use bandages, morphine injector, and epipen (epinephrine) when needed. Plus they heal each wound separately (exactly like player). This is unlike the ACE Medical AI module which makes the AI magically heal themselves! Also, if you're unconscious, the AI can revive you, even if auto-medic is disabled. But I think ACE Medical AI interferes with the mod if you're unconscious ('ACE style' unconscious, not vanilla). I don't remember if I fixed it or not!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×