Jump to content

Recommended Posts

9 minutes ago, Vandeanson said:

first you define the random marker that should be the spawnpoint

 

the code i suggested would just be run in player1 otherwise yeah it would select a random start for each starting unit. if all player units are on map at mission start it should work as intended.... should....

Share this post


Link to post
Share on other sites
38 minutes ago, damsous said:

Use the empty marker, they are not visible in game only in editor

Oh nice, I haven't thought of that, thats even better then adding code to delete the marker, thanks!

 

26 minutes ago, lordfrith said:

try something like :

player1 setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"]));

 _newpos = player1 modelToWorld [1,-2,0];

player2 setPos _newpos;

 

Thanks for the help.

So for player 1 i will need to add a name to player 1, and same for player 2 for the code to specify whos to spawn and to whom correct?

 

Then for player 2 there the newpos is where player 1 will spawn at a random marker of course and then once hes spawn player 2 will be "moved" or spawned to that

same marker as player 1 or is player 2 spawned at same time as in you and your buddy both start or appear at the same spot?

 

Share this post


Link to post
Share on other sites
12 minutes ago, Gunter Severloh said:

So for player 1 i will need to add a name to player 1, and same for player 2 for the code to specify whos to spawn and to whom correct?

 

yeah i was working on some assumptions: that all the playable units are present at mission start (regardless of if a player is 'using' them) and that all are named. If so then it should just run through the init in sequence, setting the first player to random marker x, then moving player 2 beside him, then player 3 and so on. and as Vandeanson pointed out only run this once (or from 1 player). It may need tweaked depending on mission set up but the commands should be right ;)

 

also if you have more than 2 players then you would want to change the offset in "modelToWorld [1,-2,0];" for each extra player so they don't all spawn IN each other (freaky)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Gunter Severloh said:

Hey guys a question,

Working on a coop mission for my server for ravage, now what im trying to do is have it where 2 or more players spawn together

at a random location when the mission starts.

 

This is what i use for 1 player currently, i have the following code in the player's init box:


this setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"]));

Each m stands for marker, and the number is just the number of the marker, i have 35 of them.

So i have 35 markers spaced, and spread out all over the map, and when the mission starts the player will spawn at any of the markers but just one marker,

so again question is how do i do the same thing but for 2 or more players, spawning them together at the same marker?

 

Lastly after both players have spawned i want all the markers in the code to be deleted as currently when i spawn and have a map i

see all the markers on the map, can anyone clear this up for me on how to do these 2 things?

Or you can do something like this its tinkering but that should work

Use this init only for player1

this setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"]));

 

and create and stick an empty marker on player1 in the player1 init. (p1 is player1 variable name)

and for the other player use only "mp1" as starting location, like this every player will spawn on player1 and it will be JIP compatible if some player are late....

so the init line of your player1 (the hero) should be like this :

this setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"])); this = createMarker ["mp1", [500,500]]; "mp1" setMarkerType "mil_warning"; [] spawn {
while{not isnull p1} do {"mp1" setmarkerpos getpos p1; sleep 1;};
};

 

So i use mil_warning for see the marker, if everything work just replace this line : "mp1" setMarkerType "mil_warning"; by "mp1" setMarkerType "Empty";

 

 

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, Gunter Severloh said:

Hey guys a question,

Working on a coop mission for my server for ravage, now what im trying to do is have it where 2 or more players spawn together

at a random location when the mission starts.

 

This is what i use for 1 player currently, i have the following code in the player's init box:


this setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"]));

Each m stands for marker, and the number is just the number of the marker, i have 35 of them.

So i have 35 markers spaced, and spread out all over the map, and when the mission starts the player will spawn at any of the markers but just one marker,

so again question is how do i do the same thing but for 2 or more players, spawning them together at the same marker?

 

Lastly after both players have spawned i want all the markers in the code to be deleted as currently when i spawn and have a map i

see all the markers on the map, can anyone clear this up for me on how to do these 2 things?

You should be able to use the Empty Marker so they don't show on the map but player can still spawn at the locations. Also you probably already know this but by right clicking the marker you can choose random start position and sync it to whatever you want

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, lordfrith said:

 

the code i suggested would just be run in player1 otherwise yeah it would select a random start for each starting unit. if all player units are on map at mission start it should work as intended.... should....

ooh now i notice that i did not properly read and understand your code there! 

Share this post


Link to post
Share on other sites

How would I go about setting a whitelist for the equipment used in the loot system? I would like to specify each individual item that can be used. 

Share this post


Link to post
Share on other sites

It was previously mentioned that the ravage bandit camp script doesn't work right, ainjust stand there and do not engage on dedicated server.  Looks like the vehicle patrols are doing the same thing.  Does anyone know if this was broken by an ArmA issue or asomething with Ravage?

  • Confused 1

Share this post


Link to post
Share on other sites

I have no idea what everyone is talking about with bandit camps not working. They are fully functional and working on every single mission of mine.

Share this post


Link to post
Share on other sites
Quote

player1 setpos (getMarkerPos (selectRandom ["m1","m2","m3","m4","m5", "m6", "m7", "m8", "m9","m10", "m11", "m12","m13","m14", "m15", "m16", "m17","m18","m19", "m20", "m21", "m22", "m23", "m24", "m25", "m26", "m27", "m28", "m29","m30","m31","m32","m33","m34","m35"]));

 _newpos = player1 modelToWorld [1,-2,0];

player2 setPos _newpos;

Getting back to this, i just tested this in sp, i basically named my player player1, and an AI player2 whom i grouped to me, i started the mission and i randomly

spawned who knows where lol and my AI aka player2 was with me!

Works np, thanks guys for your help!

 

Now another question is, is an idea i have to make this starting spawn a little more interesting then just randomly appearing in the middle of nowhere, i want to give the

player a small story so that when they (the player and another or more) do spawn it gives them a reason.

Heres what i have in mind basically same as is, but the player and (friend if you will) spawn wherever in a vehicle out of gas,

          So the question is how do i spawn the player as the driver, with his buddy in the vehicle randomly like before?

 

From the Ravage wiki seen on this page here ----> http://ravage.wikia.com/wiki/Tools_for_Mission_Makers

I had updated and added more details to the Bandit Camps in terms of how to set it up.

 A question i had for the ingame aspect of itself is,  can we add an actual tent/buildings, ammo box, sleeping bags etc or something

to spice that up a little as its just a handful of bandits standing around a fire currently?

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Gunter Severloh said:

So the question is how do i spawn the player as the driver, with his buddy in the vehicle randomly like before?

name the vehicle, move that to the random marker point like above (make sure markers are on road or open space ;) ), then do moveInDriver etc on each of your players

  • Like 2

Share this post


Link to post
Share on other sites
15 hours ago, Donnie_Plays said:

I have no idea what everyone is talking about with bandit camps not working. They are fully functional and working on every single mission of mine.

 

I'll have to take a look at one of your missions, someone mentioned the ai don't attack and that's the behavior I've seen with the patrols so far on the dedicated server.

 

Share this post


Link to post
Share on other sites
1 hour ago, jimbojones said:

 

I'll have to take a look at one of your missions, someone mentioned the ai don't attack and that's the behavior I've seen with the patrols so far on the dedicated server.

 

I don't know for the bandit camp on dedicated server, but the car patrol not work they just stand in the middle of the road, (crew inside the car) they fire on the player but don't move

Share this post


Link to post
Share on other sites
22 hours ago, acoustic said:

How would I go about setting a whitelist for the equipment used in the loot system? I would like to specify each individual item that can be used. 

To elaborate on my question:

 

I am aware of the system now that allows you to whitelist certain mods/expansion packs, but I am interested in a much more detailed version. Is it possible? Anything hardcoded I could take a look at? Thanks.

Share this post


Link to post
Share on other sites
4 hours ago, jimbojones said:

I'll have to take a look at one of your missions, someone mentioned the ai don't attack and that's the behavior I've seen with the patrols so far on the dedicated server.


I should note something. All of my sandbox missions are MP... but not exactly set up specifically for dedicated servers. They are set up for players to locally host games for their friends to play. There are no friendly roaming AI's in my missions. It's exclusively hostile in the world. The only way you have a friendly, is if you are playing with an actual person. I have never ran Ravage on a dedicated server, so that could be a reason why I'm not having the same experience as others.

@damsous
I have seen AI vehicle patrols run into objects in the road like wrecked vehicles, etc. This causes the AI to stop sometimes on the road. However... while playing my Rambo: First Blood on Tanoa mission (using Ravage) just the other day on Tanoa I had an AI with a 50 cal on the back of a truck drive and chase me down a hill into a valley. I ran into the jungle to hide and the AI fired into the jungle at me.

Share this post


Link to post
Share on other sites

Hello,

I liked this mod but it doesent seem to work anymore for me. I used to play it 1 year ago. Now, with the latest version, and everything re-installed, i got this problem: zombies cant attack the player. They run towards you, swing once (doing no damage) and then stops and do nothing. Im pretty sure i have the latest version of arma, i updated everything through steam; and i run the 152 version of ravage.

Other mods works fine, like rayan zombies, and the rest of the ravage mod, ai and loot, seems to work fine.

Any help?

Thanks in advance. (Sorry if this question has been asked before, but now the thread is 294 pages long and i cant read it all, if someone can point me in the right direction i would be thankful aswell).

  • Like 1

Share this post


Link to post
Share on other sites

Welcome to Bis forums and Ravage thread ninjaijk!

From what i've been reading on the thread in the past week since the latest update this might be a new bug but cant say yet til Haleks looks into

it confirms and or we get more people confirming the same issue.

All i can tell you is just make sure you are running Ravage with CBA_A3 and keep an eye on the thread and wait and see.

Share this post


Link to post
Share on other sites
6 hours ago, HeroesandvillainsOS said:

Anyone care to link me to one of their Chernarus Redux missions? 


This is the only mission I have released on Chernarus Redux. It is simply an open world sandbox survival with as few required mods as possible. Up to 10 people can play together. I have recently added a trader area so you can loot and sell weapons and gear you find.
https://steamcommunity.com/sharedfiles/filedetails/?id=1142471713

  • Like 3

Share this post


Link to post
Share on other sites

Thanks Gunter Severloh, i will wait then.

For now I can say that I tryed a previous version of ravage, 0148 if I remember correctly, and I had the same issue. Maybe it can be tied to the latest update of arma.

Share this post


Link to post
Share on other sites
5 hours ago, Donnie_Plays said:


This is the only mission I have released on Chernarus Redux. It is simply an open world sandbox survival with as few required mods as possible. Up to 10 people can play together. I have recently added a trader area so you can loot and sell weapons and gear you find.
https://steamcommunity.com/sharedfiles/filedetails/?id=1142471713

hi donnie, in mx experience, the traders will sell gear from the equipment module settings as long as its a supported mod (cup, rhs, ...) to answer your point on the steam tread

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

how AI Ravage car patrol should work? For me it only  stay at one place and doesn't move till someone shoot guner or gunner spots me and starts chasing me. All this action happens only with initiation from my side, they don't patrol by default.

Another suggestion: after some time in game map is overpopulated with cars, it would be nice to have some limitation like car patrol should spawn only if in radius e.g. 1km is not another active car patrol.

I think that despawning system doesn't work for carpatrols.... dead bodies are still there even if I go to opposite side of Map and go back.

 

I don't have bad experience with zombies stops attacking so this work for me.

 

BTW for mission makers: If you want to add some special weapons https://steamcommunity.com/sharedfiles/filedetails/?id=973548592&searchtext= That crossbow is awesome!!!

Share this post


Link to post
Share on other sites
1 hour ago, Hans(z) said:

Hi,

 

how AI Ravage car patrol should work? For me it only  stay at one place and doesn't move till someone shoot guner or gunner spots me and starts chasing me. All this action happens only with initiation from my side, they don't patrol by default.

Another suggestion: after some time in game map is overpopulated with cars, it would be nice to have some limitation like car patrol should spawn only if in radius e.g. 1km is not another active car patrol.

I think that despawning system doesn't work for carpatrols.... dead bodies are still there even if I go to opposite side of Map and go back.

 

I don't have bad experience with zombies stops attacking so this work for me.

 

BTW for mission makers: If you want to add some special weapons https://steamcommunity.com/sharedfiles/filedetails/?id=973548592&searchtext= That crossbow is awesome!!!

Melee weapon are working with that mod ?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×