Jump to content
Dwarden

Arma 3 STABLE server 1.94 "performance binary" feedback

Recommended Posts

@dwarden you need the crashdump and the client log in case of the 3FPS bug? where can we find the crashdumps from client, is it in appdata?

 

sorry for that noob question... i just wanna help!

Share this post


Link to post
Share on other sites

1.66.140303 new PROFILING branch with PERFORMANCE binaries, v16, server and client, windows/linux
+ another server crash fixed

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs
available via STEAMklient/STEAMcmd as branch too, read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server
 
BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=getLastComment
Discord feedback: https://discord.gg/0aWSevYPq5W2FeM6

  • Like 2

Share this post


Link to post
Share on other sites

1.66.140341 new PROFILING branch with PERFORMANCE binaries, v17, server and client, windows/linux
+ fixed Crash when equipping Uniforms, Vests, Headgear or Backpacks for a different skeleton
+ fixed zoom sometimes not working properly in multi-player
 

  • Like 3

Share this post


Link to post
Share on other sites
7 hours ago, dwarden said:

+ fixed zoom sometimes not working properly in multi-playe

 

Is this where you zoom in with an optic of some kind and you cannot unzoom (usually vehicles)?

Share this post


Link to post
Share on other sites

No it's the bug (we have it since december or so?) where you have to spam zoom key 20-30 times with Titan, Tank zoom or other weapons zoom and only after 20 times it would zoom 1 level or so... (Wasteland servers) FINALLY it's fixed! Now only waiting for flickering issues fix! (Houses/trees flicker on high view distance)

  • Like 1

Share this post


Link to post
Share on other sites

Im trying to figure out if these exe's will benefit me, and after some testing I have some questionable results/   

 I run the perf exe in our dedicated server and i can see that the memory stopped leaking. 

today i decided to try the perf exe for my game( i also have the 3fps bug) and ran some benchmarks. 

 http://pasteboard.co/yLlh0Bt8Q.bmp

it looks like the perf exe gives a good result if i run a benchmark when i start the game, but if i play for awhile, the results are poor compared to the vanilla exe after playing for awhile. 

 I use xtbbmalloc , it is configured correctly and i do see a benefit from that compared to the others.  is there a better mem, alloc. to use with this?

Share this post


Link to post
Share on other sites
25 minutes ago, abudabi said:

Dwarden im not sure, but then i turned off ATOC setting 3 fps bug is gone


can you tell me how to do it? I have a mission which causes 3 fps bug always so I can check

it is under video settings :)

Didn't work :(

Share this post


Link to post
Share on other sites

1.66.140454 new PROFILING branch with PERFORMANCE binaries, v18, server and client, windows/linux
+ fixed some Crashes
+ fixed setUnitPos vs Careless AI soldiers on patrol

 

https://www.dropbox.com/sh/582opsto4mmr8d8/3BSy9PdRGm
https://drive.google.com/folderview?id=0B03-H4YIbhkFMUt5RzNqZjFlNGs


available via STEAMklient/STEAMcmd as branch too,

read https://community.bistudio.com/wiki/Arma_3_Steam_Branches#Arma_3_Server
 
BIForum feedback: https://forums.bistudio.com/topic/160288-arma-3-stable-server-166-performance-binary-feedback/?do=getLastComment

https://discord.gg/0aWSevYPq5W2FeM6

 

  • Like 2

Share this post


Link to post
Share on other sites

For some reason I cannot get the PerfBinary to work with BattleEye.

I'm using the Arma3Sync launcher, it keeps giving me the BattleEye is not enabled popup.

No matter what startup parameters I use it doesn't seem to work.

 

Does anyone know what the problem is?

Share this post


Link to post
Share on other sites
1 minute ago, TheMasterofBlubb said:

you have to start the arma3battleye

 

 

I am aware of that, but how do I start BattleEye while still using the Performance Binary

Share this post


Link to post
Share on other sites
6 hours ago, cranckra1n said:

V17 : 138spieleri77700k.png

and 180 Clients 22 CPS /FPS lets go on to V18

 

V17 = 10% increasement to Stable

 

quite well optimized mission, scripting, callextension(s), server settings and hardware you got there ;)

 

thus it makes me happy to hear about your +~10% improvement experience

note: new 1.68 main branch stable binary will have way (WAY) more optimizations because many could not be merged for various reasons ...

Share this post


Link to post
Share on other sites
2 minutes ago, The_Dutchman said:

 

I am aware of that, but how do I start BattleEye while still using the Performance Binary

 

did you replaced the arma3.exe with the binary from profiling (you need rename the one from dropbox) ? (backup the old .exe)

if you used steam client for branch download then you do nothing , performance is default ...

Share this post


Link to post
Share on other sites
7 minutes ago, dwarden said:

 

did you replaced the arma3.exe with the binary from profiling (you need rename the one from dropbox) ? (backup the old .exe)

if you used steam client for branch download then you do nothing , performance is default ...

 

I've been using and updating the Perf. from your dropbox for a while now. I did not use the steam Branch.

Share this post


Link to post
Share on other sites

then there shall be no issue ... 

Share this post


Link to post
Share on other sites
17 minutes ago, dwarden said:

then there shall be no issue ... 

 

Yet there is, since I get the enable battleEye popup.

Or does it still work even thought It's using the battleEye.exe, Cause I assume it doesnt.

Share this post


Link to post
Share on other sites
2 minutes ago, The_Dutchman said:

 

Yet there is, since I get the enable battleEye popup.

Or does it still work even thought It's using the battleEye.exe, Cause I assume it doesnt.

 

check my comments in page 78. I had similar questions and it is clarified there

  • Like 1

Share this post


Link to post
Share on other sites

Apologies in advance for my (most likely foolish) question. I have a desktop shortcut for the Arma 3 Launcher. When I update the performance exe do I have to do anything with that shortcut? I know how to update the exe's, I've been doing that for a while, but the shortcut just dawned on me. Thanks. 

Share this post


Link to post
Share on other sites
10 hours ago, Devastator_cm said:

 

check my comments in page 78. I had similar questions and it is clarified there

That clears up a lot of confusion. Thanks !

  • Like 1

Share this post


Link to post
Share on other sites
On 21.2.2017 at 10:13 PM, dwarden said:

 

quite well optimized mission, scripting, callextension(s), server settings and hardware you got there ;)

 

thus it makes me happy to hear about your +~10% improvement experience

note: new 1.68 main branch stable binary will have way (WAY) more optimizations because many could not be merged for various reasons ...

 

extension(s) : ExtDB3 and our Life_Server

scripting : Try to go only remoteexeccall ore call ore FSM

mission : minimised Createvehicle and maximised createvehiclelocal

hardware : i7 7700k 4.8 Ghz , RamDisk and 1GB/s network

 

and we have massiv DB Trafic :D

 

Hope we can help you :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×