Jump to content
.kju

All in Arma (AiA) - TKOH/OA/A2/A1 merge with A3

Recommended Posts

@ Nozkin

Please check: HowTo-post-issues.

@ Tike

Please check the FAQ.

If it doesn't help, you need to explain in more detail what you are up to / what problems you have.

@ Ckrauslo

Try without mods first.

Make sure you are using the correct modline.

Don't use ACE2 in A3.

If you still have issues, please check: HowTo-post-issues.

Share this post


Link to post
Share on other sites
Q: How to use load custom modfolders with AiA?

A: You need to put them right at the start, like: -mod=@MyMod;..AiA

If it's this, it does look like it's for A3 Mods, it doesn't say anything about A2 mods.

Share this post


Link to post
Share on other sites

@ Tike

To use A2 infantry in A3 with AiA check the FAQ.

Vehicles should work more or less (aside from the known issues). Same for weapons.

Terrains are no problem. Scripted features or missions largely depend on the specifics.

Just give it a try and see how it goes.

Share this post


Link to post
Share on other sites

@.kju i'm lazy i'm using play with six i solved the issue apparently only the default A2/OA units can change their weapons, the downloaded ones, cannot interact with other guns beside the ones they come equipped with, so if you try to take other guns you wont be able to, any news if BIS will help you to solve the engine issues?

---------- Post added at 18:35 ---------- Previous post was at 18:30 ----------

@Tike if you're doing the All in arma manual install, even for A2 mods you'll use the mod line, but if you're using play with six, there will be bellow you're collection area an area for the mods that you already have in you're computer, in this area there will be the name All in arma with an arrow behind it, click on the arrow and three other options will appear below it, and will be the names of the previous titles you have installed on you're machine, and right next to the names will have a number for the number of mods you have in the paste of each games, me i have 31 mods in the Arrowhead paste so i click on it, and a list of all my mods appear, and when i find the mod i want i click on it, and select add to collection, than you simply start the game by clicking in start collection

---------- Post added at 18:39 ---------- Previous post was at 18:35 ----------

@.kju I'm having no issue using Ace 2 in A3, i can only use the editor, but for the missions i'm editing it is running perfectly, there is this guy that corrected the issue of the main menu and is now being able to use Ace2 with no problems, i'm trying to reach him at youtube, i hope the Ace team didn't stop making Ace 3, because they promised the mod for when the game was launched in alpha but until now...news

Share this post


Link to post
Share on other sites

Hey .kju sorry if I ask something that someone else asked before, but I cannot find anything.

Anyway, when I spawn the civilian, Russian or Chedaki, they will spawn like Arma 3 Civilian.

Is this a known problem or is it just for me?

Share this post


Link to post
Share on other sites

@ Antorugby

This is normal as there is no mapping to specific A3 civilians yet, nor can you mix A3 with A2 infantry models.

Share this post


Link to post
Share on other sites
@.kju i'm lazy i'm using play with six i solved the issue apparently only the default A2/OA units can change their weapons, the downloaded ones, cannot interact with other guns beside the ones they come equipped with, so if you try to take other guns you wont be able to, any news if BIS will help you to solve the engine issues?

I'm having the issue (I think) you're describing here...

When spawning with a main weapon, everything works fine. Then, if I switch to a sidearm and try to switch back to main weapon, it doesn't work and I can't move anymore until I drop the weapon. Same when I try to pick up a weapon from the ground or a container. The issue seems related to the "equip weapon" animation? I've tested on several ARMA2/OA/3 characters, it seems to happen for all weapons/characters no matter what when I have AiA enabled.

I'm using version 0.20 (also tried to revert to 0.19 and it didn't help).

Share this post


Link to post
Share on other sites

New version available: https://dev.withsix.com/projects/all-in-arma/files

Changes:

  • Changed: Update AiA to 1.10.

Full details: https://dev.withsix.com/versions/1574

WIP changes:

---

Notes:

  • CBA A3 beta 4 required (and no other CBA version).
  • Delete the former @AllInArma modfolder first.
  • The design of A3 vs A2/OA/TKOH infantry and hidden content has changed. Make sure to read the FAQ.
  • If you want to play A1 terrains without missing objects, you need to merge the misc.pbo and buildings.pbo from A1 and A2 yourself and put it into .\@A1A2ObjectMerge\addons. More details in the wiki.
  • If you want to play A1 missions, you need to load A2 and OA along as well. Queen's Gambit missions are not yet supported.
  • Please read the known-issues section, the FAQ and howTo-post-issues.

Important notes:

Please vote in the A3 Feedback Tracker (FT) for AiA related tickets.

See links in the Known issues section.

Contribute:

We are looking for a nice banner, promo screenshots and promo trailers for our new AllInArma info page.

If you want to help out with your skills, please contact me. :)

Enjoy :bounce3:

Share this post


Link to post
Share on other sites

@ Modder

This is just a hotfix / to make it compatible with the new 1.10 version. Nothing else.

If you want to check the actual code differences, use the link to the roadmap, log into your DH account,

click the ticket and check the changesets. Does this answer your question?

@ tyl3r99

No idea :(

Share this post


Link to post
Share on other sites

Is there any Arma 3 compatible script, tool or method to view building class names in a map loaded via AiA? I want to try my hand at scripting on older maps. Thanks in advance!

EDIT: I'd also like to know if there is some method to close every door on every building in a map loaded in AiA... I haven't tested many different maps yet but at least Clafghan previews in the editor with many building doors open.

Edited by Oktyabr

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

GAH! The water lines! The water lines! I wish there was a fix. I'm playing with Clafghan and most of the map you never see it... but if you end up in a firefight someplace where it's bad, it's REALLY bad. :(

Share this post


Link to post
Share on other sites
;2605996']@ Modder

This is just a hotfix / to make it compatible with the new 1.10 version. Nothing else.

If you want to check the actual code differences' date=' use the link to the roadmap, log into your DH account,

click the ticket and check the changesets. Does this answer your question?

[/quote']

Certainly does, cheers for that.

Didnt realise "Update AiA to 1.10" was to match the mod to the games current version. ;)

Share this post


Link to post
Share on other sites

Just a headsup: Kaelis released a A2 unit port that could benefit the A2 replacements of AIA - http://forums.bistudio.com/showthread.php?172176-Kaelies-South-Zagorian-Army-Mod&p=2609532#post2609532

There´s the CDF and takistani army... maybe Ohally´s aggressors could be put on the mix too (for Chedaki/Takistani rebels or takibans) - http://forums.bistudio.com/showthread.php?172069-Arma3-AGGRESSORS

cheers =)

Share this post


Link to post
Share on other sites

Hi.....

Great mod, thanks.

Not a massive problem, but i've noticed that an opfor group leader will speak in his native language i.e. not english but the rest of the units in the group speak english.

Checked in it vanilla A3 and all units plus group leader speak non english.

Edited by Tyke

Share this post


Link to post
Share on other sites

Any luck getting vehicle engine sounds working? No engine revving sound when driving sucks.

Share this post


Link to post
Share on other sites

If you add @soa_vehicles to the command line, it enable internal audio for several vehicles.

Share this post


Link to post
Share on other sites

@soa_vehicles is not a normal command structue for arma 3 so i presume its a mod but please tell us wich mod it is then at least (normaly a @ sign means a custom mod folder)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×