Jump to content
tonic-_-

Virtual Ammobox System (VAS)

Recommended Posts

I have an idea about how to resolve this loading problem. Let players / team members build their different loadouts separatly in editor mod (with some tutorial on your forum about what gear you use in your team etc ... ) and simply add a get selected loadout "in scroll menu" script in your missions.

Share this post


Link to post
Share on other sites
;2523552']I have an idea about how to resolve this loading problem. Let players / team members build their different loadouts separatly in editor mod (with some tutorial on your forum about what gear you use in your team etc ... ) and simply add a get selected loadout "in scroll menu" script in your missions.

Any example for explain this?

Share this post


Link to post
Share on other sites

I've tried one script from armaholic (the one from aeroson) but it can't works since the different game updates i think ... So ... we must wait for a vas or game fix about that loading problem of VAS.

.

Share this post


Link to post
Share on other sites
Hi, can you get this working for atlis please?

You can use anywhere, any mission, any map. Just transfer the files into your Mission Folder

and then turn On/Off with a Trigger area or an Item Initialization Box itself (proximity).

Share this post


Link to post
Share on other sites

Hi guys,

i don´t know if i have to post here or in the BTC REVIVE section. I explain you what´s going wrong:

I´m using the VAS in a mission and the BTC REVIVE.

If a player get killed , he gets "revive" by a player or choose the respawn point .

After that he goes the VAS to get stuffed .

Here is the problem.If he choose a back pack or a uniform he gets automaticly some watches in it ;)

http://i57.servimg.com/u/f57/17/93/51/86/vas_bu10.jpg (137 kB)

Here is my "description.ext"

author = "PHIL";
onLoadName = "THUNDER HOURS";
onLoadMission = "Get ready for ACTION";
loadScreen = "THUNDER.jpg";


//===================INFO SUR LA MISSION================

class Header
{
   gameType = COOP;
   minPlayers = 1;
   maxPlayers = 7;
};


//==================LE RESPAWN================


respawn = "2";
respawndelay = 15;
RespawnDialog = 1;
disabledAI = true;
enableDebugConsole = 2;


//==================VAS====================

#include "VAS\menu.hpp"

class CfgFunctions
{
#include "VAS\cfgfunctions.hpp"

class TM4
{
	class ObjectModifiers
	{
		file = "functions_f\ObjectModifiers";
		class setSkill {};
	};
};
};


//=========================MUSIC============================

class cfgMusic
{
    tracks[]={};

    class horn
    {
    name = "horn";
    sound[] = {music\horn.ogg, 1, 1.0};
    };

}; 

//================OBJECTIFS==============================

class CfgNotifications
{
class ObjectifNouveau
{
	title = "NOUVEL OBJECTIF";
	iconPicture = "\A3\ui_f\data\map\mapcontrol\taskiconcreated_ca.paa";
	description = "%1";
	priority = 3;
};

class ObjectifAccompli
{
	title = "OBJECTIF ACCOMPLI";
	iconPicture = "\A3\ui_f\data\map\mapcontrol\taskicondone_ca.paa";
	description = "%1";
	priority = 5;
	color[] = {0.69,1,0.29,1};
};

class ObjectifEchoue
{
	title = "OBJECTIF ÉCHOUÉ";
	iconPicture = "\A3\ui_f\data\map\mapcontrol\taskiconfailed_ca.paa";
	description = "%1";
	priority = 4;
	color[] = {1,0.2,0.2,1};
};

class ObjectifAnnule
{
	title = "OBJECTIF ANNULÉ";
	iconPicture = "\A3\ui_f\data\map\mapcontrol\taskiconcanceled_ca.paa";
	description = "%1";
	priority = 2;
};
};

#define FONT_Z                 "PuristaMedium"
#define CT_STATIC            0
#define CT_SHORTCUT_BUTTON     16
#define ST_PICTURE             48
#define ST_NOBORDER            512
#define ST_LEFT             0x00
#define ST_RIGHT            0x01
#define ST_CENTER             0x02
#define ST_SHADOW             0x100


//===================BTC REVIVE================

#include "=BTC=_revive\=BTC=_respawn.h"


Does anyone know what is wrong?

Share this post


Link to post
Share on other sites
Thanks ....But i´ve delete the old version and place the 2.0 version twice and it still doing the same bug :(

Here is my mission : https://www.dropbox.com/s/3by9r644g9rtwsr/LASTONE.Altis.rar

If I remember correctly BTC started using aeroson's GET/LOAD Gear script and If I remember correctly that uses something with itemWatch to make sure gear loads in the exact order it was stored, it's probably more or less an issue with aeroson's script that BTC uses.

http://forums.bistudio.com/showthread.php?148577-GET-SET-Loadout-(saves-and-loads-pretty-much-everything)

Regardless the issue is not related with VAS.

Share this post


Link to post
Share on other sites

Thanks for helping,

but i think is start to be a bit complicated for me , maybe the language is the cause . In concret what should i do ?

In advance thanks.

---------- Post added at 09:14 ---------- Previous post was at 07:37 ----------

Okay, if i use the "FAR REVIVE" everything works fine .........................

Just to let you know ....

So there is a "conflict between" the VAS and the BTC REVIVE ...............

Share this post


Link to post
Share on other sites

So there is a "conflict between" the VAS and the BTC REVIVE ...............

Nope, just update to the last version! It was a conflict with the new stable!

@Tonic

An amazing work mate!

I was wondering if there's a way to reduce the vas loading time, some players have to wait a very long time, especially in the missions scripted a lot.

I can't play without VAS script! Good job!

Share this post


Link to post
Share on other sites
LONG LOAD TIMES - VAS hasn't finished loading

A few things that we have done on our dedicated server that produces consistent VAS results.

Player #1 and #2

Player #1 logs in and starts a mission.

Player #1 instantly gets VAS menu.

player #2 now joins the server and receives not finished loading.

player #2 Gets option after 3-13 mins.

Next Test.

Player #2 login in server and loads mission.

Player #2 gets VAS menu instantly.

Player #1 joins the server.

Player #1 is now delayed and unable to get VAS menu for minutes.

The two most glaring things that we have noticed are:

First player on a newly loaded mission, gets the VAS menu instantly.

All subsequent players are delayed.

Most long wait times seem to be AMD users.

Most Intel i5/i7 users wait 3 mins while the AMD users wait upwards to 25 mins.

I know none of this is solid information but we have been beating our heads against the wall to solve this and are about to do without the SAVE/LOAD option as it is so inconsistent that it is actually easier to just use the old method and be done with it. Please do not misunderstand what i am saying here, VAS is an excellent mod but because it is acting so flaky, it is causing severe administrative activity.

Anyone have any same experiences or solutions to this/these issues?

I had one player on my ded server that was having very long (15 min +) load times until VAS would be available. He was an AMD user too. Another team mate searched for the issue and found ACRE to be the cause. Something about ACRE searching for channels, I'm not sure. The player with the long load times disabled ACRE and now the long load time issue is gone.

Z

Share this post


Link to post
Share on other sites

The only thing that I can think of off the top of my head that can slow down VAS initialization is addons such as ACRE. ACRE adds hundreds of entries into CfgVehicles & CfgWeapons. Sadly I have never found a way to search externally outside of those as the only real way to search the config dynamically is to go through the entire config.

The only way to shorten the time it takes when using something as big as ACRE is to load up VAS vanilla and do copyToClipboard str(VAS_pre_weapons); and copy the weapons into VAS_weapons and do the same thing for VAS_pre_items and copy that array into VAS_items. That is the only way to shorten the time with big addons.

My system specs is as follows:

CPU: i7 2600k @ 5.1Ghz (Air cooled).

MOBO: ASUS MAXIMUS IV EXTREME LGA 1155 (EATX)

GPU: Quad SLI EVGA Nvidia GTX 780 FTW (stock clock)

PSU: EVGA SuperNOVA NEX1500 Classified 1500W ATX12V

RAM: G.SKILL Ripjaws Z Series 8GB DDR3 2133

SSD 1: OCZ 60GB Agility 3 (Primary)

SSD 2: OCZ 120GB Agility 3 (Some games)

HDD: Western Digital Black 1TB (Games, movies, backups etc).

As you can see it's kind of hard for me to test load times when I load and initialize everything (even with ACRE) instantly.

As a personal note if you're using AMD you have my sympathy.

Edited by Tonic-_-

Share this post


Link to post
Share on other sites

What about split the VAS initialization and the load profile feature?

Most of the times i've just to take a loaded profile, so i was wondering if it could be possible without waiting the full initialization.

Do you ever think about an addon version?

Share this post


Link to post
Share on other sites
What about split the VAS initialization and the load profile feature?

Most of the times i've just to take a loaded profile, so i was wondering if it could be possible without waiting the full initialization.

Do you ever think about an addon version?

The load profile sort of relies on the setup to be initialized first.

As far as a addon no, it would be abused. The only form of an addon VAS will make is into a upcoming MCC Sandbox Editor update for A3 I believe.

Share this post


Link to post
Share on other sites

Could i make an addon version for internal use? Are you okay with that? It's just a pain update all the mission i created for one script...Let me know what you think about!

Share this post


Link to post
Share on other sites

Is there a way to get the VAS to spwan when all enemy are defeated in a set area?

For instance the first task in my current mission is to clear opfor from a small courtyard area where they are protecting a stolen convoy. I want it so when the insertion team have cleared the opfor from that area the ammo crates will " spawn in ". I have used a module to hide the ammo but can't for the life of me figure out how to get it to " spwan in " when the trigger goes off saying " area clear, now rearm and move out to the next AO "

Share this post


Link to post
Share on other sites
Is there a way to get the VAS to spwan when all enemy are defeated in a set area?

For instance the first task in my current mission is to clear opfor from a small courtyard area where they are protecting a stolen convoy. I want it so when the insertion team have cleared the opfor from that area the ammo crates will " spawn in ". I have used a module to hide the ammo but can't for the life of me figure out how to get it to " spwan in " when the trigger goes off saying " area clear, now rearm and move out to the next AO "

VAS is called from an addaction. best idea is the use the addaction condition to only show on a crate vehicle etc. when a parameter is true.

Share this post


Link to post
Share on other sites

Hi guys,

just to let you know , that i´m not the only one to have this problem with the VAS 2.0 .I mean the backback full of watches .

Share this post


Link to post
Share on other sites

Amazing Script, Using since ever, but i have two questions:

a) On which occasions could saved Loadouts be lost? I Saved 5 Loadouts, and after a Week or so, they are no longer in the Loadout List. Now, i'm sure i caused that myself, since in de/installed alot of Mods, used new Profiles etc, i jsut wanted to know what could cause it, to make sure it doesn't happen again.

b) Is there any chance to get a Dialouge like there is for Weapon attachments also, for Weapons and Uniforms/Vests? - Like, do you want to equip this Uniform now, or do you want to put it into your Backpack? Should this Vermin SMG replace your SDAR, or do you want ti put it in your Vest? Or is this somehow possible already and i did just not know? If so, please enlighten me.

The reason i'm demangind for B is, that you could e.g. make a Diver Class with Wetsuit and a SDAR which has an MX and Fatigues in the Backpack, and can switch to them on shore. I know, the weight will be great and i won't be able to carry many other thigs sice that takes up a lot of space, but i still prefer a MX with 2 Mags to an SDAR with zero effectivity.

Share this post


Link to post
Share on other sites
Hi guys,

just to let you know , that i´m not the only one to have this problem with the VAS 2.0 .I mean the backback full of watches .

This is not a issue with VAS, this is another script (Most likely a revive system) causing this issue.

Could i make an addon version for internal use? Are you okay with that? It's just a pain update all the mission i created for one script...Let me know what you think about!

Sure I guess.

Amazing Script, Using since ever, but i have two questions:

a) On which occasions could saved Loadouts be lost? I Saved 5 Loadouts, and after a Week or so, they are no longer in the Loadout List. Now, i'm sure i caused that myself, since in de/installed alot of Mods, used new Profiles etc, i jsut wanted to know what could cause it, to make sure it doesn't happen again.

b) Is there any chance to get a Dialouge like there is for Weapon attachments also, for Weapons and Uniforms/Vests? - Like, do you want to equip this Uniform now, or do you want to put it into your Backpack? Should this Vermin SMG replace your SDAR, or do you want ti put it in your Vest? Or is this somehow possible already and i did just not know? If so, please enlighten me.

The reason i'm demangind for B is, that you could e.g. make a Diver Class with Wetsuit and a SDAR which has an MX and Fatigues in the Backpack, and can switch to them on shore. I know, the weight will be great and i won't be able to carry many other thigs sice that takes up a lot of space, but i still prefer a MX with 2 Mags to an SDAR with zero effectivity.

1. When you shift profiles or deleted the old .vars file (for the account which you created the loadout) then it becomes lost. You should always backup your .vars file for the profile you originally created it so when you shift profiles you can copy the backup over and change the filename so it works with the new profile.

2. I thought about it but in honesty I have lost interest in VAS or generally anything publicly at this time however it is possible to have loadouts like that saved it just requires you using the I Inventory button (or whatever key is marked for inventory) and dragging them into a backpack and then saving.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×