Jump to content
Sign in to follow this  
highhead

Multi-Session Operations v4.5 released

Recommended Posts

I tried both the PRC 117 and 119

and cannot for the life of me figure out why

i am still being told i don't have a long range radio

for PO2 Mission assignments.

?

Share this post


Link to post
Share on other sites
Yo Mates!

Khaki, we have implemented PO2 as a module for MSO and heavily adapted it to have it fit in MSO, so im not sure if it would even work outside the MSO framework.

If you want to use it for other missions and its ok for Roy86 i see no problem, but credits always go to Roy.

Thanks for the reply HighHead! That's what I figured as much anyways, I'll keep busting my head at it. And of course credit goes to Roy86 (If it ever works).

Share this post


Link to post
Share on other sites

Just tried another session with half a dozen mates yesterday and it was fun but we faced an almost game breaking lag whenever we had to use a device with a menu (eg. ACRE radio) or an ACE action (bandaging, aiming arty and so forth), even animated reticle were lagging.

I already experienced tehs ames issues on a server runing the mission without PDB for days but here was a fresh start, both mission and server.

Anyone else facing the same issues?

Share this post


Link to post
Share on other sites
Just tried another session with half a dozen mates yesterday and it was fun but we faced an almost game breaking lag whenever we had to use a device with a menu (eg. ACRE radio) or an ACE action (bandaging, aiming arty and so forth), even animated reticle were lagging.

I already experienced tehs ames issues on a server runing the mission without PDB for days but here was a fresh start, both mission and server.

Anyone else facing the same issues?

Yah, I noticed this yesterday actually on my server. It starts off great but the longer the mission runs the longer it takes to do script actions. I also noticed this on the MilGo MSO server which is the main reason I went to start my own was because I thought it was just performing poorly. Now that I am not the only one getting this I feel much better.

MSO is by far my favorite mission of all time. I am all about dynamic coop multiplayer environments that allows me too build bases and have AI teams and everything else that it allows is just what I have been waiting for forever. Keep working at it guys!

Share this post


Link to post
Share on other sites

I can't request anything: logistics, operations, CAS, nothing. When I try to request something it says, "You require a radio". Well, I have a radio. It's called the AN/PRC-343 but apparently this isn't the right radio. I'm using ACE and ACRE by the way. Then I found a DAGR radio and a Kestrel 4500 radio but apparently these aren't good enough either and I still get the same "You require a radio" message. Any help?

Share this post


Link to post
Share on other sites

Yah when I use my Kestrel 4500 "radio" all I get is wind speeds. "Helloooo is this thing on".

A kestrel 4500 is a wind speed monitor and not a radio hahaha. Also a DAGR is an advanced GPS receiver, both of which will just get you funny looks if you talk into them.

Now if you went and grabbed yourself a PRC-119 you would be having yourself a logistical day!

Note you will have to have a marker added into your mission which spawns the radios. I think the marker name is ammo off the top of my head. Also you might be required to manually add the ace items into your mission.

Share this post


Link to post
Share on other sites
Yah when I use my Kestrel 4500 "radio" all I get is wind speeds. "Helloooo is this thing on".

A kestrel 4500 is a wind speed monitor and not a radio hahaha. Also a DAGR is an advanced GPS receiver, both of which will just get you funny looks if you talk into them.

Now if you went and grabbed yourself a PRC-119 you would be having yourself a logistical day!

Note you will have to have a marker added into your mission which spawns the radios. I think the marker name is ammo off the top of my head. Also you might be required to manually add the ace items into your mission.

lol well they looked like radios. I never saw a PRC-119 in any of the boxes at base. Should it be there? I have no idea how to add a marker into the mission. I've tried playing without ACRE and I get the same error. Should I disable ACE as well? How are you able to get around this "You require a radio" thing?

Share this post


Link to post
Share on other sites

@Jiltedjock: Wow, this is how Arma was meant to be played! Hats off to the mission creator :)

I'm pretty out of my element with this large scale warfare and you seem to have a good grasp - what would you recommend in terms of how many friendly AI groups and general makeup that would make the mission fair but still very hard?

Share this post


Link to post
Share on other sites
@Jiltedjock: Wow, this is how Arma was meant to be played! Hats off to the mission creator :)

I'm pretty out of my element with this large scale warfare and you seem to have a good grasp - what would you recommend in terms of how many friendly AI groups and general makeup that would make the mission fair but still very hard?

I've usually put a few Blufor motorized groups down eg BAF Jackal sections which I then bring into play through High Command. Alternatively you could use DAC http://www.armaholic.com/page.php?id=10621 to create the friendly groups and also to create a DAC waypoints zone whcih covers most of the map, so the AI Blufor groups will go off and do their own thing. They will basically appear to be patrolling as they will use roads until they are in contact. You can set DAC up so that cargo units in groups will leave vehicles at waypoints and patrol, check buildings etc. That can be quite an immersive way to play as conflict will erupt all over the place, particularly if you are using MSO static enemypop.

---------- Post added at 02:55 PM ---------- Previous post was at 02:54 PM ----------

Russians

My preference with MSO is to play as regulars and have opfor as insurgents/guerillas. However NATO forces versus irregulars can seem a bit imbalanced, particularly scoped weapons versus iron sights. It's reasonably trivial to set MSO up to play as the Russians, Takistan Army etc. The Russians in particular are good fun versus guerillas and insurgents on Chernarus, and the reworked Malden and Everon maps. The most straightforward way to do it is to make the Russians Blufor:

depbo one of the Chernarus MSO missions

in the editor:

replace the weapon crates with Russian versions

replace empty vehicles with Russian versions

replace units with Russians

if you want to use air support, replace the vehicles in the MSO scripts with Russian alternatives

Save, exit editor

Manually edit the mission.sqm in notepad and replace side="EAST"; with side="WEST"; against the units and the class groups

Save the mission.sqm and open the mission in the editor

Save as multiplayer mission

Edited by jiltedjock

Share this post


Link to post
Share on other sites
lol well they looked like radios. I never saw a PRC-119 in any of the boxes at base. Should it be there? I have no idea how to add a marker into the mission. I've tried playing without ACRE and I get the same error. Should I disable ACE as well? How are you able to get around this "You require a radio" thing?

So now I start MSO with a basic radio called simply, "radio" but this radio isn't the right one apparently. If it's not the right radio it would be nice if the message would tell me which radio I need instead of reading, "You require a radio" when I already have a radio. Which radio do I need and how do I get it?

---------- Post added at 13:01 ---------- Previous post was at 11:29 ----------

So now I start MSO with a basic radio called simply, "radio" but this radio isn't the right one apparently. If it's not the right radio it would be nice if the message would tell me which radio I need instead of reading, "You require a radio" when I already have a radio. Which radio do I need and how do I get it?

Found an AN/PRC-77 (P168 VHF Radio) radio in one of the larger crates. It works.

Share this post


Link to post
Share on other sites

Hey everyone,

So I was able to get everything from a mission standpoint running just fine. My trouble is with setting up the database. The database is set up with proper user and permissions and what not. When loading in the mission, it gets to the screen that says "Setting up Client please wait" on the ArmA2Net Logo image with a black screen and never completes. I can hear myself running around and what not however the screen still stays rendering the mission unplayable.

Does anyone know what could be the cause of this issue?

Share this post


Link to post
Share on other sites

Hej

We have run into a really frustrating problem,

we play with ACE on Celle 2, with very limited modules cause its a big map and we want it to run very smooth.

But For some reason when we request a patrol ops.. it atomatticly gets Accomplished in around 1 minute after we get it..

And there is also a wierd delay when we like want to treat buddies thats been wounded.. We are talking a delay of like 10-20 seconds before it starts doing what we choose to do.

its wierd and cant really seem to figure out whats causing it, since the server is running with 45-50 fps.

Share this post


Link to post
Share on other sites

Holmes, what worked for me was to wait for the mission to completely initialize and then start it. I think gunny (?) recommended this earlier in the thread. Background seems to be, that the database needs to be properly initialized and when you start the mission during initialization it is not.

I wrote a small addon for MSO with ACE, or for other missions. It's basically a search & plunder style mission: First you request some vehicle inspection; if you find evidence, the intel HQ can evaluate it and generates hint to some place to loot; once you've discovered the loot you can bring it intel HQ. rince, repeat :)

A pbo for testing on Chernarus with ACE MSO is available at http://ubuntuone.com/02ecv85mOT1MTDg3OpB2C9 . Use the radio menu 0-8-0-3 or the self interaction key to start a police op to follow some hints on a hidden stash with drugs and money. I've put all the scripts in the TeTeT folder, but for the operations_init changes for the radio and self interaction key. Some of the objects are saved in the db, however I did not really test the persistency so far.

Share this post


Link to post
Share on other sites

I can't seem to call in logistics. I choose the logistics demand and select the item I want, the number of items, I click add, and then 'ok'. I then select a spot on the map for a para drop or airlift and it says that my order is being processed but nothing ever shows up. Even the road convoy option doesn't seem to work.

Share this post


Link to post
Share on other sites

@jiltedjock: Cool man. I'm playing Lingor and switched out all Blufor for Lingor Army cause US is too overpowered.

One thing -I don't have a 'TASKS' option and am therefore just playing it like a CTI -any ideas?

Edited by froggyluv

Share this post


Link to post
Share on other sites
I can't seem to call in logistics. I choose the logistics demand and select the item I want, the number of items, I click add, and then 'ok'. I then select a spot on the map for a para drop or airlift and it says that my order is being processed but nothing ever shows up. Even the road convoy option doesn't seem to work.

Not 100% sure but I think the resupply takes a very long time (like hours) unless you change these values in the mission files. I depbo the mission example then open it in the editor and switch some values so the resupply is a little faster. My issue is that when using custom skins (US Navy Seals by Massi), the Logistics menu will NOT reflect any air or vehicles in any drop down menus.......very frustrating.

I'm also not sure if the logistics menus work unless being loaded on a dedicated server running MSO?

Share this post


Link to post
Share on other sites

Just wanted to post thanking the creators of this mission pack. I've been running it a few days now on a spare computer as a dedicated host, no PDB yet as I'm unfamiliar with SQL databases. Been having tons of fun with it though, no major issues encountered yet, just the usual ArmA 2 ai driving and pathfinding skills that threaten to leave a boot print on my monitor.

Share this post


Link to post
Share on other sites
Not 100% sure but I think the resupply takes a very long time (like hours) unless you change these values in the mission files. I depbo the mission example then open it in the editor and switch some values so the resupply is a little faster. My issue is that when using custom skins (US Navy Seals by Massi), the Logistics menu will NOT reflect any air or vehicles in any drop down menus.......very frustrating.

I'm also not sure if the logistics menus work unless being loaded on a dedicated server running MSO?

I know it takes hours for vehicles and other things to resupply or respawn but when you call in logistics out on the battlefield I can't imagine it requiring you to wait hours. I'll take a look at the settings though. I've been playing on my own LAN and the logistics menus work fine, they just never send anything.

Share this post


Link to post
Share on other sites
Just wanted to post thanking the creators of this mission pack. I've been running it a few days now on a spare computer as a dedicated host, no PDB yet as I'm unfamiliar with SQL databases. Been having tons of fun with it though, no major issues encountered yet, just the usual ArmA 2 ai driving and pathfinding skills that threaten to leave a boot print on my monitor.

i've found 99515 to be a pretty good Beta, if you are not already using them.

Share this post


Link to post
Share on other sites
I have finally gotten the connection working. However, I now get this error:

http://pastebin.com/kxqPiTHM

Any ideas?

Hey Holmes,

Pelase can you supply the Server RPT also.

Can you also check that there is an entry in the missions table for the mission.

When you first started this mission, did you see the Mission being saved ot the DB?

Are you waiting for it to fully initialize on the brieifing screen prior to continuing.

Cheers

Gunny

---------- Post added at 12:27 ---------- Previous post was at 12:25 ----------

Just wanted to post thanking the creators of this mission pack. I've been running it a few days now on a spare computer as a dedicated host, no PDB yet as I'm unfamiliar with SQL databases. Been having tons of fun with it though, no major issues encountered yet, just the usual ArmA 2 ai driving and pathfinding skills that threaten to leave a boot print on my monitor.

Hey,

Thanks for the feedback, if you want a hand in setting up PDB just give me a shout or join or Skype Channel.

Gunny

Share this post


Link to post
Share on other sites

Hi!

Holmes, it is pretty important to let MSO initilaize fully before clicking continue on the map/briefing screen. You can see the init-progress on map/MSO/Initialisation! Please wait until "completed" is displayed (can take some minutes). PDB is intended to run on a dedicated server, not as Host or in SP, just keep that in mind.

Tup logistics only work on a dedicated server (also local dedi works fine)! But Host and i think SP cant call in logistics (yet).

For the script lag (delay) issue: which mission from the 7zip did you use and did you leave default settings?

Share this post


Link to post
Share on other sites
Hey Holmes,

Pelase can you supply the Server RPT also.

Can you also check that there is an entry in the missions table for the mission.

When you first started this mission, did you see the Mission being saved ot the DB?

Are you waiting for it to fully initialize on the brieifing screen prior to continuing.

Cheers

Gunny

Server RPT: http://pastebin.com/0zCVg5s2

Arma2MySQL Log: http://pastebin.com/ShRcm09N

Arma2Net Log: http://pastebin.com/ca5aX4SW

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×