Jump to content
tophe

Tophe's Arma Dedicated Server Tool (TADST)

Recommended Posts

The server "FPS" refers to engine cycles - basically still a "frame", but without the rendering part.

As for the 3D_Performance value - it is not used. Even on the client it is only written, changing it has no effect. This question came up and was answered by Suma a looong time ago.

Apparently the server only requires it because the value is expected to exist. Setting it to 1 should be fine.

Share this post


Link to post
Share on other sites

Hi welcome back.

Really cant wait to see what ya can do with the great app.

If it wasent for you I would struggle to make a dedi server this tool is the best tool for ARMA ever.

Share this post


Link to post
Share on other sites

Thank you Algrab for bringing it up and thank you MadDogX for clearing it up!

Share this post


Link to post
Share on other sites

Quick update on what I'm working on at the moment...

The folder that gets created in the root of the disk is gone,

Expert settings are now up and running.

Drag and drop folder to mods.

Drag and drop ordering of missions and mods.

Live rtp monitoring

As I said, nothing huge, but small fixes. Stuff will be added to the list.

I have a great deal of bigger fixes and features to put in, that will take longer time do.

So I'll release these fixes first.

//Tophe

Share this post


Link to post
Share on other sites
Excellent mate. If you need someone to test, just ask. I use this CONSTANTLY!

Thx buddy, I'll keep that in mind! Might throw you a PM a few days before release.

Share this post


Link to post
Share on other sites

Hi again I did private message you but thought I would put it here to incase some one else can help

I want to be able to change the repoting IP in this tool from 127.0.0.1 to "<>" but every time I launce the tool it resets it back

I assume this is because its hard coded into the app.

Can I request a custom button where I can specify exactly what I want or does some one here know a work around all ready.

Here is the thread for whice I want to be able to do the above for

http://forums.bistudio.com/showthread.php?133268-Running-dedicated-server-and-2-clients-or-more-on-one-macine

Share this post


Link to post
Share on other sites

Hey.

Yeah, it's hard coded. The config files all get generated new when the server starts.

But I'll put a fix for your problem in the next release. It'l be out real soon, promise. I saw your PM and I might PM you with a semi finished version before release, just to let you try out if it solves your problem.

Thx for the feedback!

Share this post


Link to post
Share on other sites

Blimey Tophe thank you so so much I really appriciate you taking the time to actually add some thing I assume only I have asked for even though you have no obligation to do so.

TBH I am very very happy you have decided to though becasue with out your tool I am stuffed I have kinda managed to make a dedi server the hard way but its no way how I want it :( but with your tool its click click click DONE.

So bloody easy its amazing so yeah thanks very much.

Share this post


Link to post
Share on other sites
Blimey Tophe thank you so so much I really appriciate you taking the time to actually add some thing I assume only I have asked for even though you have no obligation to do so.

TBH I am very very happy you have decided to though becasue with out your tool I am stuffed I have kinda managed to make a dedi server the hard way but its no way how I want it :( but with your tool its click click click DONE.

So bloody easy its amazing so yeah thanks very much.

No problem. You have a PM now.

Share this post


Link to post
Share on other sites
When will you release the newer version?

I'm almost done with the bug fixes... I have a bit too much to do at the moment, but it'll be out real soon.

Share this post


Link to post
Share on other sites
I'm almost done with the bug fixes... I have a bit too much to do at the moment, but it'll be out real soon.

Good news, thanks :)

Share this post


Link to post
Share on other sites

Hi, im new with dedicated server thing but with this it looks so easy, great work but still i have some issues. When i launch TA2DST (i got all settings done correctly i think) with ACE mod i get warning "Addon ace_anims requires version 1.6 of application." then after that i get error "No entry 'bin\config.bin/CfgSurfaceCharacters.CRGrassWClutter'.".

I have latest ACE updates, steam ArmA2CO 1.60 with latest beta patch

EDIT: *Fixed*

Edited by matosinec

Share this post


Link to post
Share on other sites

Tophe - thank-you so much, this is genius!

Been having trouble setting up my dedi server,eventually got it all sorted (with the help of the community :cool: ) untill i started adding mods to the command lines of my various servers.

Only to find out that the command line length is limited, so could only add a couple of mods = no good to me!

Searched all morning on how to start them with .bat file to no avail?

Checked out this thread to find out if your tool (he he he -he said tool,lol sry) will run multiple servers,but found no info?

So in the end just thought fook it and gave it a go!

Low and behold, yes you can fire up as many servers as you want all with different settings etc :yay:

Once again thank-you for your efforts :icon_dj:

Share this post


Link to post
Share on other sites
Tophe - thank-you so much, this is genius!

Been having trouble setting up my dedi server,eventually got it all sorted (with the help of the community :cool: ) untill i started adding mods to the command lines of my various servers.

Only to find out that the command line length is limited, so could only add a couple of mods = no good to me!

Searched all morning on how to start them with .bat file to no avail?

Checked out this thread to find out if your tool (he he he -he said tool,lol sry) will run multiple servers,but found no info?

So in the end just thought fook it and gave it a go!

Low and behold, yes you can fire up as many servers as you want all with different settings etc :yay:

Once again thank-you for your efforts :icon_dj:

Thank you so much sir. Made my afternoon.

Just because of that I'm going to try and compile and release a little update tonight.

Share this post


Link to post
Share on other sites

there seems to be a new option in patch 1.60. and new default setting.

MinErrorToSend=<limit>;

Minimal error to send updates across network.

Using a smaller value can make units observed by binoculars or sniper rifle to move smoother.

Default: 0.001 (was 0.01 until ARMA 2:OA version 1.60, ARMA 2 version 1.11 uses 0.01)

MinErrorToSendNear=<limit>;

Minimal error to send updates across network for near units.

Using larger value can reduce traffic sent for near units. Used to control client to server traffic as well.

Introduced in ArmA 2 1.60, Default: 0.01

and a other stuff couple stuff

http://community.bistudio.com/wiki/basic.cfg

Share this post


Link to post
Share on other sites

Thx. Those are already added for the next version.

Share this post


Link to post
Share on other sites

Seeing the thread 'on top' i found the opportunity to personally Thank You for this awesome on-the-fly tool.

I would be happy to see the 'next version' coming up.

:)

Share this post


Link to post
Share on other sites

Hey...this is a great tool...thank you!

I also get some kind of message but it doesnt bother me (i just ignore it),because server run smooth when i need it.When first cheater come on the server,then usually something happend.Lag become unbearable or vehicles go in the air,....what kind of anti-cheat are other admins using?

I also like to use your respawn script-its easy and its working :)

Thank you!!!

Kind regards

Share this post


Link to post
Share on other sites

Just wanted to drop by and say thanks for this tool, it's a really convenient way to quickly set up a dedi server.

Share this post


Link to post
Share on other sites

I have been playing this game since Operation Flashpoint. This is the first time I have set up a dedi server. If it was not for your tool I would have never been able to do it. Thanks for all the hard work you put into this great tool.

Share this post


Link to post
Share on other sites

Great tool I've been using it for a long time now. I do however have a problem I'm running into. I'm trying to set up the server to launch Combined Operations + ACE + Isla Duala + Beta Patch properly without errors and it just doesn't want to work for me. Launching from "operation arrowhead\Expansion\beta\arma2oaserver.exe" with these mods:

@CBA;@CBA_A2;@CBA_OA;@ACE;@ACEX;@ACEX_RU;@ACEX_SM;@ACEX_USNavy;@brg_africa;@fallujah1_2;@ibr_dtowns;@ibr_plants;@isla_duala;BAF;PMC;Expansion\beta;Expansion\beta\Expansion;C:\Program Files (x86)\Steam\steamapps\common\arma 2

I get "No entry 'bin\config.bin/CfgInGamUI/MPTable.shadow'."

Edited by JuggernautOfWar

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×