Jump to content

Recommended Posts

On 1/31/2022 at 3:43 AM, Leopard20 said:

Update:
*  Fixed: Units disappearing from vehicles after save (due to a game bug, which didn't save those units into the file for some reason)

Finally it's been solved, thanks!

Share this post


Link to post
Share on other sites
2 hours ago, HBAOplus said:

Finally it's been solved, thanks!

BTW had you reported it before? I don't recall anyone telling me about this until a couple of days ago... 🤔

Anyway, if anyone knows of any more annoying bugs please let me know. I'll try to fix them this weekend.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/1/2022 at 6:22 PM, Leopard20 said:

BTW had you reported it before? I don't recall anyone telling me about this until a couple of days ago... 🤔

Anyway, if anyone knows of any more annoying bugs please let me know. I'll try to fix them this weekend.

Well, the AI units dispearing from vehicle seats after loading a saved progress bug happend several times on my end, I just can not figure it out which mod cause the problem. My mod preset is too long to do the check😂.

Share this post


Link to post
Share on other sites

Have there been any updates in development on the ai mod, as in anything major announced here as I’d rather not look through 22 pages of messages to find out, I’ve only seen the initial video for the project that’s why I’m asking 

Share this post


Link to post
Share on other sites
On 2/19/2022 at 11:05 PM, GYSGTTAYLOR said:

Have there been any updates in development on the ai mod, as in anything major announced here as I’d rather not look through 22 pages of messages to find out, I’ve only seen the initial video for the project that’s why I’m asking 

I have posted some development updates, but they're irrelevant now, since I have scrapped most of the old design decisions due to issues during testing (I have already revised many stuff during development)
Currently trying a new approach. If this fails to meet my requirements again then I'll have to cancel this project, because there's no better way left to do this anymore.
But so far everything is good.

Simply put, the biggest obstacle during the development has been performance issues. I used to make accuracy sacrifices in favor of performance and hope for the best, but those accuracy sacrifices have always caused problems here and there.

The primary performance bottleneck is SQF, Arma's scripting engine. It's the only way of "communicating" with the game, and it only runs on the main game thread, which already has so much to do. Previously everything in the mod was being done in SQF.

This time, I'm trying to make the mod as independent of SQF as I can. So I take all the information I need from the game and cache them in disk/memory (those cached to disk are "one time constant caches", such as terrain info, etc.), and use them in my own "engine", which runs on its own thread(s). So Arma will simply be in charge of "displaying" the results (AI movement, animation, shooting, etc.), while the heavy calculations (path finding, finding cover, group coordination, and other "AI brain" stuff) are being made elsewhere.
With this approach I won't have to make any compromises anymore, since Arma is running on its own thread and its performance will not be impacted as much as before.

Of course, this approach has its own challenges. So we have to wait and see how it'll turn out. But I have thought out almost everything, and I'm 90% certain that this time it'll be a success. And so far it has been going according to plan.

  • Like 9

Share this post


Link to post
Share on other sites

Really do hope that this new approach works out, am looking forward to your AI Overhaul for a while now, but if it does not work out, then I can only speak for myself and say it was a pity, but you tried as much as you can, and appreciated everything you have done regardless

  • Thanks 1

Share this post


Link to post
Share on other sites

I found an weird issue with Hunter Six mission. AIO Command Menu somehow messes with the team management. The mission includes an scripted UI to join/dismiss team members. So if you take some members with you and later dismiss them at the base and take some others with you instead, the dismissed members will be re-added to your squad as soon as you get into a fight. It's pretty annoying since you can only add or dismiss members at the base, and those who get re-added by AIO CM are actually standing at the base while you have enemy contact somewhere far away.

Share this post


Link to post
Share on other sites
2 hours ago, Godis_1 said:

I found an weird issue with Hunter Six mission. AIO Command Menu somehow messes with the team management. The mission includes an scripted UI to join/dismiss team members. So if you take some members with you and later dismiss them at the base and take some others with you instead, the dismissed members will be re-added to your squad as soon as you get into a fight. It's pretty annoying since you can only add or dismiss members at the base, and those who get re-added by AIO CM are actually standing at the base while you have enemy contact somewhere far away.

I guess you might've used a command where I store units into variables for later processing, such as follow my stance or fire on my shot?
If you apply those before dismissing units and then "undo" them after dismissing I think this can happen... I will take a quick look to see if my guess is correct.
Anyway I still need more details.

  • Like 2

Share this post


Link to post
Share on other sites
17 hours ago, Leopard20 said:

I guess you might've used a command where I store units into variables for later processing, such as follow my stance or fire on my shot?
If you apply those before dismissing units and then "undo" them after dismissing I think this can happen... I will take a quick look to see if my guess is correct.
Anyway I still need more details.

 

It's absolutely possible that I've used one or several of those commands. As of more details, I can only tell you that these units always were added back to my group as soon as I got into firefight (means, when my units enters combat mode). But I suppose you're right on your guess. That's pretty much what happened. I'm also using C2 btw. And because of this I actually never use the 'fire on my shot' function from AIO CM, but instead I use the one from C2. Also I always try to avoid giving similar orders by both mods. But just for testing I'm going to use now only AIO CM for all orders and C2 only for 3D HUD position commands.

 

EDIT: WAIT! I've done some more tests. What I did was to immediately take 4 members into my group right after mission start (new start from beginning). Then I dismissed them and took some other members into the group. And when I entered the AO with them and combat started, the exact same thing happened again. And this time I can say for sure that I did not apply any commands on them before dismissing.

Share this post


Link to post
Share on other sites
6 hours ago, Godis_1 said:

 

It's absolutely possible that I've used one or several of those commands. As of more details, I can only tell you that these units always were added back to my group as soon as I got into firefight (means, when my units enters combat mode). But I suppose you're right on your guess. That's pretty much what happened. I'm also using C2 btw. And because of this I actually never use the 'fire on my shot' function from AIO CM, but instead I use the one from C2. Also I always try to avoid giving similar orders by both mods. But just for testing I'm going to use now only AIO CM for all orders and C2 only for 3D HUD position commands.

 

EDIT: WAIT! I've done some more tests. What I did was to immediately take 4 members into my group right after mission start (new start from beginning). Then I dismissed them and took some other members into the group. And when I entered the AO with them and combat started, the exact same thing happened again. And this time I can say for sure that I did not apply any commands on them before dismissing.

Then I can safely say it's not related to my mod. There's nothing in my mod that would be triggered by this: (...I entered the AO with them and combat started...)
I don't think it's C2 either. But it sounds very much like it could be triggered by LAMB's danger.fsm or something similar (since that mod also "activates" when you enter combat). Or maybe it's a mission bug...

Also what I said before (using commands before and after dismissing) is no longer an issue. Seems like I've fixed that a long time ago with previous updates.

So I recommend that you try without any mods at first to make sure it's not a mission bug. Then only load my mod + CBA. If you still experience the issue let me know (I very much doubt there will be tho)

Share this post


Link to post
Share on other sites
14 hours ago, Leopard20 said:

Then I can safely say it's not related to my mod. There's nothing in my mod that would be triggered by this: (...I entered the AO with them and combat started...)
I don't think it's C2 either. But it sounds very much like it could be triggered by LAMB's danger.fsm or something similar (since that mod also "activates" when you enter combat). Or maybe it's a mission bug...

Also what I said before (using commands before and after dismissing) is no longer an issue. Seems like I've fixed that a long time ago with previous updates.

So I recommend that you try without any mods at first to make sure it's not a mission bug. Then only load my mod + CBA. If you still experience the issue let me know (I very much doubt there will be tho)

 

 Ok, that's really odd then. Because I'v played these missions very often with the same mods, and without this issue. It first originated when I added AIO CM. In fact I've noticed it first with Hunter Six mission, which I've started playing with the same old mod preset where I only added AIO CM then. But maybe my observation is wrong. I think it always happens when combat mode triggers. But it might be caused by something else though. 

And it also happens in Ghost Recon Altis Wildlands, which uses the very same AI management scripts, like Hunter Six. So this AI management UI might be somehow incompatible with AIO CM. At least this is the only thing that makes sense now.

Oh and btw, I don't use any AI mods like Lambs_Danger with these missions. But in other missions I do use them, also together with AIO CM - without any trouble.

 

Thank you for investigating.

Share this post


Link to post
Share on other sites

Hello, is there a way to queue multile waypoints for the AI squad in the 3D game environment (not map). As we know, the AI's pathfinding cpapbilties are not great and I prefer to micro manage the path for my AI. If it does not exist, would it be possibble to add this feature to the addon?

Thanks in advance

Share this post


Link to post
Share on other sites
2 hours ago, rainbow47 said:

Hello, is there a way to queue multile waypoints for the AI squad in the 3D game environment (not map).

Hi

The movement command is the same as vanilla, so no.
 

2 hours ago, rainbow47 said:

would it be possibble to add this feature to the addon?

I don't plan to add new features to this mod anymore, so I don't think so.

Share this post


Link to post
Share on other sites

Hi, I was wondering if the Super AI is still under development or if the project is abandoned by now?

Share this post


Link to post
Share on other sites
7 hours ago, rainbow47 said:

Hi, I was wondering if the Super AI is still under development or if the project is abandoned by now?

Hi. No, it's not abandoned. I explained what I'm doing rn in a few posts above.

If I ever abandon it I'll announce it here.

Share this post


Link to post
Share on other sites

Quick question, is there any medic logic integrrated in the mod? Eg. when I get kiloled/injured the squad AI tries to heal me? If yes, is there a way to permanently decativate it as it might have conflicts with some missions?

Share this post


Link to post
Share on other sites
11 minutes ago, rainbow47 said:

Quick question, is there any medic logic integrrated in the mod? Eg. when I get kiloled/injured the squad AI tries to heal me?

Disable Auto-Medic. It still remains active when you're unconscious.

Share this post


Link to post
Share on other sites
5 hours ago, Leopard20 said:

Disable Auto-Medic. It still remains active when you're unconscious.

When you say it still remains active when you are unconcious, does it mean you can't completely disable the integrated medic functions in AIO? I am playing the OPCOM mod and have the impression that there are some conflicts because OPCOM is using its own custom medic scripts.

Share this post


Link to post
Share on other sites
16 hours ago, rainbow47 said:

When you say it still remains active when you are unconcious, does it mean you can't completely disable the integrated medic functions in AIO? I am playing the OPCOM mod and have the impression that there are some conflicts because OPCOM is using its own custom medic scripts.

yes

Share this post


Link to post
Share on other sites

Got it, thank you Leopard.

 

On a different note, may I ask you which command/function you use to refresh the sqaud ( command under ROE )?

Share this post


Link to post
Share on other sites
49 minutes ago, rainbow47 said:

Got it, thank you Leopard.

 

On a different note, may I ask you which command/function you use to refresh the sqaud ( command under ROE )?

The function itself is AIO_fnc_setBehaviour, called as:

[arrayOfUnits, 5] call AIO_fnc_setBehavior


Most of what it does is related to the legacy version of the mod. It does the following:
1. Rejoins the AI into your squad (return to formation):

[_unit] joinSilent (group player);

2. reset combat mode to yellow
3. enable all AI features (not needed anymore)
4. removes the selected units from the "Fire on my lead" list.

I guess the only reason you might need it is to remove the units from the "Fire on my lead" list.

Share this post


Link to post
Share on other sites

Thanks Leopard.  I am trying to call the command form an .sqf. file (while AIO mod not loaded). The reason is that my units show the out of ammo alert on the group bar althugh they have enogh ammo. The Refresh fuction inAIO fixed that issue but for some reason joinSilent does not fix it for me. 

I am using this in my sqf file:

 

{
[_unit] joinSilent (group player);

 sleep 0.2;

}

 

Share this post


Link to post
Share on other sites
3 hours ago, rainbow47 said:

Thanks Leopard.  I am trying to call the command form an .sqf. file (while AIO mod not loaded). The reason is that my units show the out of ammo alert on the group bar althugh they have enogh ammo. The Refresh fuction inAIO fixed that issue but for some reason joinSilent does not fix it for me. 

I am using this in my sqf file:

 

{
[_unit] joinSilent (group player);

 sleep 0.2;

}

 

This doesn't work because you've wrapped it in a code {} which is not being executed. Also _unit is not defined. You can write it as:

{
	[_x] joinSilent group player;
} forEach (units player - [player])


Anyway, this is not the place for this. You can ask scripting related questions here or the #scripting channel in Arma Discord. Discord is preferred because communication is much faster there.

Share this post


Link to post
Share on other sites

Thank you Leopard, I got this working. I will also join the Discord server. 

Share this post


Link to post
Share on other sites

HI Leopard.

 

very cool mod. i admit i only made the switch from wwai to this today. Nostalgia i guess.

 

so far 99% of things work well. But the heal up command doesnt work. AI do the healing animation but the units hurt font get healed.

EDIT: APOLOGIES FOR THIS IT SEEMS I DIDNT EVEN HAVE A MEDIC IN THE GROUP,SEEMS NEEDED.

 

Also is there an issue with the revive? im not always revived by my AI nor do they always revive each other. In its current state i cant reliably use the revive but would love it if it was working 100%(sp revives most important sp mod out there imo) would be nice if it worked 100% of the time and if we had more options for it,but i didnt DL the mod for that,it was for the absolutely awesome pilot related stuff.

 

Literally its just not possible to be a gunner in a blackfish without your mod..the loiter clockwise/counter,elevation/distance etc(not to mention a sweet UI,Bravo),its all aces. 

 

Iv disabled most things like cheats/zues/medic etc. and im using a "scheduled' envoirnment as per your tool tip says better performance which leaves me wondering,in what situations could this mod negatively affect my FPS?

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×