Jump to content

Recommended Posts

Oh my god , why B01 not implemented this with new jets ? you are genius , Please, keep updating it guy, it is really useful, besides, I thought, it would be cool if there is a system like firewill with a plan of the plane to better realize or so kind 3 bots that spawn with a cart of ammunition to load the aircraft lol , its my dream :D 

Share this post


Link to post
Share on other sites

GOM..... I love you.... that is all ;-)

Seriously mate - really appreciate the the work you (and other modders) do for the game.

 

Share this post


Link to post
Share on other sites

Hi GOM and others

 

My community uses ASOR vehicle spawners in our ops, and were getting errors trying to get your script running alongside the  ASOR script 

 

14:51:10 Error in expression <ateDialog "ASORVS_Main_Dialog";
[] call ASORVS_fnc_CameraStart;
>
14:51:10   Error position: <ASORVS_fnc_CameraStart;
>
14:51:10   Error Undefined variable in expression: asorvs_fnc_camerastart

 

And then the server crashes...

 

ASOR VS script works fine if we remove the Dynamic Loudouts script. (which makes no sense to me if it was an error in ASOR with an undefined variable then how the hell does removing Dynamic Loadouts stop the error appearing)

This is our ASOR VS script if anyone wants to test it http://puu.sh/vWGHE/f55cac7913.zip

 

Anyone else having similar issues or can recommend another ingame vehicle spawner?

 

 

Share this post


Link to post
Share on other sites

@SnakeDocc try the fix I posted in the spoiler below:

 

9 hours ago, Jnr4817 said:

I am getting an error now.

 

It is telling me that I already have a class CfgFunctions, which I do have defined in the descrition.ext.

 

How can I get this to work if I already have this. It points me to your GOM_fnc_functions.hpp


Hey changes are in for 1.3 you can fix it for yourself by deleting everything in the GOM_fnc_functions.hpp and paste this into it:

Spoiler

 


class GOM
{
	class init
	{
		class aircraftLoadoutInit{file = "scripts\GOM\functions\GOM_fnc_aircraftLoadoutInit.sqf";preInit = 1;};
	};
};

This should be the only content of GOM_fnc_functions.hpp.

 

Then in the description.ext replace my former 3 lines with these:


class CfgFunctions
{

	#include "scripts\GOM\functions\GOM_fnc_functions.hpp"

};

#include "scripts\GOM\dialogs\GOM_dialog_parents.hpp"
#include "scripts\GOM\dialogs\GOM_dialog_controls.hpp"

And add all the other functions stuff inside the CfgFunctions brackets.

 

 

 

11 hours ago, gabberxxl said:

Very cool script, I absolutely love it!

I noticed a bug with the Wipeout, here are the steps to reproduce:

  • Clear all pylons
  • Mount 1 or 3 Macers on Pylon 5
  • No Macer weapon has been added to the pilot, so you are unable to fire any missiles
  • Same thing happens when you mount Macers x3 on all pylons

 

Couldn't really reproduce this. 3x macers on all pylons lets me fire 30 macers just fine.

Installing 1 macer on pylon 5:

 

Anything you did before that? Are you sure pylon control is set to Pilot? If you accidentally set it to gunner, saved it as a preset, then the pylon will always be controlled by the gunner, which the wipeout has none.

Probably need to add a check and default to pilot if the aircraft has no gunner to prevent mishaps.

 

Cheers

11 hours ago, ski2060 said:

So, I have been testing this out in editor.  With this and Firewill F16 / AWS running I ws able to access the AWS weapons.

Unfortunately the AWS weapons only seem to be available on select pylons for the A-164 Wipeout.  None of the other Vanilla Airframes seem to be able to utilize the AWS weapons at all.

Is this by design? Bug?  Or just not enabled yet?

Great work so far GOM!

Depends on how the pylon magazines are configured. Nothing I can do on my end, since I just read everything out of the config so it works with all proper configured mods.

 

Cheers

Share this post


Link to post
Share on other sites

Maybe I kicked the directions somewhere...I put the

[this] call GOM_fnc_addAircraftLoadout

on a huffer sitting on the flight deck...I'm able to load some preloads that I saved in your mission but For the life of me I can't load individual weapon pylons. I can select the weapon I want to stick in there but the "install weapon" button does not light up. Does it have to be on a Ammo Truck?

 

Share this post


Link to post
Share on other sites
26 minutes ago, Teuf said:

Maybe I kicked the directions somewhere...I put the


[this] call GOM_fnc_addAircraftLoadout

on a huffer sitting on the flight deck...I'm able to load some preloads that I saved in your mission but For the life of me I can't load individual weapon pylons. I can select the weapon I want to stick in there but the "install weapon" button does not light up. Does it have to be on a Ammo Truck?

 

You either need to adjust the first three parameters in the script to lift rearm, refuel and repair being tied to ammo, fuel and repair sources nearby.

Set all three to false if you want to work on your hearts content.

Gonna edit the first post to make it more clear.

 

Cheers

Share this post


Link to post
Share on other sites

Excellent, got it all working.

 

Love the work you have done.

 

Reed

  • Like 1

Share this post


Link to post
Share on other sites

Question, how would I able to carry this script into a respawned black wasp.

this addAction["<t color='#f9ff03'>Edit Payload</t>", {[vehicle player,"PILOT"] call GOM_fnc_addAircraftLoadout}, nil, 1.5, true, true, "", "true", 1, false, ""];

Meaning that, when the first aircraft is destroyed, the one that spawns after it does not inherit the script. how would i go about solving this problem?

Share this post


Link to post
Share on other sites
13 hours ago, Teuf said:

I can select the weapon I want to stick in there but the "install weapon" button does not light up. 

 

Same for me in demo  mission. install weapon" button does not light up. 

Share this post


Link to post
Share on other sites
10 hours ago, Ryan807 said:

Question, how would I able to carry this script into a respawned black wasp.


this addAction["<t color='#f9ff03'>Edit Payload</t>", {[vehicle player,"PILOT"] call GOM_fnc_addAircraftLoadout}, nil, 1.5, true, true, "", "true", 1, false, ""];

Meaning that, when the first aircraft is destroyed, the one that spawns after it does not inherit the script. how would i go about solving this problem?

 

Are you using a Vehicle Respawn Module that is a part of 3DEN? If so, the Expression field will copy over into the respawned vehicle's init section.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Ryan807 said:

 


this addAction["<t color='#f9ff03'>Edit Payload</t>", {[vehicle player,"PILOT"] call GOM_fnc_addAircraftLoadout}, nil, 1.5, true, true, "", "true", 1, false, ""];

 

 

Hey Grumpy,

I tried to set all up with the above line and I wonder how somebody else could get your script work. It seems that I am not expierienced enough for it.

 

First I ve problems with this Line of GOM_fnc_aircraftLoadoutInit.sqf:

if (_pilot isEqualTo "PILOT" AND isPlayer driver _obj) exitWith {_add = [_obj,"PILOT"] call GOM_fnc_AircraftLoadout};

it throwed this error:

10:10:44 Error in expression <r isEqualTo driver _obj) exitWith {_add = [_obj,"PILOT"] call GOM_fnc_AircraftLo>
10:10:44   Error position: <= [_obj,"PILOT"] call GOM_fnc_AircraftLo>
10:10:44   Error Allgemeiner Fehler in Ausdruck
10:10:44 File scripts\GOM\functions\GOM_fnc_aircraftLoadoutInit.sqf [GOM_fnc_aircraftLoadoutInit], line 56

I fixed it with this line:

if (_pilot isEqualTo "PILOT" AND isPlayer driver _obj) exitWith {[_obj,"PILOT"] call GOM_fnc_AircraftLoadout};

but now if get in the wipout and select the action menu entry your dialog opens and I can mark the wipeout for payload editing but there is not a single pylon on the list of pylons and so I cant edit anything.

 

I ve no clue what I did wrong. I ve included your hpp's in description.ext and added the action entry to the init line of the wipeout as shown in Ryan807's post.

Any help is very appreciated...

 

Cheers

Share this post


Link to post
Share on other sites
11 hours ago, Ryan807 said:

Question, how would I able to carry this script into a respawned black wasp.


this addAction["<t color='#f9ff03'>Edit Payload</t>", {[vehicle player,"PILOT"] call GOM_fnc_addAircraftLoadout}, nil, 1.5, true, true, "", "true", 1, false, ""];

Meaning that, when the first aircraft is destroyed, the one that spawns after it does not inherit the script. how would i go about solving this problem?

Vehicles usually don't respawn.

If you're using a respawn script or module check the documentation of that.

 

11 hours ago, sammael said:

Same for me in demo  mission. install weapon" button does not light up. 

As of 1.2 you need to have a fuel/ammo or repair source near the vehicle in order to be able to repair/refuel or rearm it.

It's all in the first post.

 

@sarogahtyp this error will be gone in 1.3, some functions still had no default return value, that was causing it.

Pylons should show up after selecting the aircraft in the first list, make sure there's an ammo truck/crate nearby or adjust one of the first parameters to disable the ammo/repair/refuel dependency.

 

The info text after starting the dialog already tells you which services are available. Will adjust this in 1.3 to make things a bit clearer.

 

Cheers

 

Share this post


Link to post
Share on other sites

First I used the older version from armaholic and the pylons did not show up even if I set the ammo truck variables to false.
Then I downloaded version 1.2 from your link and yes I forgot to set those variables to false. I ll test it. Thx for ur reply

sent from mobile using Tapatalk

Share this post


Link to post
Share on other sites

What vehicels is valid for rearming, refuling and reparing?
 

i get this when trying to refule frome a hemit fueltruck

fuel.png

 

 

Share this post


Link to post
Share on other sites
28 minutes ago, loopdk said:

What vehicels is valid for rearming, refuling and reparing?
 

i get this when trying to refule frome a hemit fueltruck

 

 

 

Every vehicle that has transportammo, transportrepair or transportfuel in the config higher than 0.

Please give some more details how the problem occurs, since's it's working fine for me no matter which vehicle I add it to, as long as there are vehicles with fuel/repair/ammo within 50m of the vehicle holding the action.

 

Cheers

Share this post


Link to post
Share on other sites

I got a hemit fuel and hemit ammo car thing....

 

Less than 50 meters froem plan

11.png

 

21.png

3.png

 

If i change the paremeters in the script to false i just get a "not valid vehecil"

Share this post


Link to post
Share on other sites

Ah no, I found it! Embarassing!

I forgot to add checks which parameters have been chosen in the respective repair/refuel and rearm functions, hotfix incoming.

 

Cheers

  • Like 2

Share this post


Link to post
Share on other sites

Don't forget to adjust the first three parameters in GOM_fnc_aircraftLoadoutInit.sqf to false. :yay:

 

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×