Jump to content
ALiVEmod

ALiVE - Advanced Light Infantry Virtual Environment 1.0 (GA)

Recommended Posts

Ok how do i setup the local database thyngy? i just svitch it in the data module and ALIVE will do it automaticaly or should i first setup anything? I dont know some text file and call it database or something? Or some 3rd party software is needed? 

Share this post


Link to post
Share on other sites
On 14. 2. 2018 at 8:07 AM, yxman said:

hmm still not sure.  "Place the ALiVE Data module and set the Database Source to Cloud or Local as required. ..... Local persistence does not require a War Room account." 

"In server.cfg include persistent=1;" 

 

That i understand, but is it all? Dont i need to do anything else? Instal inidb on the server perhaps? have a special folder for the persistence database? the page does not say.

 

 

Share this post


Link to post
Share on other sites

You don't need anything else for the DB. The local option uses in built Arma 3 functionality to store the data - no external DB required.

  • Thanks 1

Share this post


Link to post
Share on other sites

Another problem set:

 

 AI spawns as expected, but is mostly static and does not react to being fired upon, it used to react well, AI used to run trying to flank us etc, reinforcements were comming, but now it behaves like static targets unless player gets close. i do not remember changing dificuly or AI settings, only thing we changed is the dedi server machine, we got newer and more powerfull one and we stopped to use TADST and we are using new webbased tool to control our server.

 

Share this post


Link to post
Share on other sites
7 hours ago, Mirek said:

Another problem set:

 

 AI spawns as expected, but is mostly static and does not react to being fired upon, it used to react well, AI used to run trying to flank us etc, reinforcements were comming, but now it behaves like static targets unless player gets close. i do not remember changing dificuly or AI settings, only thing we changed is the dedi server machine, we got newer and more powerfull one and we stopped to use TADST and we are using new webbased tool to control our server.

 

ALiVE doesn’t handle low level AI behavior. If groups are spawned it has nothing to do with ALiVE. Try without any AI mods or another AI mod that isn’t the one you’re using.

 

If you’re using a headless client also try without.

 

If you aren’t using any of these things, and can see this in an ALiVE and CBA only mission, please post the mission here and list the repro steps.

Share this post


Link to post
Share on other sites

Unfortunately our modlist is a bit on the larger side, so no repro. Ill try to play with AI settings.

 

Share this post


Link to post
Share on other sites

"My favorite faction is incompatible with ALiVE, can I fix this with the Orbat Creator?

1.Yes! You can create a faction override for all or part of the faction, which includes groups compatible with ALiVE.

2.In the Faction Editor, check the group tree to see if the ALiVE Detecteron™ has detected any incompatible groups.

3.Open any incompatible groups in the Group Editor and change their details so they are categorised correctly.

4.If no groups exist in a category, you can build a new group using existing units from the list on the left.

5.When you are satisfied that the group tree in the Faction Editor is looking good, go to the Group Editor and Generate Config code. This code can either be pasted into the description.ext of your mission or packed as a pbo to run as an addon override."

 

My question is how to export to description.ext? What exatly to paste, because there is: faction, units, groups, full faction, full faction to file and Cfg patches to export? I already tried to paste every of this "clipboards" to des.ext, go to my placement units modules and try every possibble combination. (used generated className of faction from ORBAT creator) but without succes.

Second question is what to put in txt from whom I will make .pbo? (i will try this alternative way). 

Thanks in advance

 

*Putting this on hold for now (founded some useful text on aliveWiki)

Share this post


Link to post
Share on other sites

I am getting a slight issue with the persistence:

 

Whenever we we load in, our backpacks are on the ground. Upon equipping them, they end up glitching the character. 

 

Also 2 side issues:

 

1. CFG Weapon no entry appears when we load back in after a persistent save.

2. No entry config error about turret rotation with Orbat created faction. 

Share this post


Link to post
Share on other sites
12 hours ago, acoustic said:

I am getting a slight issue with the persistence:

 

Whenever we we load in, our backpacks are on the ground. Upon equipping them, they end up glitching the character. 

 

Also 2 side issues:

 

1. CFG Weapon no entry appears when we load back in after a persistent save.

2. No entry config error about turret rotation with Orbat created faction. 

 

Check this thread on ALiVE forums it has some suggestions

 

http://alivemod.com/forum/1849-respawning

 

 

Share this post


Link to post
Share on other sites
12 hours ago, acoustic said:

I am getting a slight issue with the persistence:

 

Whenever we we load in, our backpacks are on the ground. Upon equipping them, they end up glitching the character. 

 

Also 2 side issues:

 

1. CFG Weapon no entry appears when we load back in after a persistent save.

2. No entry config error about turret rotation with Orbat created faction. 

Hey can you reproduce this backpack on ground thing when loading a persistent save with just ALiVE and CBA? I’m thinking you might because I’ve seen this too.

 

EDIT: I’ve seen that cfg weapons error too. Can you reproduce that with just ALiVE and CBA as well?

Share this post


Link to post
Share on other sites
On 2/25/2018 at 12:45 PM, Nemanjic said:

"My favorite faction is incompatible with ALiVE, can I fix this with the Orbat Creator?

1.Yes! You can create a faction override for all or part of the faction, which includes groups compatible with ALiVE.

2.In the Faction Editor, check the group tree to see if the ALiVE Detecteron™ has detected any incompatible groups.

3.Open any incompatible groups in the Group Editor and change their details so they are categorised correctly.

4.If no groups exist in a category, you can build a new group using existing units from the list on the left.

5.When you are satisfied that the group tree in the Faction Editor is looking good, go to the Group Editor and Generate Config code. This code can either be pasted into the description.ext of your mission or packed as a pbo to run as an addon override."

 

My question is how to export to description.ext? What exatly to paste, because there is: faction, units, groups, full faction, full faction to file and Cfg patches to export? I already tried to paste every of this "clipboards" to des.ext, go to my placement units modules and try every possibble combination. (used generated className of faction from ORBAT creator) but without succes.

Second question is what to put in txt from whom I will make .pbo? (i will try this alternative way). 

Thanks in advance

 

*Putting this on hold for now (founded some useful text on aliveWiki)

 

You have to use Notepad; I use Notepad++ to build the factions; in order to have an area to paste the information into. If you watch this VIDEO from SpyderBlack you will get the gist of what to do and how to make it function as a new unit faction. It is extremely easy to do and really helps keep it from overwhelming you when you see all these exportable functions in the ORBAT creator.

Share this post


Link to post
Share on other sites
On 4/5/2018 at 9:57 AM, HeroesandvillainsOS said:

Hey can you reproduce this backpack on ground thing when loading a persistent save with just ALiVE and CBA? I’m thinking you might because I’ve seen this too.

 

EDIT: I’ve seen that cfg weapons error too. Can you reproduce that with just ALiVE and CBA as well?

 

I have never seen it with just ALiVE and CBA; it is always with TFAR but it has been a while since I messed with the TFAR aspect and I have a mission where it finally got beaten into submission so I am not sure how I made it go away.

Share this post


Link to post
Share on other sites
4 hours ago, VarsityHavoc said:

Is there a way for persistence to apply to the T.R.A.C.E System?

Not by default with any way included within ALiVE, no. Obviously with Arma anything is possible I guess if you can code, but I can’t recall of any time anyone did this even on their own.

Share this post


Link to post
Share on other sites

Hey, I’m not sure if this is the right thread but I encountered a following problem

 

I played around with AliVE yesterday after some time ago, I’ve set up the bins key for alive menu and added the default “laserdesignator” to load out, when I run the game and try to open it I only hear the distinc opening sound but the menu doesn’t appear. Tried to bind it to action 20 but it didn’t help.

 

runned the game with Lythium and RHS, and than runned vanilla, the problem

persist.

 

anyone with similar experience ?

 

sorry on the beforehand if this is the wrong thread I’ve posted it on.

Share this post


Link to post
Share on other sites

Makr sure the classname laserdesignator corresponds to the Sand color designator and not the green one .... thats all I can think of.

Share this post


Link to post
Share on other sites
8 hours ago, another123 said:

Hey, I’m not sure if this is the right thread but I encountered a following problem

 

I played around with AliVE yesterday after some time ago, I’ve set up the bins key for alive menu and added the default “laserdesignator” to load out, when I run the game and try to open it I only hear the distinc opening sound but the menu doesn’t appear. Tried to bind it to action 20 but it didn’t help.

 

runned the game with Lythium and RHS, and than runned vanilla, the problem

persist.

 

anyone with similar experience ?

 

sorry on the beforehand if this is the wrong thread I’ve posted it on.

The classname is LaserDesignator. Not sure if capitals matter but probably.

 

If that’s not the issue, you’ve probably rebound the ALiVE menu key (default is app menu key). If so, pick a new key and set it (I use the “home” key), then fully close Arma. Open it again and it should stick.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×