Jump to content

Recommended Posts

35 minutes ago, EO said:

 

Could you elaborate on "vehicles" ^^

Hand placed?...static wrecks that are part of the map?...wrecks spawned by the Vehicle module?  Certainly hand placed vehicles will have first aid kits in their inventory.

 

Without getting into editing Ravage scripts, have you tried increasing the loot spawn probabilities in the Loot System module?

 

I have added a list of vehicles that's I want to spawn on the map, at the moment those vehicles spawn with first aid kits. If possible I would like them to spawn with a mix of random items but can't find where to change the list. 

 

The loot spawn system doesn't seem to want to work for me unfortunately. I have never been able to get the option to loot furniture or wrecks to pop up.

As I am trying to use it with exile, would it be possible that the exile loot system is cancelling out the ravage loot system? 

Share this post


Link to post
Share on other sites

@sniperb: iirc, yeah, Exile can be the problem : it probably requires you to whitelist functions so they can run in MP.

  • Like 2

Share this post


Link to post
Share on other sites
9 minutes ago, haleks said:

@sniperb: iirc, yeah, Exile can be the problem : it probably requires you to whitelist functions so they can run in MP.

Okay thanks for the reply. I will try a few things to see if I can get it working as it's a really cool feature.

Share this post


Link to post
Share on other sites

@sniperb If you want random loot in the damaged or intact vehicles spawned by your custom vehicle array, you might get it done faster with an external script. Luckily, @George Floros has you covered here - just head over to his script collection thread and you will find all you need!

 

 

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

I just tested an older Ravage mission of mine that was last updated in May this year, meaning that the Ravage version used to make the mission with was version 176. Let me tell you, playing that mission felt like a completely different experience than playing one of my latest Ravage missions, using the latest version of Ravage. The older mission actually feels and plays better than the newer ones that I have. In the older mission, the AI units all spawn with gear from the gear pool, there are both hostile and friendly car patrols, there are gunshots in the distance making the game world feel alive, and there's plenty of zombies everywhere. It was exactly how I remember Ravage. On the other hand, in the newer Ravage missions I have, there are no car patrols, there's barely any gunshots in the distance and zombies feel few and far between. The world just feels empty and lifeless. That's why I was curious if the spawn systems and whatnot have changed since version 176, because Ravage feels like a much different experience now. I don't know at this point if something is wrong with my missions, or if some things have changed within Ravage. Just my two cents, and again, I don't mean to sound demanding or annoying, I'm just not sure what's going on.

  • Like 1

Share this post


Link to post
Share on other sites

@ArteyFlow: No problem mate, I'm still working on tweaks to the gearpool module and trying to find out what could be causing the problems you're having. I'm working a tad slow under this damn heat. ^^'

 

can you send me your mission.sqm file? (Or paste its content in spoilers)

The spawn systems haven't changed with the recent updates, most changes were related to the gearpool module and zombie damage handling - nothing that should impact mission design that way.

But obviously, the issue you're having with the gear pool is a game breaker and makes it hard to tell if there are other problems at hand here.

Having a mission file which does produce the issue would help me pinpoint the cause, and eventually what else is going on.

  • Like 2

Share this post


Link to post
Share on other sites
17 hours ago, haleks said:

@sniperb: iirc, yeah, Exile can be the problem : it probably requires you to whitelist functions so they can run in MP.

Tried this:

Spoiler

class CfgRemoteExec
{
    class Functions
    {
        mode = 1;
        jip = 0;
        class ExileServer_system_network_dispatchIncomingMessage { allowedTargets=2; };    // ExileMod
        class rvg_fnc_zed_spawn { allowedTargets=2; };
        class rvg_fnc_init_loot { allowedTargets=0; };
        class rvg_fnc_groupLootSearch { allowedTargets=0; };
        class rvg_fnc_lootCleanUp { allowedTargets=0; };
    };
    class Commands
    {
        mode=0;
        jip=0;
    };
};

Didnt work though, im sure I did something wrong 😛

Share this post


Link to post
Share on other sites
11 hours ago, haleks said:

 I'm working a tad slow under this damn heat.

 

Keep cool buddy, from what I read it's supposed to be even hotter there today. We had a record high here in Scotland yesterday and some real post apocalyptic thunderstorms early hours of this morning. 

  • Like 4

Share this post


Link to post
Share on other sites

Is there blacklisted areas for AI ? I Have one set for zombies but cant find one for the Ai groups

  • Like 1

Share this post


Link to post
Share on other sites

So I would like to randomly place things in buildings, not unlike the ambient furniture system in Ravage. I am trying to get all available positions within a building and then pick a random position from that array.

 

_randomElement = selectRandom [buildingpos -1];
this setPosATL ((nearestBuilding this) buildingPos _randomElement);

 

The above doesn't work. I am not a script wizzard, obviously. Please help.

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, miasdad said:

Not necessarily *blacklist*but called a safe zone(Ravage has a module for it). Look here

https://ravage.fandom.com/wiki/Creating_a_safe_zone

Thanks miasdad,

So I just place that module through the editor and it will work off the bat? Are the scripts for entering and leaving the safe-zone necessary if I dont want to have protection from damage?  

Share this post


Link to post
Share on other sites
3 minutes ago, sniperb said:

Thanks miasdad,

So I just place that module through the editor and it will work off the bat? Are the scripts for entering and leaving the safe-zone necessary if I dont want to have protection from damage?  

Yep & nope😉

  • Thanks 1

Share this post


Link to post
Share on other sites

Making a mission atm and the "Zombie Horde Placement" module seems to be removing crates (and probably other empty entities} I've placed inside the radius. Is there a way to not have my individual items disappear? My intent is to put zombies in military uniforms at military bases while having military items to loot there...but currently I can't have both.

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, haleks said:

@ArteyFlow: No problem mate, I'm still working on tweaks to the gearpool module and trying to find out what could be causing the problems you're having. I'm working a tad slow under this damn heat. ^^'

 

can you send me your mission.sqm file? (Or paste its content in spoilers)

The spawn systems haven't changed with the recent updates, most changes were related to the gearpool module and zombie damage handling - nothing that should impact mission design that way.

But obviously, the issue you're having with the gear pool is a game breaker and makes it hard to tell if there are other problems at hand here.

Having a mission file which does produce the issue would help me pinpoint the cause, and eventually what else is going on.

I'm sorry Haleks, I don't mean to keep bothering you about this. I originally wasn't going to post what I posted because I knew you were already busy working on things, but I decided to bite the bullet and go with it.

 

Thank you so much for clarifying everything, and sorry again for bothering you. I just didn't know if something was wrong with my missions and whatnot. I'll go ahead and send you the mission.sqm file, for whenever you have a chance to take a look at it. Thanks again, dude.

  • Like 2

Share this post


Link to post
Share on other sites
25 minutes ago, Recaldy (DayZ) said:

Making a mission atm and the "Zombie Horde Placement" module seems to be removing crates (and probably other empty entities} I've placed inside the radius. Is there a way to not have my individual items disappear? My intent is to put zombies in military uniforms at military bases while having military items to loot there...but currently I can't have both.

Have you tried turning off the "Garbage Collection" feature in the "Settings" module? That could be what's removing the crates.

  • Like 1

Share this post


Link to post
Share on other sites

I cant get the safezones to work. I have set it so that it deletes the Ai and zombies but they can still can walk past the set radius and hit players.

Share this post


Link to post
Share on other sites
16 minutes ago, sniperb said:

I cant get the safezones to work. I have set it so that it deletes the Ai and zombies but they can still can walk past the set radius and hit players.

Are the zones equal to the spawn radius of said offenders?

Share this post


Link to post
Share on other sites
19 minutes ago, miasdad said:

Are the zones equal to the spawn radius of said offenders?

Never mind..just tried it myself and didn't hold..got over run.Sorry,man.

Share this post


Link to post
Share on other sites

I have the radius set to 500m to test but zombies and AI just walk past it no problem. The issue I had last night was on of my players was getting hit in a safezone by a zombie and his gun was duped. 🤔

  • Like 1

Share this post


Link to post
Share on other sites

Hey @haleks, your Contact mod is A LOT better than the official Contact DLC!!! 

 

 

😂👏

 

Can you imagine a whole team was working on this for over 2 years??? No wonders DayZ development has stopped...

 

At this pace Arma 4 will be released in 2026 sadly...

  • Haha 3
  • Confused 2

Share this post


Link to post
Share on other sites
14 hours ago, sniperb said:

I have the radius set to 500m to test but zombies and AI just walk past it no problem. The issue I had last night was on of my players was getting hit in a safezone by a zombie and his gun was duped. 🤔

TBH it's been awhile since I've run the zombie & safe zone mods.Last cpl years I've taken on a somewhat *nomadic* role with just renegades,drones(drones being the hunter)...never settling down.always on the move.

  • Like 1

Share this post


Link to post
Share on other sites

@LSValmont The video is a product of someone who hasn't followed the development of Contact DLC over the last few months. A whole bunch of Contact assets have custom scripted features that are tied to the SP campaign, whereas in the Editor they are purely cosmetic. 

 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, EO said:

@LSValmont The video is a product of someone who hasn't followed the development of Contact DLC over the last few months. A whole bunch of Contact assets have custom scripted features that are tied to the SP campaign, whereas in the Editor they are purely cosmetic. 

 

 

Yeah but the amount of alien content, scripted or not, is incredibly small considering the whole DLC is "Alien" themed.

 

My whole point was that the Aliens got like 4 different vehicles/drones and that's it, and 2 of them are the size of a watermelon. There are also giant roots that are just decorative assets.

 

Compared to the already existing and free modding content found on the workshop alone this 2 years old DLC looks amateurish in my book. Worth perhaps 10/15 $$ and not the 25.

 

Just imagine what would Haleks be able to accomplish with a team of 5 other devs, 2 years and 100K in budget! I can assure you it would be 10 times the size of this.

 

In fact for the GM third party DLC, two modders did a whole lot more than the entire Contact DLC team, and that was with no budget and on their free time!

  • Like 1

Share this post


Link to post
Share on other sites

I'm not the only one that has the main menu shortcuts messed up from Ravage? Ie, no Single Player/Editor/Multiplayer shortcut buttons anymore? Just narrowed it down to Ravage being the cause.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×