Jump to content
.kju

All in Arma Terrain Pack (AiA TP) - A1/A2/OA terrains from BI in A3

Recommended Posts

Maps other than Sahrani and Takistan work fine. I know atleast Altis and Zargabad works fine.

I don't knwo what you play, but maybe posting a repro mission where the CTD happens after 5 min. would be a better starting point for someone here to help you out.

EDIT: Also, if you could quick-port your Sahrani missions to SMD Sahrani, and see what happens, that would give more data to troubleshoot the problem.

Share this post


Link to post
Share on other sites

I also got 2-3 CTDs on sahrani in coop with my friend,

It happened like, randomly in the mission, I couldnt pinpoint a specific thing but it defintley seemed to be from the map, like once we moved a mile or so in some direction it just happened, and this wasnt some mission running 3000 scripts so yeah im pretty sure it was the map.

I assume you would want logs but you gotta tell me how to find them etc I really have never even used them

(and i dont even know if coop logs)

But if possible, I can recreate the CTD and send you whaetever relevant info you need

Edit: No problems on takistan for me

Also my CTD happened twice in a row, during the same 10 minute time span in the same rough area of the map, but not the same "direction" ie: from my knowledge of arma and etc, it didnt seem to be some one object or something rendering in the distance causing this, but I cant be sure

Share this post


Link to post
Share on other sites
The last patch introduced several new CTDs, but they happens all across the board - A3 and A2 maps. You might be chasing a ghost here.

Is that something you experienced yourself? Because, to my surprise, things have improved on my end; the only crashes I had this week were happening when switching maps in editor mode with AiA maps - wich is a known problem.

Share this post


Link to post
Share on other sites

Hey, I think I can share quite a bit of information on this Sahrani crashing issue.

First off, I play small highly modded coop with one to nine other people. Sahrani is a past time of ours. We have a dedi server that was using A3MP and MP_AP for awhile with SMD_Sahrani running.

I made three missions on SMD Sahrani, as part of a small campaign. Never had an issue with them. When we switched to AiA TP, I merely went into the mission.sqm and replaced the map names so the mission would load up properly. In the editor, there was no difference between AiA Sahrani and SMD. All objects were placed properly. Testing in the editor revealed no issues.

Went to play the first mission in the series with one other friend, "No message received" after about two minutes. Figured it was just the server being ArmA, so we restarted it. Same problem.

I hypothesized it had something to do with my porting of the mission, so instead I just copied and pasted everything over in the editor and then all of the scripts. Same issue.

Then, I figured it might be the mission itself. I gave up on Sahrani for awhile, ported Domination around to Chernarus, Zargabad, and Bornholm, and then figured I'd give it a try ported over to Sahrani.

Again, crash after spawning in.

My community uses a ridiculous 133 mods. However, only mods required by missions are run on the server. Due to the logistics of the server, all of the .pbos are in a single folder (I know, not very professional, but it works), so it would take some time to find all of the mods running on the server. Here is the PlaywithSIX collection all clients were using: https://play.withsix.com/arma-3/collections/8qm3ZuwBJEC624BubGjcaw/Highly-Modded-ArmA-3

Here are the addons used in the first 'campaign' mission:

"A3_Characters_F_BLUFOR",

"a3_characters_f",

"ARMSCor_A109",

"caf_ag_faction_eeur_r",

"A3_Modules_F_Intel",

"sfp_btr60",

"HAFM_UAZ",

"A3_Modules_F_Effects",

"A3_Structures_F_Mil_Helipads",

"aia_sara_config"

And in the domination:

"A3_Modules_F",

"A3_Characters_F_BLUFOR",

"a3_characters_f",

"rav_lifter_a3",

"tog_jtac",

"Cha_LAV25",

"rhsusf_c_m113",

"A3_Structures_F_Mil_Helipads",

"A3_Soft_F_Gamma_Quadbike",

"a3_soft_f_quadbike",

"A3_Air_F_Beta_Heli_Transport_02",

"A3_Air_F_Beta_Heli_Attack_02",

"A3_Armor_F_Panther",

"A3_armor_f_beta_APC_Tracked_02",

"A3_Armor_F_Marid",

"A3_Armor_F_AMV",

"A3_Air_F_Heli_Light_01",

"A3_Air_F_Heli_Light_02",

"lkr_762x51_NATO",

"a3_weapons_f_ammoboxes",

"aia_misc_e_config",

"HAFM_ArmA2_Helis",

"us_helo_hmds_kimi",

"A3_Structures_F_System",

"A3_Data_F",

"a3_roads_f",

"Cha_AV8B",

"hafm_air",

"A3_Weapons_F_EPA_Ammoboxes",

"bwi_a3_su25",

"DAR_HMMWV",

"RHS_US_A2Port_Armor",

"A3_Soft_F_Gamma_HEMTT",

"A3_Structures_F_Mil_TentHangar",

"aia_sara_config"

Here are the three 'campaign' missions (not sure if uploading the domi would piss someone off, not going to test it) in a .rar:

Surprisingly, it is actually quite rare that our server has issues. In the last week it has run five AO sets of domination on Bornholm, Chernarus, and Zargabad, as well as two hour plays of insurgency. Fifty FPS is the norm. Our server is hosted by Nitrado, in either Frankfurt or Hamburg, I forget, and they're not willing to give me the specs :mad:.

If you need any additional data it will be forthcoming. Server .rpts will be available later this evening. I will also try a mission with just a single player on the map and nothing more.

Additional data Tinter suggests could be of use:

Server crashes more quickly on domination. First campaign mission, "HVT," allows the player to swim out of the water and arm up (about three minutes) before a crash. Domination lets you take two steps.

Share this post


Link to post
Share on other sites
Is that something you experienced yourself?

Yes of course. A3 never crashed on me before, I don't know why, must be luck. Then right after the patch one CTD while I was watching the Huron from 3rd person flying over Altis in a rainy extraction, just when I was noticing the new cool camera shake effect. Then the day after my cousing CTD while doing nothing during a MP session. That's it for now on my end, but remember those are the first two CTDs we had since the game came out.

Share this post


Link to post
Share on other sites

This is what we get from the rpt regarding the Sahrani crash

23:21:10 Game started.
Error: EntityAI SubSkeleton index was not initialized properly (repeated 0x in the last 60sec)
name: Land_Dum_mesto3, shape: ca\buildings\dum_mesto3.p3d, index: -1, matrices: 13
Segmentation fault (core dumped)

Share this post


Link to post
Share on other sites
Yes of course. A3 never crashed on me before, I don't know why, must be luck. Then right after the patch one CTD while I was watching the Huron from 3rd person flying over Altis in a rainy extraction, just when I was noticing the new cool camera shake effect. Then the day after my cousing CTD while doing nothing during a MP session. That's it for now on my end, but remember those are the first two CTDs we had since the game came out.

I'll never understand Arma... It is pretty much the opposite for me! ^^'

But I shouldn't speak too soon, I didn't play that much for the past two weeks - we'll see.

---------- Post added at 00:31 ---------- Previous post was at 00:28 ----------

This is what we get from the rpt regarding the Sahrani crash

23:21:10 Game started.
Error: EntityAI SubSkeleton index was not initialized properly (repeated 0x in the last 60sec)
name: Land_Dum_mesto3, shape: ca\buildings\dum_mesto3.p3d, index: -1, matrices: 13
Segmentation fault (core dumped)

Yep, this appears in the last lines in Tinter's RPT - I'd say at least one building class is causing the issue on that map.

Share this post


Link to post
Share on other sites

Ok so I managed to make a mission that crashes. It's just one blufor rifleman as the player and then an amount of RHS units, I don't know how many but here's a pic from the editor http://i.imgur.com/GT5MzDg.png . Playing this mission on a dedicated server will cause it to crash after around 5 minutes. Replacing all the RHS units with vanilla CSAT, will not crash within 5 minutes, if at all. RHS is unlikely to be the issue. Even if not tested thoroughly other mission not using RHS has crashed the server before.

Another .rpt from a crash shows this error.

23:53:10 Game started.

23:53:10 Warning: Destruction of beb34200# 279789: dum_istan3_hromada2.p3d owned by a static object (beb34200# 279789: dum_istan3_hromada2.p3

d)

Segmentation fault (core dumped)

Share this post


Link to post
Share on other sites

Here is the full .rpt from my dedi server crashing while playing my HVT.Sara mission "Corazol Ball" on Sahrani.

Additionally, some notes I took.

The mission was selected immediately after restarting the server. I was the only person on the server. 269 MB RAM in use after restart. 274 MB RAM in use after selecting mission. 502 MB RAM in use on the briefing screen. 522 MB RAM in use after spawning in, by myself. Spawned in at 18:46:04. Crashed at 18:46:32 by my eyes though the .rpt was last edited by the server at 18:46:26. #monitor 1 still reports 522 MB RAM in use at time of crash. Lost connection with host 90 seconds after the crash, as usual. Tried searching for the .rpt entries submitted by Tinter and cuel. Nowhere do they occur in the log.

Share this post


Link to post
Share on other sites

I don't see Clafghan on the list? Is there a way to use Clafghan with AiA TP?

Share this post


Link to post
Share on other sites
Here is the full .rpt from my dedi server crashing while playing my HVT.Sara mission "Corazol Ball" on Sahrani.

Additionally, some notes I took.

The mission was selected immediately after restarting the server. I was the only person on the server. 269 MB RAM in use after restart. 274 MB RAM in use after selecting mission. 502 MB RAM in use on the briefing screen. 522 MB RAM in use after spawning in, by myself. Spawned in at 18:46:04. Crashed at 18:46:32 by my eyes though the .rpt was last edited by the server at 18:46:26. #monitor 1 still reports 522 MB RAM in use at time of crash. Lost connection with host 90 seconds after the crash, as usual. Tried searching for the .rpt entries submitted by Tinter and cuel. Nowhere do they occur in the log.

Are you running Swedish Forces Pack on the server? It seems that 'sfp_grgreturnround' is causing your server to bug out.

Share this post


Link to post
Share on other sites

could we all somehow write a list with mods that are known to make problems with aia? i think that would help a lot of people (myself included).

we also cannot start our servers with aia in our modset (we don't use the swedish forces pack).

i will try around with our servers today and maybe i can add another mod to that list then...

Share this post


Link to post
Share on other sites
Are you running Swedish Forces Pack on the server? It seems that 'sfp_grgreturnround' is causing your server to bug out.

Our server doesn't run with the Swedish Forces Pack and still crashes, so it cannot be the sole cause.

Share this post


Link to post
Share on other sites
You can put the home of DaiZ Standalone?

Not gonna happen : that's illegal.

If you own the SA though, it is possible to load the map in Arma3 (for you own usage only!).

Share this post


Link to post
Share on other sites
Playing this mission on a dedicated server will cause it to crash after around 5 minutes. Replacing all the RHS units with vanilla CSAT, will not crash within 5 minutes, if at all. RHS is unlikely to be the issue. Even if not tested thoroughly other mission not using RHS has crashed the server before.

It funny, if I was you, after those results, I would be reporting the problem to the RHS guys, see how receptive they are :). Truth is, if you use RHS units and the game crashes, and you take them out and the game runs well, I don't know how you could say it the map. They are no cathalist to reveal map problems.

Share this post


Link to post
Share on other sites

Well since we're a lot if people crashing is doubt it's RHS since we had crashes before on Sahrani before rhs was even released

Share this post


Link to post
Share on other sites
It funny, if I was you, after those results, I would be reporting the problem to the RHS guys, see how receptive they are :). Truth is, if you use RHS units and the game crashes, and you take them out and the game runs well, I don't know how you could say it the map. They are no cathalist to reveal map problems.

As I said, there has been crashes when not using RHS.

Share this post


Link to post
Share on other sites

The crashes seem to occur when a certain number of modded things are on the map for a certain duration, it does not seem to be specific to any particular mod, so that is why we come here. It seems more modded things on the map decreases time before crash. Tinter has experienced these crashes with only RHS in use, I have experienced these crashes when RHS is not in use, but instead HAFM UAZ and SFP, both of which Tinter was not using. To me it appears that AiA's version of Sahrani is highly unstable when playing with other mods.

It is also worth noting that when missions that crash on Sahrani are ported to other maps, they do not crash, at least in my case.

Edited by ColonelHartigan

Share this post


Link to post
Share on other sites
As I said, there has been crashes when not using RHS.

Can you produce a repro mission of one of those?

Share this post


Link to post
Share on other sites
Just curious, as the only 'bug' I have with this great mod is the LOD/ground texture bug with the arma 1 maps where the terrain within a 50m radius of you is 'good' quality, and beyond that you can see a clear line where it turns into a very low quality blurry mesh.

Now I know that this issue was acknowledged a month ago or so, but is there any update on it? I remember a comment saying that it's the way ArmA 1 maps render it anyway, but isn't there a work-around. The bug does not exist with SMD_Sahrani (for instance), for ArmA 2 (and when you port it to arma 3, neither).

Just wondering, as it's the only thing bothering me, don't have any other complaints :P

Kind regards,

Sanchez

Please don't give up trying to fix this ^^

Share this post


Link to post
Share on other sites

I'm supporting AiA in all my upcoming A2 island conversions. Be sure to grab it, it's a great addon!

Share this post


Link to post
Share on other sites

Finally got around to DL this pack in place of A3MP. New to Arma, so I never had the chance to play with too many other Maps. This is great!

Except Sahrani, Crash! ...Are those Sahrani maps just not ready yet, or can we still play them if objects are kept low? Tried with ALiVE and as

soon as I get close to the island, it locks up the game in both SP and MP. Bummer. Anyway, just stopping by here quick to see if everyone else

was having the same issue. Keep up the great work. Love the maps!!

Share this post


Link to post
Share on other sites
Finally got around to DL this pack in place of A3MP. New to Arma, so I never had the chance to play with too many other Maps. This is great!

Except Sahrani, Crash! ...Are those Sahrani maps just not ready yet, or can we still play them if objects are kept low? Tried with ALiVE and as

soon as I get close to the island, it locks up the game in both SP and MP. Bummer. Anyway, just stopping by here quick to see if everyone else

was having the same issue. Keep up the great work. Love the maps!!

Yes several people (check this and previous page). Trying to find the issue.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×