Jump to content

Recommended Posts

Hey im been trying to make my BMR Insurgency mod save on my server im not sure how. I use TADST for the dedicated server and have Inidbi and im not sure how to make it work. May someone please help me

I'm sorry, this is not a supported  feature of this mission

 

@jigsor

 

Hi, great news and thanks for Napf island (and other ones ;) ), dont hesitate to post a beta, friends and me can test mission one by one on a dedicated server  ;)

Check front page link to new build.

 

Thanks for the Alpha maps Jigsor!

Awesome work :)

Although, is anyone else getting a constant freeze for a quick second every 5 seconds or so during game?

i only get this on the zargabad map with the alpha update, . i also got the same issue on kunduz on the previous release.

i think other players were fine, at least they never mentioned anything to me, could it be something that's only effecting the host (me) ??

like i say all other maps are fine if i host a LAN just for myself, and online is fine with other players, it only seems to be Kunduz and Zargabad i get this issue.

Any ideas?

Thanks.

And keep up the good work, its much appreciated :)

This is a known problem of Kunduz. i beleive its a problem with the terrain itself as rpt show related errors when this occurs. Zargabad has and is running smooth for me. Try the new updated version.

 

Hello, love the mod. I only play on servers with your mission.. however I am trying to use BMR insurgency on my own private server for my friends and I. Whenever i load the mission the Virtual Arsenal and Halo jump works for me, but it does not work for any of the players. for example they go up to the flag pole and there are no options at all. The same applies to the Ammo Box. I do not know how to fix this and i do not know anything about SQF files or how to "MAKE" a SQF.

These problems happen with and without mods (TRYK, CBA, RHS, CUP)

On a side note when one of my friend enters the server she falls through the ground and into water and is not able to re spawn.

Reaver62 Could you provide .rpt error logs and mission version or link to file with trouble?

Share this post


Link to post
Share on other sites

v1.45alpha updated again. Includes minor tweaks, added helicopter ear plugs and fixed some CUP classnames and added Napf Winter version

Link on first page.

Share this post


Link to post
Share on other sites

v1.45alpha updated again. Includes minor tweaks, added helicopter ear plugs and fixed some CUP classnames and added Napf Winter version

Link on first page.

Thank you once again for the updates, and taking the time to reply.

 

Share this post


Link to post
Share on other sites

@tomrattler, I think your suggestion assumes this line is a typo containing "_" at the end. _namespaceId = "BIS_stackedEventHandlers_"; Its not a typo. by commenting that line that bit of code it still runs at mission start but becomes ineffective at searching for running stacked EHs.

I recommend to remove the whole block instead of just that line, but I have just found the Key IDs for Enhanced movement and TFAR and added them to White list.

This block should not be a problem any more for users of those mods. Just now added in version 1.45alpha. Could use feedback.

The purpose of this block is to prevent one possible method of hacking and also removes HUDs/GUIs still running from players that come from life servers and such.

This type of hack can be done without addon/mod. Its funny that the Stacked Event Handlers stickied thread created by devs containing my post on discovery of this exploit has been deleted in the Mission Editing and Scripting forum with no replies. Its very likely to still be a major exploit issue.

 

Hi jigsor.

Thanks for your replay.

I had download the new mission from your dopbox and try the Altis map with following mods on our server:

@CBA_A3;@ace;@BWA3;@BWA3_comp_ace;@task_force_radio;@Ares;@sthud_a3

The major point is TFAR. At the mission start, while camera flight the TFAR flight works, TFAR seems running for a moment(connecting sound) but a few seconds the TFAR disconnect sound appears and TFAR isnt working anymore.

I tried to activate the whitelist at file ASORVS\config.sqf Line 20: ASORVS_Whitelist ["ItemRadio"];

Nothing happens.

 

The other maps not checked. Anyone the same problem?

Share this post


Link to post
Share on other sites

Good day, i have training to understand this mission so i can play it at Iraq map but no luck..I know jigsor has not been on for some days now and i wondering why i cant get this to work, have any of you got any id to place this mission to a new map. I'm getting a error when i start the mission-

scripts\unattenden_mainteance.sqf

error undifinding varible in  expression: airfiel_opt

well i will properly just wait to he can take a look at it, but been trying this sins the map come out for 4 days go.

http://www.armaholic...ge.php?id=30960
This is the mission if someone want to take a look at it.
http://tbf.me/a/BdEuvh

 

;)

Share this post


Link to post
Share on other sites

Hi jigsor.

Thanks for your replay.

I had download the new mission from your dopbox and try the Altis map with following mods on our server:

@CBA_A3;@ace;@BWA3;@BWA3_comp_ace;@task_force_radio;@Ares;@sthud_a3

The major point is TFAR. At the mission start, while camera flight the TFAR flight works, TFAR seems running for a moment(connecting sound) but a few seconds the TFAR disconnect sound appears and TFAR isnt working anymore.

I tried to activate the whitelist at file ASORVS\config.sqf Line 20: ASORVS_Whitelist ["ItemRadio"];

Nothing happens.

 

The other maps not checked. Anyone the same problem?

@tomrattler, Thanks for the feedback. After trying several unsuccessful resolutions I think 'll just go with having the stacked event handler remover bypassed for those running TFAR.

 

Good day, i have training to understand this mission so i can play it at Iraq map but no luck..I know jigsor has not been on for some days now and i wondering why i cant get this to work, have any of you got any id to place this mission to a new map. I'm getting a error when i start the mission-

scripts\unattenden_mainteance.sqf

error undifinding varible in  expression: airfiel_opt

well i will properly just wait to he can take a look at it, but been trying this sins the map come out for 4 days go.

http://www.armaholic...ge.php?id=30960

This is the mission if someone want to take a look at it.

http://tbf.me/a/BdEuvh

 

;)

Hold tight CptDeZusa, I already have a Diyala version ported. Just need to tidy some things on it.

  • Like 1

Share this post


Link to post
Share on other sites

Napf summer and Diyala map versions added.

Link to alpha on first page.

  • Like 1

Share this post


Link to post
Share on other sites

Napf summer and Diyala map versions added.

Link to alpha on first page.

i, have tried your mission in Diyala map and it's very good. Thanks for your fast respond and hard work, I'm hoping to start a public server using your mission on the Iraqi map soon, it's so goddamn beautiful and looking forward to play on it. And looking for your update on the BMR insurgency. Good morning :)

  • Like 1

Share this post


Link to post
Share on other sites

Hello, good day. So i figured out that i was eager to play this mission on the Diyala province Iraq map, i rented a server.

 

Server Name: Infinity V Servers Diyala |=IVS=||NEED DIYALA MAP|[steam for Mods]

Server IP: 108.61.120.68:2302

 

Hope you will enjoy this mission as much as i do. I haw change the location to Miami for better server connection.

  • Like 2

Share this post


Link to post
Share on other sites

Napf Server 

 

Server Name: Willkommen im Dreck | BMR Insurgency - @CUP Cor @Napf @rhs_afrf

Server IP: 178.32.49.181:2302

 

 

Free Addon´s

 

@TFAR + @CBA

@BC-Phoenix

@Arma Enhanced Movement

  • Like 3

Share this post


Link to post
Share on other sites

@Jigsor

 

Thanks for the update v1.45alpha! We enjoy your mission alot, great work!  I see you are supporting CUP's Takistan army and Militia. I have CUP mods launched but for whatever reason is doesn't change the enemy.

 

I saw in the INIT that you have this

 

case 6: // CUP - Takistan Army and Takistan Militia
    {
        if ((isClass(configFile >> "cfgPatches" >> "CUP_Creatures_Military_Taki")) &&
        {(isClass(configFile >> "cfgPatches" >> "asdg_jointrails")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_Creatures_People_Military_DummyInfantrySet")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_WheeledVehicles_LR")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_WheeledVehicles_UAZ")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_WheeledVehicles_Ural")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_WheeledVehicles_BRDM2")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_WheeledVehicles_BTR60")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_TrackedVehicles_M113")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_TrackedVehicles_T55")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_TrackedVehicles_T72")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_TrackedVehicles_ZSU23")) &&
        (isClass(configFile >> "cfgPatches" >> "cup_watervehicles_rhib")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_AirVehicles_Su25")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_AirVehicles_Mi8")) &&
        (isClass(configFile >> "cfgPatches" >> "CUP_AirVehicles_Mi24"))}) then {
            activateAddons ["asdg_jointrails","asdg_jointmuzzles","CUP_Creatures_Military_Taki","CUP_Creatures_People_Military_DummyInfantrySet","CUP_WheeledVehicles_LR","CUP_WheeledVehicles_UAZ","CUP_WheeledVehicles_Ural","CUP_WheeledVehicles_BRDM2","CUP_WheeledVehicles_BTR60","CUP_TrackedVehicles_M113","CUP_TrackedVehicles_T55","CUP_TrackedVehicles_T72","CUP_TrackedVehicles_ZSU23","cup_watervehicles_rhib","CUP_AirVehicles_Su25","CUP_AirVehicles_Mi8","CUP_AirVehicles_Mi24"];
            [EAST,7,8]execVM "eos\OpenMe.sqf";
        }else{INS_mod_missing = true;};

 

I tried adding asdg_jointrails since it seems like its required but that doesnt work either. Am i missing something?

 

Looking thru my rpt I did see this error:

12:01:46 Conflicting addon asdg_jointrails in 'asdg_jointrails\', previous definition in 'x\cba\addons\jr\'
12:01:46 Conflicting addon asdg_jointmuzzles in 'asdg_jointrails\', previous definition in 'x\cba\addons\jr\'

 

Any help you can provide with be appreciated.

 

Thanks

Aztec

Share this post


Link to post
Share on other sites

Thanks for the servers guys!

@aztec_ghost,

Its working here. Make sure you are running the latest 1.45 alpha build 5/11/16.
Are EOS grid zones actually activating? If so, are you seeing the wrong faction when it activates?
I don't fully understand the problem so maybe this helps.
Requirements for some Islands -
    @cup_terrains_core
        Version 1.0.1 (02.01.2015)
    @cup_terrains_maps
        Version 1.0.1 (02.01.2016)

Requirements for CUP Takistan Army and Takistan Militia -
    In Lobby Parameters page at mission start Under "Opposing Army/Mod Initialization" select
    "CUP Takistan Army and Takistan Militia - Requirements :: @CBA_A3;@cup_units;@cup_weapons;@cup_vehicles"

    @CUP Units
        Version 1.3.1 (17|Apr|2016)
    @CUP Weapons
        Version 1.6 (13|Apr|2016)
    @CUP Vehicles
        Version 1.3 (16|Apr|2016)

Any other cup mods are obsolete. It is recommended by cup to delete any existing cup mods prior to installing these listed above.
asd joint rails/asd joint muzzles have been officially merged into CBA_A3 since many months. Do not run both or else duplicate conflict can possibly occur as per .rpt

  • Like 2

Share this post


Link to post
Share on other sites

@Jigsor

 

I am running 1.45 on Diyala map. I have CUP Units, Weapons and Vehicles, CBA and ACE. Zones are activating but I'm seeing default Arma 3 OPFOR units and not Taki Army or Militia. All Mods are current.

 

Any ideas?

Share this post


Link to post
Share on other sites

You must select opposing faction/ mod combination in lobby parameters to activate those factions and mods. The default choice is CSAT/ no mods. In no case will selecting an opposing faction other than CSAT ever spawn CSAT.
Once mission is started verify lobby settings viewable in Map - Log - Parameters.

Share this post


Link to post
Share on other sites

I run a on dedicated server but found the hpp file to change paramaters. Thank you I figured it out.

One more question:

How would I accelerate time? I would like faster day and night cycles.

Appreciate your help and responses!

Share this post


Link to post
Share on other sites

Ok great. I see you figured it out but I'll post this anyway.

I too experienced this the other day after launching a new mission build for the first time on dedicated.
After loging in as admin then reloading the mission with #missions command I could change parameters.
But first I recommend adding this parameter to your server launch startup:
-loadMissionToMemory

You should now be able change parameter. If still you cannot change parameters. You can edit the defaults in BMR_Insurgency_v1_45alpha.DYA\Hpp\Parameters.hpp

    class INS_enemy_army//11
    {
    title = "        Opposing Army/Mod Initialization";
    values[]={1,2,3,4,5,6,7,8,9,10,11};
    texts[]={
    "CSAT - Requirements :: None",
    "AAF - Requirements :: None",
    "Africian Rebel Army and Armed African Civilian Rebel supporters - Requirements :: @african_conflict;@nato_russian_sf_weapons",
    "CAF Aggressors - Requirements :: @caf_ag1.5",
    "Islamic State of Takistan/Sahrani and Afghan Militia - Requirements :: @rhs_afrf3;@rhs_usf3;@leights_opfor",
    "CUP Takistan Army and Takistan Militia - Requirements :: @CBA_A3;@cup_units;@cup_weapons;@cup_vehicles",
    "Taliban and Islamic State - Requirements :: @mec;@cup;@asdg_jr;@rds;@rds_tank;@cha_mi24",
    "Hamas and Hezbollah - Requirements :: @mec;@cup;@asdg_jr;@rds;@rds_tank;@cha_mi24",
    "Sud Russians - Requirements :: @evw;@rds",
    "RHS Armed Forces of the Russian Federation - Requirements :: @rhs_afrf3",
    "Syrian Arab Army and Islamic State - Requirements :: @iraqi_syrian_conflict;@cup_weapons;@mas_nato_rus_sf_veh;@rhs_afrf3;@rhs_usf3"};
    default = 1;
    };

Change

default = 1;

to

default = 6;

For Time acceleration,
Under "Weather" lobby parameter options,
the only weather option supporting this by mission is
"Dynamic Real Weather Enabled"
It is hard set to 2.6 times normal speed.
To change you must edit script variable BMR_Insurgency_v1_45alpha.DYA\scripts\real_weather.sqf

_timeratio = 2.6;//Jig

Share this post


Link to post
Share on other sites

Hi, how to skip time as admin ? I am in the game and want to jump time to morning.

Share this post


Link to post
Share on other sites

Hi, how to skip time as admin ? I am in the game and want to jump time to morning.

There is a time of day parameter in lobby. The first one i beleive.

  • Like 1

Share this post


Link to post
Share on other sites

Good morning, yes that i know but i had a doubt that i am wondering, can you change the time while playing and you have players on the server. I was in one of the BMR maps at altis then the time change, an it say 3 hours later. am i right about this ? How do i do that.

Share this post


Link to post
Share on other sites

Good morning, yes that i know but i had a doubt that i am wondering, can you change the time while playing and you have players on the server. I was in one of the BMR maps at altis then the time change, an it say 3 hours later. am i right about this ? How do i do that.

Zeus has a skip time function, that's probably what it was.....

  • Like 1

Share this post


Link to post
Share on other sites

Getting this Spammed in Chat when using this mission;

 


!!!! WARNING ONEACHFRAME POSSIBLY REASSIGNED !!!! IT APPEARS THAT A ADDON OR MISSION HAS POSSIBLY FAILED TO CORRECTLY USE THE BIS STACKED EVENT HANDLER FUNCTIONS FOR ONEACHFRAME!

 

using the 1.45alpha version of the mission.

 

EDIT:

So I found out it seems to be caused when using the ACRE2 Mod, Its actually ACRE2 Spamming this for incorrect use of something or other.

Edited by nohalfmeasures

Share this post


Link to post
Share on other sites

Hi, how to skip time as admin ? I am in the game and want to jump time to morning.

 

You can change the time directly in the game.

Open debug console, write the command skiptime 2 and click on global execute button for 2 hours plus (for example). or similar -2 for 2 hours back.

 

@dreadpirate

How do that works ?

 

Jigsor.

Something you can integrate to your mission ?

like only admin has the options.

 

 

I create a Zeus game master module into the mission and put #adminlogged at owner and change the forced interface to disable.

Login as admin and you can use Zeus.

  • Like 2

Share this post


Link to post
Share on other sites

You can change the time directly in the game.

Open debug console, write the command skiptime 2 and click on global execute button for 2 hours plus (for example). or similar -2 for 2 hours back.

 

 

I create a Zeus game master module into the mission and put #adminlogged at owner and change the forced interface to disable.

Login as admin and you can use Zeus.

Hi, Good day. I will take a look at this..what do you mean about change the forced interface to disable ?  Thank you.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×