Jump to content
major_shepard

LEA - Loadout Editor for ArmA 3

Recommended Posts

Hi, first of all: i want to say this is a wonderfull addon! but I have some problems:

1- I manually added all the weapons from Arma 2 in LEA, but weapons G36 and Carabine XM8 are missing, these only 2 are missing, ¿what could be the problem?

2- I've created a SP mission in ARMA 3 editor with one team of 5 soldiers, and then save it and in LEA editor added the units loadouts: I can add the weapon, helmet and uniform without problems and works fine in-game, but when I tried to add some vest (any), the units in-game appears with is default outfit and weapon (loadout from arma 3 vanilla), not with my LEA loadout edition. ¿solutions?

Thanks

Share this post


Link to post
Share on other sites

Thanks for sending us the new release :cool:

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites
Hi, first of all: i want to say this is a wonderfull addon! but I have some problems:

1- I manually added all the weapons from Arma 2 in LEA, but weapons G36 and Carabine XM8 are missing, these only 2 are missing, ¿what could be the problem?

2- I've created a SP mission in ARMA 3 editor with one team of 5 soldiers, and then save it and in LEA editor added the units loadouts: I can add the weapon, helmet and uniform without problems and works fine in-game, but when I tried to add some vest (any), the units in-game appears with is default outfit and weapon (loadout from arma 3 vanilla), not with my LEA loadout edition. ¿solutions?

Thanks

Do you run your game with the showScript error option? If you use ArmA 2 weapons it means you load an addon with ArmA 3 for that. So could you make tests without addon in a mission an ArmA 3 only stuff?

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
Do you run your game with the showScript error option? If you use ArmA 2 weapons it means you load an addon with ArmA 3 for that. So could you make tests without addon in a mission an ArmA 3 only stuff?

In LEA Editor, all weapons of arma 2 that I added manually appears with no problem, also in game shows all and work fine (ex: Ak 107, Bison, Saiga,etc) but only weapons carbine xm8 and G36 rifle doesn't appears in LEA editor. I've tried reinstalling the weapons from arma 2, but keep not showing.

I run Arma 3 with the Arma 2 addon active.

Share this post


Link to post
Share on other sites

Would like to add that 9mm pistols are compatible with the 30rnd 9mm magazines from PDWs in game. Not sure if you want to reflect this in LEA, but just thought I'd let you know. Thanks for the great work!

Share this post


Link to post
Share on other sites
Would like to add that 9mm pistols are compatible with the 30rnd 9mm magazines from PDWs in game. Not sure if you want to reflect this in LEA, but just thought I'd let you know. Thanks for the great work!

Thanks, I change it ;)

Share this post


Link to post
Share on other sites
Can someone please help I have done all the steps but in game there is no action menu that pops up when I scroll down?

Are you running your game with CBA & LEA?

Do you have a folder named LEA in your userconfig one?

Share this post


Link to post
Share on other sites
Are you running your game with CBA & LEA?

Do you have a folder named LEA in your userconfig one?

Yep I have Initialised the profile aswell.

Share this post


Link to post
Share on other sites

I really missed LEA when I made the move to A3, thanks for making it happen.

Cheers!

Share this post


Link to post
Share on other sites

hi is there a script i can include in my mission that prevents people from using LEA, im making a survival based game where you have to loot gear and weapons and if people can use lea on the mission it will be giving them an unfair advantage....

Please help :)

many thanks

Raven

Share this post


Link to post
Share on other sites
hi is there a script i can include in my mission that prevents people from using LEA...

From the LEA read-me:

Misson makers

-------------

To desable the posibility to use @LEA in your mission, adds the ligne "enable_lea_addon = false;" into the init.sqf file.

Share this post


Link to post
Share on other sites

Hey guys! This is my first time using LEA and it looks ery promising! Im having an issue (and dont really know how) with adding weapons/equipment from other addons? I see all the vanilla arma 3 stuff in the list but none of the custom stuff. How would I add this stuff? Also whenever I try and connect to the repository it says "failed to connect to the respostiroy". I also have turn off windows firewall and added an exception in my norton

Thanks for your help!

EDIT: Nm for soemr eason it works now, but I was wondering with the extracted and analysed files, do we need to keep the analyzed files and the original mod? im just wondering because it would essentially double the modpack size, also I read that the loadout option whould go away after 5 minutes or when you leave the spawn area but mine is sticking around no matter how much itme passes or where I go?

Edited by Opendome

Share this post


Link to post
Share on other sites

You can delete the "analyse folder" once you have checked that eveything works fine.

For the "Apply loadout" as it says in the Wiki: In case of multiplayer game, player can change their loadout as long as he stay 100 meters around his spawning location. The is no restriction for singleplayer game or in ArmA 3 Editor.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

I found a singleplayer A3 bug that also affects LEA in a minor way.

If "briefing = 1;" is set in the description.ext, addUniform does not work properly from any scripts (even init.sqf) called before the briefing. This causes units affected to be in their underwear upon mission start.

This means that LEA generated loadouts that alter uniforms don't work if you have show briefing enabled. As a temp fix you can make a !isMultiplayer condition trigger in the editor that adds the uniforms to the units or set "briefing = 0;" (or remove the line altogether).

This doesn't affect multiplayer (surprisingly).

Vote up here.

Share this post


Link to post
Share on other sites
I found a singleplayer A3 bug that also affects LEA in a minor way.

If "briefing = 1;" is set in the description.ext, addUniform does not work properly from any scripts (even init.sqf) called before the briefing. This causes units affected to be in their underwear upon mission start.

This means that LEA generated loadouts that alter uniforms don't work if you have show briefing enabled. As a temp fix you can make a !isMultiplayer condition trigger in the editor that adds the uniforms to the units or set "briefing = 0;" (or remove the line altogether).

This doesn't affect multiplayer (surprisingly).

Vote up here.

Another weird bug from ArmA 3 that won't get fixed ? :rolleyes:

There is no use to add "Briefing = 1;" into description.ext since Briefing is enabled by default.

---------- Post added at 07:10 PM ---------- Previous post was at 07:09 PM ----------

"x39_earplug" is missing in the xMedsys from the repository

ok thnaks

Share this post


Link to post
Share on other sites
Another weird bug from ArmA 3 that won't get fixed ? :rolleyes:

There is no use to add "Briefing = 1;" into description.ext since Briefing is enabled by default.

You're correct, I simply hadn't noticed as I always assumed briefing was disabled for SP by default. In that case addUniform doesn't work with preloaded scripts in SP period. But if you disable the briefing with "briefing=0;" addUniform does function as expected.

Share this post


Link to post
Share on other sites

Wow! reported some hours ago and already fixed the missing earplugs :)

However i found more missing things from "xMedsys" repository

"x39_medikit" is there

"x39_medikit2" is missing

"x39_medikit3" is missing

"x39_medikit4" is missing

"x39_medikit5" is missing

They add x39_medikits with different application times, so they are quite important. I'm very sorry to annoy you with this :/ <3 This is a great tool btw! i love it.

Share this post


Link to post
Share on other sites

Need to update EricJ. The L85A2 has been added and the L85 AG36 is pending. Being in a british milsim group we are sick and tired of Kiory's rail-less L85. Its great, but it's gotten old

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×