Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Furniture spawning is really hard to perfect on certain types of buildings (especially takistani buildings). It works flawlessly on Arma 3 building's but some takistani maps can really suffer because they have so many house positions that are outside of the actual building. There might be a way highhead can improve this but I have my doubts as it would probably be very time consuming and resource intensive.

Share this post


Link to post
Share on other sites
I've been playing around with the new Asymmetrical behaviour for the AI commander, but one thing I have noticed when using All In ArmA is that Recruitment HQ's are often blocked off one way or another by the furniture spawning. Sometimes the building itself might be completely be sealed off with furniture in the doorways or I'm able to enter the building but a staircase or room might be blocked by furniture, meaning I have to move it out of the way to get inside.

It's a small thing to move it out the way, I just wondered if anyone else has this experience when using the Asymmetrical AI Commander with AiA?

Hey mate!

I agree totally! But believe me, either this or "nothing"! I dont expect an Insurgents force to build an IED factory in the outside, where you simple can spot it from the next hill! This wont happen in reality. So I took the sour pill to find a way to spawn "dynamic" furniture inside of buildings. And thats really a hard job without compromising performance. If you come a across a "blocked" entry, simply use the ALiVE logistics (ALiVE menu -> Player logistics -> enable actions) and move it away :).

Of course im working on getting it more perfect, but its just not as simple as it "looks".

I hope this helps

Share this post


Link to post
Share on other sites

Not sure where this came from but without changing anything, my server is crashing upon a player joining. It does not register the player as joining and it crashes. It generates no .rpt and no alive logs.

I know Kocrachon (page 562) had this issue a little bit ago - ("And I should mention, Im not getting an error. It just sort of sits and hangs at the loading screen, that the server never seems to recognize that anyone is joining.")

but I don't see any followup on this from him.

Server was working just two days ago and now this. It seems to work just fine without @Aliveserver running but I can't find a reason for that.

Edit: Posted on alive forums, probably a better spot for this

Edited by SpyderBlack723

Share this post


Link to post
Share on other sites

I'm building an OCCUPATION vs ASYMMETRIC campaign where my players are 3rd party augments.

I have the following custom objectives for my OCCUPATION force:

2 x 500 point

8 x 400 point

15 x 300 point

10 x 200 point

10 x 100 point

In addition to this I have the MIL_CIV working on N'Ziwasogo. Towns vary from ZERO value to like 75 or 100.

My ASYMMETRIC force has:

3 x 500 point

6 x 300 point

These are my "home areas"

Questions:

My OCCUPATION force pool is 10000 for reinforcements. However I've found that my starting forces are large and attempt to occupy towns in far flung corners which I don't want. I think I'm going to cut these current standing forces by about half. Will my occupation force start receiving reinforcements if they're force level is too low for the areas they occupy point wise? So like they hold X number of objectives and require Y per OPCOM to be 100% strength but are only at Z force level well below Y. Does the logistics module start sending troops from the 10000 force pool to get the objectives up to Y and keep replenishing up the Y level, or does it only keep replenishing up to the Z level?

Basically I'm trying to simulate the start of an insurgency where the insurgents have almost free reign across the empty parts of the map and the occupation AI spends the initial stages mobilizing and reinforcing its controlled areas.

As for my ASYMMETRIC force, I have 3 x HQs, but the insurgency is always starting in the same place. The only HQ that seems to be detailing any tasks is the far southeast HQ while the southwest and far north HQ just sort of sit there. I have done a 6 hour run of one build and many many many areas were infiltrated by the asymmetric AI, but I would like to have the insurgency start in the north rather than the southeast. How can I change this? I still want to have an HQ or at least a large force in the southeast. Should I just delete or turn off the HQ function in the southeast and only have one in the north? Or does it not matter? OPCOM is detecting the objectives it wants it just so happens they're the same ones all the time to start?

Share this post


Link to post
Share on other sites
Hey mate!

I agree totally! But believe me, either this or "nothing"! I dont expect an Insurgents force to build an IED factory in the outside, where you simple can spot it from the next hill! This wont happen in reality. So I took the sour pill to find a way to spawn "dynamic" furniture inside of buildings. And thats really a hard job without compromising performance. If you come a across a "blocked" entry, simply use the ALiVE logistics (ALiVE menu -> Player logistics -> enable actions) and move it away :).

Of course im working on getting it more perfect, but its just not as simple as it "looks".

I hope this helps

Thanks for the answer mate, I fully understand your considerations regarding the performance when spawning furniture and it being a very hard job to do overall, as I said in my first post it's a small thing for me to use the logistics to move it out the way, especially when everything else seems to run just the way I want it and this is the only small "issue" annoying me slightly. :)

So a big kudos to you and the rest of the team for all the effort and time spend on this project! KUTGW it's all appreciated.

Share this post


Link to post
Share on other sites

The Insurgency is centered around the Asymmetric AI commander module, if you want it to start in the north then place the module around that area and give it a whirl.

Edited by SpyderBlack723

Share this post


Link to post
Share on other sites

Also, Combat Logistics only resupplies troops, it doesn't reinforce them. So it will replace losses but will not create new forces over and above what they start with.

Share this post


Link to post
Share on other sites
Not sure where this came from but without changing anything, my server is crashing upon a player joining. It does not register the player as joining and it crashes. It generates no .rpt and no alive logs.

I know Kocrachon (page 562) had this issue a little bit ago - ("And I should mention, Im not getting an error. It just sort of sits and hangs at the loading screen, that the server never seems to recognize that anyone is joining.")

but I don't see any followup on this from him.

Server was working just two days ago and now this. It seems to work just fine without @Aliveserver running but I can't find a reason for that.

Edit: Posted on alive forums, probably a better spot for this

Yo Spyder!

Sorry, really no clue where that comes from but if I may have a guess its something related to some version mismatch! Try to allow only same mods as server and see if it continues - we have had a session for about 7 hours with Kellys Heroes and 8 ppl constantly JPDing and didnt have any hickup. Really wanting to help, so if you have it nailed down some more i would love to look into it some more!

Enjoy mate

Share this post


Link to post
Share on other sites
Also, Combat Logistics only resupplies troops, it doesn't reinforce them. So it will replace losses but will not create new forces over and above what they start with.

Okay cool, but the Assymetric OPCOM can grow in numbers correct? Due to recruiting from the civilians...

Share this post


Link to post
Share on other sites
I'm building an OCCUPATION vs ASYMMETRIC campaign where my players are 3rd party augments.

I have the following custom objectives for my OCCUPATION force:

2 x 500 point

8 x 400 point

15 x 300 point

10 x 200 point

10 x 100 point

In addition to this I have the MIL_CIV working on N'Ziwasogo. Towns vary from ZERO value to like 75 or 100.

My ASYMMETRIC force has:

3 x 500 point

6 x 300 point

These are my "home areas"

Questions:

My OCCUPATION force pool is 10000 for reinforcements. However I've found that my starting forces are large and attempt to occupy towns in far flung corners which I don't want. I think I'm going to cut these current standing forces by about half. Will my occupation force start receiving reinforcements if they're force level is too low for the areas they occupy point wise? So like they hold X number of objectives and require Y per OPCOM to be 100% strength but are only at Z force level well below Y. Does the logistics module start sending troops from the 10000 force pool to get the objectives up to Y and keep replenishing up the Y level, or does it only keep replenishing up to the Z level?

Basically I'm trying to simulate the start of an insurgency where the insurgents have almost free reign across the empty parts of the map and the occupation AI spends the initial stages mobilizing and reinforcing its controlled areas.

As for my ASYMMETRIC force, I have 3 x HQs, but the insurgency is always starting in the same place. The only HQ that seems to be detailing any tasks is the far southeast HQ while the southwest and far north HQ just sort of sit there. I have done a 6 hour run of one build and many many many areas were infiltrated by the asymmetric AI, but I would like to have the insurgency start in the north rather than the southeast. How can I change this? I still want to have an HQ or at least a large force in the southeast. Should I just delete or turn off the HQ function in the southeast and only have one in the north? Or does it not matter? OPCOM is detecting the objectives it wants it just so happens they're the same ones all the time to start?

WoW..... Dont be harsh on me, but I need to re-read that and get into myself before i can give an intelligent answer!

---------- Post added at 19:16 ---------- Previous post was at 19:15 ----------

Okay cool, but the Assymetric OPCOM can grow in numbers correct? Due to recruiting from the civilians...

correct, also depending on amount of civis, a town with more civis will create more insurgents than a small one

Share this post


Link to post
Share on other sites
Yo Spyder!

Sorry, really no clue where that comes from but if I may have a guess its something related to some version mismatch! Try to allow only same mods as server and see if it continues - we have had a session for about 7 hours with Kellys Heroes and 8 ppl constantly JPDing and didnt have any hickup. Really wanting to help, so if you have it nailed down some more i would love to look into it some more!

Enjoy mate

Yep, going through everything related and reinstalling/making sure everything is up to date, I'll keep working on it.

---------- Post added at 20:02 ---------- Previous post was at 19:40 ----------

Seems to be one of my mods (like you said) .. I probably should have check that before posting so thanks.

Time to go through and find which of my 25 mods broke it... Off the top of my head I'm thinking ACE Unofficial since it just updated on playwithsix

EDIT: Yep, the problem for me is the @ace3_unofficial mod off playwithsix .. For others using this mod v0.0.0.1 Works but v0.0.0.2 seems to crash server

Edited by SpyderBlack723

Share this post


Link to post
Share on other sites

I moved the OPCOM modules to different places. Running a test now. I'll see what it looks like in 4 hours. Anyway to greatly speed up what the AI does over time other than the max 4X speed in game?

Share this post


Link to post
Share on other sites
I moved the OPCOM modules to different places. Running a test now. I'll see what it looks like in 4 hours. Anyway to greatly speed up what the AI does over time other than the max 4X speed in game?

You could try setAccTime x; x being a number 1-120 with 1 being normal speed. Unsure of how well this would actually work but it's the only thing that comes to mind.

Try putting this in the debug console in the start menu: setAccTime 16; //60 times normal speed

Edited by SpyderBlack723

Share this post


Link to post
Share on other sites
Basically I'm trying to simulate the start of an insurgency where the insurgents have almost free reign across the empty parts of the map and the occupation AI spends the initial stages mobilizing and reinforcing its controlled areas.

Trying this myself at the moment, it always ends in the asymmetric side getting more or less crushed in less than 30 mins. Starting forces roughly 600 resistance (asymmetric) vs 1000 CSAT (occupy). I found separating them gives them more of a chance, ie: 3 separate groups of 200 on different corners of the map, they manage to get a few buildings up before going down, you see the odd trickle of new profiles popping up from HQs and moving towards empty areas.

The only thing I can think of is to give the asymmetric side a head start, hiding resistance objectives from the occupation OPCOM for the first 10-15 minutes of play. Would make the advance seem more like a response to an upcoming threat rather than a zerg rush too.

edit:

Just had a 3 hour game with resistance controlling the majority of the map.

http://steamcommunity.com/sharedfiles/filedetails/?id=431624783

Edited by bhaz

Share this post


Link to post
Share on other sites
Is your 2nd AI Commander on the same side as the first? Also double-check and make sure your logistics modules are synced and not grouped.

Arg, for some reason there was a duplicate logistics module unsynced underneath the one from the opposing side essentially making for three, that was a bizarre error on my behalf.

Share this post


Link to post
Share on other sites

Some Help would be appreciated. I am on Altis, setting up an Asymmetric insurgency. I have dived the map in half with two markers, and have an Opcom in Asymmetric mode synced to, two sets of civ and mil placement modules one with the TAOR set to the east marker and one set with the west marker, so both halves of the map are covered, they are set to objectives only, i have hand placed some units down for the opcom to start with. However it seems to be insistent on sending all units it can to objectives near the Pyrgos area, where as the player forces deploy from the AAC airfield. Is there a way to make it so that the units in the east half only operate on objectives in the east marker, and the western units only operate in their western marker? I tried setting up two opcoms one for each half but you can only have one opcom assigend to a single faction. Any help would be greatly appreciated. :)

Share this post


Link to post
Share on other sites

Just another fast question, I use a3mp, I was wondering if the arma 2 maps are supported even tho I'm playing them in arma 3, like clafghan ?

Or am I going to run into problems ?

Share this post


Link to post
Share on other sites
Just another fast question, I use a3mp, I was wondering if the arma 2 maps are supported even tho I'm playing them in arma 3, like clafghan ?

Or am I going to run into problems ?

A3MP is outdated !!!

use instead All-in-Arma-Terrainpack

will soon be replaced and updated by CUP Terrains

Share this post


Link to post
Share on other sites
A3MP is outdated !!!

use instead All-in-Arma-Terrainpack

will soon be replaced and updated by CUP Terrains

See, I love all AIA, but I noticed he discontinued support and maintenance due to financial posture. To be honest, I used it till about a few days ago, and now I'm kinda looking elsewhere knowing it will go out of date itself with no person at the helm of its hotfixes. I'll have to check that cup terrain out tho! Love cup! Had no clue it even existed. So thanx for the heads up!

Share this post


Link to post
Share on other sites

Hi guys, don't suppose I could get a list of ports I need to have open on our server for it to connect properly to the ALiVE Database for persistence. Someone mentioned a few pages back that with certain providers (i.e NFO) you have to call them to get some ports opened.

Share this post


Link to post
Share on other sites

Something weird happened last night with our alive mission. After (about) 3 days running our mission with Alive (asymetric stuff) in takistan. AI units stoped patrolling areas. They were just freezed out there. I had to give them a little "push" with Zeus moving them a little so they (some of them) could continue moving arround. We are using CBA_A3 | versión 1.1.20.150416 RC6 and ALiVE | versión 0.9.7

@AGM

@RHS

@ARS_AI3

We will keep testing our server performance these days and keep reporting!

XOXO

Edited by AlexSegen

Share this post


Link to post
Share on other sites

If the AI doesn't build IED factories, can they still use IEDs?

I've got it synced to the asymmetric commander but I don't see any IED factories on N'Ziwasogo. Just Recruit, Depot, Roadblock.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×