Jump to content
major_shepard

ArmA3Sync - launcher and addons synchronization software for ArmA 3

Recommended Posts

Is it possible to launch the game in Borderless Window using A3Sync?

Share this post


Link to post
Share on other sites
Is it possible to launch the game in Borderless Window using A3Sync?

Simply set it to Borderless Window in the Arma 3 settings, and to not touch the "start in windowed mode" option.

Share this post


Link to post
Share on other sites

Everytime i launch arma3sync i get this error.

Error

An error occured.

Failed to load one or more repositories.

What should i do?

Share this post


Link to post
Share on other sites
Everytime i launch arma3sync i get this error.

Error

An error occured.

Failed to load one or more repositories.

What should i do?

From ArmA3Sync installation directory \resources\ftp remove the repository file that is not loading into the Repositories Panel.

Share this post


Link to post
Share on other sites

Ello Major Shepard,

I have asked with my provider and checked mine rights of the folders with FTP program filezilla.

All the folders have the 755 and the files in the folders like .pbo have the right 644 read.

This should be okay not ?

Also the program files have 644 like this one as example cba_xeh.pbo.cba_a3_rc4.bisign.zsync.

Also the .a3s folder had the premission of 755 and the files in there all have right 644.

I also downloaded the folder with filezilla no problem !

Might be there a problem with creating the .a3s file that makes it go bonkers ?

Hope this make more sense too you than me

Thanks,

KillerBee

Share this post


Link to post
Share on other sites
clan Killer Bee;2891903']Ello Major Shepard' date='

I have asked with my provider and checked mine rights of the folders with FTP program filezilla.

All the folders have the 755 and the files in the folders like .pbo have the right 644 read.

This should be okay not ?

Also the program files have 644 like this one as example cba_xeh.pbo.cba_a3_rc4.bisign.zsync.

Also the .a3s folder had the premission of 755 and the files in there all have right 644.

I also downloaded the folder with filezilla no problem !

Might be there a problem with creating the .a3s file that makes it go bonkers ?

Hope this make more sense too you than me

Thanks,

KillerBee[/quote']

So what is the new problem as you now switch to a FTP server?

Be aware that you must upload the repository using ArmA3Sync Upload command or be sure to set Binary transfer mode with FileZilla.

Share this post


Link to post
Share on other sites

Solve the problem in my case !

Okay the problem is in the making of the checksum building the repository ! ( I Think ! )

This is what I had to do !

When I got the first repository done it gave errors about missing files and such.

After 5 days with trail and error and frusty cakes. I got pissed off. What happend is that I made a new repository and pressed build !

Didn't upload it !

And pressed built again and again just because I was pissed.

I noticed that it kept checking but still builded less and less !

I did this 5 times than I uploaded the file to the server and DL with another pc.

I had one error but checking the files it said 1 more update.

Updated and all the files were correct downloaded.

I assume when building the checksum it skips some of files.

By redoing the build it sees the ones are done and that is sees the ones it missed and add them to the list !

By doing it 5 times I covered them all !

Good thing is that when you have uploaded your file and there are broken you do a rebuild and it just only add the files that were broken or mission , so no big ass uploads again !

For the maker :

Program doesn't take all the files at once.

Solution for the user at the moment:

Just hit rebuild and upload the files by FTP build in the program. Keep doing this till all the files are complete on your serve or ftp !

I hope with my 5 days I could be some help for someone else and the builders !

Thank for the help of mr shep. :o

More info:

I had this with and without virus scan the problems so was not my virus scan.

Used win 7 64 bit

And the missing files were all 0kb

Edited by [LOL]clan Killer Bee

Share this post


Link to post
Share on other sites

ArmA3Sync 1.4 Update 2

Download

Check for Updates or use Windows installer ftp://62.210.177.238/ArmA3/ArmA3Sync/releases/arma3sync-installer-1-4-58.exe

Changelog

Added: Profiles can now be exported as desktop shortcut.

Added: Repository: connection timeout and read timeout can now be set manually (see the wiki).

Added: Space bar can now be use to check/uncheck mod selection.

Added: ArmA3Sync Console: -SYNC command can now use with/without exact file matching (see the wiki).

Added: Download: Errors messages can now be exported to desktop as a log file.

Fixed: Download/Upload freezes if transfer file has a zero byte size (regression from version 1.4)

Fixed: ArmA3Sync Console: main folder path sets to null when creating a new repository from command line (regression from version 1.4)

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

New release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account (Major_Shepard) on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

Share this post


Link to post
Share on other sites

For some reason loading my game through Arma3Sync disables all my mods in the Expansions menu since updating. I have to re enable and restart and join our server normally without using A3Sync.

Share this post


Link to post
Share on other sites
For some reason loading my game through Arma3Sync disables all my mods in the Expansions menu since updating. I have to re enable and restart and join our server normally without using A3Sync.

Let say that you have at first started the game from Stream then enable some mods from Expansion panel. Then close the game and start ArmA3Sync.

Let say now you want to start the game from ArmA3Sync with no mod and no Game Profile is selected from Launch options Panel (i.e Default).

In this case the game would start by itself with the previous selected mods from Expansion panel whereas no mod has been selected from ArmA3Sync.

That's why ArmA3Sync now delete Expansion selected mods to prevent from this behaviour.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

I have some questions to this app.

In original A3 launcher there is maxMem up to 8GB.

A3Sync allows to choose max 2GB. Why?

Is it better to use instead of predefined values in JComboBox JTextField with upper limit?

I am not sure (and cant find info) what for is field "additional parameters".

When i try to put there some text, eg. "-mamMem=8192" nothing happen.

Can you explain it to me?

regards

Share this post


Link to post
Share on other sites

Hi Major, we're using A3sync on a server using HFS - Http File Server.

We got 2 repo on this server one for guests called "Other" one for us called "TS" and one for us. We build the repo right on the server, we download mods from armaholic directliy from the server then build the repo and export then autoconfig.

Today we got this error connecting on the repo called "TS":

failed to read file /.a3s/sync
Connection reset

Here is HFS log:

15:21:02 xxx.xxx.xxx.xxx:xxx Connected
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxx Requested GET /Other//.a3s/sync
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Fully downloaded - 8.35 K @ 356 KB/s - /Other//.a3s/sync
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Disconnected by server - 8551 bytes sent
15:21:02 xxx.xxx.xxx.xxx:xxxxx Connected
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Requested GET /Other//.a3s/serverinfo
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Fully downloaded - 276 @ 11 KB/s - /Other//.a3s/serverinfo
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Disconnected by server - 276 bytes sent
15:21:02 xxx.xxx.xxx.xxx:xxxxx Connected
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Requested GET /Other//.a3s/changelogs
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Fully downloaded - 536 @ 26 KB/s - /Other//.a3s/changelogs
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Disconnected by server - 536 bytes sent
15:21:02 xxx.xxx.xxx.xxx:xxxxx Connected
15:21:02 xxxx@xxx.xxx.xxx.xxx:xxxxx Disconnected by server - 2338 bytes sent
15:21:04 xxx.xxx.xxx.xxx:xxxxx Connected
15:21:04 xxxx@xxx.xxx.xxx.xxx:xxxxx Requested GET /TS//.a3s/sync
15:21:04 xxxx@xxx.xxx.xxx.xxx:xxxxx Fully downloaded - 19.70 K @ 841 KB/s - /TS//.a3s/sync
15:21:04 xxxx@xxx.xxx.xxx.xxx:xxxxx Disconnected by server - 20173 bytes sent

As you can see the "other" repo works, the "TS" repo stop at downloading sync file.

on "TS" repo we have

531 files

12.8GB

@agm

@aiatp

@asdg_jr

@Bornholm

@cba_a3

@fhq_accessories

@mas

@strykerpack

@task_force_radio

userconfig

On "Other" repo we have

210 files

4.28GB

@agm

@asdg_jr

@Bornholm

@cba_a3

@fhq_accessories

@mas

@strykerpack

@task_force_radio

As you can see the difference is All in ArmA Terrain Pack, we removed @aiatp from "TS" folder rebuild the repo and then "TS" repo start again to work. If we put @aiatp back and rebuild, then the repo stop working again giving the same error.

Also if we remove all mods and leave only @aiatp then rebuild the repo, we got error again, so the problem is @aiatp or is there a limit in numer of file or GB that A3sync can handle? Because @aiatp is bigger than the rest of the other mods.

Is there a way to fix this?

Share this post


Link to post
Share on other sites

In the log it says "Disconnected by server"

Which means that the server close itself the connection. Check your server conf. (presumably to short server connection timeout)

There is absolute no limit regarding ArmA3sync and the size of the repository.

---------- Post added at 04:13 PM ---------- Previous post was at 03:59 PM ----------

I have some questions to this app.

In original A3 launcher there is maxMem up to 8GB.

A3Sync allows to choose max 2GB. Why?

Is it better to use instead of predefined values in JComboBox JTextField with upper limit?

I am not sure (and cant find info) what for is field "additional parameters".

When i try to put there some text, eg. "-mamMem=8192" nothing happen.

Can you explain it to me?

regards

Typically you do not have to set the amount of memory to use as ArmA 3 run at best performances by default. Unless you have a Win XP rig with a 2 GB size memory and thus you need to limit the memory load.

The other thing is that ArmA3.exe is a 32 bit running process and thus can't be allocated more than 2 GB memory. Setting 8192 is simply ignored by the game.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

thanks major, the spacebar function is working now!

gonna save me lots of time doing multi-selections for the repo now!!!

Share this post


Link to post
Share on other sites

With the new update the function to hide folders doesn't work anymore like it used to. I selected the userconfig-folder of our repo to be hidden, but it doesn't take over the setting.

Share this post


Link to post
Share on other sites
In the log it says "Disconnected by server"

Which means that the server close itself the connection. Check your server conf. (presumably to short server connection timeout)

There is absolute no limit regarding ArmA3sync and the size of the repository.

Yes I can read, thank you, and I can also read the timings, as you can see it disconnect me immediately, but if it's a timeout it should happen also in "other" repo (but there is not @aiatp inside), so I think it's something about what's in @aiatp.

Today I tryed to download again @aiatp, done a rebuild but I get again the same error. It doesen't happen without @aiatp

Anyone has @aiatp in their repo could please tell me if it's working?

tnx

Share this post


Link to post
Share on other sites
Yes I can read, thank you, and I can also read the timings, as you can see it disconnect me immediately, but if it's a timeout it should happen also in "other" repo (but there is not @aiatp inside), so I think it's something about what's in @aiatp.

Today I tryed to download again @aiatp, done a rebuild but I get again the same error. It doesen't happen without @aiatp

Anyone has @aiatp in their repo could please tell me if it's working?

tnx

You can import the autoconfig for my HTTP repo => www.sonsofexiled.fr/a3s-repository/.a3s/autoconfig

And try dowloading @aiatp from MAPS folder.

It does work.

Again you should not have "Disconnected by server" line in the log. It's server issue.

As an example here is the Apache log of my server when I connect to the repo:

82.124.42.116 - - [07/Mar/2015:19:20:20 +0100] "GET /a3s-repository/.a3s/sync HTTP/1.1" 200 37184

82.124.42.116 - - [07/Mar/2015:19:20:20 +0100] "GET /a3s-repository/.a3s/serverinfo HTTP/1.1" 200 291

82.124.42.116 - - [07/Mar/2015:19:20:20 +0100] "GET /a3s-repository/.a3s/changelogs HTTP/1.1" 200 719

82.124.42.116 - - [07/Mar/2015:19:20:20 +0100] "GET /a3s-repository/.a3s/events HTTP/1.1" 200 145

---------- Post added at 07:31 PM ---------- Previous post was at 07:06 PM ----------

With the new update the function to hide folders doesn't work anymore like it used to. I selected the userconfig-folder of our repo to be hidden, but it doesn't take over the setting.

Working here, try my repo www.sonsofexiled.fr/a3s-repository/.a3s/autoconfig

Do you upload the repo?

Edited by Major_Shepard

Share this post


Link to post
Share on other sites
Added: Repository: connection timeout and read timeout can now be set manually (see the wiki).

Nice ! This solved the problem we had with our member. Thanks a lot for the fix.

Share this post


Link to post
Share on other sites
Working here, try my repo www.sonsofexiled.fr/a3s-repository/.a3s/autoconfig

Do you upload the repo?

We host our repo on our own root-server: http://spezialeinheit-luchs.de/repo/Arma3/minimal/.a3s/autoconfig

I've added the userconfig-folder to the excluded folders with local content in the Options for "Build or update repository", just like I used to. But with 1.4.58 it doesn't hide the folders anymore.

It doesn't work for multiple repositories. We've got one repository with a key-folder, which is being hidden correctly, but the userconfig folder of this repository is not being excluded just like the one above.

Funny enough I've updated my personal Arma3Sync-Client first and found that it wouldn't hide the userconfig folder. Just then I updated Arma3Sync on our server and rebuilt the repositories to double-check. I even created the repositories compeletely from scratch. Didn't work unfortunately.

#edit: I found that deleting the .a3s-folder and all *.zsync-files fixed the problem for me.

Edited by Belbo

Share this post


Link to post
Share on other sites

A3S is wonderful, love it. There is really one feature that I think would enhance it from wonderful to AMAZING:

Add BitTorrent Sync features to it, similar to how A3 Breaking Point launcher allows updating.

In my community's case, we use ~20gb of mods and sometimes a mod repo update is as big as 5gb, which is hosted on a private NAS and has a 10mbps upload bandwidth that has to supply over 50 downloaders... With BitTorrent sharing, the NAS will only have to upload the update once, saving everyone a lot of time.

Share this post


Link to post
Share on other sites
A3S is wonderful, love it. There is really one feature that I think would enhance it from wonderful to AMAZING:

Add BitTorrent Sync features to it, similar to how A3 Breaking Point launcher allows updating.

In my community's case, we use ~20gb of mods and sometimes a mod repo update is as big as 5gb, which is hosted on a private NAS and has a 10mbps upload bandwidth that has to supply over 50 downloaders... With BitTorrent sharing, the NAS will only have to upload the update once, saving everyone a lot of time.

Bittorent has some interest if there are permanently several peers that can share the filles. If the only shearing source is the server, Bittorent has zero interest.

Moreover ArmA3Sync use ZSYNC algorithm with HTTP hosted repository to perform differential update (i.e only piece of file is transferred). Whereas standard Bittorent protocol can only transfer the whole file (like FTP protocol).

Regarding Bittorent Sync, it is a proprietary protocol. I guess we have to pay for using it into another software. I really doubt it is better than HTTP/ZSYNC when it comes to updating files.

You can also hire a dedicated server for a very low price with a good 1 gbit/s bandwith => http://www.online.net/fr/serveur-dedie/comparatif-serveur-dedie-perso

Absolute no need for a strong hardware when is comes to file sharing.

Put a linux and a Apache server on this, you good to go.

Edited by Major_Shepard

Share this post


Link to post
Share on other sites

Of course anyone can buy a dedicated server, might as well just use free hosting services like mega.co.nz or dropbox or copy.com or whatever.

I like A3S, I want to keep using it, and if it had file sharing capabilities, it would be amazing.

Bittorent has some interest if there are permanently several peers that can share the filles. If the only shearing source is the server, Bittorent has zero interest.

Current situation: One sharing host updates repo with 5gb upload. 50 users connect and download a total of 5gb x50 = 250gb traffic from host

BitTorrent: One sharing host updates repo with 5gb upload. 50 users connect and BT protocol sends only unique parts from the host so that once a single 5gb upload is done, all the data is acquired by the peers and is shared between them. total of 5gb x1 = 5gb traffic from host.

If that's not amazing I don't know what is.

Share this post


Link to post
Share on other sites
Of course anyone can buy a dedicated server, might as well just use free hosting services like mega.co.nz or dropbox or copy.com or whatever.

I like A3S, I want to keep using it, and if it had file sharing capabilities, it would be amazing.

Current situation: One sharing host updates repo with 5gb upload. 50 users connect and download a total of 5gb x50 = 250gb traffic from host

BitTorrent: One sharing host updates repo with 5gb upload. 50 users connect and BT protocol sends only unique parts from the host so that once a single 5gb upload is done, all the data is acquired by the peers and is shared between them. total of 5gb x1 = 5gb traffic from host.

If that's not amazing I don't know what is.

Is it kind of Altis no-life community ? ;)

Adding Bittorent protocol (not Bittorent Sync) is definitely possible ^^

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×