Jump to content
.kju

All in Arma (AiA) - TKOH/OA/A2/A1 merge with A3

Recommended Posts

What is the Island shown in the OP video @ 0:17?

Looks like Sahrani to me.

Share this post


Link to post
Share on other sites

@ Doln

Looks funny. :)

Please upload the rpt log file for analysis.

@ Marioshata

Unfortunately there is no other way.

However if you provide the download links to the exact files needed for the latest JSRS/the set you use, I can add an updated config for it as optional addon. How does that sound?

@ Black Cat, postalsam, GvsE

Sorry it is not possible to support both stable and dev branch.

However a new stable update should come later this week.

@ Valken

Please provide me the rpt log file from AiA with TKOH demo.

@ Shard

You need to download both AiA and CBA A3 beta4. Make sure to "add selected" the CBA to the AiA modset with the button in the bottom right.

Does that help? Did you watch the video guy linked in the wiki yet? If not, please describe more in detail your problems.

Best stick to the latest stable release of PwS (1.03.x) and NOT use the beta preview.

Share this post


Link to post
Share on other sites
Looks like Sahrani to me.

Thanks. Looks pretty cool with the high mountains.

Share this post


Link to post
Share on other sites

Sound good :rolleyes:, but i don't want to waste your time friend. Using the last JSRS 1.5 final on default set and my god it's a different game (suggesting everyone should try it).

Also want to recall about that strange thing happening when using last AiA version without and with the sound mod.

AiA without sound mod = Arma 2 default sounds with some missing.

AiA with sound mod = Arma 2 default sounds + some Arma 3 default sounds (probably the ones you defined with the new A3 effects implementation) + the ones from the mod ofc.

Share this post


Link to post
Share on other sites

If this helps you with updating the mod to the upcoming stable release, currently when I load AiA on devbranch the game screams "'loadafterA3data_c_pvpscene' requires addon 'A3_anims_f_config_wmn'." I think I noticed a few more voice actors now after the most recent patch, which might be related to the error mentioned in the previous post.

I hope the stable patch comes here soon and you can get this sorted as I want to go back to Chernarus asap;)

Share this post


Link to post
Share on other sites

With the new Patch v0.72, i get a no entry error everytime i preview a mission in the editor.

exact error: no entry 'config.bin/cfgVoice.Male00ENG'.

I found the bug report atm an dev-heaven.. :yay:

Hope we get a update soon, and keep up the good work .kju

Share this post


Link to post
Share on other sites

Update should be available very soon. :)

Share this post


Link to post
Share on other sites

Here are the RPTs...

This is when I tried to load TKOH demo directly to the game folder:

=====================================================================
== d:\Arma 3\arma3.exe
== arma3.exe  -nosplash -skipintro -cpucount=4   "-mod=@sum_rep_1.0;@Igit_FT;@CBA_A3;@AllInArma\ProductDummies;\DBE1;;@AllInArma\A1Dummies;;;\Expansion;d:\Steam\SteamApps\common\Take On Helicopters Demo\;@A1A2ObjectMerge;D:\ArmA 3;@AllInArma\Core;@AllInArma\PostA3"

Exe timestamp: 2013/07/05 23:28:31
Current time:  2013/07/09 22:48:55

Type: Public Beta
Branch: Development
Version: 0.71.107360

Allocator: d:\Arma 3\dll\tbb4malloc_bi.dll
=====================================================================

ErrorMessage: Cannot open file 'd:\Steam\SteamApps\common\Take On Helicopters Demo\\dta\bin.pbo'

Here are the rest of the RPTs that were too big for embedding. I even tried to rename the demo folder but it still did not work.

https://www.dropbox.com/s/qgq7u7s5hdyq1qr/arma3_2013-07-09_22-52-40.rpt

https://www.dropbox.com/s/9l0gjoxrb3j42nk/arma3_2013-07-09_22-50-17.rpt

https://www.dropbox.com/s/5tp4o02c6yfgu6n/arma3_2013-07-10_00-13-09.rpt

Share this post


Link to post
Share on other sites

New version available: https://dev-heaven.net/projects/all-in-arma/files

Changes:

  • Added: 0.72 compatibility.
  • Added: beautiful preview images for terrain selection. Thanks to deFUNKt!
  • Added: beautiful SAT images for terrain loading screen. Thanks to Karel MoÅ™ický!
  • Added: optional addon to have all JSRS sounds.

  • Fixed: The UAV/ULB module doesn't work.
  • Fixed: With AIA some markers have an incorrect size.
  • Fixed: Some A3 sounds get overwritten by A2/TKOH definitions.

Full details: https://dev-heaven.net/versions/1494

WIP changes:

---

Notes:

  • A3 BETA required.
  • CBA A3 beta 4 required (and no other CBA version).
  • Delete the former @AllInArma modfolder first.
  • The design of A3 vs A2/OA/TKOH infantry and hidden content has changed. Make sure to read the FAQ.
  • If you want to play A1 terrains without missing objects, you need to merge the misc.pbo and buildings.pbo from A1 and A2 yourself and put it into .\@A1A2ObjectMerge\addons. More details in the wiki.
  • If you want to play A1 missions, you need to load A2 and OA along as well. Queen's Gambit missions are not yet supported.
  • Please read the known-issues section, the FAQ and howTo-post-issues.

Important notes:

Please vote in the A3 Feedback Tracker (FT) for AiA related tickets.

See links in the Known issues section.

Contribute:

We are looking for a nice banner, promo screenshots and promo trailers for our new AllInArma info page.

If you want to help out with your skills, please contact me. :)

Enjoy :bounce3:

---

Let me repeat the outreach to you - the community, players and fans of All in Arma. :)

1. First off be sure to check out the lighting tweaks shared by Fabio_Chavez.

Please give them a try ingame and leave him your feedback, or even try to do tweaks yourself (see also).

Based on your feedback and input, new lighting will be set for A2 and OA terrains - both official and community made terrains. :)

2. Please leave your comments and vote what you want me to look into next.

This is an input and community driven project - with the exception of things only BI can address.

3. Please report issues in this thread or the issue tracker and tell your friends to do so as well.

You guys need to tell me what needs fixing or improved.

4. It appears still quite many people have problems with the installation/setup process.

Hence it would be great to have a) the guide improved and b) translations for different languages available.

Please contact me, if you want to help here, have suggestions or know better/translated guides already available.

5. Anyone wants to help out with assigning custom look to the A1/A2/OA/TKOH units when A3 models are used,

or for A3 units when the A2 models are used, or for women replacements in general which currently all use the same civilian model.

It is essentially a simple, yet rather boring and time consuming copy paste job. :o

You would get a text file with the different templates available and another text file with the units.

The job is to assign meaningful models to the different type of classes - in other words it involves some creativity and sense of realism.

Thanks :)

Share this post


Link to post
Share on other sites

Thank you! :)

A3 weapons seem to have recoil now. The previews and loading screens are superb, and most importantly, the mod is compatible with the beta. hurray! :D

Share this post


Link to post
Share on other sites

@ kyu - testing a simple mission - Seattle map, added a AH64D, pilot , co pilot, marines... and an alien.

Just flying around but I noticed the LOD or building models were big black pixels that shakes around until I got really close to it. Then it popsup but with no texture? All the model textures were blueish in color.

RPT - https://www.dropbox.com/s/pmz9r5r0ek9kfm3/arma3_2013-07-13_04-03-39.rpt

Share this post


Link to post
Share on other sites

I have been having a problem with this mod lately, and this mod is the only one affected. Whenever I strat up the game, I get this

No entry 'config.bin/CfgVoice.Male00ENG

When I load up a mission in the editor I get the same thing, and I cannot start any mission I make. Are there any solutions to this?

Share this post


Link to post
Share on other sites

@kju

OT, but gotta say thanks for all the community resources you tirelessly provide/update, all the time ..... along with this mod.

*hat off to you*

Cheers.

Share this post


Link to post
Share on other sites

Short heads-up: The new version should become available in Play withSIX/SIX networks later today.

Share this post


Link to post
Share on other sites

@ Marioshata

The addon is in the optional folder in core\addons. Please give it a try and provide feedback if and how it works.

@ Valken

Unfortunately it seems most of the TKOH demo pbos are encrypted and hence cannot be loaded by A3 (similar to OA DLC).

BI needs to port support for large buildings from TKOH to the A3 engine. See known issues .

Share this post


Link to post
Share on other sites

Hey kju, I tested almost everything and the JSRS compatibility works like a charm! Thank you for making this possible for me and others and for the lightning fast job that you have done! I also tested the new release without the sound mod and found out that the crash sound is back, but the GAU-8 sound is still missing (haven't found any other so far). Not a problem for me anymore but worth to mention. I will provide feedback if anything pops up.

Share this post


Link to post
Share on other sites

@.kju

At first a big thanks to you to put this lot of work in there, its an awesome mod!!!!!!

I found a little problem, the MXM 6.5 and the P07 have no recoil.

Also the starting time from arma 3 with this mod takes a while, after that the loadingtime (from Islands/ missions) is normal. Is there a way to get this optimized ??

Share this post


Link to post
Share on other sites

@ Marioshata

You are welcome and glad to hear. :bounce3:

I have tried to fix the bug of A3 sounds being overwritten too yes.

What do you mean with GAU-8? A3 doesnt have it. Please clarify.

Let me know if you find more problems please.

@ gizz46

Recoil is unfortunately a long time issue and can only be fixed by BI.

I will create a FT ticket for people to vote - lets hope BI will sort this soon.

Share this post


Link to post
Share on other sites

I have one question - how real is it to make arma 2 cars lighting work exactly like arma 3 cars lighting. Can that be changed through config at all? Just wondering.

thumb.png

And I found one small UI bug caused by mod. (Not presented in a stable build, so I guess nvm)

thumb.png

Other than that, thanks for update again. This mod is great.

Edited by rebelvg

Share this post


Link to post
Share on other sites

The GAU-8 Avenger the huge 30mm gun mounted on the A-10 plane (or should I say huge plane mounted on that gun :)). Two versions ago it had its default Arma 2 sound on, but as of v13 and v14 no sound comes out when firing. I will report any other problems I come across!

Edit: Getting an error when running my server: No entry 'config.bin/CfgVehicles/AH1Z/Sounds/WindNoiseOut.frequency'.

It should be JSRS config related.

Edited by Marioshata

Share this post


Link to post
Share on other sites

Hey, having an issue with this mod. It worked perfectly fine in the past, perhaps it's the new beta update and everything, but for some reason whenever I try to load any unit from Arma 2 (i.e. basic USMC rifleman) The model is replaced by an arma 3 rifleman with nothing but multicam pants and a screwed up texture of a jacket, and NODs. The M16 rifle is there (arma 2 version) but its just the model thats not working right.. I don't know if this has come up before, but does anyone know why this is? Any help would be greatly appreciated, thank you.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×