Jump to content
Sign in to follow this  

What are the most important sounds for you while using JSRS?  

176 members have voted

  1. 1. What are the most important sounds for you while using JSRS?

    • The weapon sounds!
    • The vehicle sounds!
    • Environmental sounds!
    • Explosions, Soniccracks, Bullethits, the sound of danger!
    • The script features like the "distance sounds"!
    • Everything combined! The whole Mod itself is important.


Recommended Posts

Finally got around to play a bit with v1.5 and i must say it's brilliant, execellent work :cool:

Share this post


Link to post
Share on other sites
Posting here for the third time with this question which will hopefully get answered this time. The problem is - i can't hear gun mechanisms, nor interior sounds. What should I do to fix it? What i've tried

- fixing all problems with files game couldn't find

- lower gfx details in case it was a performance issue

- check wether i have all 3 newest CBAs

- redownload JSRS 1.5 full

- defrag the disks

- launch with no other mods than JSRS and CBAs

- try different soundcard

- try launching the distance script from a separate mod folder in case jsrs one was blocking something from loading

Nothing has worked so far. Other than that, mod works because there are new sounds. It's just that the script doesn't. I'm out of ideas on how to make it work.

Hey.

Ya you seems to be really the only one here with those problems. I'm running out of ideas too. Well I ran out... otherwise I would have told you. You must be kinda millionth users or so....

You looked into the RPT after you started a game and played a bit to trigger the sounds? Maybe something else got fucked up...

LJ

---------- Post added at 03:51 PM ---------- Previous post was at 03:49 PM ----------

Given your competences, does anyone know how to combine a DVD version of A2 with a Steam version of OA to get CO?

You will find a topic in this forum concerning this question. There are also tips how to manage steam version at all.

This thread is JSRS related only!

Share this post


Link to post
Share on other sites
You will find a topic in this forum concerning this question. There are also tips how to manage steam version at all.

This thread is JSRS related only!

I posted in the aforementioned thread almost 3 months old and never got an answer.

Here today others offered advice so I took the opportunity.

Sorry if it got your knickers in a twist.

Share this post


Link to post
Share on other sites
I posted in the aforementioned thread almost 3 months old and never got an answer.

Here today others offered advice so I took the opportunity.

Sorry if it got your knickers in a twist.

Yah sure. I would just like to stay on-topic here and get JSRS bug free for now ;)

I wouldn't suggest it, you just shouldn't buy a game from Steam and try to combine it with a DVD game or a separate downloaded one, but Google is also kinda helpful too sometimes :)

- install ArmA 2 (from DVD)

- install Arrowhead (from Steam)

- update ArmA 2

- install OA Betapatch

- copy complete ArmA 2 from the Main Arma 2 folder inside your OA folder in Steam so that the Arma2OA.exe is next to the Arma2.exe

- edit with RegEdit the entry and paths of ArmA 2 to the folder of Arma 2 OA in steam

- Test, post info if work

LJ

Edited by LordJarhead

Share this post


Link to post
Share on other sites
Hey.

Ya you seems to be really the only one here with those problems. I'm running out of ideas too. Well I ran out... otherwise I would have told you. You must be kinda millionth users or so....

You looked into the RPT after you started a game and played a bit to trigger the sounds? Maybe something else got fucked up...

LJ

---------- Post added at 03:51 PM ---------- Previous post was at 03:49 PM ----------

You will find a topic in this forum concerning this question. There are also tips how to manage steam version at all.

This thread is JSRS related only!

I realized you must have run out of ideas so I posted here hoping that someone encountered this problem too and solved it...

Anyway, i did try to give it some time to kick in (around 10 minutes), but i didn't try checking the RPT. I deleted the old one, played the game and then checked it. I'm not too good at reading these things but what I've made out is that the game sees the script but the script itself seems to have an error in expression (?), or it is missing something. And it does this to every single gun. The error message is as follows:

if (cameraView in ["INTERNAL">

Error position: <_shooter;

if (cameraView in ["INTERNAL">

Error Missing ;

File JSRS_Distance\scripts\ammo\M9.sqf, line 6

Error in expression <oter = _this select 0;

_eyePos = eyePos _shooter;

And it repeats for every other gun.

This is my rpt file. Perhaps you might find out what's the problem.http://www.sendspace.com/file/zdkj6y

Share this post


Link to post
Share on other sites
I realized you must have run out of ideas so I posted here hoping that someone encountered this problem too and solved it...

Anyway, i did try to give it some time to kick in (around 10 minutes), but i didn't try checking the RPT. I deleted the old one, played the game and then checked it. I'm not too good at reading these things but what I've made out is that the game sees the script but the script itself seems to have an error in expression (?), or it is missing something. And it does this to every single gun. The error message is as follows:

if (cameraView in ["INTERNAL">

Error position: <_shooter;

if (cameraView in ["INTERNAL">

Error Missing ;

File JSRS_Distance\scripts\ammo\M9.sqf, line 6

Error in expression <oter = _this select 0;

_eyePos = eyePos _shooter;

And it repeats for every other gun.

This is my rpt file. Perhaps you might find out what's the problem.http://www.sendspace.com/file/zdkj6y

Do you use any other mods? Whats the version of your game showing in the main menu? This is a script error maybe, yes, but no one else got it. So either your downloaded files are corrupted or you mixed something with JSRS 1.4,3? Maybe both mods are running the same time?

I mean we got this already, but you really have Arma 2, not the free one? You have Arma OA, all on Steam? DVD? Sprocket? Did you downloaded the UPDATE 2? This is really weird and I'm afraid it must be your game! It wont be any external thing like a software, or your audio card or your headphones, this is directly in you game, related with something that Arma is maybe missing...

LJ

Share this post


Link to post
Share on other sites
I realized you must have run out of ideas so I posted here hoping that someone encountered this problem too and solved it...

Anyway, i did try to give it some time to kick in (around 10 minutes), but i didn't try checking the RPT. I deleted the old one, played the game and then checked it. I'm not too good at reading these things but what I've made out is that the game sees the script but the script itself seems to have an error in expression (?), or it is missing something. And it does this to every single gun. The error message is as follows:

if (cameraView in ["INTERNAL">

Error position: <_shooter;

if (cameraView in ["INTERNAL">

Error Missing ;

File JSRS_Distance\scripts\ammo\M9.sqf, line 6

Error in expression <oter = _this select 0;

_eyePos = eyePos _shooter;

And it repeats for every other gun.

This is my rpt file. Perhaps you might find out what's the problem.http://www.sendspace.com/file/zdkj6y

Your RPT is filled with confusing stuff.

Lets try this.

Disable ALL mods except CBA and JSRS (You do have the latest CBA right? Go into the @CBA folder and check the version.txt ;Post that number)

Delete your RPT and try playing.

Post the new RPT.

Share this post


Link to post
Share on other sites

I've never thank you before, I think it's about time :). These sounds give at least 20% of the overall inmersion and atmosphere we get when we play Arma. Thanks a lot for all your work. I remember a while back when I first saw your mod frontpaged in Armaholics, and thought "Gee, another sound mod. What else do we need." I was wrong, we needed your another-sound-mod from the moment Arma was released.

Share this post


Link to post
Share on other sites
I've never thank you before, I think it's about time :). These sounds give at least 20% of the overall inmersion and atmosphere we get when we play Arma. Thanks a lot for all your work. I remember a while back when I first saw your mod frontpaged in Armaholics, and thought "Gee, another sound mod. What else do we need." I was wrong, we needed your another-sound-mod from the moment Arma was released.

Really nice said! Thank you so much ;)

LJ

Share this post


Link to post
Share on other sites

First of all you, sir is probably the only reason I can stand vanilla Arma at the moment so thanks for the awesome work you put in, how BIS have not stolen you yet is beyond me but I digress.

I think I found a small bug with JSRS and was not able to figure out how to make a bug report on devheaven so I came here.

If you are in a gunner / spotter position inside a lynx and the pilot fires a rocket that will cause your client to crash, did a few tests and the crash was consistent.

Uploaded a quick vid to yt as a demonstration but BIS forums won't let me post it, chan name is J4gz3ro.

Again thanks for an awesome mod!

Edit: Tested in SP where pilot was ai and I was the gunner but didn't get the same result.

Edited by J4gz3r0

Share this post


Link to post
Share on other sites
First of all you, sir is probably the only reason I can stand vanilla Arma at the moment so thanks for the awesome work you put in, how BIS have not stolen you yet is beyond me but I digress.

I think I found a small bug with JSRS and was not able to figure out how to make a bug report on devheaven so I came here.

If you are in a gunner / spotter position inside a lynx and the pilot fires a rocket that will cause your client to crash, did a few tests and the crash was consistent.

Uploaded a quick vid to yt as a demonstration but BIS forums won't let me post it, chan name is J4gz3ro.

Again thanks for an awesome mod!

Edit: Tested in SP where pilot was ai and I was the gunner but didn't get the same result.

Are you using a Audio card?

Oh and now you can post the video here, you need to post at least one post here to be allowed to do that ;)

LJ

PS: https://dev-heaven.net/projects/jsrs/issues

You need to register yourself of course. Then you go to the certain project and click on "New Ticket" and there you go ;)

Share this post


Link to post
Share on other sites

Actually using a USB headset with a "soundcard" but onboard soundcard is Realtek ALC892, a friend of mine had the same issue so don't know if it's hardware related.

But VG has been running their servers with the same version of Insurgency for the past year or so and JSRS has not caused such a crash before hence I believe it's related.

Could post my rtp file if that would help you.

Linky here:

V28phAD2Iz8

Share this post


Link to post
Share on other sites
Could post my rtp file if that would help you./QUOTE]

Yah, post the RPT, at least the latest part before the crash!

JSRS1.5 rocks but don't you find the indoor "echo" a bit overdone?

You never fired a gun inside a building, did ya? ;) Its fine the way it is... in my opinion they are still to quiet but I kept it down for the general public.

Share this post


Link to post
Share on other sites
Do you use any other mods? Whats the version of your game showing in the main menu? This is a script error maybe, yes, but no one else got it. So either your downloaded files are corrupted or you mixed something with JSRS 1.4,3? Maybe both mods are running the same time?

I mean we got this already, but you really have Arma 2, not the free one? You have Arma OA, all on Steam? DVD? Sprocket? Did you downloaded the UPDATE 2? This is really weird and I'm afraid it must be your game! It wont be any external thing like a software, or your audio card or your headphones, this is directly in you game, related with something that Arma is maybe missing...

LJ

Tried playing with no other mods than CBAs. Game version is 1.60.87580. Files must be alright because I downloaded them for the second time, from the source you posted. I deleted JSRS 1.4.3.

I had the retail ArmA2 on a disc from a game mag (but it is most definitely a retail one since it runs mods and free one can't), and a bought Reinforcements on DVD. I did not download Update 2 since i just downloaded the updated one full, that you posted.

Your RPT is filled with confusing stuff.

Lets try this.

Disable ALL mods except CBA and JSRS (You do have the latest CBA right? Go into the @CBA folder and check the version.txt ;Post that number)

Delete your RPT and try playing.

Post the new RPT.

There is no version.txt in my CBA folder but the in-game menu says it is 1.0.0.188. Stripping game of other mods didn't help, but here's the RPT http://www.sendspace.com/file/b2mfn6

Share this post


Link to post
Share on other sites
Could post my rtp file if that would help you./QUOTE]

Yah, post the RPT, at least the latest part before the crash!

You never fired a gun inside a building, did ya? ;) Its fine the way it is... in my opinion they are still to quiet but I kept it down for the general public.

Agreed. Gunshots indoors can echo like crazy. Everyone who was on a enclosed shooting range knows that ear protection is a must, now imagine small rooms....those sound waves bounce from wall to wall like insane, sort of like flashbangs.

Share this post


Link to post
Share on other sites
Tried playing with no other mods than CBAs. Game version is 1.60.87580. Files must be alright because I downloaded them for the second time, from the source you posted. I deleted JSRS 1.4.3.

I had the retail ArmA2 on a disc from a game mag (but it is most definitely a retail one since it runs mods and free one can't), and a bought Reinforcements on DVD. I did not download Update 2 since i just downloaded the updated one full, that you posted.

There is no version.txt in my CBA folder but the in-game menu says it is 1.0.0.188. Stripping game of other mods didn't help, but here's the RPT http://www.sendspace.com/file/b2mfn6

Hmm... I just compare now with my version:

Arma 2 CO 1.62.100544

CBA 1.00.190

CBA A2 1.00.8

CBA OA 1.00.6

See the difference ;) You should get the latest Patch though: http://www.armaholic.com/page.php?id=17252

After that, try: http://www.armaholic.com/page.php?id=10989

Also I really suggest SixUpdater for the CBA's, the best way to keep them up to date!

LJ

Agreed. Gunshots indoors can echo like crazy. Everyone who was on a enclosed shooting range knows that ear protection is a must, now imagine small rooms....those sound waves bounce from wall to wall like insane, sort of like flashbangs.

Fired a 9mm pistol in a room of 25 m² ones. I went almost deaf, JSRS almost never made it :P

EDIT:

Updated the ReadMe (front page) and added the version numbers just to make sure for what "latest version" I base my stuff on ;)

Edited by LordJarhead

Share this post


Link to post
Share on other sites
Hmm... I just compare now with my version:

Arma 2 CO 1.62.100544

CBA 1.00.190

CBA A2 1.00.8

CBA OA 1.00.6

See the difference ;) You should get the latest Patch though: http://www.armaholic.com/page.php?id=17252

After that, try: http://www.armaholic.com/page.php?id=10989

Also I really suggest SixUpdater for the CBA's, the best way to keep them up to date!

LJ

Fired a 9mm pistol in a room of 25 m² ones. I went almost deaf, JSRS almost never made it :P

EDIT:

Updated the ReadMe (front page) and added the version numbers just to make sure for what "latest version" I base my stuff on ;)

I updated the game to 1.62 and IT WORKS!!! Thanks LJ, you're grand! The additional sfx really add to the immersion.

Share this post


Link to post
Share on other sites
I updated the game to 1.62 and IT WORKS!!! Thanks LJ, you're grand! The additional sfx really add to the immersion.

Haha, you're welcome ;) Have fun finally!

LJ

Share this post


Link to post
Share on other sites
Could post my rtp file if that would help you./QUOTE]

Yah, post the RPT, at least the latest part before the crash!

Uploaded it to your devheaven bug tracker.

Share this post


Link to post
Share on other sites

Try to delete the jsrs_FFAR_c.pbo from your addons folder and repeat the test, see if you still crash then...

LJ

Edited by LordJarhead

Share this post


Link to post
Share on other sites

Hi Jarhead,

Just wanted to post that this is beyond doubt the king of soundmods now.

I would normaly switch out one or two pbo's ... but I played a session last night (havent played arma in months but this always brings me back) and I couldn't fault it, and im a fussy audiophile git!

Great job, time taken has paid off, it simply feels so much better now with solid gunfire and just a small skirmish draws you in much more than before. I will say it again, BIS TAKE NOTE.

I would say that it was a shame it took you so long and disappointed the world not releases before the holidays, and also messing up Bikeys which clearly ruined peoples lives and scarred them for an eternity, you should me ashamed of yourself to be honest, you dont realise the impact you have on others entire lives pulling these kind of stunts. And to think you did this flying in the face of free work ... its a outrage! ;)

Share this post


Link to post
Share on other sites
Hi Jarhead,

Just wanted to post that this is beyond doubt the king of soundmods now.

I would normaly switch out one or two pbo's ... but I played a session last night (havent played arma in months but this always brings me back) and I couldn't fault it, and im a fussy audiophile git!

Great job, time taken has paid off, it simply feels so much better now with solid gunfire and just a small skirmish draws you in much more than before. I will say it again, BIS TAKE NOTE.

I would say that it was a shame it took you so long and disappointed the world not releases before the holidays, and also messing up Bikeys which clearly ruined peoples lives and scarred them for an eternity, you should me ashamed of yourself to be honest, you dont realise the impact you have on others entire lives pulling these kind of stunts. And to think you did this flying in the face of free work ... its a outrage! ;)

Hehe, thanks for the kind words matey!

You are very welcome ;) I hope you enjoy this little moddy and I hope we still have some time to play with this before Arma 3 hits the ground ;)

LJ

Share this post


Link to post
Share on other sites

This mod is awesome! Using it on my DayZ server

Share this post


Link to post
Share on other sites

OMER - how did you get it working?

I have the newest beta patch installed 100296.

I've got a fresh download of the CBA suite (CBA / CBA_A2 / CBA_OA)

I've got the full install of JSRS (redownloaded today).

When I launch, i'm using the parameters "-mod=@CBA;@CBA_A2;@CBA_OA;@JSRS 1.5;Expansion;"

When I do that, I get kicked with the following message.

jsrs%20error1.jpg

So ok... I remove the @CBA_OA part of the call.

I then get this error.

jsrs%20error2.jpg

So... I CAN load JSRS by just using @CBA.... but it doesn't seem right. I had it working on my test server 2 days ago with all three CBA mods working, and the sound was much better. ANYONE got an idea of what's going on and what I can do to fix it?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×