Jump to content

Recommended Posts

Alright, I have a question, I have the steam version of the game, where would I add my mods to to be able to enable them with the launcher, I have tried the AddOns file in the ARMA 2 Directory and they didnt show up on the launcher, please help :confused_o:

Never put anything in the default "AddOns" folder in the game directory. Apart from possibly borking the installation, each & every mission you create will require anyone attempting to play it to have all of your addons.

You need to create new folders in the main game directory with appropriate names preceded by the @ symbol, e.g., @mod1, @mod2, etc. See this excellent tutorial on Armaholic:

http://www.armaholic.com/plug.php?e=faq&q=18

BR

Orcinus

Share this post


Link to post
Share on other sites

Alright, I figured it out, silly Nightmare had put the wrong selection path for the launcher so it couldnt find the mods, I just had to add an additional search path

*Edit* Does I44 work with this launcher? or is it abnormal when you press start game it brings up the launcher again

Edited by NightmareUS

Share this post


Link to post
Share on other sites

any chance to have this also working with the new takeon helicopter-rearmed beta ? would be great. also the the comiing soon takeon patch 1.06.

liek the launcher. thx for your work.

Share this post


Link to post
Share on other sites

Like it ? I LOVE IT ! I couldn't possible work without it. Being able to change all my mods at a single click is indispensable.

Share this post


Link to post
Share on other sites

I have just one problem with this launcher.

When I start it up. I get it on the task bar yet if I click it nothing shows up. Just the icon representing the launcher is happening on the task bar. Nothing else. I tried bring to front and stuff on Windows Task Manager to no avail.

Anyone have any ideas?

Share this post


Link to post
Share on other sites
*Edit* Does I44 work with this launcher? or is it abnormal when you press start game it brings up the launcher again

Yes I44 works with the launcher. As long as it's in an @I44 folder in your game dir the launcher will automatically find it.

I have just one problem with this launcher.

When I start it up. I get it on the task bar yet if I click it nothing shows up. Just the icon representing the launcher is happening on the task bar. Nothing else. I tried bring to front and stuff on Windows Task Manager to no avail.

Anyone have any ideas?

Try right clicking the icon in the system tray and then click "Reset window position".

Share this post


Link to post
Share on other sites
Yes I44 works with the launcher. As long as it's in an @I44 folder in your game dir the launcher will automatically find it.

Try right clicking the icon in the system tray and then click "Reset window position".

I love you man.

Thanks!

Share this post


Link to post
Share on other sites

Im having issues with the mod launcher. I use it all the time but now whenever I try to launch arma 2 and error pops up saying "arma 2 OA has stopped working" even though I was JUST playing it 2 minutes ago.

EDIT: It might be an OA issue since I cant launch it standalone. Dafuq?

Edited by solidsnake2384

Share this post


Link to post
Share on other sites

When i open it, it starts minimized and i cannot get it out of bieng minimized, i have totally uninstalled and reinstalled three times and still no joy. Any ideas? Worked flawlessly until about twenty minutes ago!

Share this post


Link to post
Share on other sites

this addon launcher is not working completely for me. I had to write each addon folder in the path! Same thing happens each time I add a new addon. It is not very problematic cuz I only run a group of addons. But this only works with either Arma2 o Arma2:AO/CO, if I add the path for arma2 the path is set for AO, and viceversa. So I use another launcher for Arma2 and this one for OA/CO. The problem is that sometimes when addin a new addon or I don't by which reason the path is erased for the mod folders. To make it clear: clicking on each addon folder in the addon group does not add the given addon folder to the path automatically, as I've seen in this video (

).

I've seen some ppl saying in fact they have the same problem (once I looked for arma tutorial videos and some guys installed this launcher and you can see they had problems making it work). So, I suspect that this launcher works for some PCs but not others (what it be the reason). So, I cannot find another launcher for CO (yes there are for OA but not CO), seems it is the only one, or is there another? Or is there a solution for my problem?

I hadn't this problem in my old computer, now I have a new computer (6 months old) I run windows 7 and i have Steam

I expect BIS makes an official arma3 launcher as since arma2 part of the community has issues on this matter.

Share this post


Link to post
Share on other sites
this addon launcher is not working completely for me. I had to write each addon folder in the path! Same thing happens each time I add a new addon. It is not very problematic cuz I only run a group of addons. But this only works with either Arma2 o Arma2:AO/CO, if I add the path for arma2 the path is set for AO, and viceversa. So I use another launcher for Arma2 and this one for OA/CO. The problem is that sometimes when addin a new addon or I don't by which reason the path is erased for the mod folders. To make it clear: clicking on each addon folder in the addon group does not add the given addon folder to the path automatically, as I've seen in this video (
).

I've seen some ppl saying in fact they have the same problem (once I looked for arma tutorial videos and some guys installed this launcher and you can see they had problems making it work). So, I suspect that this launcher works for some PCs but not others (what it be the reason). So, I cannot find another launcher for CO (yes there are for OA but not CO), seems it is the only one, or is there another? Or is there a solution for my problem?

I hadn't this problem in my old computer, now I have a new computer (6 months old) I run windows 7 and i have Steam

I expect BIS makes an official arma3 launcher as since arma2 part of the community has issues on this matter.

Im sad to say that this launcher ERASES your addonfolders... I thouhgt to erase all settings including addon folder links to make it work, but it erased addon folders not just the links of this launcher to the addon folder (which is what I wanted)... well seems Im downloading again those 40 addons again... This has become annoying... Not blaming addon makers for filling a gap, but BIS does need to realease an *official* launcher

Share this post


Link to post
Share on other sites

The only version available on Armaholic is 1.4.0 but the latest version is 1.4.1. Anyone have the link for the newest version? The authors domain seems to be expired :(

Share this post


Link to post
Share on other sites

I can't the game to automatically load up ACR using this launcher. I've done the trick detailed below

http://forums.bistudio.com/showthread.php?135429-Army-of-the-Czech-Republic-DLC&p=2213118&viewfull=1#post2213118

And sure enough, if I run the game from the exe in the root directory, it loads the ACR in the same way it loads the other DLCs.

But with this launcher, it doesn't. Not a real problem as ACR is shit at the moment, but hopefully when it's patched and good, we'll want to use it.

Share this post


Link to post
Share on other sites

With Launcher 1.4.1, if you select Arma II - CO + beta to run, this is the modline:

"-mod=C:\Program Files\Bohemia Interactive\ArmA 2;Expansion;ca;Expansion\beta;Expansion\beta\Expansion"

This runs A2 as a mod, which is incorrect; you will get Arma 2 showing up twice in the expansions list after you start the game (otherwise everything runs fine, I think).

If you select Arma II - OA + beta to run, the modline is correct for CO:

"-mod=Expansion\beta;Expansion\beta\Expansion"

In addition, shouldn't the modline for the beta now be "-beta" instead of "-mod"? Here is the correct beta modline:

"C:\Program Files\Bohemia Interactive\ArmA 2\Expansion\beta\arma2oa.exe" -beta=Expansion\beta;Expansion\beta\Expansion ...

ACR must be selected as a mod with the Launcher for it to run properly, due to its new registry-based origin.

Share this post


Link to post
Share on other sites

Arma 2 showing up as a mod is fine. That is how CO is supposed to work as all it does is tell the exec to look for content A2 folders at the specified location.

The beta exec is ran as a mod to override the original, but also be able to easily switch back with a simple removal of the \beta.

Here's my full vanilla + all DLC + beta line:

"-mod=S:\Steam\SteamApps\common\arma 2;Expansion;ca;Expansion\beta;Expansion\beta\Expansion;baf;pmc;acr"

It looks weird with all the beta folders, but that's because there's files in all of them that are required for launch.

Here's without the beta:

"-mod=S:\Steam\SteamApps\common\arma 2;Expansion;ca;baf;pmc;acr"

Share this post


Link to post
Share on other sites

Yes, CO works fine if A2 is loaded as a mod of OA, but you get A2 showing twice in the expansion list. See shot below, which uses the launcher to launch CO, and I've selected ACR as a mod:

85de5f212542581.jpg

"-mod=C:\Program Files\Bohemia Interactive\ArmA 2;Expansion;ca;Expansion\beta;Expansion\beta\Expansion;acr" -nosplash -winxp -world=empty -maxMem=2047 

With the above, everything will work fine, I believe, but it's annoying that A2 shows up twice (not a big deal though, obviously).

The issue is that the default CO shortcut, straight from BIS, uses this:

"C:\Program Files\Bohemia Interactive\ArmA 2\arma2OA.exe"

So, loading A2 as a mod of OA is not necessary to get CO to work perfectly; just run OA alone, and all is well (assuming that CO is installed properly).

Below is a shot of the expansions menu after using the launcher to start OA (NOT CO) with this modline:

"-mod=Expansion\beta;Expansion\beta\Expansion;acr" -nosplash -winxp -world=empty -maxMem=2047

37f4d2212741302.jpg

Note that CO is loaded perfectly, even though A2 was not loaded as mod to OA.

The solution for the launcher is simply have two game versions available to start, A2 and OA, omitting CO. That is the functionality of alpinestars' launcher (http://arma2.paro-technology.com/).

Edited by OMAC

Share this post


Link to post
Share on other sites

I can't understand how to enable DLC(PMC & BAF) full versions, i always get lite versions.

I have steam versions of ARMA 2, ARMA 2 OA, BAF and PMC.

Share this post


Link to post
Share on other sites

Hello,

I am the author of this software, it has been a long time since I've checked these forums. I just wanted to check in and say hello, but also to apologize that the software has not been maintained. I haven't played ARMA2 for over a year, and the launcher has been out of development for about that same time. It's hard to believe that it is almost 3 years old already. I didn't imagine that so many people would still be using it to this day.

It was working well at the time that I quit updating it, but since then I'm sure several things have changed. Judging by what I have read in more recent posts it doesn't behave the way it should. Use it at your own risk. Unfortunately I do not have the time to make updates/fixes right now, and it is probably unlikely that it will be developed any further. I may post the source code if anyone wants to continue its development. If I do, be aware that the code is messy because it was one of my first hobby software development projects.

Share this post


Link to post
Share on other sites
Hello,

I am the author of this software, it has been a long time since I've checked these forums. I just wanted to check in and say hello, but also to apologize that the software has not been maintained. I haven't played ARMA2 for over a year, and the launcher has been out of development for about that same time. It's hard to believe that it is almost 3 years old already. I didn't imagine that so many people would still be using it to this day.

It was working well at the time that I quit updating it, but since then I'm sure several things have changed. Judging by what I have read in more recent posts it doesn't behave the way it should. Use it at your own risk. Unfortunately I do not have the time to make updates/fixes right now, and it is probably unlikely that it will be developed any further. I may post the source code if anyone wants to continue its development. If I do, be aware that the code is messy because it was one of my first hobby software development projects.

It's a pity. But the program is still very good, though it needs a few fixes. Thanks SpiritedMachine!

Share this post


Link to post
Share on other sites
I may post the source code if anyone wants to continue its development. If I do, be aware that the code is messy because it was one of my first hobby software development projects.

Much appreciated. Is it C#? I was actually thinking to do a rewrite. What's your plan with ArmA 3?

Share this post


Link to post
Share on other sites

Even 3 years down the line, this is still the best launcher. It'd be cool if development could carry on.

Share this post


Link to post
Share on other sites
Much appreciated. Is it C#? I was actually thinking to do a rewrite. What's your plan with ArmA 3?

It was written in VB.NET, but in the past year or so my language of choice has become C#. Hearing from all of you is making me want to rewrite it in C# myself.

I'm not sure about ArmA3, I haven't given it any thought before now.

If I were to update the launcher, a list of things that aren't working correctly would be very helpful. Do most of the problems have to do with the latest DLC? (All I have is Operation Arrowhead, I never ended up buying BAF or PMC before I quit playing. I didn't even know about ACR until this morning.)

Edited by SpiritedMachine

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×