Jump to content

Recommended Posts

Hi, I heard that the proper shortcut load order is for example:

nosplash -mod=

But in this launcher nosplash is placed at the right. For example:

-nosplash -showScriptErrors -maxMem=2047 -cpuCount=2

Share this post


Link to post
Share on other sites
Hi, I heard that the proper shortcut load order is for example:

nosplash -mod=

But in this launcher nosplash is placed at the right. For example:

-nosplash -showScriptErrors -maxMem=2047 -cpuCount=2

The order you put most things doesn't matter. The way the launcher does it is correct.

Share this post


Link to post
Share on other sites
The order you put most things doesn't matter. The way the launcher does it is correct.

What? You mean the this launcher places the mods in the right order automatically?

Share this post


Link to post
Share on other sites

Yes I think you are a little confused... understandable if your just getting into mods and stuff for Arma II. :)

I'll try to explain it a little better.

-nosplash -mod=@mod1;@mod2 -skipIntro etc... those are all startup parameters and do not matter what order they go in.

http://community.bistudio.com/wiki/ArmA:_Startup_Parameters

The actual -mod=@mod1;@mod2 parameter CAN control what order a specific mod is launched... I believe it loads last mod as priority (so let's say you have 2 sound mods, I believe the last one listed would be read last and therefore would be used).

http://www.wikihow.com/Create-Mod-Folders-in-Arma-2

If I confused you even more I'm sorry. The search feature really is your best friend here.

Good luck and have fun.

As far as this launcher goes, without it there's no way I'd be able to manage the amount of stuff I play with.

Edited by Mosh
more info

Share this post


Link to post
Share on other sites
Yes I think you are a little confused... understandable if your just getting into mods and stuff for Arma II. :)

I'll try to explain it a little better.

-nosplash -mod=@mod1;@mod2 -skipIntro etc... those are all startup parameters and do not matter what order they go in.

http://community.bistudio.com/wiki/ArmA:_Startup_Parameters

The actual -mod=@mod1;@mod2 parameter CAN control what order a specific mod is launched... I believe it loads last mod as priority (so let's say you have 2 sound mods, I believe the last one listed would be read last and therefore would be used).

http://www.wikihow.com/Create-Mod-Folders-in-Arma-2

If I confused you even more I'm sorry. The search feature really is your best friend here.

Good luck and have fun.

As far as this launcher goes, without it there's no way I'd be able to manage the amount of stuff I play with.

Thanks buddy for your explanation and links, you explained it very well:bounce3:

Btw, you were correct in assuming i am new. (joined in 2 days ago) I noticed you joined in in 2002, wow. I thought i was a veteran in my forum(Elder scrolls) I joined there in 2003. I believe Arma2 is becoming my new obsession. Amazing and unique military game. The most serious game of any genre out there I believe.

Edited by Lorca

Share this post


Link to post
Share on other sites

Sorry, for the double post. I was wondering if the launcher is capable of writing down in notepad for example the script errors in the game when "show script errors" is enable? I'm trying to write down on a piece of paper those game errors but they fly so fast.

Share this post


Link to post
Share on other sites

Check your error report file:

C:\Users\YourWindowsUsername\AppData\Local\ArmA 2 OA\arma2OA.RPT

Share this post


Link to post
Share on other sites
Check your error report file:

C:\Users\YourWindowsUsername\AppData\Local\ArmA 2 OA\arma2OA.RPT

Ah, thanks buddy.

Share this post


Link to post
Share on other sites

i have a suggestion for ur next update. plz plz plz do it

since these there r so many mod out there and every server love to run their own selection of modsssss, almost every bloody server does it. (thats great, all those excellent mod won't go to waste but also very annoying)

trying to match their mod isn't the worst part, to make it worse every bloody server keep every things in 1 mod folder like say (@UOmod or @pecamod or @XRIP2011) u can't tell whats inside!!!!!!!!! just by looking at it.

its frankly a bitch to follow, lucky we hav your spirited machine arma luncher and yoma addon sync...

first:

i use yoma to find out what inside (@UOmod or @pecamod or @XRIP2011) or other mods they using.

then:

i use your arma launcher to build up a profile run certain mods just for that server.

so i don't hav to DL the same mod over n over n over n over, normally these (@UOmod or @pecamod or @XRIP2011) share atleast 50% or more identical mods. thats where your arma launcher really come in handy.

!!!!!!!!!!!skip the trash talk above here is the main point!!!!!!!!!!!!!!

its very hard to pick out the necessary mod to build up a profile to match a the server mods. when you have 80+ mods in your arma folder.

i just wonder if u could add the group directory function to the (available addons) side too. for quicker access and better organizsastion.

though it must be share by all profile, or else it is just pointless doing so. since it only come in handy when u create a new profile.

so u won't need to spend whole day to build up a profile because u need to pick out that 1 mod from that endless list.

visual explanations:

http://img21.imageshack.us/f/mysuggestion.jpg

Edited by j rock

Share this post


Link to post
Share on other sites

Spirited Machine - a little help please if possible. I have just downloaded and installed your launcher (v1.4.0) and configured it with my Steam-based Combined Ops installs and mods.

However, despite the summarised launch line at the bottom looking fine, it insists on loading Arma2 (not OA engine / combined ops) no matter what I do. I even changed the "Arma II" path from the A2 executable to the OA one to trick it, yet somehow it is still loading arma 2 1.08?!? I am at a loss as to 1/ why it is doing this, and 2/ how does it even know what/where to load arma2 having reconfigured it and hidden the path?

Is this a known issue for the latest steam versions? Any workarounds? Unfortunately the launcher and its handy grouping features are rendered useless to me as it plain refuses to work. :(

Share this post


Link to post
Share on other sites
Spirited Machine - a little help please if possible. I have just downloaded and installed your launcher (v1.4.0) and configured it with my Steam-based Combined Ops installs and mods.

However, despite the summarised launch line at the bottom looking fine, it insists on loading Arma2 (not OA engine / combined ops) no matter what I do. I even changed the "Arma II" path from the A2 executable to the OA one to trick it, yet somehow it is still loading arma 2 1.08?!? I am at a loss as to 1/ why it is doing this, and 2/ how does it even know what/where to load arma2 having reconfigured it and hidden the path?

Is this a known issue for the latest steam versions? Any workarounds? Unfortunately the launcher and its handy grouping features are rendered useless to me as it plain refuses to work. :(

Do you have the correct version selected in the dropdown menu just above the start button?

Edited by SpiritedMachine

Share this post


Link to post
Share on other sites

Yep, CO is definately selected. And as i say, the modpath looks as I would expect (having familiarised myself with the necessesary CO'fication of Steam OA):

Presently, at the bottom it shows:

"-mod=D:\Games\Steam\steamapps\common\arma 2;Expansion;ca;@acre;@cba;@fallujah1_1;@jayarma2lib;@lingor;@okt_noblur" "-name=TeeCee" -nosplash -maxMem=2047 -cpuCount=4 -exThreads=7

...with "D:\Games\Steam\steamapps\common\" being my steam app root.

Testing further, even selecting "Arma II - OA" it STILL loads Arma2!?!

I have:

- Uninstalled, and ensured c:\progra...\sprited machine\.. was wiped clean.

- Cleared out C:\users\<me>\appdata\local & roaming of "sprited machine" saved data files

- Reinstalled using download from your site in 1st post

- Re-setup the app double-checking exe location paths etc

- Identical behaviour - any option loads Arma2 irrespective of dropdown choice (and even if I point the arma2 exe at the OA one...).

The main app claims to be v1.4.0.0, but despite the clean reinstall I can see that in:

- "Help - About", it reads 1.3.3.0

- <appdata>\local\spirited machine\ , it reads 1.3.3.0

Is that normal?

Are there any registry entries that need clearing?

Why / how else is this application finding my arma2.exe, even when I trick it?

Can I provide any form of debug / error / test files, or further info?

Share this post


Link to post
Share on other sites
...

Are there any registry entries that need clearing?

Why / how else is this application finding my arma2.exe, even when I trick it?

Can I provide any form of debug / error / test files, or further info?

It doesn't do anything with registry. The only thing it knows is what you provide it. I've never run into a problem like this myself, and no one else has reported it.

The only thing I could look at would be your settings files and/or screenshots of the app. But it sounds to me like you know what you're doing, so I'm not sure what I could tell you.

Share this post


Link to post
Share on other sites

Okey. Probably useless to you at this point, but I have assembled what you requested anyway, not that it seems to show much.

You can grab a screenshot and the user-profile config files from my latest clean install HERE.

Other info: Vista 64 SP2, Steam based Arma2 + OA installs.

Very, very odd issue or bug for sure. :confused:

Share this post


Link to post
Share on other sites
Okey. Probably useless to you at this point, but I have assembled what you requested anyway, not that it seems to show much.

You can grab a screenshot and the user-profile config files from my latest clean install HERE.

Other info: Vista 64 SP2, Steam based Arma2 + OA installs.

Very, very odd issue or bug for sure. :confused:

The issue had to do with an error in my code when the launch delay timer was used. It has been fixed in version 1.4.1, which is available now by the built-in updater, or on the original post of this thread.

Share this post


Link to post
Share on other sites

Im having trouble launching. cant even launch getting NET framework error.

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.Configuration.ConfigurationErrorsException: Configuration system failed to initialize ---> System.Configuration.ConfigurationErrorsException: Invalid character in the given encoding. Line 1, position 1. (C:\Users\damon\AppData\Local\Spirited_Machine\ARMA2_Launcher.exe_Url_gmdmynthavifqkudqwj42kxvph0u2asf\1.3.3.0\user.config line 1) ---> System.Xml.XmlException: Invalid character in the given encoding. Line 1, position 1.

at System.Xml.XmlTextReaderImpl.Throw(Exception e)

at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)

at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res)

at System.Xml.XmlTextReaderImpl.InvalidCharRecovery(Int32& bytesCount, Int32& charsCount)

at System.Xml.XmlTextReaderImpl.GetChars(Int32 maxCharsCount)

at System.Xml.XmlTextReaderImpl.ReadData()

at System.Xml.XmlTextReaderImpl.SwitchEncoding(Encoding newEncoding)

at System.Xml.XmlTextReaderImpl.ParseXmlDeclaration(Boolean isTextDecl)

at System.Xml.XmlTextReaderImpl.Read()

at System.Xml.XmlTextReader.Read()

at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)

at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()

--- End of inner exception stack trace ---

at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)

at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)

at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()

at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)

--- End of inner exception stack trace ---

at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(Object sender, InternalConfigEventArgs e)

at System.Configuration.Internal.InternalConfigRoot.OnConfigRemoved(InternalConfigEventArgs e)

at System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(String configPath, BaseConfigurationRecord configRecord)

at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)

at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)

at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)

at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String sectionName)

at System.Configuration.ConfigurationManager.GetSection(String sectionName)

at System.Configuration.ClientSettingsStore.ReadSettings(String sectionName, Boolean isUserScoped)

at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(SettingsContext context, SettingsPropertyCollection properties)

at System.Configuration.SettingsBase.GetPropertiesFromProvider(SettingsProvider provider)

at System.Configuration.SettingsBase.GetPropertyValueByName(String propertyName)

at System.Configuration.SettingsBase.get_Item(String propertyName)

at System.Configuration.ApplicationSettingsBase.GetPropertyValue(String propertyName)

at System.Configuration.ApplicationSettingsBase.get_Item(String propertyName)

at ARMA2_Launcher.My.MySettings.get_winwidth()

at ARMA2_Launcher.Main.MainForm_Load(Object sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Form.OnCreateControl()

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ScrollableControl.WndProc(Message& m)

at System.Windows.Forms.ContainerControl.WndProc(Message& m)

at System.Windows.Forms.Form.WmShowWindow(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4952 (win7RTMGDR.050727-4900)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

----------------------------------------

ARMA2 Launcher

Assembly Version: 1.3.3.0

Win32 Version: 1.4.0.0

CodeBase: file:///C:/Program%20Files/Spirited%20Machine/ArmA%20II%20Launcher/ARMA2%20Launcher.exe

----------------------------------------

Microsoft.VisualBasic

Assembly Version: 8.0.0.0

Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Runtime.Remoting

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

----------------------------------------

System.Configuration

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)

CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Share this post


Link to post
Share on other sites
Looks like you have .NET Framework 2, you need 3.5.

I downloaded 4.0 AND 3.5

edit: Its been working fine and for some reason stopped working.

Share this post


Link to post
Share on other sites

Any reply dude?

Ive been using the launcher for ages, I downloaded NET 4.0 and it still isnt working...

Share this post


Link to post
Share on other sites
I downloaded 4.0 AND 3.5

edit: Its been working fine and for some reason stopped working.

If all else fails unistall/reinstall the launcher?

Share this post


Link to post
Share on other sites
If all else fails unistall/reinstall the launcher?

Done, 3 times.

Deleted NET 4.0 and 3.5, Reinstalled, Nothing.

Ive done pretty much everything, Are there any other launchers than control mods and let you launch CO?

Share this post


Link to post
Share on other sites

Not sure about other launchers... haven't used anything else since this was released, did you delete any files left over from program?

Look in

C:\Users\YOU\AppData\Local\Spirited_Machine

I once had an issue where deleting the old files and reinstalling helped... only reason I suggested that.

Share this post


Link to post
Share on other sites
Not sure about other launchers... haven't used anything else since this was released, did you delete any files left over from program?

Look in

C:\Users\YOU\AppData\Local\Spirited_Machine

I once had an issue where deleting the old files and reinstalling helped... only reason I suggested that.

Im using W7 and In my user folder for me, There is no AppData.:butbut:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×