Jump to content

Recommended Posts

Wonderful with the last version!

Instant startup compared to the (very) slow old one. I like it a lot, thank you!

Share this post


Link to post
Share on other sites

I'm glad to see that this worked for some of you that were having problems.

1.3.3 won't add my AddOns to the parameters window no matter what I click... It seems them, I can click on them and add them to groups, but it won't add them to the line.

I don't know what to tell you on that. All I can say is just make sure the topmost box in the Groups tree-structure is checked, as well as all the mods you intend to use.

Thanks for this great launcher!

I would like to be able to change the row of the mods to be started.

Like mod3 -> mod6 -> mod1

Is this possible ?

Do you mean change the order that the mods load? In the Addon Options tab you can either use the arrow buttons or drag and drop. If you mean reorder them in the "Groups" tree-structure, you can drag and drop items anywhere you want, including groups.

I've recently switched to this launcher and I really like it. Is there a way to auto-load TrackIR for those times when I stupidly forget to manually start it?

That's something I've been meaning to add, but haven't yet. You can see on the External Apps tab I have included Ventrilo, Teamspeak, and FRAPS. I'm going to get rid of those three things and instead allow you to add any external application you want, as well as command-line parameters. I assume starting TrackIR is just as simple as starting up an executable?

Share this post


Link to post
Share on other sites
do you mean change the order that the mods load?

thx ;)

;)

Share this post


Link to post
Share on other sites

allow you to add any external application you want, as well as command-line parameters. I assume starting TrackIR is just as simple as starting up an executable?

That'd be cool. Yes, TIR starts without any parameters, it loads up the default profile when it starts.

Here's another program I would like to have started automatically at the same time as the game..

http://electracode.com/4/joy2key/JoyToKey%20English%20Version.htm

(allows me a comms transmit key on my joystick.)

Share this post


Link to post
Share on other sites

Hi SpiritedMachine,

I tried your launcher today and found it useful and easy to manage. Just one little thing disturbs me: if I create any profiles with it, your launcher goes to the Arma2 other profiles folder on the system partition ("C").

I do not want to clutter my system partition with the big savegames of A2 campaigns and missions and therefor have a commandline parameter added to my manually created shortcuts pointing to a profiles folder WITHIN my game directory for A2. It's named Profiles and the shortcut parameter is accordingly like this: -profiles=Profiles.

I cannot add this parameter to the commandline in your launcher, but would very much like to. If you think it's possible to choose a profiles location in the next version of your otherwise great working launcher, that would be cool!

keep up the good work,

touristo

Share this post


Link to post
Share on other sites
Hi SpiritedMachine,

I tried your launcher today and found it useful and easy to manage. Just one little thing disturbs me: if I create any profiles with it, your launcher goes to the Arma2 other profiles folder on the system partition ("C").

I do not want to clutter my system partition with the big savegames of A2 campaigns and missions and therefor have a commandline parameter added to my manually created shortcuts pointing to a profiles folder WITHIN my game directory for A2. It's named Profiles and the shortcut parameter is accordingly like this: -profiles=Profiles.

I cannot add this parameter to the commandline in your launcher, but would very much like to. If you think it's possible to choose a profiles location in the next version of your otherwise great working launcher, that would be cool!

keep up the good work,

touristo

If you add "-profiles=Profiles" in the Additional Parameters box, does that do what you want? If not, I'm afraid I don't follow what it is you're trying to do.

Share this post


Link to post
Share on other sites
I don't know what to tell you on that. All I can say is just make sure the topmost box in the Groups tree-structure is checked, as well as all the mods you intend to use.

They are. :(

nomodsshowing.jpg

Update: Total reinstall seemed to fix this. When I clicked on the Profiles option I'd received an Unexpected Exception thing with references to the profiles XML.

Edited by kylania

Share this post


Link to post
Share on other sites
Update: Total reinstall seemed to fix this. When I clicked on the Profiles option I'd received an Unexpected Exception thing with references to the profiles XML.

You mean when you click on profiles now it shows you an exception, or it was before you reinstalled?

If you continue to have problems you can clean up your data files by clicking on "Save Data Cleanup" under the help menu. If one of your data files is corrupted it may be causing problems.

Share this post


Link to post
Share on other sites
I've recently switched to this launcher and I really like it. Is there a way to auto-load TrackIR for those times when I stupidly forget to manually start it?

Just FYI.

If you forget to pre load Track IR5 software you can still get it going after the game has started. All you have to do is alt tab, start Track ir software, go back into the game and just enter the key bindings window in options. The moment you enter that window track ir will reactivate. So you just close it again and start playing.

Share this post


Link to post
Share on other sites
Just FYI.

If you forget to pre load Track IR5 software you can still get it going after the game has started. All you have to do is alt tab, start Track ir software, go back into the game and just enter the key bindings window in options. The moment you enter that window track ir will reactivate. So you just close it again and start playing.

Nice one, thanks :)

Share this post


Link to post
Share on other sites

I found a bug.

In Addons Tab -> Addons Groups window

If i right-click an addon and select Move Up/Move Down - i'm getting unhandled exception.

It works, if i try to move the whole group.

Drag and drop works fine.

Thank you for this great mod, since i'm on steam i find it invaluable.

Share this post


Link to post
Share on other sites
I found a bug.

In Addons Tab -> Addons Groups window

If i right-click an addon and select Move Up/Move Down - i'm getting unhandled exception.

It works, if i try to move the whole group.

Drag and drop works fine.

Thank you for this great mod, since i'm on steam i find it invaluable.

Thanks, I'll work on that this weekend.

Any planes making a update to take into account official DLC?

Launch with DLC, yes no, or something like that?

I haven't been in the loop lately when it comes to Arma, I don't know anything about it. It doesn't run like a normal mod? I'll have to take a look this weekend.

Share this post


Link to post
Share on other sites

Has there been any work to fix the Launcher working with the STEAM Version? Now that the 1.54 patch is out, my beta is outdated and I want to use all those goodies with my mods :\

Share this post


Link to post
Share on other sites
Has there been any work to fix the Launcher working with the STEAM Version? Now that the 1.54 patch is out, my beta is outdated and I want to use all those goodies with my mods :\

That's something you'd have to ask the BIS team, it has nothing to do with my launcher. It's all about whether or not they still use Steam security with Operation Arrowhead.

Share this post


Link to post
Share on other sites
Has there been any work to fix the Launcher working with the STEAM Version? Now that the 1.54 patch is out, my beta is outdated and I want to use all those goodies with my mods :\

This launcher works with steam, I have ArmA2, ArmA2:OA and BAF-DLC from steam and it all works with this launcher.

Edited by Jonn

Share this post


Link to post
Share on other sites
This launcher works with steam, I have ArmA2, ArmA2:OA and BAF:DLC from steam and it all works with this launcher.

Same here, no problems at all. Even with the latest beta.

Share this post


Link to post
Share on other sites

Weird, everytime I set it to CO or OA and try to use the launcher it opens up the Steam dialog box you know... "Preparing to Launch Arma 2: Operation Arrowhead"

And it will just stay there. HOWEVER it works fine if I just launch Arma 2 with my mods. Gah!

Share this post


Link to post
Share on other sites

sorry if it's obvious, but can I use this launcher to run Arma2 as Administrator in Windows 7?

Share this post


Link to post
Share on other sites
Weird, everytime I set it to CO or OA and try to use the launcher it opens up the Steam dialog box you know... "Preparing to Launch Arma 2: Operation Arrowhead"

And it will just stay there. HOWEVER it works fine if I just launch Arma 2 with my mods. Gah!

I've noticed this sometimes too... I think it's something to do with "maximum allowed command line length" or something like that... I've noticed that if I shorten the total command line by unticking certain stuff - like "no splash screen", or simply by activating less modfolders, it works fine... too many, it hangs like you describe...

My setup is DVD A2, and Steam OA - so two different main directories means enormous commandlines...

B

Share this post


Link to post
Share on other sites

I see what you mean, I have 25 addons, and was able to launch it with CO, and just using 1 addon. With the beta, i could run all of them. Meh.

Share this post


Link to post
Share on other sites
I've noticed this sometimes too... I think it's something to do with "maximum allowed command line length" or something like that... I've noticed that if I shorten the total command line by unticking certain stuff - like "no splash screen", or simply by activating less modfolders, it works fine... too many, it hangs like you describe... Running it with all the extra crap beta adds in and most of my options wouldn't even load.

My setup is DVD A2, and Steam OA - so two different main directories means enormous commandlines...

B

Yup, I had this problem as well. I had Steam ArmA2 installed to E:\Steam\steamapps\common\arma2\arma2.exe or something and OA was in E:\arma2\bohemia interactive\operation arrowhead\arma2oa.exe so basically I could add one mod folder and options before I couldn't add anything else.

Initially I investigates subst'ing a drive letter to the root install folders, but eventually just bought the DVD of CO and installed it all to E:\CO and now i have no problems at all. :)

And yes, running the launcher as admin runs the game as admin. If you make shortcuts, just run those as admin.

Share this post


Link to post
Share on other sites

Hey SpiritedMachine,

Can you add an option to turn on TrackIR (like the fraps option) when you start the game, Please :pray: ?

Thanks

Share this post


Link to post
Share on other sites
I've noticed this sometimes too... I think it's something to do with "maximum allowed command line length" or something like that... I've noticed that if I shorten the total command line by unticking certain stuff - like "no splash screen", or simply by activating less modfolders, it works fine... too many, it hangs like you describe...

My setup is DVD A2, and Steam OA - so two different main directories means enormous commandlines...

B

Originally Posted by Bushlurker

I've noticed this sometimes too... I think it's something to do with "maximum allowed command line length" or something like that... I've noticed that if I shorten the total command line by unticking certain stuff - like "no splash screen", or simply by activating less modfolders, it works fine... too many, it hangs like you describe... Running it with all the extra crap beta adds in and most of my options wouldn't even load.My setup is DVD A2, and Steam OA - so two different main directories means enormous commandlines...

B

Yup, I had this problem as well. I had Steam ArmA2 installed to E:\Steam\steamapps\common\arma2\arma2.exe or something and OA was in E:\arma2\bohemia interactive\operation arrowhead\arma2oa.exe so basically I could add one mod folder and options before I couldn't add anything else.

Initially I investigates subst'ing a drive letter to the root install folders, but eventually just bought the DVD of CO and installed it all to E:\CO and now i have no problems at all. :)

And yes, running the launcher as admin runs the game as admin. If you make shortcuts, just run those as admin.

eeh... I didn't actually say the bit about the beta, Kylania... you shouldn't really "edit" peoples quotes - I've not actually been trying the betas - too busy working on my terrain project, but from the way this quote reads someone might think I have, and ask me questions about it, and I'd wonder why...:rolleyes:

B

Edited by Bushlurker

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×