Jump to content
vilas

Vilas addons in A3 w.i.p.

Recommended Posts

G'day @vilas

Welcome back to the community. I'm looking forward to seeing what content you bring to Arma3. I used to play with your A2 mods a lot.

 

I agree with @hcpookie. Let's just wait and see what Vilas is KIND enough to GIVE us to play with.

Share this post


Link to post
Share on other sites

i am still importing weapons but I have now 2 problems:

- weapon which has integral bipod - how to animate it ? i have no problem with bipod being item - animations work, but when bipod is integral part of weapon ? or i should do it simply "forever attached" and treated as "any other bipod"

- sight or weapon with integral laser or flashlight , for example we have one type of sight which has integrated laser , another example is submachinegun with built-in flashlight (yes, i know that it works as "item") 

Share this post


Link to post
Share on other sites

Integral flashlights are made in the same way as attachments. You just need to add the FlashLight property to the weapon class and define things from there (like in Arma 2):

 

class my_weapon: Rifle_Base_F
{
	...

	class FlashLight
	{
		color[] = {180, 160, 130};
		ambient[] = {0.89999998, 0.81, 0.69999999};
		intensity = 100;
		size = 1;
		innerAngle = 5;
		outerAngle = 100;
		coneFadeCoef = 8;
		position = "flash dir";
		direction = "flash";
		useFlare = 1;
		flareSize = 1.4;
		flareMaxDistance = 100;
		dayLight = 0;
		class Attenuation
		{
			start = 0;
			constant = 0.5;
			linear = 0.1;
			quadratic = 0.2;
			hardLimitStart = 27;
			hardLimitEnd = 34;
		};
		scale[] = {0};
	};

	...
};

Never tried integrated IR lasers though, so I'm not too sure whether you only need assign a value to irDistance or not.

Share this post


Link to post
Share on other sites

i will try with this flashlight, but so far I observed that :

 - integral bipod is always "on" , despite legs are hidden in model but in-game legs are opened imidiately (when bipod is part of weapon, not item) for example tactical foregrip with bipod, or sniper rifle shich is produced with it's own bipod (dedicated) 

- i tried few tricks but cannot force weapon sight to be laser pointer (example - old sight for Beryl : https://i.imgur.com/N8Ik1uf.jpg  this sight has laser , so it is combo 4x sight + laser beam (i would have to make invisible fake pointer which has memory points in place of sight - but this is nonsense cause player could de-attach this fake pointer or remove sight and pointer would remain) 

- integrated lasers also exist - Polish army has pistol called P-94L , it has integrated laser in its frame  (  https://docplayer.pl/docs-images/48/21205295/images/page_3.jpg   it is visible on photo )

Share this post


Link to post
Share on other sites

I'm late to the party .... Welcome back - always liked you're work mate.

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, vilas said:

- integral bipod is always "on" , despite legs are hidden in model but in-game legs are opened imidiately

 

Maybe try switching minValue and maxValue in weapon's class CfgModels.legs?

Share this post


Link to post
Share on other sites

Here's what I used for the PLA M99 bipod, based on the BIKI articles....

 

THe M99 has a fixed, permanent bipod.


modelcfg:

Spoiler



skeleton:
	class M99_bones: QBS06_bones {
		skeletonInherit = "QBS06_bones";
		skeletonBones[] = {
			"bipod_F","",
			"bipod_L","bipod_F",
			"bipod_R","bipod_F"
		};

	};

cfgmodels:
			class bipod_F {
				type = "rotation";
				source = "bipod";
				sourceAddress = "clamp";
				selection = "bipod_F";
				axis = "bipod_axis";
				memory = 1;
				minValue = 0;
				maxValue = 1;
				angle0 = 0;
				angle1 = "rad -90";
			};
			class bipod_L: bipod_F {
				selection = "bipod_L";
				axis = "bipod_L_axis";
				angle1 = "rad -17";
			};
			class bipod_R: bipod_F {
				selection = "bipod_R";
				axis = "bipod_R_axis";
				angle1 = "rad 17";
			};

 

 

 

and in the config, make sure to add:

		hasBipod = 1;
		deployedPivot = "bipod";

 

I haven't played with lasers yet... I think that someone made a sample laser once, and perhaps that or some other sample could be used to add the laser as part of the optic.  Multi-setting optics are typically cycled, so that you switch between the modes.  I'm really not sure how you would combine these except to add it as a red dot overlay on the optic, which would literally be a copy of the "normal" optic zoom, with the red laser dot on it.  So for example you might need to make:

low zoom

low zoom + laser

high zoom

high zoom + laser

secondary zoom

secondary zoom + laser

 

I don't see any other way to go about doing that.  And that assumes that the "red dot overlay" would work for your needs...

Share this post


Link to post
Share on other sites

As for lasers integrated in weapons/optics wouldn't something like that work?

class MyCoolWeapon: Rifle
{
  yadda="yadda";
  class Pointer
  {
    irLaserPos="laser pos";
    irLaserEnd="laser dir";
    irDistance=5;
  };
};

class MyCoolOptic: ItemCore
{
  yadda="yadda-yadda";
  class ItemInfo: InventoryOpticsItem_Base_F
  {
    moreyadda=true;
    class OpticsModes {};
    class Pointer
    {
      irLaserPos="laser pos";
      irLaserEnd="laser dir";
      irDistance=5;
    };
  };
};

I know that CUP got working integrated flashlight in their MP5, so having integrated laser in weapon shouldn't be out of realm of possibility.

 

But when it comes to lasers integrated in optics, I have a feeling that most important values are in class ItemInfo. In case of vanilla laser it's inheriting from class InventoryFlashLightItem_Base_F (optics inherit from InventoryOpticsItem_Base_F). Unfortunately I couldn't find that class content anywhere (only blank entry in weapons_f/acc).

 

Naturally you need memory points in the model set up.

Share this post


Link to post
Share on other sites

i had such model cfg, i had such config entry , the problem is that bipod is always "on", never "off" 

so it is always active , never hidden 

 

https://i.postimg.cc/TYMzRWnT/cooo1.jpg

 

in-game vs in buldozer 

 

"As for lasers integrated in weapons/optics wouldn't something like that work?"

 

weapon - but sight ? CWL-1 for Beryl ? it is sight with laser , not weapon with laser but sight (ITEM) with laser (another item) 

 

 https://i.postimg.cc/2y29F39K/cooo1.jpg

Share this post


Link to post
Share on other sites

Witamy spowrotem @vilas, ciekawy czyj rosomak wyjdzie pierwszy  😂

 

A tak poza tym na Grocie masz szyne picatinny i możesz montować na niej co tylko chcesz.

 

//eng

Welcome back vilas 

Share this post


Link to post
Share on other sites

i know there is picatiny but i want grip with bipod not bipod , game doesn't support grips as item, so it must be "new model" 

grip 1 , grip2, grip 3 - etc. must be new model not item that changes holding RTM

edit:

animrtm1.jpg  

i see that RTM differs from Arma2 because sizes of skeletons doesn't match but i fugured how to fix it , but there is problem that BISkeleton.p3d doesn't match size of A3 man, while man.p3d file from samples (which looks like skeleton) doesn't obey "show local axis" so there is need to use old BISkeleton 

 

 

  • Like 5

Share this post


Link to post
Share on other sites
15 hours ago, vilas said:

CWL-1 for Beryl ? it is sight with laser , not weapon with laser but sight (ITEM) with laser (another item)

 

I'm perfectly aware what CWL-1 is. In my example there's one class for gun with laser (class MyCoolWeapon), and one class for optic with laser (class MyCoolOptic). Issue is that while I'm 99% sure MyCoolWeapon will work, I have no idea if MyCoolOptic will do too, as I don't have any A3 optic model laying around for tests. Logic dictates that adding memory points to optic model, and then adding class Pointer to optic's class ItemInfo should be enough. But unfortunately BIS is BIS, and logic never worked in Bohemia land!

Share this post


Link to post
Share on other sites
9 minutes ago, vilas said:

i try to put icon and as visible author

 

Rather than cfg mods, try adding a mod.cpp file to your main root folder. 😉

Share this post


Link to post
Share on other sites

And I suspect Author isn't inherited (must be declared in each class).

Share this post


Link to post
Share on other sites

i found solution - i had to use @vilas folder on disc not Arma3/Addons but E:/@vilas/addons 

 

but still "author uknown"
 

Share this post


Link to post
Share on other sites

can someone help me with mass of weapons ?

all my weapons "weight zero"

i set mass in geometry, i set now mass = to weaponinfo and ... nothing

 

mass set in Geometry LOD

mass set in weaponsunitinfo: weaponsunitinfo (not like config paste-bin above)

 

i set mass in GEO like 5-6 , 1 unit is  1 kg ? 0.8kg ? 

but in config mass = 100 

 

should mass be bigger in GEO ?

 

i use BIS example of rifle and... it causes problem 

 

can it be due to BIS tools ? 

i set mass of rile like 5, 6, 7, i set mass in config - my rifles weight nothing

Share this post


Link to post
Share on other sites
10 hours ago, vilas said:

i set mass in geometry, i set now mass = to weaponinfo and ... nothing

 

GEO mass is measured in kilograms so a total "mass" of 1.000 in Object Builder equates to 1 kg.

 

On the other hand, config "mass" is separate and only determines how much stamina is consumed while the weapon is carried. It isn't measured in kilograms, and I don't think there's a real-world equivalent for it. Perhaps 1 "mass" = 0.1 grams? I'm not too sure though.

Share this post


Link to post
Share on other sites

Hm, and how the weapon not having mass  affect the game - you cannot drop it on the ground, it levitates, or what?
But if you cannot drop it - it might be connected with not closed/not convexed geometry or maybe lack of "autocenter=0" property of the Geo LOD? I wouldn't be also surprised if BI samples weren't updated to the recent changes in the game engine...
AFAIK 1.000 mass in Geometry LOD equals to 1.0 kg. The mass of weapon in config is unitless, or rather combined "volumemass" unit, in which relation between each - volume vs mass - is not clear to me. But, it was already checked by others, so: usually the real weight (mass) in kg is multiplicated by the ratio between 22 and 31 to get the mass of a weapon in config. Most of the BI default weapons follow ratio of ~29. So, 6kg x 29 gives 174 volumemass units in config. But don't cite me on that, no expert in this matter at all.
Maybe this topic will help you understand the problem?

 

Share this post


Link to post
Share on other sites
13 hours ago, vilas said:

mass set in Geometry LOD

mass set in weaponsunitinfo: weaponsunitinfo (not like config paste-bin above)

 

As @drebin052 noted, mass in Geo LOD and mass in config are two different things. The one in Geo LOD is your "real mass in kg", the one in config is an artificial value, sort of encumberance factor.

 

As for your problem - are you sure the class name is okay? It should be WeaponSlotsInfo, not WeaponsUnitInfo.

Share this post


Link to post
Share on other sites
On 2/15/2020 at 4:10 AM, wld427 said:

and you said you would never do it 🙂 !!!!

So did I. 😂

Vilas, it's very good to see you and your army of addons in ArmA3. Might be a long way to go, but better late than never I would say.

Looking forward to see what you pull out of your sleeve. 🙂

Share this post


Link to post
Share on other sites

seems that mass issue was... configuration of tools

i had configured other path than game was using so i was packing on and on and on changed new version but game was using "mod" from other folder (which had old version of addon), shame on me 😉

Share this post


Link to post
Share on other sites
On 3/12/2020 at 1:51 PM, Defunkt said:

And I suspect Author isn't inherited (must be declared in each class).

THIS!  Vilas, you have to put "author" for every. single. class.  No inheritance for that value!  I had the same exact problem!  Also don't forget to declare the icons so they appear in the menu.  That, and the editor preview pic has to be configured as well... I have a method to make those in bulk using GIMP..

 

On 3/8/2020 at 12:16 PM, vilas said:

i had such model cfg, i had such config entry , the problem is that bipod is always "on", never "off" 

so it is always active , never hidden 

 

https://i.postimg.cc/TYMzRWnT/cooo1.jpg

 

in-game vs in buldozer

I see.  I think you need to reverse the animations.  The PLA sniper rifle's bipod is configured to be "closed" by default.  Otherwise those config sections I previously mentioned would apply.  Also, make sure they aren't part of a different animation.  In other words, the skeleton bones should not be inheriting the bones from elsewhere; they should be at the "root" of the skeleton.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×