Jump to content

Recommended Posts

I could explain it, but I think its easier to just show you:

 

 

Features:

 

This mod does what it says, it caches some data that Zeus usually has to reload everytime you open the interface.

In short it fixes the freeze when opening the Zeus interface with many mods loaded.

I also optimized the searching in TreeViews (that is, all tree views anywhere, not just Zeus, even ones added by mods), I posted a video further below showing a comparison.

 

Limitations:

This might seem magic to you, and it kinda is but it also has some downsides:

- Only works with BattlEye disabled (This mod simply cannot possibly ever work with BattlEye unless you want to get game-banned permanently. So please stop asking me about BE compatibility)
- Disables Zeus pricing system (all units cost 0)

- Makes all units/vehicles/items from all loaded mods available, activatedAddons in mission.sqm or addCuratorAddons are all irrelevant, you cannot hide things.

 

Multiplayer notes:
This mod is clientside only. Only Zeus users need to load this.

You just need to add the bikey to the server to whitelist the pbo if you have signature verification enabled.

 

FAQ:

  1. Can you make a BE compatible version?
                No its not possible to make a BE compatible version.
  2. Can you get the mod whitelisted by BattlEye?
    I can. But it will just cause BE to gameban you, and I kinda don't wanna give you the ability to get yourself banned. Thank me later.
  3. Can you make a 32bit version?
    No, that would be a waste of time as barely anyone is on 32bit anymore, just use 64bit.
  4. Does this work with ZEN/Ares/Achilles?
    Yes.

 

Download:

You can get the mod here:

https://steamcommunity.com/sharedfiles/filedetails/?id=1908099028

I currently don't plan any other mirrors besides the steam workshop.

In case Armaholic decides to just upload this without asking me, Armaholic downloads are not official and not supported.

 

License:

This mod is licensed under CC-BY-NC-ND.

Meaning you cannot reupload it to the workshop, cannot share it without giving credit (not removing my name from the pbo is enough), and cannot sell it.

 

If you want to support me, I have a patreon, every dollar makes me happy and proud of my work. Link below.

  • Like 16
  • Thanks 4

Share this post


Link to post
Share on other sites

very nicely and well done

  • Like 2

Share this post


Link to post
Share on other sites

Hey mate, this is amazing!

I honestly have no clue how it works, so pardon the naive question: Any chance to see a version that works with BattlEye enabled?

Share this post


Link to post
Share on other sites
10 minutes ago, laxemann said:

Any chance to see a version that works with BattlEye enabled?

Battleye might auto-whitelist it when enough people try loading it with BE enabled. But I don't know if the code might trigger some other battleye detections, so.. Probably not.

  • Thanks 1

Share this post


Link to post
Share on other sites

I really do like this. Especially when running mods that add a lot of new units/factions to the Zeus interface.

 

I noticed a few issues however. It is a bit of a Russian roulette to open it for the first time for me,  it likes to crash 50/50 on initially entering Zeus.

 

Once the Zeus interface opens, you are golden so to speak. However I am also finding some issues there. First one is the Zeus search bar. If you search for example for "surv" you will find all units called "Survivor". Now with this result you do not clear the search bar and you close and open the Zeus interface again. Now, you only have Survivors in your unit tree. No way of getting any other units back. The issue is with all categories (units, groups, modules, markers, last used). This could be done until you cannot spawn anything in Zeus anymore unless you copy paste existing objects.

 

Another issue I noticed is while using Zeus Enhanced. I take it the mod readds the custom script modules once you reopen the interface, as the vanilla interface does not cache. This however means you end up with duplicate modules and duplicate Category groups.

Share this post


Link to post
Share on other sites
10 hours ago, diwako said:

It is a bit of a Russian roulette to open it for the first time for me,  it likes to crash 50/50 on initially entering Zeus.

Please, you telling me it crashes doesn't help at all when I cannot reproduce it. But if you send me the crashdump (mdmp, don't even need rpt) then I can see what went wrong and hopefully fix it.

mdmp could contain personal information (where your arma is installed and what other software you run) so I'd recommend not posting the link in public.

 

10 hours ago, diwako said:

you close and open the Zeus interface again. Now, you only have Survivors in your unit tree.

Theres one thing I didn't test. Thanks. I know how to solve that but it's gonna be annoying.

 

10 hours ago, diwako said:

This however means you end up with duplicate modules and duplicate Category groups.

I will solve this with the next update. Actually I think the fix for searching might also fix that.

 

I want to try this out tomorrow, so I guess I'll have to fix it today.

  • Like 1

Share this post


Link to post
Share on other sites

oo, nice man! I will try it when i get to PC.
 

16 hours ago, Dedmen said:

you cannot hide things.

 

so hideObject and hideObjectGlobal won't work, or what is that mean?

Share this post


Link to post
Share on other sites
39 minutes ago, Madin said:

oo, nice man! I will try it when i get to PC.
 

 

so hideObject and hideObjectGlobal won't work, or what is that mean?

its literally the first half of that sentence which gives context. you cant hide addons in zeus interface (tree structure on the right)

Share this post


Link to post
Share on other sites

Good news bois and gurls.
I have fixed the issue with searching (reported above) and also the Zen/Ares/Achilles module duplication issue.
Also the crashes that some people reported seem to be Arma's fault, or rather the memory allocators fault. BI already fixed that on latest RC branch, if you need a workaround you can change Arma's memory allocator to "system", but don't forget to change it back later.
I don't want to release the fixes yet, I found out why TreeView searches (which you do often in Zeus) are so slow, and I can fix that so I'll wait with the release till I'm done with that, if I can get it done today.
If I can't do that today then I guess I'll have to release the update without that.

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

Okey its done, update has been pushed to Steam.

Changelog:

Fixed Ares/Achilles/Zen causing duplicate entries in Modules lists
Fixed search getting "stuck" when leaving zeus
Made TreeView searches multithreaded, making them much faster (applies to all TreeViews, not just Zeus search)

 

And here is a video showing how much the TreeView search fix really does:

 

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

I made a bug report for this a while ago because the long loading times also come with some issues:

- The whole server will hang while the zeus is loading the interface.

- Slingloaded crates will drop when the server hangs for this long.

- Server hang is substantial, even with vanilla and arma on SSD on a public zeus server.

 

I haven’t tested if your mod fixes this issue, but regardless: This is more of a bug that should be fixed than something a mod should do.

Share this post


Link to post
Share on other sites
3 minutes ago, T. Miller said:

- The whole server will hang while the zeus is loading the interface.

Only if you are the server. Your game freezes, if your game is the server, the server freezes too.
Yes my mod fixes that too.

 

 

Share this post


Link to post
Share on other sites

It feels incredibly weird being able to practically instantly open the zeus interface now. Incredibly nice too! Thanks!

Now if only you could make the rest of Arma run as well.

Share this post


Link to post
Share on other sites
4 hours ago, T. Miller said:

The whole server will hang while the zeus is loading the interface.

In my experience, it is not loading the interface but assigning a Game Master module to a player. At least, that is the only time our server hangs related to Zeus.

Share this post


Link to post
Share on other sites

kudos Dedmen 👍

Share this post


Link to post
Share on other sites
8 hours ago, NeilZar said:

At least, that is the only time our server hangs related to Zeus.

Thats a different thing, I can fix that too but due to you basically only doing that once in a mission. I don't think its worth investing the time. Actually... You can fix that yourself.
Just give the game master module literally 0 addons, don't allow any addons.
Sending the addons to the server and back is the stuff that causes server lag, if you allow 0 addons then it shouldn't lag. My mod disables that whole addon system and always makes everything available, so even if you disable all addons and fix the server lag, Zeus users with my mod will still have access to everything.

Loading interface is clientside only, no effect on the server, though zeus spawned AI's run on the zeus, so if he lags, his AI does too.

Share this post


Link to post
Share on other sites

Found an issue with the search. When I search for something that doesn't exist, the tree remains empty after clearing the search bar in one go. Issue remains on reloading the interface and restarting the mission. Searching again for something returns the tree.

 

https://i.gyazo.com/cd4a3d80bd0a446f26a5d111ad3c9b34.mp4

Similar to this issue; if the search bar empties and a faction didn't show up in the last search it will be removed from the tree. *EDIT* < This issue happens sometimes, not everytime. 

Share this post


Link to post
Share on other sites

Exiting Zeus interface and reentering sometimes makes some units throw the Insufficient Resources prompt. Exiting and reentering again seems to fix it.

Tested with Gendarmerie men, keep exiting and reentering until it breaks seems to only happen sometimes.

 

2 hours ago, NeilZar said:

Found an issue with the search. When I search for something that doesn't exist, the tree remains empty after clearing the search bar in one go. Issue remains on reloading the interface and restarting the mission. Searching again for something returns the tree.

^^ also can confirm this, pressing *space* then *backspace* is the easiest way to bring back the entire tree.

Share this post


Link to post
Share on other sites
23 hours ago, T. Miller said:

I made a bug report for this a while ago because the long loading times also come with some issues:

- The whole server will hang while the zeus is loading the interface.

- Slingloaded crates will drop when the server hangs for this long.

- Server hang is substantial, even with vanilla and arma on SSD on a public zeus server.

 

I haven’t tested if your mod fixes this issue, but regardless: This is more of a bug that should be fixed than something a mod should do.

To add to this, if you remote control a unit and then exit that, that unit will be completely frozen while the interface is loading. Which can be especially jarring when you remote control a plane and then let go of it as it's still flying. I assume this mod will help with that too.

Share this post


Link to post
Share on other sites
5 hours ago, NeilZar said:

Found an issue with the search. When I search for something that doesn't exist, the tree remains empty after clearing the search bar in one go.

I fixed that yesterday evening (24 hours ago exactly now). Guess your steam didn't update.

Quote

Fixed tree view list staying empty when deleting whole search text at once, while in a search with 0 results

 

2 hours ago, CW4 Carrera said:

pressing *space* then *backspace* is the easiest way to bring back the entire tree.

Backspace doesn't work for me in the text field at all, i dunno why. Thinking about fixing that, but its more effort than its worth really. Is it supposed to work? Only DEL button works for me.

 

2 hours ago, CW4 Carrera said:

Exiting Zeus interface and reentering sometimes makes some units throw the Insufficient Resources prompt. Exiting and reentering again seems to fix it.

Just pushed fix for that 5 minutes ago.

 

8 minutes ago, simkas said:

that unit will be completely frozen while the interface is loading. Which can be especially jarring when you remote control a plane and then let go of it as it's still flying. I assume this mod will help with that too.

Yup, as it fixes the interface loading freeze, it fixes that too.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Dedmen said:

Backspace doesn't work for me in the text field at all...Is it supposed to work?

Works for me, I've never had an issue with it.

Share this post


Link to post
Share on other sites
18 hours ago, Dedmen said:

I fixed that yesterday evening (24 hours ago exactly now). Guess your steam didn't update.

Still happens in the latest version on 10/11/19 at 18:06GMT+1. If a faction didn't show up in the search, resetting the search won't bring the faction back. Need to start a new search to get everything back. As an example, searching for "1" in the BLUFOR unit tree leaves me with just the NATO factions in base game.

Can also confirm, entering a space and then deleting it with backspace fixes the issue. Backspace has always worked for me in the text field.

 

*EDIT* To confirm, steam DID update to the 10/11/19 17:22 update.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, NeilZar said:

Backspace has always worked for me in the text field.

Okey pressing it doesn't work, but pressing and holding does 😄
 

I cannot reproduce it at all, when I run with my modpack.. But if I run vanilla like you described, I can reproduce it.. but also not really. I search for "HEMTT" and find nato/nato pacific.
I remove whole text and then the factions nato/nato pacific AND nato woodland show up, even though woodland was missing before.


Certainly very weird behaviour 🤔

Share this post


Link to post
Share on other sites

Oh F'in hell. Found it. Its a bad copy paste of when I last thought I fixed that issue.

After you search I do "firstVisibleItem = firstChildren;" to tell the tree which item is at the top.
but if search text is empty I do a "firstChildren;" .. I think someone missed to copy paste the actual assignment part.
This causes the last search results firstVisibleItem to stay, which caused all items after that to display, but none that come prior.
And I couldn't reproduce it on my modpack, because I had a search result in the first node.

Thanks... Pushing to steam in ~5 minutes.

  • Thanks 5

Share this post


Link to post
Share on other sites

Think I've found a bug
Open the interface and enter any search into blufor/opfor/etc and delete the search term.

Go then to empty objects and search for something (e.g desk).

Then close the interface and open it again. The blufor/opfor/etc list (whichever one you searched in) will now be empty unless you enter and delete a search term, or restart game

 

Will note I am running with ZEN, but that's the only zeus-modifying mod installed

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×