Jump to content
Flax

FAST2 - Arma Server and Steam Workshop Tool

Recommended Posts

Thanks to all of you for your kind suggestions. I honestly did appreciate the direction given.

Share this post


Link to post
Share on other sites

Hi,

 

The steamcmd keeps getting stuck on the following:

 

Steam Console Client (c) Valve Corporation-- type 'quit' to exit --
Loading Steam API...OK.
 

 

I think its to do with the 2 factor auth, how would I get around this?

Share this post


Link to post
Share on other sites

 

I have the same thing happening.. 

Steam Console Client (c) Valve Corporation-- type 'quit' to exit --
Loading Steam API...OK.
 

.. Any solution? 👀

Share this post


Link to post
Share on other sites

problem with players set i wanted 64 players slot on server but cant see this program all time server is full

Share this post


Link to post
Share on other sites
On 3/21/2019 at 10:32 PM, scarecrow369 said:

Hi,

 

The steamcmd keeps getting stuck on the following:

 

I think its to do with the 2 factor auth, how would I get around this?

 

On 3/24/2019 at 5:36 PM, DRACUS said:

 

I have the same thing happening.. 

.. Any solution? 👀

 

Check this post for the temp fix.

 

 

 

1 hour ago, otarius-big said:

problem with players set i wanted 64 players slot on server but cant see this program all time server is full

 

If the server says it is full when there are no players in it it is usually due to a mod mismatch.

 

Share this post


Link to post
Share on other sites

@otarius-big @Flax
 

I found an exit to this problem:

 

1) Identifying the problem:> FAST2 crashes when checking MODs at the beginning of the program.

 

2) Preparing the solution:> Make a copy of the FAST2 installation folder.

 

3) Server's MODs:> Go to the SteamCMD folder (C: \ SteamCMD \ steamapps \ workshop \ content \ 107410) in our case here. Note that each mod is indicated with the Workshop ID (example ACE3 for ArmA3 the Workshop ID is 463939057). You will have to test all ID's one by one in order to find out which mod was taken from the workshop.

 

5) To facilitate:> https://steamcommunity.com/sharedfiles/filedetails/?id=463939057
you only have to change the number at the end of this address, which is already on the MOD page.
  
6) Download the latest version of the program. Unzip it to a different folder and run the FAST2 configuration as the original installation of your server.

NOTE: Do not run the SteamCMD installation (since it is already installed)

 

7) The improvised solution:> in item 5 support test, you should already have located which mod's are no longer part of the workshop, so, you will run this new installation, the server's mod's will be on the tab LOCAL MOD's. Go to the problematic mod and delete it.

 

8 ) Close this improvised version of the FAST2 installation and run the version in which it was previously installed. If you have performed the correct step by step, the program will not lock again.

 

9) Tip to avoid new problems:> go to settings tab and uncheck "Check for Steam Mod Updates on Launch" and "Auto Update FAST on Launch".

 

I hope it helped you.

Share this post


Link to post
Share on other sites

when next update?

if i write my mod collection link from workshop will it work?

https://steamcommunity.com/sharedfiles/filedetails/?id=1694799132

will it download all automaticly or i must downloat all my choiced mods manualy? it was problem too 

i used all time arma 3 laucher exported mod list file with this program to download  mods what i want but when it finish download one mod it all time closed

Share this post


Link to post
Share on other sites

Hi, I'm trying to setup a new dedicated server. It's a fresh installation. Right now the arma3server is working with a basic configuration and FAST2 can Update in the "Steam Updater" menu.

 

The problem is: once i added workshop mods and i press the update button, FAST2 shows the next error:
 

Quote

 

Downloading item 450814997 ..

ERROR! Download item 450814997 failed (Failure).Redirecting stderr to 'E:\Apps\Steam\logs\stderr.txt'

 

 

 

 

If i press the "update all" i got one line like that for each mod added (each line with his own workshop ID).

 

I tried delete steamcmd, the arma3 folder and FAST2 and repeat again all process. Still the same problem.

I tried use the FAST2.exe temp fix. Doesn't works neither (anyway my problem is not being stuck in Loading Steam API).

 

Also, the stderr.txt log is empty, so i can have clues about what's happening.

 

Any suggestions??? Thanks in advance

 

EDIT: I'm going answer myself.

 

The steam user i'm using in FAST2 doesn't own a copy of Arma3. With my steam user works fine. (with errors if i got steam opened).

Share this post


Link to post
Share on other sites
On 3/28/2019 at 9:02 AM, otarius-big said:

when next update?

if i write my mod collection link from workshop will it work?

https://steamcommunity.com/sharedfiles/filedetails/?id=1694799132

will it download all automaticly or i must downloat all my choiced mods manualy? it was problem too 

i used all time arma 3 laucher exported mod list file with this program to download  mods what i want but when it finish download one mod it all time closed

 

 

I'm not sure if the program accepts MOD's collections. I recommend you put the links of each MOD individually.

Share this post


Link to post
Share on other sites

Helice - Steam doesn't let you download mods off the workshop unless the login details you are entering owns a copy of ArmA 3, You can download server files with any login your like but mods must be downloaded with a steam account that owns ArmA 3.

All - My FAST 2 keeps crashing also when checking for mod updates, A work around for this which is a bit easier than what Arghbra posted is turn Auto Update FAST on Launch to OFF, then when you know a mod needs to be updated just simply click the Clock icon for each mod - basically you have to manually update the mod, which isn't too much of a pain in the ass as you should know what mods need updating from your own personal PC updating from Steam.

 

Flax - Is there is any interest in getting the Keys automatically copied to the Keys folder after a mod is updated? This was a very useful feature from the original FAST that would be very appreciated for the latest version.

Share this post


Link to post
Share on other sites

Sorry guys but this is confusing.

I just want to run ONE instance of dedicated server (pretty much what TADST does..but due to it's UI size

restrictions i can't use it anymore).

 

I dont want separate server folder -neither to re-download any addon i already have (i tried importing an exported

.xml of my addons which are commented as "not installed").

Is it possible?

In case anyone responds to my call..please take the time to explain the steps with simplicity.

As i m getting older -i m getting dumber

 

 

Share this post


Link to post
Share on other sites

Come on, giorgygr:

Explain to me how you downloaded the MOD's on the server?

Because you can put FLAX to locate the MOD's from the root folder of ArmA and the program will arrive if each MOD has association in the workshop.

Anyway, I recommend you download the MOPD's through the program, in order to keep the library always in line.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 4/16/2019 at 5:22 PM, rekkless said:

All - My FAST 2 keeps crashing also when checking for mod updates, A work around for this which is a bit easier than what Arghbra posted is turn Auto Update FAST on Launch to OFF, then when you know a mod needs to be updated just simply click the Clock icon for each mod - basically you have to manually update the mod, which isn't too much of a pain in the ass as you should know what mods need updating from your own personal PC updating from Steam.

 

Flax - Is there is any interest in getting the Keys automatically copied to the Keys folder after a mod is updated? This was a very useful feature from the original FAST that would be very appreciated for the latest version.

 

Top bit - yes I have noticed this too. I believe it happens when a mod changes its name or is removed from the workshop. I will try and find a way around this however not the quickest thing to replicate. 

 

As for Keys yes it's top of my list for things to add. I am going to sit down and work through the back log next week and get a release out as soon after as possible. 

Share this post


Link to post
Share on other sites
9 hours ago, Arghbra said:

Come on, giorgygr:

Explain to me how you downloaded the MOD's on the server?

Because you can put FLAX to locate the MOD's from the root folder of ArmA and the program will arrive if each MOD has association in the workshop.

Anyway, I recommend you download the MOPD's through the program, in order to keep the library always in line.

I just wanted to use the mods i already have as client-that's why (as client) i exported an .xml from my ArmA-launcher to (i.e.) desktop

and imported it afterwards to FAST2.

 (for my intended server use..it's considered overkill to re-download 30-40 gigs with my available bandwidth and HDD space)

 Mod list was properly recognised..but the mods status was not-installed (because FAST2 didn't knew WHERE the mods was located)

..what brings another confusion because FAST2 NEVER gave me the option to manually select the exact folder location

i want my new server (which it might have been my MAIN ArmA3 folder..

 

 

Share this post


Link to post
Share on other sites
5 hours ago, giorgygr said:

I just wanted to use the mods i already have as client-that's why (as client) i exported an .xml from my ArmA-launcher to (i.e.) desktop

and imported it afterwards to FAST2.

 (for my intended server use..it's considered overkill to re-download 30-40 gigs with my available bandwidth and HDD space)

 Mod list was properly recognised..but the mods status was not-installed (because FAST2 didn't knew WHERE the mods was located)

..what brings another confusion because FAST2 NEVER gave me the option to manually select the exact folder location

i want my new server (which it might have been my MAIN ArmA3 folder..

 

I get what you are looking for - this is possible in FAST but it was not designed for it. If you completely ignore the steam part of FAST you can create a server profile and point it at the arma3server.exe in your client install. Then for the mods to be detected you can go to settings and add the hidden !Workshop folder in the arma 3 client folder as a place to look for local mods. These should then show up for you and allow you to launch with the mods you want without having to re download from steam.

  • Like 1

Share this post


Link to post
Share on other sites

Not sure if I should stick with FAST or make the jump to FAST2, haven't had an issue with FAST as yet.

Share this post


Link to post
Share on other sites
2 hours ago, Lachlan Woodcroft said:

Any chance we could get the option to add extra parameters to the headless clients?

 

Drop an issue in the Git repo and I'll mark as a feature request and add when I get a chance. 

 

As a general reminder guys, Git Repo is best place to report bugs and feature requests as I don't tend to trawl back through this thread or the Discord for issues from ages ago. If it's on the Git Repo i will get round to it eventually.  

Share this post


Link to post
Share on other sites

What about specifically setting up a folder for your mods without them being downloaded into the main Arma 3 folder and then pointing the fast2 program at the !workshop folder for the symlinks?

Share this post


Link to post
Share on other sites

@Nichols
I do not use private mods, but the program has a session for this type of MOD, "LOCAL MODS and you can link to their source folder.

Share this post


Link to post
Share on other sites

I never could get FAST2 to work with the existing installations of SteamCMD, Steam and Arma 3. I went back to what worked for me and it was good. Thanks for the attempted help.

Share this post


Link to post
Share on other sites

https://imgur.com/io89l02

 

Can anyone tell me why I can't download mods? login details are correct, I have downloaded SteamCMD and can log in no problem. But as soon as the mods try to download I just get these errors.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×