Jump to content
Gekon

[Official] Launcher Feedback

Recommended Posts

For me personally, I would like to know how to get rid of the launcher. It seems that every game company has their own idea of how it should be done, or how they can do it best. I can update my own games not to mention I have a personal launcher called my monitor. I would like to launch my game from my desktop without having to go into the Steam launcher, to get to the  Arma 3 launcher, just to launch my game. Is it possible to completely get rid of that launcher?

Share this post


Link to post
Share on other sites
3 hours ago, Nover05 said:

For me personally, I would like to know how to get rid of the launcher. It seems that every game company has their own idea of how it should be done, or how they can do it best. I can update my own games not to mention I have a personal launcher called my monitor. I would like to launch my game from my desktop without having to go into the Steam launcher, to get to the  Arma 3 launcher, just to launch my game. Is it possible to completely get rid of that launcher?

 

Totally possible. Easiest way is to go to F:\Program Files\Steam\steamapps\common\Arma 3 (Will be different on your pc depending on where you installed it)

an make a shortcut of arma3_x64.exe or arma3.exe

 

The game should start without launcher that way.

In the shortcut you can still use https://community.bistudio.com/wiki/Arma_3_Startup_Parameters

Share this post


Link to post
Share on other sites
37 minutes ago, R3vo said:

 

Totally possible. Easiest way is to go to F:\Program Files\Steam\steamapps\common\Arma 3 (Will be different on your pc depending on where you installed it)

an make a shortcut of arma3_x64.exe or arma3.exe

 

The game should start without launcher that way.

In the shortcut you can still use https://community.bistudio.com/wiki/Arma_3_Startup_Parameters

yea lol. thank you

Share this post


Link to post
Share on other sites

I have a new issue in that it seams the launcher is not showing all my STEAM mods or there is a huge delay between STEAM populating the list. Also a huge delay in updating the mods for some reason. 

 

If there is low HD space, perhaps it can note it.

 

Anybody know if there is MOD limit it can show? Hope its not 999! :D

  • Sad 1

Share this post


Link to post
Share on other sites

Hi Wiz,

 

It started about 2 to 2.5 weeks ago? I thought I was seeing things. The symptons are like this:

 

  • Start A3L
  • Click on MODS
  • Some mods are not shown - missing but in the STEAM CLIENT under WORKSHOP, it shows  I have subscribed to it.
  • About 1 to 2 minutes later, a BUNCH of MODS have been updated or downloaded. Like as if it was parsing back all the missing mods. I just saw ~ 52 mods updated. Click on the triple X to close it all.
  • Scroll through the list and see a bunch of mods waiting to update or still download but the missing mods come back.

 

 

Close A3L, restart it and it does it again.

 

At first I thought my SSD was going bad so I scandisk it. No issues.

 

Also, if I try to run ARMA with some of the affected mods in a profile, that means it disappears or reappears in the mod list, but is still physically on the HD, it takes a LONG time to load (same SSD).

 

I tried to uninstall the mods via steam work shop and re-subscribe. It just sits there waiting to update.

 

This affects the workshop mods only. The mods that are manually loaded have no issues. Not sure what to do here and don't want to reinstall gigabytes of mods again.

 

Is there a MOVE function so it basically copies and uninstalls the mod from Steam Workshop so I won't have 2 copies? Maybe that would fix it?

Share this post


Link to post
Share on other sites
8 hours ago, Valken said:

 

Is there a MOVE function so it basically copies and uninstalls the mod from Steam Workshop so I won't have 2 copies? Maybe that would fix it?

 

Not as far as I know - God knows that would be usefull...

I do that manually, delete the related folder linked in the hidden workshop folder, and then unsubscribe from the mod on Steam.

Share this post


Link to post
Share on other sites

Hi Wiz,

 

I did a check and there is something wrong with my launcher again. Under the mods list, it would show about 3xx mods subscribed.

 

I then wanted to confirm this because it should be a tad more.

 

So I selected the 107410 folder to be WATCHED and it now shows it has added 27xx mods...!!!

 

Can you check if STEAM is acting up again where last year it was not syncing to the actual subscribed mods to the launcher? I believe it may be server change on their end again. For now, I have it selected to watch the folder to enable the mods temporarily.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Wiz,

 

I have zipped up the logs but dropbox won't let me link it anymore. I have email it to somewhere. 

 

Check your PM and thanks!

 

Share this post


Link to post
Share on other sites

Update... I am getting a lot of "STEAM IS OFFLINE" errors in ARMA 3 LAUNCHER even though Steam is connected to the internet clearly and can download and play other games.

 

Seems there is something going on locally on my computer or if the launcher is trying to connect to the internet separately even though the local Steam client has connected successfully to Steam.

Share this post


Link to post
Share on other sites


I read the thread but did not see what I'd hoped for. It appears that the mod list exporter creates a list of links for subscription that are alphabetical and does not preserve load order. I know that re-foldering is a solution for some people, but there are mods that you may not do this with and none of my players are Arma monks. They are family members and work-mates who only have so much patience. They need the game to be as accessible as I can make it. So do I understand correctly: Is load order not preserved? And is there some reason I don't gather why not?

Share this post


Link to post
Share on other sites
13 hours ago, bugbear44 said:

Is load order not preserved? And is there some reason I don't gather why not?

Load Order doesn't matter if the Mods are written correctly.

Share this post


Link to post
Share on other sites

That's not an answer for me. You can vouch for all fifty three thousand or so entries on the workshop and it doesn't make any more satisfaction from their shifting around, apparently at random, in the list. I want them to go where I put them.

  • Like 1

Share this post


Link to post
Share on other sites

I get very few administrative events in Windows 10 Event Viewer, I like to squash any that appear or understand why they appear.

What is get MOST of the time is Launcher errors. The launcher doesn't crash or anything and works 100% of the time to launch the game.

Anyone (BI)? have any idea why these appear?

 

Spoiler

Application: arma3launcher.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
   at <Module>.Steam.ServerFavoritesService.RefreshFavoriteGame(Steam.ServerFavoritesService*)
   at SteamLayerWrap.ServerFavoritesServiceWrap.GetFavoriteServers()
   at Launcher.Steam.Servers.ServerBrowserService+<>c__DisplayClass32+<<GetList>b__2e>d__37.MoveNext()
   at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.Start[[Launcher.Steam.Servers.ServerBrowserService+<>c__DisplayClass32+<<GetList>b__2e>d__37, arma3launcher, Version=1.5.145.285, Culture=neutral, PublicKeyToken=null]](<<GetList>b__2e>d__37 ByRef)
   at Launcher.Steam.Servers.ServerBrowserService+<>c__DisplayClass32.<GetList>b__2e()
   at System.Threading.Tasks.Task`1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].InnerInvoke()
   at System.Threading.Tasks.Task.Execute()
   at System.Threading.Tasks.Task.ExecutionContextCallback(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(System.Threading.Tasks.Task ByRef)
   at System.Threading.Tasks.Task.ExecuteEntry(Boolean)
   at System.Threading.Tasks.Task.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

 

 

Spoiler

Faulting application name: arma3launcher.exe, version: 1.5.145.285, time stamp: 0x5c109749
Faulting module name: SteamLayer.dll, version: 1.5.0.0, time stamp: 0x5c1096d9
Exception code: 0xc0000005
Fault offset: 0x000454dc
Faulting process id: 0xa78
Faulting application start time: 0x01d4a37c6aaeae47
Faulting application path: E:\Steam\steamapps\common\Arma 3\arma3launcher.exe
Faulting module path: E:\Steam\steamapps\common\Arma 3\Launcher\SteamLayer.dll
Report Id: 55ea6f38-e485-41cc-87b0-b2c54d33fc7e
Faulting package full name:
Faulting package-relative application ID:

 

At the time of these errors I had no clue these events were being written because the game launched without issue.

Share this post


Link to post
Share on other sites

Steam broke my ARMA 3 just now (says not installed, but it is) and I had to reinstall the game. No issues. 

Steam WIPED ALL of my workshop mods off the SSD! over 600 GB... almost had a heart attack!!!

Steam is trying to reinstall mods... waiting...

ARMA 3 Launcher still has bug that it cannot see / list some of the mods that I had already subscribed too - RHS and CUP for example.

I checked my profile on STEAM and it says I have subscribed to 4941 entries (mods + missions)...

I don't want to unsubscribe all as I cannot export a subscribed mods to a list from Steam Client or Workshop via browser. Arma 3 Launcher can export but it only shows ~ 300 out of 4941 mods... sigh...

Both Steam Client and Internet Browser logged into Steam does show all subscribed mods...

 

Any idea? Oh Great Wizard, are you back yet?!

Share this post


Link to post
Share on other sites

What's happened with the Launcher?

Before I could unfold a mod and then click on the square icon with an arrow pointing NE to open that mod's page in Steam's Workshop but not anymore..

Clicking the icon doesn't appear to do anything now...

Any ideas on how to restore the original behaviour? 

Share this post


Link to post
Share on other sites
9 hours ago, domokun said:

What's happened with the Launcher?

Before I could unfold a mod and then click on the square icon with an arrow pointing NE to open that mod's page in Steam's Workshop but not anymore..

Clicking the icon doesn't appear to do anything now...

Any ideas on how to restore the original behaviour? 

I quick look at my dev and main lauchers, both work fine. It's your side. Verify integrity of game files maybe (Steam). Not every mod have this link.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×