Jump to content

Recommended Posts

Hi Jigsor, 

I'm starting to get an issue now where connecting to v1_49 servers works grand but attempting to connect to servers running v1_50 causes the game to crash upon receiving mission file.
Have done the usual checks of clearing the cache and reinstalling to be safe but it appears to be specifically affecting v1_50 servers.

Share this post


Link to post
Share on other sites

@dunadrian This is the first I've heard about this particular issue. Have you tried to verify integrity of game files through steam? I recommend this first then try to connect to this server with no mods. If it happens again there might be something useful in your .rpt log file. You can send me a link to it and I'll have a look.
https://www.battlemetrics.com/servers/arma3/2753090

Share this post


Link to post
Share on other sites

Hello Friends,

 

Having a frustrating problem. I am hosting a server with the latest download link from this top of this thread. I can run the server myself and play without any issues whatsoever however my friends connect and their arma says provides a "cannot load texture" error with "bmrflag.paa" as well as a "script vehrespawn.sqf not found". It also appears that when they connect they dont see the typical download progress of the mission file which normally takes a few seconds but rather, It just snaps to 100% and they load into the server. They can connect but as soon as they try to enter the game itself they either spawn in the middle of the ocean dead or get stuck in the underground below spawn. Also sometimes they get a message saying that they are requiring DLC addons to join then then mission terminated. I always thought you didn't need any of the DLC's to join a server? They have the standard original ones but not necessarily the newer Contact and Tac Ops ones. Anyone experiencing this? Or is it something with my machine? Thanks!

 

-nozzle

Share this post


Link to post
Share on other sites

@Nozzle

Hello Nozzle and welcome to the forums.

 

"cannot load texture" error with "bmrflag.paa"
This can be ignored. There may be a fix for this but i am unaware of it. To me this is an Arma engine design problem. Why this happens? This happens when a new player who is not the server joins a server running a mission or choosing a mission in mission selection screen wich uses loadScreen command (this mission does).

The image is contained in the mission and the mission must first be downloaded successfully in to MPmissions cache in order for the picture to be accessible/viewable. So once the player has the mission this should no longer occur if they play the same mission again.

 

"script vehrespawn.sqf not found"
There is nothing actually wrong with this script or script path but probably rather a side affect of missing terrain wich can cause all sort of anomalies.

 

Enoch/Livonia version requires Contact DLC
Tanoa versions require APEX DLC
The other versions do not require dlcs. At least they never have on our dedicated servers.

 

Also have a look at you latest .rpt when this occurs and have your players look at their .rpt log as well. This will show wich mods and dlcs are actually loaded which may differ from not the ones you thought were loaded.

 

 

Share this post


Link to post
Share on other sites

I need help getting it to run on a dedicated server, most of the maps give me a, "no entry error". I must be missing something easy.

Share this post


Link to post
Share on other sites
1 hour ago, richh001 said:

I need help getting it to run on a dedicated server, most of the maps give me a, "no entry error". I must be missing something easy.

 

 

What mods are you running on the server/client?

 

 

Share this post


Link to post
Share on other sites

Thanks for the response. I am not running any Mods on the server. the only maps that run on the server are the one that don't require any mods. The maps that do require mods always give the client, "No entry" errors of some kind. and when mods are installed on the client that are listed in the notes, it is unable to connect because of the mods........Whatever it is that I am doing wrong must be simple and stupid, as I am really new at this.

Share this post


Link to post
Share on other sites

Ok, I had the wrong server setup. is there a guide on how to setup a server on aPC that will run BMR?

 

Share this post


Link to post
Share on other sites

Hello, 

I wanted to remove from arsenal thermal optics:

"NVGogglesB_blk_F",

"NVGogglesB_grn_F",

"NVGogglesB_gry_F",

"H_HelmetO_ViperSP_hex_F",

"H_HelmetO_ViperSP_ghex_F",

 

is there any config or white / black list file to add this ?

Share this post


Link to post
Share on other sites
On 2/24/2020 at 2:48 PM, Komaros said:

Hello, 

I wanted to remove from arsenal thermal optics:

"NVGogglesB_blk_F",

"NVGogglesB_grn_F",

"NVGogglesB_gry_F",

"H_HelmetO_ViperSP_hex_F",

"H_HelmetO_ViperSP_ghex_F",

 

is there any config or white / black list file to add this ?

Hello Komanos, There is whitelisting which you can enable in lobby but currently only contains vanilla and WWII content. Its a huge pain to list all allowed contents and probably not what you want.  In this script You can black list weapons which will still appear in arsenal but will be removed when player exits arsenal.
This edit will detect the types of items you listed and remove these on arsenal closed as well.
 

private _p = player;
private _bannedWeapons = ["HLC_wp_M134Painless","NVGogglesB_blk_F","NVGogglesB_grn_F","NVGogglesB_gry_F","H_HelmetO_ViperSP_hex_F","H_HelmetO_ViperSP_ghex_F"];
private _found = false;

if (currentWeapon _p in _bannedWeapons) then {
	_p removeWeapon currentWeapon _p;
	_found = true;
};
if (secondaryWeapon _p in _bannedWeapons) then {
	_p removeweapon secondaryWeapon _p;
	_found = true;
};
if (handgunWeapon _p in _bannedWeapons) then {
	_p removeWeapon (handgunWeapon _p);
	_found = true;
};
if (!isNull backpackContainer _p && {(weaponCargo backpackContainer _p) findIf {_x in _bannedWeapons} != -1}) then {
	{
		_p removeItemFromBackpack _x;
	} forEach _bannedWeapons;
	_found = true;
};

private _allHG = assignedItems _p;
_allHG pushBack (headgear _p);
private _detected = (_bannedWeapons arrayIntersect _allHG);
if !(_detected isEqualTo []) then {
	{_p unlinkItem _x;} forEach _detected;
	_found = true;
};

if (_found) then {hintSilent "Sorry, Weapon Banned :("};

 

Share this post


Link to post
Share on other sites

thanks for reply

it sounds good, i just want ban few thermal items which are OP.

this edit will ban these items from any kind of arsenal option ? or only whitelisting which i can enable in lobby ?

Share this post


Link to post
Share on other sites

"this edit will ban these items from any kind of arsenal option?"   Yes.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×